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Preface

About This Book

HypcrC;u’d”"'J [IGS” is a software package that allows you to create
your own ways of doing things on your Apple I1Gs* computer.

This book is a reference to everything you might need to know as
you use HyperCard, including how to use and create “smart”
documents called stacks. Stacks can do many of the things that
ordinary Apple IIGS application programs can do, and more,
because you can decide for yourself how you want your stacks to
work—without knowing a word of programming,

If you do know something about programming, or even if you're
just curious, you might want to learn more about HyperTalk? the
programming language that’s built into HyperCard. This book

@ doesn't cover HyperTalk in detail. You don’t need to know anything
about HyperTalk to use HyperCard effectively; but if you want to
learn more about it, you can read the HyperTalk Beginner’s Guide.
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Whﬂ[ YOU ﬂ@@d This book assumes that you know how to use your Apple I1Gs,
to knO‘W to use and that you understand the fundamentals of HyperCard.

: You should know
this book

s How to use the mouse and keyboard

= How to choose from a menu

s How to use (i-key commands (such as (3-X)

= How to copy files and disks

s How to open disks, folders, applications, and documents
s How to do simple text editing

s How to use the directory dialog box to locate files

» What a HyperCard stack is

= What the components of HyperCard stacks are—cards,
backgrounds, buttons, fields, and graphics

If you're not sure how to do all of the first seven tasks listed, go
through the documentation that came with your Apple 11Gs before
you do anything else.

If you don't know whar a HyperCard stack is, or if you’re not
familiar with the components of stacks, go through the book
Getting Started With HyperCard IIGs and the Tour that comes

with HyperCard before using this book. (Getting Started With
HyperCard 1165 tells you how to start the Tour.) These tutorials
teach the concepts you need to know to use this book. )
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HOW tO use  This book is a reference to everything you might need to know as
this h()Ok you use HyperCard. (It doesn't cover scripting with HyperTalk—
! HyperCard’s programming language.) This book is designed to
help you find answers to your questions quickly and get on with
your work.,

Once you understand the basic concepts presented in the Tour
stack and the book Getting Started With HyperCard IIGs, refer to
this book as you begin doing your own work in HyperCard. If
you're still not sure how to use the Home stack or how to find
your way around in HyperCard, you might want to review the
information in Chapter 1, “Using HyperCard Stacks.” If you
want to begin building stacks, consult Chapter 2, “Creating and
Modifying Stacks.”

This book is organized according to tasks. Use the Contents or the
Index to locate instructions for specific tasks. You can also use the
Index to find information about individual topics and commands.

Descriptions of specific tasks in this book often include numbered
steps. Each step consists of a short instruction in boldface type
followed (usually) by further explanation in plain type. Depending
on your level of expertise with the Apple I1Gs, you may find that
you can speed through some or all of the instructions by reading
just the boldface steps.

The book contains the following chapters and appendix:

s Chaprer 1, “Using HyperCard Stacks,” describes how to
e use HyperCard stacks—“smart” documents creared with
HyperCard. This chapter also explains how to get help with
HyperCard and how to use stacks stored on file servers and
compact discs.
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» Chapter 2, “Creating and Modifying Stacks,” provides
information about building stacks. This chapter includes specific
instructions for working with a stack as a whole.

a Chapter 3, “Working With Cards and Backgrounds,” explains
how to create and modify individual cardsand backgrounds

s Chapter 4, “Working With Buttons,” explains how to create and
modify buttons (“hot” spots) and use them to link related pieces
of information.

» Chapter 5, “Working With Text and Fields,” explains how to
create and modify flelds (the places you create to hold text), how
to enter text into fields, and how to control text styles.

s Chapter 6, “Working With Graphics,” describes HyperCard’F.
Paint tools and commands and shows you how to use them to
create graphics.

a Chapter 7, “Printing,” explains how to print the information in
a stack.

You can find definitions of unfamiliar terms in the Glossary. Terms
that appear in italics in this book are defined in the Glossary.

The HyperCard 11Gs Quick Reference Card gives keyboard
shortcuts for HyperCard operations.

At the end of the book is a Tell Apple card. By answering the
questions and mailing the card to Apple$ you help us improve our
products and documentation. Fill the card out after you've worked

with this book.
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\\ hLJl'C O E*_J,L’[ A HyperCard stack can be as simple as a collection of information,
Tvrvarl arel ctacl-e or as complex as any > [IGS applicar ogram. (Chapter 2
Hy, ]')LJI(A“ d stacks oras complexasany Apple IIGs jpphmrmn program (Chapter

: shows some examples of | lyperCard stacks.) You can use the stacks
that come with HyperCard, create stacks yourself, or get stacks
from a variety of other sources:

= You'll find HyperCard stacks for sale at your local computer
SUH—\-V'JFC store.

» Check with your local Apple IIGs user group to find out the
meeting time of the HyperCard special interest group. Members
often share their stacks with each other. (The next section

explains how to find a local Apple I1GS user group.)

= Most on-line electronic information services like CompuServe®
® and GEnie™ have HyperCard special interest groups. These
groups have stacks you can get free, except for the service’s
time charges.

Other sources Although this book is a reference to HyperCard, it doesn't contain
of information tutpri"&l insrruc.tion for novice users, and it giveskonl’v a brief loc?k at
scripting (creating programs that control the actions of HyperCard).
Other kinds of information and instruction on HyperCard are
available from a variety of sources. This section describes some
of these sources.
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xviii

Other learning materials

In addition to this book, the following learning materials are

included in the HyperCard package:

(;f’!!mg Started With HyperCard 11Gs: A book that tells you how to
install HyperCard, teaches the basic ‘slx[”\ you
need to get going, and shows you how to start
creating and modifying stacks

Tour: A stack that introduces basic HyperCard concepts by

g \“‘a showing you what HyperCard can do.

HyperCard 1IGs Help: A stack that answers your questions while @)
- . -
% P you're using HyperCard.

Hyper z'af.{’ Beginner's Guide: A book that teaches you how to use
- HyperCard’s programming language by helping

you create a new SI‘EICI'CT one step ata time.

Hy/mr Talk Help: A stack that provides easy access to information
about HyperTalk for people who use

%9 HyperCard’s programming language.

If you're serious about building stacks, you may also want to
consult the following books, which were written at Apple and
are published by Addison-Wiesley as part of the Apple Technical

Library:

HyperCard Stack Design Guidelines: A book that provides
information about how to design and build effective stacks. Its
focus is the look and behavior of stacks (for example, navigation
methods and card layouts) rather than the mechanics of scripts.

Preface: About This Book
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HyperCard I1GS Script Language Guide: A book that provides
detailed reference information about scripts and HyperTalk. This

book 1s for puuplc with some programming or scripting ¢xpericnc.

Several other excellent books have been written abour HyperTalk.
Books about HyperTalk that were written for HyperCard 1.2.5,
which runs on Macintosh® computers, contain much information
that also applies to HyperCard IIGs.

User groups — Apple I1Gs user groups can be a great source of information about
HyperCard, and about Apple computers in general. Members of
user groups meet to share ideas, discuss problems, and exchange
. software and information. By attending user group meetings, you
can learn more about HyperCard and see how others are using it.

Ask your authorized Apple dealer for the name of the Apple 11Gs
user group nearest you, or call (800) 538-9696, Extension 500.

Preface: About This Book XIx




Chapter 1

Using HyperCard Stacks

Ihis chaprer begins with a brief summary of what HyperCard"
[1GS is and whar you can do with it. One of the first things you'll
learn is that documents created with HyperCard are called stacks.

The remainder of the chapter describes what you need to know to
use HyperCard stacks effectively, including

= What hardware and software you need to use HyperCard
= How to start HyperCard

=  How to use the Home stack

= How to open, explore, and close stacks

= How to get help

10 do the tasks described in this chapter, you need to have your
user level set to Typing or higher. When a rask requires a user level
higher than Typing, the instructions say so. (The section “User
Levels and Options™ in this chapter explains how to set your

user level.)




What is HyperCard?

HyperCard lets you create your own ways of doing things on your
computer. Unlike most application programs, which are designed to
Pcr[i;rm one type of task (such as word processing or creating
graphics), HyperCard can be used for many different kinds of rasks.
For example, you can use HyperCard to do any of the following:

= Gather information and organize it in any way you like,

= Browse through information you've assembled yourself, or
information gathered by someone else. You can follow links to
topics you want to know more about, skip over things you're nor
interested in, and search for specific facts or text.

» Create HyperCard stacks that meet your own specific needs—
for example, stacks that help you write a report, learn a new ®
language, organize a collection of electronic clip art, or present
information stored on a videodisc.

s Customize your computer work space—so that, for example,
with a single mouse click, you can log onto another computer,
launch an application that’s hidden away in a folder, or send a

message toa lncnd.

Using Hyper Talk’, HyperCard'’s English-like script language, you
can gain even more control over your HyperCard environment,
whether or not you have prior programming experience. You can
tap the power of HyperTalk without knowing anything about how
it works. For example, you can link a burtton to a stack—creating a
Sf.l'ip[ [hi‘ll’ TCHS T.'ht' I’ILH’[U” (L8] li].}{l' }-"[)ll o [i"li.l[ SlilLl\'——‘u’\r"i[}"ll'Hl.l
writing a word of HyperTalk. And HyperCard comes with
readymade scripts you can copy and paste. (You can learn to create
your own scripts by working through the exercises in the HyperTalk

Beginner’s Guide.)
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The more you learn about HyperCard, the more uses you'll see for
it. HyperCard allows you to shape the way your computer organizes
and presents information, which can help you use the information
efficienty. You may even find that HyperCard helps you discover
new ways of organizing your work and new approaches to old
problems. HyperCard provides you with a creative environment
that’s limited only by your imagination.

Chaprer 2 shows examples of the kinds of stacks you can create with

HyperCard.

Chapter 1: Using HyperCard Stacks 3




Cards and stacks — In HyperCard, information appears on cards. HyperCard cards
are a lot like paper index cards on which you can jot notes or
miscellancous information. In HyperCard, cards can contain

both text and pictures:
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Cards are grouped into stacks. The cards within a stack are usually
(bur not necessarily) related to one another, or based on a common
theme. They usually have the same look and contain similar
informartion.

Tau po Stamp
NEW ZEALAND

-~

Whakatane Stamp
NEWZEALAND

FYTUTTsee e e

=

(Go toHistory Stack)<a > P1%

Figure 1-2  Cards are grouped into stacks

Every stack has a name. An icon for each stack appears in
the Finder™:

&

StampStack

Figure 1-3 A HyperCard stack icon in the Finder

+ Ifyour stack icons look different: HyperCard stack icons will look
like the icon in Figure 1-3 only if you have followed the standard
installation procedure. If your stack icons look different, see
"HyperCard Icons and the Finder,” later in this chapter.
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What you need
to use HyperCard

You can learn a lot about the power of HyperCard just by exploring
the stacks that come with it. These stacks provide good examples of
the kinds of things HyperCard can do. If you wish, you can obtain
additional stacks from the sources described in the Preface.

HyperCard includes tools you can use for modifying and creating
stacks. With these tools, you create and manipulate the elements,
or building blocks, that make up stacks. You can arrange the
information on cards in any way you like. And you can tie together
related information by creating /inks—so that a single click takes
you immediately to the information you want, whether it’s in the
same stack or a different one.

s
i -

L i
Whakatane

History of New Zealand
NEW ZEALAND WHAKATANE

ey
- pledyele

Figure 1-4 A link from one stack to another

When you're ready to begin building stacks of your own, go to
Chapter 2, “Creating and Modifying Stacks.”

To use HyperCard, you need the following hardware and software:

s An Apple [IGS® computer with 1.5 megabytes (MB) of memory
or more. (To find out how much memory your computer has,
follow the instructions in “Checking Your Computer’s
Memory,” later in this chapter.) Your authorized Apple dealer

can help you add memory to your computer.

s  An 800K disk drive.
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» A hard disk. If you don't have a hard disk of your own, your
computer must have access to a file server over an AppleShare”

nerwork.,

= System software version 5.0.3 or later. Your authorized Apple
dealer can help you obtain the system software you need.

» o print with HyperCard, you need the appropriate printer
driver for your printer. The printer driver must be in the Drivers
folder, which in turn must be in your System folder when you
start your computer. For example, if you have an ImageWriter
printer, the Drivers folder must include the ImageWriter driver.
"I'he documentarion that came with your Apple 11Gs discusses
how to install system updates, including drivers.

HyperCard and your HyperCard requires a minimum of 1.5 MB of random-access

L‘(JI]]})LI[Q'I"H memory  memory (RAM) to run efficiently. However, the more memory
you have installed in your computer, the better HyperCard will
perform. The sections that follow describe how to find out how
much memory your computer has and how to identify and deal
with symptoms of low-memory conditions.

Checking your computer’s memory

Once your computer is set up, you can easily find out whether you
have enough memory to run HyperCard. Just follow these steps:

1. Choose Control Panel from the Apple menu.
2. Scroll through the icons on the left until you see the RAM

1Con.
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3. Click the RAM icon and check the numbers labeled “Memory

in use” and “Free memory.”

It these numbers add up to 1,536 or more, you have L‘[luugh

memaory.

t[J==——— lontrol Panel
{r] RAMDisk:  RAM Cache:

Printer Port

e Memory in use: 1177K These numbers
H}lﬂ free memary Q*]Bkj_'_ should add x“ I
[_]Resize after reset AR . vibicd
: at least 1,530

Time L
v1.0]  Help

Figure 1-5 Checking your computer’s memory

Your authorized Apple dealer can help you add memory to your

computer if you need ir.

Symptoms of low-memory conditions

HyperCard’s use of memory depends on many factors, including
the number of desk accessories you have installed in your system,
the network software you're using (if any), and the complexiry of
the card or stack you're currently working with. Even if you have
1,536K or more of RAM installed in your computer, you may find
that HyperCard sometimes performs differentdy than you expect.
This is most likely to happen if your computer has close to the
minimum amount of memory you need to run HyperCard and is

part of an AppleShare nerwork.
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Installing HyperCard

After you have installed HyperCard and learned o use i, you may
want to evaluate its use of your computer’s memory. The following

symptoms are signs that HyperCard is running out of memory:

» Fields and buttons in the card layer disappear when you're using
the Paint tools in the card layer.

» Fields and buttons in the background layer disappear when

you re using the Paint tools in the background layer.

» The Undo command doesn’t always work when you're using the
Paint tools.

» Buttons that play complex sounds don’t work.

You can keep working if these symptoms occur—HyperCard’s
behavior remains the same in most other ways, although it may run
more slowly than it would with more memory.

The best way to avoid low-memory conditions and to iImprove
HyperCard’s speed and general performance is to install additional
RAM. However, it may help to remove some of the desk accessories
you have installed in your system; avoid using a RAM disk; and
lower the RAM cache to 32K (or, if all else fails, to 0K).

For information abour desk accessories, RAM disks, and the RAM
cache, see the documentation that came with your computer.

For information abour working with the Paint tools under low-
g

memory conditions, see “Wﬂrl{jng With Paint Tools When

Memory Is Low” in Chapter 6.

Before using HyperCard, you should install it on your hard disk.
(You must have a hard disk to run HyperCard.) See the book
Getting Started With HyperCard 1165 for installadon instructions.

It you don't follow those instructions exactly, the HyperCard icons
in the Finder may look and behave differently than you expect.
For more information, see “HyperCard Icons and the Finder,”
later in this chaprer,
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Starting HyperCard

Beginning with
the Home stack

After you install HyperCard, make sure you have a backup copy of
each disk that comes with it, and lock your backup disks. (If you
don’'t know how to lock a disk, see the documentation that came
with your Apple IIGS.) It’s a good practice to back up any new
software before using it. However, it’s particularly important to do
this with HyperCard, because HyperCard automatically saves any
changes you make to stacks—withourt asking. Keep a backup copy
of each stack that comes with HyperCard, so that you can always
retrieve the original copy of any stack.

Before you start HyperCard, make sure you have a backup copy of
each disk that comes with it, as described in the preceding section@

The Home stack serves as a home base whenever you use
HyperCard, and it’s a good place to start exploring. It includes
a visual directory of other HyperCard stacks and provides easy
access to them. (You need to have a Home stack to run

HyperCard.)

[f you followed the installation instructions in Getting Started With
HyperCard 116, there are two ways to start HyperCard so that it
opens the Home stack:

é"ﬂh — Inthe Finder, ™= L ordouble-click
double-click the the Home icon. .

HyperCardII6S HyperCardicon... Home

Figure 1-6  Starting HyperCard with the Home stack

You n‘.igh[ have to close windows or open tolders to find the
HyperCard icon or the Home icon.
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If you did not follow the installation instructions exactly, or if you
have subsequently moved the HyperCard program file to another
location on your hard disk, you may find that these icons look or
behave differently from the way they are described in this section.
For more information, see “HyperCard Icons and the Finder,” later
in this chaprer.

+ Where is Home? When you start HyperCard by double-clicking
its icon, it looks for the Home stack (1) in the System folder;
(2) in your user folder, if you're running HyperCard over an
AppleShare network, or in the folder that contains the
HyperCard program, if you're not running HyperCard over a
network; and (3) in any folder named Stacks that’s inside the
folder it checked in (2). If it can't find Home in any of chese
places, HyperCard displays the directory dialog box and asks
where Home is. Use the directory dialog box (shown in the
following figure) to locate and open the file called Home.

This is the current directory level. You
can see the next higher level in your disk
directory (if there is one) by clicking
here or pressing Esc.

Where is Home?
=2:HordDisk:HyperCard:

(Volumes— You can view the

£ Stacks volumes that are

S ) : currently available
(__OoenJ L0 your computer

by clicking here or
pressing the Tab
key.

You can open a stack, folder, or volume in
this list by double-clicking it. You need to
locate the Home stack and open it.

Figure 1-7  The directory dialog box for finding a file
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For more information abour using the directory dialog box, see the
documentation that came with your system software.

For more information about Home, see “The Home Stack, * later

in this chaprer.

Beginning with a stack  You can start HyperCard so that it opens to a particular stack other
other than Home  than Home, as shown in the following figure:

double-click the

St-ﬂﬂk stack’s icon

= In the Finder,
b -é

Figure 1-8  Starting HyperCard with a stack other than Home .

You migln have to close windows or open folders to locate the
stack’s icon.

If you can't start HyperCard by double-clicking a stack’s icon, or i
the icon looks different from the one shown in Figure 1-8, see the
next section, “HyperCard Icons and the Finder.”

& Where is Home? When you start HyperCard by double-clicking
a stack’s icon, it looks for the Home stack (1) in the System
folder; (2) in the same folder as the stack you double-clicked;

(3) in your user folder, if you're running HyperCard over an
AppleShare network, or in the folder that contains the
HyperCard program, if you're not running HyperCard over a .
network; and (4) in any folder named Stacks that's inside the
folder it checked in (3). If it can't find Home in any of these
places, HyperCard displays the directory dialog box shown in
Figure 1-7, which you must use to locate the file called Home.
After you tell it where Home is located, HyperCard opens to the
stack whose icon you double-clicked. <«
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HyperCard icons
and the Finder

Important: Whether or not you want to start HyperCard with the
Home stack, you need o have a Home stack on your disk 1o run

HyperCard. A

% Seea padlock (&) in the menu bar? When you open a locked
stack, a padlock appears in the menu bar to the right of the
rightmost menu title. The padlock means the stack is
locked

you can't make changes to it. The section “Opening

a Locked Stack,” later in this chaprer, describes how to work

with such stacks. «

If you install HyperCard exactly as described in Gerting Started
With HyperCard 11Gs, and if you leave the HyperCard program and
the Home stack where the Installer program puts them on your
hard disk, the icons for the HyperCard program, Home, and other
HyperCard stacks will look just like those in Figures 1-6 and 1-8
(that is, like miniature stacks). If you don't follow the instructions
exactly, or if you move the HyperCard folder, the HyperCard
program, or Home after installation, you may find that double-
clicking stack icons to open them from the Finder won't work.

You may also find that HyperCard’s icons change their appearance,
so that they look like standard Apple 11Gs application and

document icons.

When the Installer pre igram installs HyperCard on your hard

disk, it also places two files (called FTYPE.HyperCard and
HyperCard.Icons) in the Icons folder on the same disk. These files
contain information the Finder needs about HyperCard’s icons and
the location of the HyperCard program on your hard disk. If these
files aren’t inside the Icons folder, the Finder uses its standard icons
instead of the HyperCard icons for all the HyperCard files, and
cannot automatically locate the HyperCard program file. When rhis
is the case. you can start HyperCard only by double-clicking the
HyperCard program icon. Double-clicking the icon for a
HyperCard stack won't work.
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The Home stack

If the HyperCard icons you see in the Finder are correct, but

you still can't start HyperCard by double-clicking a stack icon,

it's probably because you have changed the arrangement of
HyperCard’s files on your hard disk. Even if the correct files are

in your Icons folder, the information they contain about the
location of the HyperCard program on your startup disk will not
be valid if you have moved it. To avoid this situation, keep both the
HyperCard program file and the Home stack where the Installer
places them: inside the HyperCard folder, which in turn should be
at the top level of your hard disk directory (visible in your hard

disk’s window).

If you need to keep the HyperCard program somewhere else, make
sure you keep the Home stack at the same directory level (in the .
same window) as the HyperCard program file, and remember that
you must always start HyperCard by double-clicking its icon.
Double-clicking stack icons to open them won't work, but

otherwise HyperCard will function the same way.

Home is HyperCard’s central stack. You can return to it easily from
any other stack ar any time. You use the Home stack as your base
of operations, a jumping-oft point for your work in | lyperCard.
This section describes the standard Home stack that comes with

H x—-‘pcrL:;n'-;L
o

The cards in the standard Home stack contain information vital u.
HyperCard’s performance:

» The first five cards in the Home stack, called the Home cards,
are designed to hold buttons thar rake you o stacks.
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The Home cards

m The Scarch Paths card tells HyperCard where to find stacks,
applications, and documents that you use frequently.

= The User Preferences card lets you customize the way you
interact with HyperCard.

[he Home cards are

designed w0 hold
buttons that take you
to your stacks.

o The User Preferences
card lets you customize
the way you interact
with HyperCard

The Search Paths card
tells HyperCard where to
look for different files.

Figure 1-9  The cards in HyperCard's standard Home stack

Warning: HyperCard will not operate withour a Home stack.
Do not delete the Home stack. A

I you haven't customized your standard Home stack, the first

three Home cards (the first three cards in the stack) conrain

buttons that take you to all the stacks that come with HyperCard—
from collections of electronic art to special stack-building tools.

In addition, the standard Home stack has two blank Home cards.
Collectively, the Home cards provide a visual directory for

your stacks.
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HyperCard I1GS

&

fielp Ficture Puzzler

2 /A
Tour Story Board

Copyright @ 1990 fipple Computer, Inc

I—am1 Beskset | [ ToolKit J[ Mutic ][ Sasenent ]

s —
Home Stack / Desksel

HyperCard [1GS
[Create buickLink. |

User Name

{allndﬂr

| The buttons on

the first three .
Home cards take
you to the stacks

Phese buttons 41— ereonr ) TSR [ Tori¥e J[ Suie [ fosement | that come with

move vou through - HyperCard

HyperCard [1GS
Create Etm:Llnll
lser Pr mu

Rddresses

the caards in the

0 RN R L1111 11111111
Home Stack / Toal Kit liser Nome

Home stack

r‘h.li;.
Seripter's Tools irt ldeds
il
<
Button leus leon Editor

1 Velcome | [ Deskser | NETETNCTOIN [ mevic Bosement |

Figure 1-10  The first three Home cards .

As you become more comfortable with HyperCard, you can make
your Home cards even more useful by adding butrons that link
your Home cards to your favorite cards, stacks, and applications.

Y Seeabso: “Customizing Your Home Stack™ in Chaprer 2
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User levels and options  You can adjust the settings on the User Preferences card to
customize the way you interact with HyperCard. To get to the
User Preferences card, first go to the Home stack (if you're not
already there) by choosing Home from the Go menu, or pressing
~-H. Then click the User Preferences button.

dSetting your user level

On the User Preferences card, click the user level that matches what

you want to do in HyperCard:

This column explains what you can
do at each user level.

Home Stack / User Preferences

Your Name. |ser ame

HyperCard [1GS
Seerch Puths
Return

Click here o

change the user
name.

w

Fond Edit the scripts of buttens, fields,
S‘:”F'tmf- cards, bockgrounds, and $tocks

: Create buttons and fields. Link
Authoring buktons to cords and stocks

Use the Pgint toals to change the

When you click a
higher user level

=

Pmnllng appearance of cards ond bockgrounds.
L ?f:ﬁ:_"h Enter and edit Lext in T Text Arroms
2 1. Tor elicking only. Youmoy explore
Browsing stocks but not change them o N

A —— 1111
Home Stack / User Preferences

HyperCard [1GS
Search Paths
Retura

Your Name: fser Meme

.. the appearance ol ___WI Fdit the seripts of buthons, fieldy, ] 8lind Tuming

§
cords, bockgrounds, und stocky
W Create buttons ond fields. Link

e User Prelerences :
. L'lﬂ.l k|'|'|['|“L"~ o % buttons to cords ond stocks. |
¢ alipes : Painlin,g 3. Use the Paint tools to change the ] Power Keys
reflect your choice |___sbpearance of cards and backgrounds. ] P
T}'ping 1 E::I;:u:ks Enter ond edit Lext in O Text frroms. |
|1 Far clicking only, Voumoy explore .

[

Browsing stacks but not chonge them.

Figure 1-11  Setting your user level
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The features available art the different user levels are cumulative—
that is, each level gives you all the features from the previous levels,
and also gives you additional capabilities. For example, the features
available at the Browsing level are also available at the Typing level;
the features available at the Browsing and Typing levels are also
available at the Painting level; and so on. The higher the user

level you choose, the more you can do with HyperCard.
You might want to set a low user level now and ¢ lmra\t;c Lo A h];;hu:
one later, when you feel comfortable experimenting with more

advanced features. You can change your user level at any ume.
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User level

Browsin g

T}fping

Painting

Authuring

Scripting

What you can do

Open, close, and browse through stacks, search
for text, click buttons, move between stacks, save
copies of stacks, and print the information in

stacks.

The same things you can do at Browsing level,
plus type and edit text in existing fields, set the
Text Arrows option on the User Preferences card
in the Home stack (explained in the next section),
and add and delete cards.

The same things you can do at Typing level, plus
set stack protection, delete stacks, create graphics
with the Paint tools in the Tools menu, edit
graphics and patterns using the Paint, Options,
and Patterns menus (which appear when a Paint
tool is selected), move between the background
layer and the card layer, and use the Power Keys
(explained in “The Power Keys Option,” later in
this chapter).

The same things you can do at Painting level,
plus create, modify, and delete buttons, links,
fields, cards, backgrounds, and stacks using the
Button tool, the Field tool, and commands in the
Objects menu.

The same things you can do at Authoring level,
plus write and edit scripts and use the Blind
Typing option (explained in “The Blind Typing
Oprtion,” later in this chapter).
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The File and Edit
menus you get
when your user
level is Browsing
or Typing.

The File and Edir
menus you gel
when vour user
level is Painting,
Authoring, or
scripting.

New Stack...
Open Stack...
Save a Copy...

Print Card
Print...

Quit HyperCard

a0

Page Setup...

aP

a0

New Card OGN

Undo

{ut K
Capy 1
Paste aV

Llegs

Delete Card

New Stack...
Open Stack...
Save a Copy..

Protect Stack...
Delete Stock...
Page Setup...
Print Card
Print...

el

Compact Stock

aP

Undo

New Card GN

fut, 8
Capy a4
Paste ay
Grear

Delete Card
Cut Cord
Copy Card

Quit HyperCard 40

Figure 1-12

Text Stnle.. 0O
Bockground (B

Short and full File and Edit menus
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w  User preferences and stack protection: The tools and commands
you have at your disposal while you’re using a specific stack
are determined by both the user level you set on your User
Preferences card and the stack’s user level (which is set in the
Protect Stack dialog box). When a stack is set for a different user
level than the one set on your User Preferences card, HyperCard
uses the lower setting. (Lower means “closer to Browsing.”)
For information on setting and changing a stack’s user level,
see “Protecting Your Stack” in Chapter 2. «

The Text Arrows option

When you click any user level button except Browsing on the
User Preferences card, a check box labeled Text Arrows appears
(see Figure 1-11). You select or deselect this option by clicking it.

When this option is turned off, the arrow keys on the keyboard
move you through cards in a stack; when this option is turned on,
the arrow keys move the insertion point through text—ijust as they
do in most word processors. (The Message box is a place where you
can type instructions to HyperCard. It's discussed in the section

Looking for Specific Text,” later in this chaprer.)
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[ 1Text Arrows

Takes you to the Takes you to the Takes you back Takes vou forward
previous card in next card in the through cards through cards

the current stack current stack VOUL'VE seen vouve reviewed

B< Text Arrows

\-‘I\

| ]

Moves the Moves the Moves the Moves the

insertion point insertion point insertion point insertion point

left over text gl over Lext down through up through lines
lines in a field in a hield. or t
or 1o the end of the beginning of
the hne in the the line in the
Message box Messige box

Figure 1-13  The effect of the Text Arrows option
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When “Text Arrows is turned on, yOU Must press the ( )ption kev in
combination with the arrow keys to move through cards in a stack:

To go 1o the previous card
in the current stack

To go to the next card

in the current stack

To go back through cards

VOU'Ve seen

[ go forward through
cards you've reviewed

Figure 1-14  Moving through cards when the Text Arrows option is turned on

> See alo: ”:\-1“\'ing Around in a Stack” in this L‘h.lprm'
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How HyperCard
finds stacks

The Power Keys option

When you click Painting (or a higher user level) on the User
Preferences card, a check box labeled Power Keys appears (see
Figure 1-11). When the Power Keys option is turned on, you can
use specific keys on the keyboard to make changes to graphics—
pressing a single key does the work of choosing a menu command
that affects the selected graphic (or the graphic element you've just

created). You select or deselect the Power Keys oprion by clicking, ic
4 I : :

» Seeabo: "\ Ising Power Keys™ in Chapter 6

The Blind Typing option

When you click Scripting on the User Preferences card, a check h(.
labeled Blind Typing appears (see Figure 1-11). When this option is
turned on, you can type in the Message box even when it’s hidden

(as long as the insertion point isn't in a field). Typing in the Message
box sends instructions to HyperCard.

You select or deselect the Blind Typing option by clicking it. When
the Blind Typing option is turned off, you can type in the Message
box only when you see it on the screen. When this option is turned
off, HyperCard beeps if you try to type in the Message box when

it's hidden.

The Message box is discussed in the section “Looking for Specific

Text,” later in this chaprer.

When you tell HyperCard to open a document, an application,
or a stack—by clicking an icon on one of the Home cards, for
example—HyperCard searches for the file by first looking in the
folder that contains the current stack. Then it checks the Search
»aths card in the Home stack (described next) to see where clse to
look for the requested file.

To see the Search Paths card, first go to the Home stack (if you're
not already there) by choosing Home from the Go menu or

pressing - ~-H. Click the User Preferences button, and when the
User Preferences card appears, click the Search Paths burton.
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'| s line lx'H'-

I |‘_;5}L'!'E ard o look L [Stacks:

for stacks in the
folder Stacks.

The following figure shows the Search Paths card:

You can click these buttons 1o see the Search Paths ficlds for non-
HyperCard documents or applications. The information in these
ficlds helps HyperCard find documents and applications you try
o open from within HyperCard

T
Home Stack / Search Paths

m [ Aoplications | | Documents |

HyperCard 1S -
|
|

Help

Figure 1-15  Where HyperCard looks for stacks

There are three fields on the Search Paths card that tell HyperCard
where to look for files. One tells HyperCard where (in which
folders) to look for stacks, another tells it where to look for
documents, and a third tells it where to look for applications.

lo view cach hield, click the appropriate button on the Search Paths
card. These fields contain lists of search paths, or pathways through
the folders on your disk, that HyperCard should follow to retrieve
a stack, application, or document.

If you ask HyperCard for a file it can't find (that is, one whose
search path isn't recorded in the appropriate field on the Search
Paths card), it displays a directory dialog box and asks you where
the file is. (Figure 1-7 shows a directory dialog box.) Use the
directory dialog box to locate the file. Once you've located the file,
HyperCard notes the disk and folder (and subfolder, if necessary)
where the file is located, and records this information in the
appropriate field on the Search Paths card. The next time you ask
for that file, HyperCard will know where to look for it without
having to ask you (unless you’ve renamed it or changed the name
of the disk or folder that conrains ir).
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Getting 1o the
Home stack

Alchough HyperCard updates the Scarch Paths card for you (as just
described), you can also add search paths to the card yourselt. For
example, if you move a stack into a folder named Old.Stacks within
the Stacks folder, you can add the following line to the Stacks field
on the Search Paths card (so HyperCard will know where to find

the stack):

:HardDisk:HyperCard:Stacks:0ld.Stacks:

To add a line to one of the Search Paths fields, just click and rype.
When you rename a disk, folder, or file, you can change its name in
the appropriate Search Paths field. Or, if you prefer not to deal
directly with these cards, you can always use the directory dialog
box to help HyperCard locate the files you need.

2w Oeccasional housecleaning: HyperCard keeps a search path on .
record until you erase it. It's a good idea to erase a search path
you no longer use, to free that space on the Search Paths card
and help HyperCard search for files more efficiently. To erasc a
search path, just drag to select it, then choose Clear from the

Edit menu.

While you're using Hypcr\(jnrd. you can get to the Home stack

by doing any of the following:
s Choose Home from the Go menu.
s Press -H (press and hold the '~ key while you press H

for Home). .

» Click the button with a house icon, which appears in many
stacks, or another button that’s linked to the Home srtack.

s Choose Message from the Go menu (or press  -M), type

"Home". and press Return.

s Choose Open Stack from the File menu (or press  -O), and
locate and open the Home stack using the directory dialog box.
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Opening and
closing stacks

Opening a stack

Because HyperCard automatically (without asking) saves any
changes you make to stacks as you work, it’s a good idea to make
sure you have a backup copy of a stack before you open it. Thar way,
if you change the stack (intentionally or otherwise), you can always
go back to the original version. (“Saving a Copy of a Stack” in
Chapter 2 gives instructions for making a backup copy of a stack.)

There are several different ways to open a stack:

- 1 I
é _;_3 Dauble-click the stck's icon in the

PicturePuzzler

Finde

Click a4 button that's linked to the stack
(if there is such a button),

0 A
go to stack "PicturePuzzler" — Choose Message from the Go menu 1o
open the Message box, type go t«
stack and the stack’s name (in quotes),
and press the Return key.

New Stack...
Oven Stack 50 Choose Open Stack from the File menu
S [: s and open the stack

ave a Lopy...

Figure 1-16  Opening a stack

 About stack names: A stack name that you see in the Finder or in
a directory dialog box may differ from the name that appears on
the HyperCard button that takes you to thar stack. This is
because the stack’s name must follow the standard Apple 11Gs
naming, rules for documents, whereas the rules for naming
HyperCard buttons are more flexible. When you type in the
Message box to open a stack, you must type the stack’s name
the way it appears in the Finder. <
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When you double-click a stack’s icon in the Finder, HyperCard
will launch (and the stack will open) only if you have installed
HyperCard correctly and have not subsequently moved any of its
files. For more information, see “HyperCard Icons and the Finder,”

earlier in this L‘haptcr.

When you click a button or type in the Message box to open a
stack, HyperCard looks for the stack using the strategy described in
the section “How HyperCard Finds Stacks,” earlier in this chaprer.
[f it can’t find the stack, HyperCard displays the direcrory dialog
box and asks you to tell it where the stack is. (If the stack is on a
floppy disk, make sure that disk is in one of your drives.)

When you choose the Open Stack command, HyperCard &
displays a directory dialog box and waits for you to tell it which

E\[Ll&.’l{ Lo (]pt‘ll:

[his is the current directory level. You
can see the next higher level in your disk
directory (if there is one) by clicking
here or pressing Esc

Locate the stack Choose a stack:
you want o open <=:HordDisk:HyperCord: sty ¢
by double-clicking (Volumes — You can view the
16 open folders '.; T Home volumes that are
- i O Stacks currently avadable
volumees i s st 3 Tour e e
Wien vou see ﬂ (pen il CF ST O
[ i W chickimg her
! s [ s : =2 ¥ | ! % 11}
Eily ko
Lupen i ( Cancel ) Faby key .

Fieure 1-17  Opening 4 stack with the Open Stack commund
g | : |
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After you double-click the stack (or select it and click Open),

HyperCard closes the stack you are currently looking at and opens

the stack you selected.

Opening a stack protected  When you tell HyperCard to open a stack that’s set for private
with a password — access, you see the following dialog box:

This stock requires o possword:

[ ]

|i 0K Il |Euncel|

Type the password
here and click OK.

Figure 1-18  Opening a stack set for restricted access

To open the stack, you must know the password and type it

correctly, character for character—except that capitalization doesn't
matter. (As you type, you will see asterisks, not the actual letters you

type.) Then click OK. If the password you type is incorrect,
HyperCard tells you so and won't open the stack.
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UpCI'II]'I}.,T a locked stack  When you open a stack that’s locked—for example, a stack for
which “Can’t modify stack” is selected in the Protect Stack dialog
box—a small padlock (&) appears in the menu bar:

s The small padlock
I tells Yo that the
stack 1s locked-

"""""""""""""""""" OU can't make
h’h:t!nlilcunshnwlungbenkuhuneﬁilki i 1' e ]_ z
scoops to help them cotchwriggly, slippery [ changes o it

| fish. They hunt cooperatively, surrounding |

i fish in the water,

nlr Ed1t Eu Tools Uhmts

| When they hatch, pelicans have no feothers
| ond need their porents to protect them from
the sun.

| Inthe summer, Nilcnns like the open water
| of morshes in the northern United Stotes and
il southern Canadn. They spend the winter in

¥l Florida, California, and Mexico

Figure 1-19  Working with a locked stack

You can use a locked stack and copy information from it, but if you
try to make any changes to it, the following dialog box appears:

Con't modify this stack.

Figure 1-20  Trying to make changes to a protected stack .

P Secabo: + “Protecting Your Stack” in Chaprer 2
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Cl ISINE 1 stack  There are two ways to close a stack:

= Quit HyperCard. HyperCard saves any changes you've made to

the current stack betore closing it and quittng,

= Open another stack. (See “Opening a Stack,” earlier in this
chapter, for instructions.) HyperCard saves any changes you've
made to the current stack before closing it and opening the
El[]1L'|' .\'lll(_'[(.

« Before you close a stack: 1t's a good idea to choose Compact Stack
from the File menu before you close a stack that you've changed
significantly. This rearranges the current stack on the disk,
removing any unused space so that it fits into the smallest
possible space. The Compact Stack command is always visible

. when your user level is Painting (3) or higher. You can make it
visible when your user level is Typing (2) by holding down the
key while you pull down the File menu. «
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Lo )l(lng One of the best ways to learn about HyperCard is to explore
the )UQh stacks stacks—including the stacks rl‘;a; come with Hg.f‘per(:ard. and any
¢ other stacks you can find. (The Preface gives informarion about
where you can ger additional stacks.)

Many stacks have a button you click to learn about the stack.
[t usually looks like one of these:

- r"'-%;..
Figure 1-21  Buttons you can click to get information about a stack

Stack menus I'f}-'pcr(':nrd allows stack dc‘vcl()pt"rﬁ to customize the menus that
appear with a stack. Therefore, you may encounter stacks that have
one or more of their own menus. You see a stack’s custom menus
(if it has any) only when the stack is active. The Picture Puzzler
stack and the Addresses stack are examples of stacks with their
OWN menus.

Customizing menus requires a knowledge of HyperTalk and
external commands (XCMDs). For information abourt customizing

menus, see the Scripter’s Tools stack.

Displaving the menu bar — If vou use stacks other than the ones that come with HyperCard,
YIS ¥
you might encounter stacks in which the menu bar is hidden. !u,
see the hidden menu bar, press the *' key and the Space bar at th

same time. To hide the menu bar again, press ~—Space bar again,
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.\!t}‘.'iﬂf’ around in a stack Moving around in HyperCard stacks—moving from card to card,
going to other stacks, and so on—is called browsing.

There are several ways to browse thmugh stacks:

s Choose commands from the Go menu (or type their ™ -key

equivalents).
m Click icons on the Go palerte.
s Click burtons or text in the stack.
m Press arrow keys on the keyboard.
= lype commands in the Message box.
) » Use the Find command to search for specific text.

To browse through stacks by clicking buttons, you must first choose
HyperCard’s Browse tool ().

This is l]]L'.Hl'L WSe -
dicking buttons 12

to browse /
thri '-ug;| jlr.n'.u:: :% g
O
Al

. Figure 1-22  Choosing the Browse tool

@ Cant see the Tools menu? 1f you can't see the menu bar, you can
make it appear by pressing ' '—Space bar. If you can see the
menu bar but not the Tools menu, you can make the Tools
menu appear by changing your user level to Painting, Authoring,
or Scripting. (For instructions, see “User Levels and Options,”
earlier in this chapter.) <

The techniques for browsing are described in the sections that

follow.
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Using commands in the Go menu

You can usc the commands in the Go menu to look through cards
in the current stack, look for specific text, go to another stack, or go
back through cards and stacks you've already seen.

Back - i
Home aH
Help 4?7
Recent R

First |

Prev 42 .

Next 43
Lost oy
Find... aF
Message (M

Show A11 Cards

Figure 1-23  The Go menu
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-key

Command equivalent What the command does

Back Takes you back to the last card vou saw

Home -H Takes you to the Home stack.

|‘:-._|;' 4 liakes vou i».-§|l;:|:-

e It LCts you review upr o the Bist Iy cards vou sis

First lor -« Takes you to the first card in the current stack

Pres -2 Takes you to the previous card in the current
stack,

. Next -3 Takes you to the next card in the current stack
Last dor -2 Takes §.<|l|Illl|:L".|L.|_‘.1IL!'.":I||k current stuck
Find i-F Lets you search lor specific text
Message =M Lets you navigate by typing commands in the

Message box.
Show All Cards  (No (. key) Shows you all the cards in the stack, one after

the other.

@ DPrev versus Back: The Prev command takes you to the previous
card in the current stack; Back takes you to the card you last
. looked at, which might be in another stack.

The Back and Recent commands are explained in more detail in

“Looking Through Cards You've Seen,” later in this chaprer.
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The cards in a stack are arranged as if they were looped on a ring,
When you're looking at the last card in the stack, choosing Next
[TUIII [hL‘ (_;{] menu [id((f.'i you I_')H.L'k to th(f ﬁ]‘h‘t f__'d.l'd in [h{_’ Sri_li__k.
When you're looking at the first card, the Prev command takes
you to the last card of the stack.

__Second e

First card

Last card

Figure 1-24 A stack is structured like a circular card file
gt

Using the alternate Go menu and Go palette

An alternate Go menu that contains icons instead of words appears
if you press and hold the (* key while you pull down the Go menu.
'Ilh(.' 1(:("15 dl'C qu]i‘fllllfl‘l[ o [I]C l.:(}[".[]n"lél]'ld.‘i iI'l [h(‘.‘ I'L'gl_ll'e_ll' (0 menu
You can choose any of these icons by dragging and releasing the .
mouse button, the same way you choose a regular menu command.

You can also “tear off ” the alternate Go menu (as shown in the
following figure) to create a moveable Go palette that you can leave
open while you work, so you have easy access to all the navigation
commands. To do this, hold down the ™ key and drag down
through the menu, past the bottom or beyond either side.
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Edit i) Tools Objects

'%)[] You can close the

155 Go palete by
clicking here.

i To move

SN
k [6[&]=D|D0]  here

To tear off the alternate Go menu,

Click any 1con 1o
drag beyond the bottom or side choose the command
of the menu. it represents.
. Figure 1-25

Tearing off the alternate Go menu

Clicking an icon in the Go palette does the same thing as choosing
the corresponding command from the Go menu:

Home Help

A

Back Gé] Et 22 IE== recen:

B u
First

o |IEI G| = %ﬂ_m

|-'md_(:].. m—— li}-f}

‘.\'iu w All Cards

Message

Figure 1-26  The Go palette

You can make the Go palette disappear by clicking its close box.
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Clicking buttons to move around

A stack can have lots of different kinds of buttons. Some buttons
take you to another place in the stack (or to another stack) when
you click them. Other burtons make things happen right where you
are—a button might make a sound, make a message appear, or
create an interesting visual effect.

w  Where are the buttons? You can find all the burtons on a card
(except those that have been deliberately hidden) by holding
down the  and Option keys at the same time. Gray or colored

rectangles appear around the buttons.

Clicking buttons is one of the most effective ways to explom a stack.
Here are some buttons that are commonly used for moving :u'ou.
in stacks:

K <& © o < Mk

First Previous Next Last Return Home
card in card in card in card in
stack stack stack stack

Figure 1-27  Navigating with buttons

@ You click only once: One click is enough to make a HyperCard
button work—don’t double-click it. When you double-click a
HyperCard button, sometimes HyperCard saves the second
click until another card appears. Then you might find you've
accidentally clicked a button you didn't mean ro click. =
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Clicking text to move around

In some stacks you can click text in fields to make things happen.
For example, you can click a topic on the first card of the
HyperCard Help stack to see a list of related subtopics, and

then click one of the subtopics to go to a card that contains
information about it. Clicking text can do the same kinds of
things that clicking burtrons can do.

Stacks thar rake advantage of this feature of HyperCard will
contain information abourt which text in the stack you might want
to click and why. Clicking text will have no effect unless the stack
includes a script thar tells HyperCard what to do when a particular
portion of text is clicked.

Using the arrow keys to move around

You can move from card to card by using the arrow keys on the
keyboard. The way you use arrow keys to move around in a stack
depends on whether the Text Arrows option is selected on the User
Preferences card in your Home stack.

When the Text Arrows option is turned on, you must press the
Option key along with the arrow keys to move through cards.
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When Text Arrows When Text Arrow:
Togo... is turned on, press is turned off, press

To the previous card in the
current stack

To the next cod in the
current stack

Back through cards you've
seen

Forward through cards
you've reviewed

Figure 1-28 Navigating with arrow keys

P Seealso: * “The Text Arrows Option” in this chapter
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Going to a specific card

If you know the name, number, or ID of a specific card in a stack,
you can go to the card directly by using the Go command in the
Message box. (You can use the Message box to send instructions to
HyperCard.)

You can find the name, number, or ID of the current card by
choosing Card Info from the Objects menu. (To see the Objects
menu, you must have your user level set to Authoring or Scripting,
“User Levels and Options,” earlier in this chapter, gives instructions
for Ch;mging your user level.)

The card’s name

Cord Nome: Im |

Card 10: 3046. Card number 1 out of 7

Che card's number

The card's 1D

Contoins 0 cord fields.
Contains 5 card buttons.
B Can't Delete
[1Don't Search

|Scriot.,.| lL‘nlnrs...I H 0K “ |tunctl|

Figure 1-29  The Card Info dialog box

To get to a specific card from any other card in the same
stack (or from another stack, such as the Home stack), follow
these steps:

1. Open the Message box (if it isn’t already open).
Choose Message from the Go menu, or press ("'-M.

2. Type any of the following, substituting the name, number, or
ID of the card you want to go to:
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To o to the card with the

1A 0 05O T LA A IS S0

go to cord "card name" specified name in the
e eyrrent stick

T T T AL To go o the card with the

go to card Y specified number in the
A 8 e e s current stiack

0 0 RS WS () the card with the

go to card ID 1672Y4 specified 1D in the curren
e stack

S To go to the card with the
go to card "card name" in stack "stack name" —— specilicd nume in the

ﬁ]wcltli{'d stack (Specihy
the stack name only wher

the card you want ln_l.

15 i another stack )

Figure 1-30  Going to a specific card

3. Press Return or Enter.

To hide the Message box, click its close box or press ~-M again.

Seeing all the cards in a stack

You can take a quick look ar a stack by flipping through all of its
cards quickly. The easiest way to do this is to choose Show All
Cards from the Go menu. But you can also use the Message box
to flip through the cards in a stack. Follow these steps:

1. Open the Message box (if it isn't already open).
Choose Message from the Go menu, or press — -M.
2. Type show all cards and press Return.

HyperCard shows you all the stack’s cards quickly, one after
the other.

) Chapter 1: Using HyperCard Stacks




Looking for specific text

To hide the Message box, click its close box or press ~ -M again.

[f you want to stop flipping through the cards, cither press the
mouse button or press -, (* -period). (This will also stop the
action if you choose Show All Cards from the Go menu.)

Some stacks have a button you can click ro see all the cards. It
usually looks something like this:

Figure 1-31 A button for flipping through the cards in a stack

You can also move around in a stack by asking HyperCard to find
specific field text. This makes it easy to find just the information
you need in a stack—no matter how large the stack is.

When HyperCard searches for specific text that you've asked it to
find, it pays no attention to case or to diacritical marks: “apple
Compiiter,” “apple computer,” and “Apple Computer” are all
considered the same.

You can search an entire stack for the text you want, or search only
in a specific background field.

Finding field text anywhere in a stack
1. Choose Find from the Go menu, or press ~-F

HyperCard displays the Message box with the Find command

n it:

A O

Find "' The insertion point

Figure 1-32  Searching for text
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2. Typc the text you want to find.

Make sure the texe you want to find is between the quotation

marks that appear after the word “Find” in the Message box.
3. Press the Return key or the Enter key.

HyperCard displays the first card containing a word or words
that begin with the specified text. (It looks for the first card with
a field that contains everything between the quotation marks,
even if the words are in a different order or in different fields).
HyperCard puts a box around the first word that starts with

the text you're looking for.

[f HyperCard can't find the text, it beeps. If this happens, Cl’lt!{jb

the text in the Message box for typos and spelling errors.

4. If you want to find the next occurrence of the same text, press
Return or Enter again.

You can repeat this step as many times as you like to find

additional occurrences of the same text.
To stop a search in progress, press . -. (_ -period).

+ Note: HyperCard won't look for text in fields for which the
option Don't Search is selected in the Field [nfo dialog box.
[t will also exclude from the search all fields that belong o
backgrounds for which the Don't Search option is selected in
the Bkgnd Info dialog box, and all fields on cards for which
Don't Search selected in the Card Info dialog box. < .

Once you're through with the Message box, you can close it by
clicking the close box in its upper-left corner. The next time you
choose Find, the Message box reappears with the Find command
in it—and the last text you typed between the quotation marks is
selected. You can search for the same text again by pressing Return
or Enter. To search for different text, just type the text you want to

find and press Return or Enter.
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+« lo jpf’m’ your search: 1f }rmi’rc Iooking for spcciﬁc text in a very
large stack, it’s best to give HyperCard a large enough portion of
the rarget text to distinguish it from other text in the stack’s
fields. This prevents HyperCard from displaying cards that don't
actually have the text you're trying to find. HyperCard finds text
faster when you specify the rarget text in strings of three

characters or more, not counting spaces. %

Finding text in a specific background field

[f you want to search for text only in a specific background field,
you need to know the name, number, or ID of the field. To find
out a field’s name, number, or ID, first choose the Field tool from
the Tools menu, and then double-click the field. (You must have
your user level set to Authoring or Scripting.)

Field home: ! The field's name
Bkgnd field number: 1 Bkgnd field ID: The field's ID
Olteeklet ™\ guye: (oot}

[Jfuto Tab The field's number
[CJoon't Search [ 5how Lines

[ Shaored Text [IWide Margins

(@

Figure 1-33  Finding out a field's name and number

To search for text only in a specific background field, follow
these steps:

1. Choose Find from the Go menu, or press "-E
2. Type the text you want to find.

3. Click after the last quotation mark in the Message box.

Chapter 1: Using HyperCard Stacks




4. Type a space, then type in background field and the
name (in quotes), number, or ID of the field in which you
want to search.

[f you type the field name, enclose it in quotes.

A 00000
Find "Hong Kong" in background field "Headquarters"

Figure 1-34  Searching for text in a specific field

5. Press the Return key or the Enter key.

HyperCard displays the first card containing a word (or wc.rds_.
in the specified background field that begins with the specified
text, and puts a box around that word.

If HyperCard can't find the text, it beeps. If this happens, check
the text in the Message box for typos and spelling errors.

6. To find the next occurrence of the same text, press Return or
Enter again.

You can repeat this step as many times as you like to see
additional occurrences of the same text.

To stop a search in progress, press -, ("-period).

% Note: HyperCard won't look for text in fields for which the
option Don't Search is selected in the Field Info dialog box. L
It will also exclude from the search all fields that belong to
backgrounds for which the Don't Search option is selected in
the Bkgnd Info dialog box, and all fields on cards for which

Don't Search is selected in the Card Info dialog box.

Finding a whole word or phrase

To search for a specific whole word or phrase in any field in a stack,
follow these steps:
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1. Press -Shift-F

T'he Message box appears with the Find Whole command in it

AN 000000000
Find whole "'

Figure 1-35  Scarching for a whole word or phrase

2. Type the word or phrase you want to find.
3. Press the Return key or the Enter key.

For the Find Whole command to find a march, all the characrers
must be in the same field on a card, and they must be in the same
consecutive order as they appear between the quotation marks.
For cxumplc,

Find Whole "Apple Computer"

tells HyperCard to find cards that have the phrase “Apple
Computer” in a field—it won't find “Apple Computers” or
“This apple is a computer.” (The Find command without Whole
would find matches for all three cases.)

Find Whole won't stop on cards that have only partial matches. For
example,

Find Whole "Ed"
won't find “Edward.”
To stop a search in progress, press -, ( -period)

As with Find, you can use Find Whole to search for text in a
specific background field (as described in the previous section).

The HyperTalk Help stack describes other ways to search for text in
background fields, including scarching for a specific string (that is, a
specific sequence of characters, regardless of word breaks) and for
individual characters.
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Moving from one stack  You can move easily from one stack to another using any of the
to another  following techniques:

a Click a burton that’s linked to the stack (if there is such
a button).

s Choose Message from the Go menu, type go "stack name",
and press Return. (Replace stack name with the name of
the stack.)

s Choose Open Stack from the File menu and use the directory
dialog box to locate and open the stack.

w If the stack is represented by a button on one of the Home cards,
you can press (-H to go to the Home stack, then go to the
Home card that contains the stack’s button and click the buttc)

Looking through  As you go from card to card and stack to stack, HyperCard
cards you've visited  automarically keeps a record of where you've been. When you want
to back up and review the cards you've visited, you can do either of
the following;

s Choose Back from the Go menu, or press Tilde (-) or Esc, 1o
go to the last card you visited, no matter what stack it’s in. To
continue retracing your steps, choose Back (or press Tilde or
Esc) again. You can review up to the last 100 cards you visited,
in the reverse of the order in which you viewed them.

w Ifthe Tilde key doesn’t take you back: Chances are you have
one of the Paint tools selected. While you're working with .
the Paint tools, press -Tilde to go back to the last card you
visited. (Pressing Tilde alone while using a Paint tool undoes
your last action.)

After you review the cards, you can press the Up Arrow key to
come forward again through the reviewed cards (or press
Option—Up Arrow, if Text Arrows is selected on your User

Preferences card).
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= Choose Recent from the Go menu to see miniature versions of
the cards you've visited most recently—up to the last 18 cards
you looked at (as shown in the following figure). A card
miniature appears just once, even if you've visited the card more
than once. Click a miniature and then click OK (or double-click
a miniature) to go to the card it represents:

Double-click any miniature to go
to the card it represents.

Cards recently viewed:

- IS | ok w1 g
A v R Rt
PRIEE PRI A

This is the card you were looking at
when you chose Recent.

Figure 1-36  Using Recent to go back to cards you've visited

To return to the card you were looking at when you chose
Recent, double-click the miniature that has a box around ir,
press Return, or click OK.
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Returning Home

Entering text

No matter where you are in HyperCard, you can always get back to
the Home stack. Here are four ways to do it:

—y= | e

(S 4 | \Lal

Choose Home Press | -H Click any button Choose Message
from the Go with the house from the Go
Menu icon, or another menu, type

button that's jo “Hamea"

linked 10 the and press

[ome stick Return
Figure 1-37  Returning to the Home stack .

When you return to the standard Home stack (the one that comes
with HyperCard) using any of these methods, you return to the
Home card you visited most recently—that is, the last Home card
you saw the last time you were in the stack.

You can also go Home by choosing Open Stack from the File menu
and using the directory dialog box to locate and open the Home
stack. This method always brings you to the first Home card,
regardless of which Home card you visited most recently.

The most common way to add text to a card is by typing into ﬁcl(p

+  Check your user level: To type and edit text in stacks, you must
have your user level set to Typing (2) or a higher level. If you
need instructions for changing your user level, see “User Levels
and Options,” earlier in this chapter. +
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If your user level is Painting (3) or higher, you must choose the
Browse tool (¥) from the Tools menu (if it isn't already selected)
before you can type text in fields.

i

Choose this tool
[\Ptil[:[: R EER
&S| S

Bao

IO |

.. not this tool, ! A Q =

Figure 1-38  Choosing the Browse tool

When your user level is Typing (or higher), the Browse tool
becomes an [-beam (I ) when you move it over a field you can
type in:

The I-beam pointer over

Hame | | Johnf Bloom ]

Cnlu-nnul 5...-_“ e 'nd 154 ;lﬂ Edj[}]h]t "f.";[ ﬂ':'d.
_ Rddress | | 6925 Daffodil Way 1

Stuu| | tn

Ty en] | s

. B Telehone] | svaem

Figure 1-39  The I-beam pointer for typing and editing text

o enter text in a field, just move the I-beam over the field, click in
the field, and type. You edit field text in HyperCard the same way
you edit any Apple IIGS text—you can click anywhere in the field
and begin typing, or drag to select text for copying, pasting,

deleting, or replacing,
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‘o fix typing mistakes while you're editing text in a field, do one of

the following:

s DPress the Delete key to delete characters to the left of the

insertion point, one character at a ume.

= Drag the [-beam over the incorrect text to select it, and then

retype or delete ir.

While you're editing text in a field, choosing Undo undoes all the
changes you've made since the last time you clicked in the field to
edit. Therefore it’s not a good idea to use Undo to fix typing
mistakes, unless you want to retype everything you've typed since
you last clicked in the field. To fix editing mistakes, it’s better to use
the Delete key, or select the incorrect text and retype or delete it.
To save the changes in a field (so that Undo can't undo them), click
anywhere outside the field.

O[I)’C"l'liﬂg You can launch an application from HyperCard by following
applications ~ these steps:
I. Open the Message box (if it isn’t already open)

Choose Message from the Go menu, or press  -M.

2. Type one of the following messages in the Message box,
substituting the names of the application and document you

want to open: .

0 00 A A

open ."uppliﬂutiun"

This launches the
specified application

This launches the
e e I, specal ied application

open "document" with "ﬂDDliGﬂtiﬂn" and {.1_[l)t't'|.‘i the
..... specified document

Figure 1-40  Opening an application
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3. Press Return or Enter.

4. If HyperCard displays the directory dialog box and asks you
where one of these files is, use the dialog box to locate and

open the file.

When you quit the application you've opened, you return to the
card in HyperCard from which you launched the application.

You might encounter stacks with buttons that launch applicadions.
When you launch an application by clicking one of these buttons
on a card, you return to the same card in HyperCard after you quit

the application.

. » Secabo: “Customizing Your Home Stack™ in Chaprer 2

G@[[ing hUIp iﬂ While you're working in HyperCard, you can always get immediate
[.]Vp(fr(“;“-d assistance from the HyperCard Help or HyperTalk Help stacks.

These stacks provide the following types of information:

s [ }fpcr{_:;lrd Hdp covers Hyper( ‘ard rasks rhrough the
Authoring level.

= Hyperlalk Help provides reference and conceptual information
abour HyperTalk, HyperCard’s script language. (For
information about how you might want to use HyperTalk,
sce the HyperTalk Beginner's Guide.)

There are several ways to get to the HyperCard Help stack:
s Choose Help from the Go menu.

m Press (-2,

s lype Help in the Message box and press Return.

m Click the Help icon on the Home card called Welcome (in

the standard Home stack).
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Once yuu'vc opcncd the Hypchard Hclp stack, it shows you how
to find the information you need.

[t you need help using HyperTalk, click the Hyperlalk burron at
the bottom of any card in the HyperCard Help stack to go to the

HyperTalk Help stack.

Although there’s some overlap between the material covered in this
book and the information in the HyperCard Help stack, these two
sources of information give different kinds of help:

» This book gives more details on some topics than the
HyperCard Help stack does. Turn to this book when you need
a more thorough discussion of a topic. To find information

quickly in this book, look up the subject in the Index ]

or Contents.

» The HyperCard Help stack provides immediare assistance on
your computer’s screen and gives concise instructions for tasks.
You can use HyperCard Help when you've forgotten some
procedure you read abour in this book, or when you want a
quick overview of a feature that's unfamiliar to you. The
HyperCard Help stack uses HyperCard’s features to explain
HyperCard and provides an excellent example of what
HyperCard can do.
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Lurilng a stack [f your Apple IIGS is part of a network that includes AppleShare file
' v 1|« N ey SEIVErS, VO dn use L 5T: “I( [ i F C server ‘t"ﬂ‘l
on a file Server  servers, you ca HyperCard stacks s:mrrhd‘nn ile server volumes
However, you need to be aware of the following considerations
when you use stacks on a file server:

= Aswith any file on a file server, you must have the appropriate
access privileges to use the stack. For information about access
privileges, consult your network administrator.

» If the stack is on a locked medium—a locked disk, a CD-ROM.
or a locked folder on the file server—or if it’s locked in the
Finder (thar is, if its Locked option is selected in the Icon Info
dialog box), any number of network users can use the stack at
the same time. However, no one can make changes to the stack.

[ J s When a stack is unlocked on a file server, only one person can
use it at a time. This user can make changes to the stack, but
others cannot open the stack while it’s in use.

The AppleShare network software uses a lot of your computer’s
random-access memory (RAM), which means there is less memory
available for HyperCard to use. Depending on how much RAM
you have installed in your computer (and on several other factors,
such as the number of desk accessories installed in your system), you
may find that HyperCard behaves in unexpected ways while you're
using the Paint tools or playing complex sounds. For more
information about such symptoms and what to do about them, see
“HyperCard and Your Computer’s Memory,” earlier in this chapter.
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Using a stack

on a CD-ROM

You can use any HyperCard stacks you have on a CD-ROM
(compact disc) just as you would other stacks. However, changes
you make to a stack on a CD-ROM won't be saved. If you want
your changes saved as you work, be sure to copy the stack to an
UlllOCde dlik :1l1d OPCII th{: StﬂCl( f['{)ﬂ_l [—hﬁ Ll[ll[J(:!{Cd dJ:Sl‘(‘

It’s best not to run HyperCard itself from a CD-ROM (or from
any other locked medium), or use a Home stack that’s on a locked
disk. Although you can’t damage anything by doing this, you might
encounter some annoying problems, like the following:

s Ifyour Home stack is on a locked disk, HyperCard can't update
the Home stack’s Search Paths card when you tell it where to
find stacks via the directory dialog box. Therefore, it never learns
where your stacks are and has to keep asking you to locate stacl@f)
when you want to open them.

»  When you're running HyperCard from a locked disk and you
launch an application, HyperCard returns you to the first card of
the Home stack when you quit the application, instead of the
card from which you launched the application. This is because
HyperCard can’t mark your place when you leave, as it would if
it were on an unlocked disk.
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= .
Qlil[[lﬂg I{\ S Card 1o quit HyperCard, choose Quit HyperCard from the File menu,
or press ' -QQ.
HyperCard doesn't ask whether you want to save changes, because
it saves your information automatically as you work.

e

ew Stack...
Open Stack... a0
Save a Copy...

Compact Stack
. Protect Stack...
Delete Stack...

Paoge Setup...
Print Card aP
Print...

Quit HyperCard &0

Figure 1-41  Quitting HyperCard
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Chapter 2

Creating and
Moditying Stacks

’]_}:is chapter provides examples of the kinds of stacks you can
create, tips for modifying existing stacks, and instructions for
creating a new stack. This chapter also describes how to customize
the standard Home stack that comes with HyperCard.

To do the rasks in this chapter, you must have your user level set
to Authoring or higher. For a few of the tasks, your user level must
be set to Scripting. When a task requires the Scripting level, the
istructions say so. (For instructions on setting, your user level,

see “User Levels and Options” in Chapter 1).




Creating stacks

This button dials
the phone number
shown to the left.

Once you've learned to get around in HyperCard, you can begin
thinking about the kinds of stacks you might want to create. You
don't need any programming experience to create stacks. Using
HyperCard's tools, you can combine text, graphics, and numbers
according to your own specific needs; and you can add buttons to
link related pieces of information.

Figures 2-1 through 2-5 show cards from stacks people have created
with HyperCard. These cards give you an idea of the kinds of stacks
you can build:

You can type name, address, and
phone number information here.

You can click these
buttons 1o Jook for
informanon or to
add or delete

cards

ol ik

TR

Ilnnl |

Company | ‘ Greenhouse Industries |

ﬂddrnsl

R

Zip Code i "hi
| LRI This button
I - . {f o
Telephone | | 535-9087 —— takes you to the

Home stack.

=
=

=

Stack Infs

[tlendsr  Home Iﬂ

!. I e 4§ ﬂ -I—_

This button This huton

gives you takes you 1o

information the Calenda

about the stack.  stack .
Figure 2-1 A stack that helps you keep track of phone numbers and addresses
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You can type
information about the
catalog item here.

This button takes you
to the Home stack.

This button allows you to
find time zone information
about a country by typing its
name in a dialog box.

This button allows you to

specify your own location and __§"

other information needed 1o
calibrate the stack.

This button tikes vou __8

to the Home stack

I'he name of the
catalog item

A picture of the
catalog item

PN 456-A Sprocket

This button

takes you to
the next card
in this stack.

This button
takes you to
the previous
card in this
stack.

This button
takes you to
the last card
you saw.

A stack that catalogs information about bicycle parts

Figure 2-2

You can click any country shown on this map to see information
about the time zone(s) and current time(s) for that country.

Time Zones

Select a country on this map...

A stack that provides information about time zones
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fs2

These buttons take you forward and back
through the parts of the current lesson,

e

This button prints
all the text for the
current Jesson.

Working with stacks
Protecting Stacks - Protected Stacks

This indicates the
current lesson’s
difficulty

Intermediate

l'he text for each part of | || Sacks.can bel

a lesson appears here.

This area is used for

l Advenced / -

Begianer

[ Let Me Try |

This button allows
you to try the
techniques taught
in the current
lesson

[:unlri

This button starts

This disk is
not write-
protected.

This disk
illustrations or 4s a4 is wnte-
workspace
This button shows —= In;rnductwnﬁ Lessons _EL LessonFlon
Vou miormanon :
about using the stack

s bunon tikes
vou back 1o the
current lesson
from any other
part of the stack.

Figure 2-4

_CATEGORY

E]nﬁnru Index

This button
provides
information for
the teacher
about the
current lesson.

|_ hc.k

£ IRRTTET:C s iR

| No Sisters

TITLE

You can type information [ Sound Ravice

about the record here.
HOTES

This button
takes you to
a glossary.

Index

Sound

1. Blueprint for Trouble 4:10
2 Totolly Great 2:13

3. Roscoe's family 3:30

4. Tolk tome in French 2:35
5. Sibling Rewelry 5:10

Sort

Quit

About this stack

bl o

oL S S

This button takes you
to the previous card in
this stack

Figure 2-5
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This button takes
you Lo the next
card in this stack.

A stack that catalogs a record collection

a demonstration

This button takes
vou Lo an index ol
key words and
related lessons.

A stack that teaches schoolchildren how to use HyperCard

You can

use these
buttons to
organize and
work with

| the stack

This button takes
you to the Home
stack.




The card layer versus
the background layer

The stacks that come with HyperCard are examples of the kinds of

stacks you can create with HyperCard. You can explore these stacks

to find out how they work by using the techniques described in the
. Iy Foow . - ¥ . ¥

section “Examining a Stack,” later in this chapter.

The way a stack works is determined by its scrips, which contain
instructions that tell the parts of the stack what to do. The
instructions are written in HyperTalk, HyperCard’s English-like
programming language. However, you don't need to know
HyperTalk to create scripts. For example, you can link a button

to another card without writing a word of HyperTalk. The button
will contain a scripe that tells HyperCard which card to go to—but
you don't have to know anything about how the script works to
make the button act the way you want it to.

If you decide you want to learn how HyperTalk scripts work, go
through the exercises in the HyperTalk Beginner's Guide.

When you look at a card, what you see is a composite of two
layers—a foreground layer, called the card layer, and a background
layer. Both layers can contain text, buttons, and graphics. You see
the elements of both layers when you look ar a card, as if the card
layer were a transparent layer in front of the background.
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The hackground layer

i B

73 '.)‘ - .E - '_,-d'
| 1e=
l o

What you see¢ when vou
look ata card is a

compuosite ol the card

The card layer liverard the

background layer

Figure 2-6  The background layer and the card layer

Any number of cards can share the same background. Each
background serves as a template for the cards that share it. The
elements in a background (that is, the buttons, text, and graphics)
appear in the same location on all the cards associated with that
background. If you want a button, field, or graphic to appear on a
number of cards, you put it in the background layer. Together, the
elements in a background give a similar appearance and function to
the cards that share the background.

You can see just the elements that are in the current background

by pressing -B to go to the background layer. (This is equivalent

to choosing Background from the Edit menu.) Pressing ~-B
repeatedly moves you back and forth between the card layer and

the background layer. .
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* File Edit Go Tools Objects Rddresses Toekgronnd —— When you're in
‘ the background

layer, the word
Backerond

Rddress | | T e kF
e appears in the
Show Hotes
e ment b
Stat
z Delete Card

el [ e

Zin Code

=

elephone

e
< D m

Suekind  Colendsr e

TIT

When you're i the background Liyes
you see just the elements that are in the
background—the elements in the card
layer disappear temporarily.

Figure 2-7  The background layer

The elements in the card layer appear only on that card:
yer app y

This text changes from card to card—it's part of the card layer l

e | . bl Hem Rome | | Babert Bt
L | Pensembmsss [ndvisries Commony | | byparn Semisenguntar
Mdrein | | RIS Betiedil vy Bidreds | | 100 LineolnWay —
Fiea | "I'T ity IIM;HIIH
Sate] | o Shate | | i
Zatate ] | a1 diatete ] | grit
o lepbara | | 555 GH) m— Telephone | | 555 7Tl —mn
= =
= =
i ' T

The other elements appear on all the cards—they're in the background layer

Figure 2-8 Background elements versus card elements
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What buttons, fields, The elements you add to the cards and backgrounds of a stack
and graphics can do  determine how people will use the stack.

for your stacks You can add buttons, which are rectangular “hot spots” you click
to make things happen. Buttons often link related information.
When you click a button that’s linked to another card or stack,
that card or stack immediately appears. The ability to link
information with buttons creates all kinds of interesting
possibilities, such as stacks that teach, stacks that let you play
a game, and stacks that present a report or a story.

In addition to linking information, buttons can also play songs,
launch applications, perform calculations, control videodisc
players, and much, much more.

= To put text on cards and backgrounds, you can add text ﬁclds..
You can set the style of the text in a field by choosing from a
variety of type styles. You edit the text in a field just as you
would in any Apple 11Gs word-processing program. You can also
search for specific text in background fields.

» Graphics can enhance the visual appeal of a stack and help
communicate its purpose. You can add pictures, charts,
drawings, and other graphics to stacks. Draw them yourself,
copy them from the stacks that come with HyperCard (or from
graphics applications), or scan them 1n.
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DF Tl Camman Nami

_ wtAILE Iﬂl’ﬁﬂhﬂ I[
Graphics o
created with | fionwis b fpeas I
the Paint tools | Serranlne spiloplears —
Habitnt L Field text

[ AmBzon river

Nots
o bravs b 15 inches. ir

[ tndex | Sort | tuit | _ o Nane neans "Inthed
i aed

bout this stoack| Card 7 fish”

I Buttons for navigating

. Figure 2-9  Examples of buttons, fields, and graphics in a stack

HyperCard comes with stacks that contain readymade buttons
and graphics that you can copy and paste into your stacks. The
readymade buttons contain pre-programmed scripts that can make
your stacks more useful. You don't need to know HyperTalk to
make these buttons work—you just need to understand whar they
do, so that you can use them appropriately in your stacks.

You can combine buttons, fields, and graphics in any number of
ways to create a stack that looks and works the way you want it to.
Chapters 4, 5, and 6 give detailed instructions for adding buttons,
fields, and graphics.
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Using Hy [)L,‘I'L:;i_ll[-\ lools  To create and work with buttons, text, and graphics in stacks, you
use the tools in the Tools menu. You can have only one tool selected
at a time, and one tool is always selected while you're using

HyperCard.

:I_ The General 1ools

| The Pamnt tools

G

o
C(O10(%W0
O\

[

Figure 2-10  HyperCard's tools

The Tools menu appears when your user level is Painting,

.-"\Urhnring. or Scripling.

The Tools menu contains the General tools and the Paint tools, as
shown in Figure 2-10. The General tools are for browsing, text
editing, and working with buttons and fields. The Paint tools are for
creating and editing pictures. If you've used an Apple IIGS paint
program, you know more or less how the Paint tools work. In most
cases, you choose the Paint tool, then drag to make it work. (The
Paint Text tool is an exception. To make it work, you first choose it,

then click and type.) Lo
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th e Browse The Button tool = I'he Field tool
£ } 1ol is tor D is for working - is for wy rking
Drowsing with buttons with liclds

through stacks
and editing

text.
=1 The Selection F The Lasso is =) The Pencil
l-a taol 1s for for selecting F-F' draws thin
selecting nonrectangular free-form
graphics graphics lines

g&) The Brush g The Eraser J.l"' The Line tool
. paints with erases the part draws straight

the current of a graphic lines
pattern or vou drag it
color Over.

:'D'E The apray tool D The RI:.'L'..‘,J'JIL’JL‘ I:I The Rounded
spritzes paint tool draws Rectangle

onto the rectangles and ool draws
screen in the squares. rectangles
current pattern with rounded
or color corners
.:ﬂ_a The Bucket fills D‘ The Oval tool Q_'-.-" The Curve tool

enclosed areas draws ovals draws free-form
or one-color and circles, lines and
areas with the shapes

. current pattern

or color

The Paint Text I:::I The Regular
£ tool is for Polygon tool

The Polygon

100l creates

]

lyping texl credtes polygons with
that's pur ol polygons with irregular sides
a graphic regular sides

Figure 2-11  What the tools are used Tos
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You can “tear off” the Tools menu (as shown in the ﬂ}lluwing
figure) to create a movable 7ools palette. To do this, drag down
through the menu, past the bottom or beyond either side.

6o Objects

=

You can close the Tools
palette by clicking here.

To move the
palette, drag

> | P || D=
2(O(O(Q[D]0
RSO ]

= =
e P ‘? from here
\ &SP
i) (5] [ @
O |2
AlD|Z
To tear off the Tools menu, drag beyond Click any tool
the bottom or side of the menu, to choose it

Figure 2-12  Tearing off the Tools menu

e A shortcur: You can make a Tools palette appear or disappear

quickly by pressing Option-Tab. «

To choose any tool in the Tools palette, just click it. (Depending on
the tool you select, the shape of the pointer might change.) The
Tools palette remains visible on your screen until you click its dos@
box, or until you press Option-Tab to make the palette disappear.
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Selected Paint tool

Even if you have the Tools palette open, you can still choose a tool
from the Tools menu (in the menu bar)—the palette reflects your
menu choice. It's a good idea to leave the Tools palette open while
you're working on a stack, so you can see which tool is selected.

When you choose one of the Paint tools, three new menus appear:
Paint, Options, and Patterns. (These menus are described in
Chaprer 6.) The Objects menu disappears while you're using a

’aint tool. It reappears (and the Paint, Options, and Patterns menus
all go away again) when you choose any of the General tools.

I'hese three menus appear when
you have one of the Paint tools
selected,

int

Options Patterns

File Edit Go Teols Pa

e s e

Home Stack / Déslsel

tulmdr el (S

el g

=iV

S ] o] (e
Ef_.i_l L EE
Addresses AlO|E

[ Deskser | INETINCTSN|

Figure 2-13  Menus that accompany the Paint tools

Chapters 4, 5, and 6 give specific instructions for using
HyperCard’s tools to create buttons, fields, and graphics,
respectively.
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Selecting buttons, fields,
and graphics

To select and work with the different HyperCard elements—
buttons, fields, and graphics—you need to use different tools. And
you select and manipulate one element ac a time. You can't select

multiple elements.

To select a button, choose the Button tool (=) from the Tools
menu and click the button:

Choose the and then chick
Button Tool the button 1o select it

=h F’ :

E:C e When a button
'Addresses; is selected, ir's
2. i ..,i, .. surrounded by

4 moving

dashed line
Heloone | [IETCVN

Figure 2-14  Selecting a button

Whether the button is in the background layer or the card layer,
you can select it from the card layer. When the button is selected,
it’s surrounded by a moving dashed line.
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To select a tield, choose the Field tool (1) from the Tools menu and
click the field:

Choose the .and then click
Field tool the tield to select i
Tools Zip Code ||| [89647___

== )

TR 0 rie e

. ‘\tht‘ﬂ a field is selected,
it's surrounded by a
moving dashed line

Figure 2-15  Selecting a field

Whether the field is in the background layer or the card layer,
you can select it from the card layer. When the field is selecred,
it’s surrounded by a moving dashed line.
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There are many different ways to select a graphic. Generally, you
choose either the Selection tool (72) or the Lasso (+) from the Tools
menu and drag to select the graphic:

and then drag
diagonally with the
Selection tool Or drag around the

[rom here grplic with the Lasso

#

Choose the
Selection ool

or the Lasso . . AR

R T e T Ee T R
S
—
i
-
o
o, o L L L L L L

o DI e o
Figure 2-16  Selecting a graphic

» Secalo: o “Selecting a Graphic” in Chaprer 6
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]’Iallming 4 Stack  Before you begin building a stack, you should have a clear idea
" of who will use the stack and what you want the stack to do.
Knowing your audience and the scope of your stack can help you
make decisions about the design of your stack—both before you
start and while you're building it.

[f you expect your stack to be used by other people, make sure you
know what they will use your stack for, and in what context. Find
out what your users already know, how much experience they have
with computers and HyperCard, and what their reading level and
attention span might be.

An understanding of the stack’s users can help you decide how to
present the information in the stack, how much text and how many

® graphics to use, and how to structure the stack. For example, a stack
for teaching children geography skills might require lots of pictures,
a simple and consistent way to navigate through information, and
frequent reinforcement. Depending on your stack’s subject marter,
you can choose from a variety of presentation methods—including
a slide show, a tutorial, a game, or an interactive story.

Before you begin building a stack, it’s a good idea to draw a map
showing the structure of the stack, which cards are linked rogether,
and how users will move through the stack. If the map looks
confusing, it’s probably an indication thar the resulting stack will
be confusing and difficult to use, and you might want to consider
simplifying the stack’s structure.

] « Keep your stack simple: Adding lots of buttons and links in your
stack won't necessarily make information more accessible—
users can get lost or confused easily in a stack that has too

many links. «
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The stack-building
Process

Building a stack involves deciding how to present and structure the
information (as discussed in the previous section, “Planning a
Stack”) and carrying out your design decisions by creating cards,
backgrounds, buttons, text fields, graphics, and links berween
related pieces of information. (Chapter 3 explains how ro creare
cards and backgrounds; Chapters 4, 5, and 6 give derails about
creating buttons, text fields, and graphics, respectively.) Most of
your stack-building time will be spent on the details of integrating
text and graphics, and making the stack easy to navigate.

As you build a stack, it’s important to evaluate it frequently, to

make sure it still does what you've designed it to do. To evaluate a
stack, try it out yourself. See if you can accomplish the tasks for
which the stack is designed without getting lost or feeling confusedff)

[f the stack will be used by others, show it to people who are similar
to your users in background and level of computer experience. Give
them specific tasks to perform, and watch and listen carefully—
without interfering—while they try the stack.

As you evaluate the stack (and watch others use it), keep the
following questions in mind:

= s it clear what the stack is for and how to use it? The text,
buttons, and visual images in the stack can communicate a lot
about the stack’s purpose. They should be understandable and
consistent (in appearance and behavior) and should clarify the
purpose of the stack. If the stack is confusing, think about ways
in which the text, buttons, and visual images can be improved l.
create a clearer visual message. The stack should also give the
user appropriate feedback (for example, most buttons should
highlight when they’re clicked).
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= s it easy to get around in the stack? Make sure that, as you use
the stack, you can tell where you are, how you got there, how
to get back to where you came from, where to go next, and
how to leave. If it’s easy to get lost or trapped in the stack,
consider reducing the number of links, or simplifying or
clarifying the navigation scheme (for example, by using a
standard set of navigation buttons on each card).

= Do the features work correctly? Test the burtons to see if they
take you where they’re supposed to in all circumstances. Make
sure each field is visible and unlocked if the user needs to see it
and type in it, or locked if the user just needs to read or click
text in the field. The stack should prevent the user from
losing information and make it clear when an action will
not be reversible.

s Does the stack require a particular user level? The features
available to a user vary with the user level (as explained in
“User Levels and Options” in Chapter 1). Try using the stack
at every user level. If it has any features that require a certain
user level, make sure the stack either sets the appropriate user
level (through the stack script) or tells the user to set the
appropriate user level. (The HyperTalk Help stack describes

how to set the user level through a script.)

Obraining periodic evaluation and feedback from typical users is
an important part of building a stack. It’s a good idea to begin
evaluating a stack early in its development. HyperCard makes

it casy to build a prototype of your stack that you can use for
gathering preliminary feedback from users. Be prepared to make
changes to the stack to fix problems and incorporate ideas that
grow out of your evaluation and user testing.

When you've finished building a stack, put it through a final test,
checking all of the points listed above.
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Modifying an
existing stack

For more detailed information on designing a stack, consult
the HyperCard Stack Design Guidelines (available from
Addison-Wesley).

Modifying stacks created by others is not only a great way to learn
about HyperCard—it’s also a good way to get stacks that are
tailored to your needs. There are lots of ways to customize an
existing stack. You can add text and pictures and create new links
between picces of information. You can make new cards and cards
with new backgrounds or change any of the elements of a stack in
any way you like. You can even delete any elements you don't want.

This chapter includes the basic information you need to create am’
modify stacks. Chapter 3 describes how to create and manipulate
cards and backgrounds. Chapters 4, 5, and 6 give details about
working with buttons, fields, and graphics, respectively.

[ you want to modify stacks created by other people, you should be
aware of the following considerations:

» FEach object in a stack—that is, each button, field, card, and
background, as well as the stack itself—can have a script
attached to it. Scripts contain instructions that tell che different
objects in a stack what to do. The scripts that belong to the
different objects in a stack often interact with other objects and
their scripts. When you delete any object that conrains a seripr,
or move it to another part of the stack, its script goes with it. 1f.
other scripts rely on that object or its script (or vice versa), you
may find that your stack behaves unexpectedly after you've
moved the object. For example, you might see messages that
begin with “Never heard of . . .” or “Can’t understand. . . .”
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[f you see such messages (or other strange behavior) in a stack
you're modifying, the stack’s scripts probably refer to objects
that you've changed in some way. If you're familiar with
HyperTalk, you might be able to fix or rewrite the scripts.
Otherwise, consider modifying a different stack or creating a
stack of your own. (If you want to learn HyperTalk, see the
Hyperlalk Beginner's Guide.)

= As you modify a stack, HyperCard saves your changes

automatically—without asking. Therefore it’s a good idea to
make sure you have a backup copy of a stack before you begin
changing it, so that you can get back to the original if you need
to. It's also a good idea to save a copy of your modified stack

. periodically while you’re working on it. That way, if you make
a mistake that “breaks” the stack, you can go back to a recent
version (rather than starting all over again).

= Some stacks are protected, which means you can’t change them.
A small padlock (a) appears in the menu bar when you're in a
protected stack. In some cases you can remove a stack’s
protection by using the Protect Stack command in the File
menu. ("Protecting Your Stack,” later in this chapeer, tells you
how.) However, in stacks that have a password, you can't change

the stack’s protection serting unless you know the password.
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Examining a stack

Before you begin modifying a stack, you can find out what makes it
work by examining its parts. The Objects menu contains some
commands to help you do this—Button Info, Field Info, Card
Info, Bkgnd Info, and Stack Info. Each of these commands presents
a dialog box that shows the characteristics of the pertinent object
(the selected button or field, or the current card, background, or
stack)—including the object’s name, number, and attribute settings.
Through these dialog boxes, you can learn about the objects in a
stack, look at their scripts, and change their attributes.

% 10 look at scripts: You must have your user level set to Scriptng.
“User Levels and Options” in Chapter 1 explains how to change

your user level. %

To locate and learn about the buttons in a stack, follow these s,tcp.
1. Choose the Button tool (=) from the Tools menu.

Rectangles appear around the buttons that don't already have

an outline;

When you

choose the .. rectangles appear
Button tool . . . around the buttons.
-1 Home Stack / Welcome User Neme |§ H“Tﬁ_@'rd lig i
Create ﬂl.ul:Ll-i.

: 4

| o] 2]

lielp Pioture Puzzier

Copyright € 1990 Aople Computer, Ine

BT [ Deskser [ Toalkin [ Ausic Bosement

B

Figure 2-17  Choosing the Button ool
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2. To get information about any button, click to select the
button, then choose Button Info from the Objects menu.

Or simply double-click the button. The Button Info dialog box

These options determine
the button's highlighting
behavior. (The Share Hilite
option is active only for
background buttons.)

This lets you assign an
icon to the button.

This links the butt imn

ta another card or stack

dppears:

[his option allows you to display
the button's name on the button,

¥,
Button Nome: [[TETUITR |

\Ekgnd button number: 1° Bkgnd button ID: 2\

st han seale
[ Auto Hilite . N
Fomily: [ 0 Cnone) |
=] Share Hilite

H 0K ﬂ' | Concel )

(ficn;LJ [Enlms ]1

,liiu'k here o see I'l'hlﬁ lets you assign
the button's script.  colors to different parts
of the button.

Figure 2-18  Getting information about a button
g !
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To locate and learn about the fields in a stack, follow these steps:
1. Choose the Field tool (1) from the Tools menu.

Lines appear in all the fields:

When you choose lines appear
in the fields

the Field wol . .

SRS o
T 5a

N R

Figure 2-19  Choosing the Field tool
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2. 'To get information about any field, click the field to select it,
then choose Field Info from the Objects menu.
Or simply double-click the field. The Field Info dialog box
appears:

The field’s name

hese aptions allow vou Field Nome: |mm/ | Fhe hield's number

to lock the field, prevent Band fieldnumber: 2 Bkond field 10: 3\ || The field's ID
searching in the field [ Lock Text Style: [ transparent § The selected
and mor [:]Fluw Tab stvle of the field
[(JDen't Search [1Show Lines
Click here orse e ey [__IShared Text Clwide H(]I'EH;l | Tiest opticns alow you

lorm or the hieled
format tor the tield (Font.. ) to display lines in the
AL b v e - t=] field and add margins.
. Click here to set [5"[“._| |Culnr5...| 0K Cancel ) &

the field's sc ripl

This lets you assignl Click here 1o close the
colors to different  dialog box without
parts of the field saving any changes

Figure 2-20  Getting information about a field
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To get information about the current card, choose Card Info from
the Objects menu. The Card Info dialog box appears:

The card’s name

o . Nome: | JEIDTETS -
The card's ID Cord ~ elcone = ] The card's number
Cord 10: 3046. Card number 1 out of 7 The number of fields
Select this opuon 1o Contains 0 cord fields. s in the card Laver
protect the L_'i“'d Contains 5 cord buttons. The number of
trom deletion. E=]Can't Delete huttons in the
select this option [ 0on't Search vard |'.1y1'r
1o exclude the fields m - e, lick | Joseil
- . - -tn]urs... Click here to close the
on this card from : : dialog box without
text searches, saving any changes.

Click hereto 1Click here 1o
see the card's  see the card's
sCripl. color sets.

Figure 2-21  Getting information about a card
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Select this ¢ |§‘l[ic>|'|
1o profect the
background
from deletion.

Select this option
to exclude the
fields in this
hackground from

text searches

You can sce what's in the background layer of the current card by

choosing Background from the Edit menu, or pressing ' -B. To get

information about the current background (whether or not you're
in the background layer), choose Bkgnd Info from the Objects
menu. The Bkgnd Info dialog box appears:

e background's 11 The background's name
: :

I'he number of

[ICan't Delete
[CJ0en't Search

.
Bkgnd Hame:
Bkand 10: 2760. Shared by 5 bards.

Contains 3 background fields.
Contoins 7 background buttons.

cards that share
this background

The number ol
fields in this
background

The number of

buttons in this

(script..) [Colers..) ( ox B[Eancel] background
l | R

Click here to
see the
background's
script

Click here 1o J!’Clit'k here to close

see the the dialog box
background's  without saving
color sets. any changes.

Figure 2-22  Getting information about a background
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To get information about the current stack, choose Stack Info from
the Objects menu. The Stack Info dialog box appears:

The stack's name

Stack Name: [ (RN

The disk and folder in Where: ‘HardDisk-HuperCord:
which the stack is stored St bk contuing 7 dands The number of cards
The niimhber . in the stack
Ihe number of Stack contoins 2 bockgrounds. u o
backgrounds in the stack Size of stack: 43K Ihe amount of disk space
The amount of free Free in stack: DK the stack reruires

space in the stack

Click here to see the [Scrint...] [Cnlurs_._] . J
stack's script .

Click here to see Click here o close

the stack's color the dialog box

sets. without saving
any changes.

Figure 2-23  Getling information about a stack
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Undoing your
mistakes

>

While you're working on a stack, you can usually undo your last
stack-editing action by immediately choosing Undo from the Edit
menu (or pressing - -Z), Choose Undo when you make a mistake,
or when you change your mind about your last action. (You must
choose Undo before doing anything else.)

Important: You can’t undo the deletion of a button or field. 2

To undo typing mistakes while you're editing text in a field, do one
of the following;

m Press Delete to delete characters to the left of the insertion point,
one character at a time.

® Drag the I-beam over the incorrect text to select it, then retype
or delete it,

While you're editing text in a field, choosing Undo undoes all the
changes you've made since the last time you clicked in the field to
edit. Therefore it’s not a good idea to use Undo to fix typing
mistakes, unless you want to retype everything you've typed since
you last clicked in the field. To fix editing mistakes, it’s better to use
the Delete key, or select the incorrect text and retype or delete it.
To save the changes in a field (so that Undo can't undo them),

click anywhere outside the field.

When you're using one of the Paint tools, pressing the Tilde (-) or
Escape key is the same as choosing Undo. (The Paint tools are

described in Chapter 6.)
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Modeling your stack
after an existing one

You can model a new stack after a card or stack you like by copying
its background. When you copy a background from an existing
stack, you get the basic design of the original stack—that s, its
template—but not any of its data. For specific instructions on
creating a new stack that uses a background from an existing stack,
see the next section, “Making a New Stack.”

Before you decide whether to copy the background of an existing
card or stack, you can look ar the background by going to that card
or stack and choosing Background from the Edit menu (or pressing
-B). This takes you to the background layer and shows you just
the buttons, ficlds, and graphics thatare in the background.
(Pressing - -B repeatedly moves you back and forth between the

card layer and the background layer.) o

» See the word Background in the menu bar? To make sure you're
looking at the background, check the menu bar. When you're in
the background layer, the word Background appears in the menu

lj dl. %

Toskgrowd —}— 1he word

B Backgroundells
e you that you're
Company | | | it looking at the
13 | [ ] hackground.

ilhje:tl Rddresses

VE L bk b bk AV T MR o LGB 0 SR P R RATL

ity
State
Zip Code

Telephone .

Sickinf  Calender

Figure 2-24  Looking at the background




\1 1!\|I]” Jd NCW Stace |\ When you're ready to create a new stack, begin by following
these steps:

If you want your new stack to have the same background as an
existing card or stack, go to that card or stack.

The previous section, “Modeling Your Stack After an Existing
One,” discusses why you might want ro copy a background
from another stack.

2. Choose New Stack from the File menu.

The New Stack dialog box appears.
3. Set up the New Stack dialog box for your new stack:
Your new stack will be stored in

this folder unless you choose
another folder.

= :HardDisk:HyperCard:

1803 free of 20860 K. m Click here to view
7] the volumes that are

currently availahle 1o

your computer.
{lose

New Stack Nome: [ Create )

Type a name [HuStenk l ( Concel )

LN Y OUELE 1 Copy Current Backaround

stack here,

Click here if you want your new
. stack to have the same background
as the current card.

Figure 2-25 Creating a new stack

— Important: If you want your new stack to have the same
background as the current card, be sure you click the Copy
Current Background check box to select it. 2
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4. Type a name for your new stack.
5. Click Create.

If you've selected the option Copy Current Background, your
new stack has all the same background elements as the card
you were looking at when you chose New Stack. Otherwise,

it’s blank.
As you build your new stack, your changes are saved automatically.

For instructions on adding cards and backgrounds to your stack, see
Chapter 3. For details about adding buttons, fields, and graphics,
see Chapters 4, 5, and 0, respectively.

Copying parts ~ Copying parts from other stacks can make stack building easier

from other stacks  and save you a lot of time. If you see a button that does something
you like, or an atrractive background picture, there’s no sense in
reinventing it—copy it and paste it into your stack. Two of the
stacks that come with HyperCard, Art Ideas and Button Ideas,
contain readymade parts you can copy and paste into your stacks.
The buttons in Button Ideas are designed to work independently in
a variety of stacks—they don't depend on your stack’s having any
particular characteristics. You can also paste fields, cards, and
backgrounds from any of the other stacks that comes with
HyperCard. (Chapter 3 gives instructions for copying cards and
backgrounds; Chapters 4, 5, and 6 explain how to copy buteons,
fields, and graphics, respectively.)

When you copy a button, field, card, or background from another
stack, its script comes with it (if it has a script). Scripts contain
instructions that tell the parts of a stack what o do. In most cases,
you want the script, because it makes the object work. (For more
information about HyperCard objects, see “Examining a Stack,”
;arlier in this chapter.)
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However, the scripts that belong to the different objects in a stack
often interact with other objects and scripts. An object you copy
from another stack might have a script that relies on objects in its
original stack. Copying such an object can cause your stack to act
strangely. For example, you might see messages that begin with
“Never heard of . . .” or “Can’t understand. . . .”

[f you're familiar with HyperTalk, you might be able to fix or
rewrite the object’s scri pt. (The HyperTalk Beginner’s Guide teaches
HyperTalk at an introductory level.) Otherwise, consider deleting
the script (as described next), copying a different object, or creating
the object yourself. (For instructions on deleting and creating
buttons and fields, consult Chapters 4 and 5, respectively.)

If you copy a card or background tha causes trouble in your stack,
and you can't fix the scripts, first try deleting the buttons and fields
on the card or background, one at a time. If the problem persists,
delete the script of the card or background by following

these steps:

1. Open the script.

To open the script of the current card, press -Option-C; to
open the background script, press “-Option-B.

2. Select all the text in the script by pressing ~-A.
3. Press Delete to delete the script.
4. Press Enter.

% Note: Aher you delete the buttons, fields, and scripts from a
card or background, you're left with just the picture on that card
or background. Any functions associated with the card or
background are gone.
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Getting information  You can use the Stack Info command to ger information about the

about i stack  current stack and change some of its characteristics.
Follow these steps to get information about the current stack:
1. Make sure you have one of the General tools selected.

The Browse tool (), the Button tool (=), or the Field tool ()

will work.
2. Choose Stack Info from the Objects menu.
The following dialog box appears:

The disk and folder in

The stack’s name which the stack is stored .
Stack Nome: [0 |
Fhe number ol Where: :HardDisk:HuperCard: The number of
backgrounds Stock contains 7 cards cards in the stack
in the stack Stack contains 2 backgrounds. The amount of disk space
The amount of free Size of stock: 43K, the stack requires
space in the stack Free in stack: OK.

Click here to close the

Click here to see (seriot..) (Coters.) E m } dialog box without

the stack’s script saving any changes.

Click here to see or change
the color set specified for
the stack

Figure 2-26  Getting information about a stack

3. When you're finished, click OK.

w Another way to open the Stack Info dialog box: 1f you are using the
Home stack that comes with HyperCard, the following shortcut
opens the Stack Info dialog box for any stack you're working in:
While any General wol is selected, press -M to open the
Message box, type s, and press Return. (This shortcut is built
into the standard HyperCard Home stack.)
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Naming i stack  When you first create a stack, you type a name for it in the New
Stack dialog box. This is the name that appears for the stack in the
Stack Info dialog box and in the Finder.

HyperCard uses the stack name to identify the stack. You can use
the stack name in the Message box to navigate to the stack. (And
you use the stack name when you address the stack through scripts.)

You can change a stack’s name at any rime (as long as the stack isn't
locked). Here's one way:

1. Make sure you have one of the General tools selected.

"The Browse tool (¥), the Button tool (=), or the Field tool (2)
will work.

2. Choose Stack Info from the Objects menu.

3. Type a new name for the stack.

Stack Nome: [TTREID ) Type the stack name

here. (This name
Where: :HardDisk:HyperCard:

. also identifies the
Stack contains 1 cards. stack in the Finder)

Stack contoins 1 bockgrounds.
Size of stock: 7K.
Free in stack: 0K,

(Seript..) (Colors..) t 0K ][Euncei]

Figure 2-27 Naming a stack

Follow the usual Apple I1Gs naming rules for documents: Start
with a letter; use no more than 15 characters; don't include
spaces; and don't use characters other than letters, numbers, or
periods. (If your Apple IIGS is part of an AppleShare network,
you have more choices. For more information, see the
documentation that came with your Apple I1GS.)
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4. Click OK.

Warning: Changing the name of a stack will break any links you've
made between a card in another stack and a card in the renamed
stack (it might even break links within the renamed stack itself).
When you change the name of a stack, be sure to redo all the links
to the stack. “Linking Information” in Chapter 4 gives instructions
for creating links. A

You can also L'h;mgu a stack’s name in the Finder:
1. In the Finder, locate the stack’s icon.

You might have to open folders or close windows to find .

the icon.

I~

. Click the icon once to select it.
3. Type a new name for the stack.

Changing the stack name here also changes it in the Stack Info
dialog box. Remember to follow the applicable naming rules.

4. Press the Return key.
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Ch[ll]g]ﬂg d 5111{_'1\'. S The color set for a HyperCard stack determines the 16 colors
L‘()](}I' set currently available for use by rhe backgrounds, cards, buttons, ..md
fields in the stack. You can choose from among five color sets for
any given stack: the standard system color set, a gray scale color set,
and three others.

When you change your stack’s color set, the colors of some or all
the graphics, buttons, and fields in the stack may change to reflect
the new colors. For example, these three images all make use of the
same graphic, but different color sets:

Standard system color set Gray scale color set

A pastel color set

Figure 2-28  The cffeat of changing color seis
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If you wish, you can select color sets for the cards and backgrounds
in your stack that are different from the color set selected for the
stack as a whole. If a card’s color set has not been specified
individually, the card makes use of the color set currently selected
for its background. Similarly, if a background’s color set has not
been specified individually, the background makes use of the color

set currently selected for the stack.

For example, the cards in the Birds stack make use of several
different color sets so that the colors used in each drawing match
the bird’s true colors more closely. By carefully selecting the color
sets for cards and backgrounds in a stack, you can control the colors

in your stacks more precisely than would be possible with just one

color set. .
The instructions that follow describe how to change the color set

for a stack. You can follow the same basic steps to change the

color set for a card or a h;lci-;ground from its Info di;tlug box (see
“Changing a Card’s Color Set” and “Changing a Background'’s
Color Set” in Chapter 3 for more details).

To change the color set for the stack you're working in, follow
these steps:

1. Make sure you have one of the General tools selected.

The Browse tool (¥), the Button tool (=), or the Field tool (CJ)

will work.
2. Choose Stack Info from the Objects menu. .
3. Click Colors.

The Colors dialog box for the stack appears.
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Select the color set you want:

Ihsnluu :nluri for stock "MyStock"

il T TR 1 1) Stondord system colors

m Groy scale

Fhese are the MR T W T WT T ] Other color sets...

TR | |
LLrrent s |~. ——— ) .
Click the one you When disploying this stack:
A [ Use these colors i

then press and hold the mouse button here and drag to
choose “Use these colors” (if it's not already selected) from the
. pop-up menu. If you choose “Get standard system colors”
instead, your stack will use the standard system colors no
matter which color set is selected for the stack

Figure 2-29  Changing a stack’s color set

When you're finished, click OK.

The Colors dialog box disappears, and you see the Stack Info
dialog box again,

6. In the Stack Info dialog box, click OK.

If none of the five color sets for a given stack includes the colors you

want, you can add a sixth color set to a card or background in the
. stack from any document in the Apple Preferred File Format.

“Importing a New Color Set for a Card or Background,” in

Chapter 6, describes how ro do this.
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daving a copy
of a stack

You ¢an type a name

here for the copy of
the stuck—otherwise

HyperCard will save
the copy under the
NAME you See.

You can also add a sixth color set to a card or background by using a
desk accessory, an XCMD, or HyperTalk to specify the colors you
want. If you use a desk accessory or an XCMD to do this, the color
set you specify will be added automatically to the color sets for the
current card or background and will be selected. For instructions on
using HyperTalk to add a sixth color set to a card or background,
see the discussion of the colorset property in the HyperTalk
Help stack.

P Secalo:  *"( “hanging Color Sets™ in ('.}mplt'r G

[t’s a good idea to make a copy of a stack before you begin workin.
with it, and save a copy of the stack periodically as you make
changes to it. This is because HyperCard automarically saves the
stack as you work. (Your work is saved, and so are your mistakes.)

If you make a big mistake on your stack, you can recover from it
more easily if you have a recent, working version of the stack—

you won't have to start all over again.

Follow these steps to copy a stack from within HyperCard:

1. While the stack is open and active, choose Save a Copy from
the File menu.

The following dialog box appears:

~=:HardDisk:HyperCard:Stocks: Your new stack
2545 free of 20860 k. ( Volumes ) will be stored in
71 Addresses this [older unless

vou choose

anather folder

L § Ak o
) LGILAl

Save copy of stack in;

[ddresses oy

Figure 2-30  Saving a copy of a stack
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Reclaiming free space
in a stack

2. Type a name for the copy of the stack, if you want to give it a
name that’s different from the one shown.

3. Click Save.

HyperCard saves a copy of the stack, but it leaves you in the
stack you're working on.

You can also copy a stack in the Finder. Follow these steps:
1. In the Finder, locate the stack’s icon.

You might have to close windows or open folders to find the
icon.

2. Click the stack’s icon once to select it.
3. Choose Duplicate from the File menu, or press (“-D.

The Duplicate dialog box appears.

4. Click OK.

Each time you delete a card, background, field, or button, free
space gets introduced into a stack. As you work on a stack, it can

accumularte a substantial amount of free space—and the more extra
space a stack has, the slower it runs and the larger it is.

Free space on a disk is available storage space. You can use it to store
information. But free space in a stack is like extra baggage in the
stack: It’s no longer useful, but it’s stored with the stack and it takes
up disk space that you could be using to store other data. The more
free space you have in your stacks, the less disk storage you have for
your other files.
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[he amount of disk
spaice the stack

s Lking up
(including free

space)

To check the amount of free space in a stack, choose Stack Info
from the Objects menu. To see the Objects menu, you must have

one of the General tools selected.

Stack Nome: [(PEITTL |
Where: ‘HordDisk:HyperCard:

Stock contaoins 1 cards

Stack contoins 1 bockgrounds.

Size of stack: 7K. The amount of free space in the
stack. If you compact the stack
this nomiber will become (O

(Seript...) [Colors..) |! 0K !I ( Cancel ) (zero), and the stack will get

smaller and run faster,

Free in stack: 0K

Figure 2-31  Checking free space in a stack

You can get rid of free space in a stack by choosing Compact Stack
from the File menu. To use the Compact Stack command when
your user level is Painting (3) or higher, you must have one of the
General tools selected. (If your user level is set to Typing (2), hold
down the ' key while you pull down the File menu in order to see
the Compact Stack command. If your user level is set to Typing (1),
the Compact Stack command is not available.)

When you choose Stack Info after compacting the stack, the
“Free in stack” number (in the Stack Info dialog box) will be OK
(zero K), and the size of the stack will likely be smaller than it was{)
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Prote 'L[lﬂg youl stack When your stack is finished—and perhaps while you're building
it—you might want to protect the stack to keep others from using
or changing it. There are several different kinds of protection you

can set for a stack:

» You can keep a personal stack private by preventing others from
opening it.

= You can limit access to a stack’s protection settings (so that no
one else can change them).

= You can limit the way people use and change a stack.

Hl‘."HII'IL'Hﬂ}_{ access  To restrict access to a stack so that no one can open it withour the
@ (o a stack  password, follow these steps:

1. Choose Protect Stack from the File menu.
The Protect Stack dialog box appears.

2. Click the Private Access check box to select it.

Protect Stack Limit user level to:
— () Browsing
[CJCon't modify stack O Typing

[ICan't delete stack () pginting

Click here [CJerivate fccess () Ruthoring
@ Scripting

GO G

then click here,

. 10 restrnct access Lo e stack

Figlll’t‘ 2-32  Setting protection for a stack

3. Click Set Password, or click OK.

The dialog box for setting a password appears.
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4. Enter a password.

| lype the password
Please enter o new password: | once here
| 1

.
‘ . and again here,

for verification
!_'['hen click OK.
Clicking None or Cancel closes
this dialog box without setting

N a4 password

Please enter it ogain:
[ |7

[ 0K :ﬂ [Cuncel]

Figure 2-33  Setting o password for a stack

5. Click OK. .

A Warning: Once you've restricted access to a stack and set a
password, the stack can’t be opened without the password. There’s
no way to find out a password once it’s been set—so make a note
of the password, or use a password you won't forget. A

When you type the password to open the stack, it must match
character-for-character the one you set. (Uppercase and lowercase
letters don't have to match.)

» Seealo: o “Removing a Password” in this chapter
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Protecting a stack from  ‘To prevent others from changing or deleting the current stack,
changes or deletion  follow these steps:
1. Choose Protect Stack from the File menu.
The Protect Stack dialog box appears.
2. Click “Can’t modify stack” or “Can’t delete stack.”
Click here to prevent changes to the stack.

Selecting just this option doesn't protect the
stack from deletion.

Protect Stack: Limit user level to:
\ .
. Browsin
. _ [JCon't modify stock g i !
l.lll.‘\' here 1o Prote [ the I:]Cun"t delete stock L’i:l"uinting
stack from deleton. Selecting ;
st thicemtinn dsesrt orotec [ Private Recess O"”",h“r_mg
just this.option doesn't protect @) Scripting
the stack from changes
et Possword ﬂ 0K ' |[:uncel|
e

Figure 2-34  Protecting a stack from changes or deletion

As long as the “Can’t modify stack” option is turned on, no one
can make any changes to the stack. (Anyone can, however, copy
'.mything from the stack, or copy the stack itself.)

As long as “Can't delete stack” is turned on, no one can delete

. the stack.

However, unless you set a password—as explained in the
following two steps—anyone can open the Protect Stack dialog
box and turn off these options.

103
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3. 'To prevent others from changing your protection settings, click
Set Password.

(This step 1s optional.)
The dialog box for setting a password appears.
4. Enter a pusswm'd.

(This step is optional.)

Type the password
Please enter a new possword: once here

| ] cund again here
Please enter it agoin: lor verification

| | [hen click OK .
a: 0K D [Eunce}] Clicking None or Cancel closes

this dialog box without setting

\ d password.

Figure 2-35 Setting a password

Setting a password for the stack prevents unauthorized users
from opening the Protect Stack dialog box, whether or not
Private Access is selected. If you've selected Private Access as well
as setting a password, the same password will be required to

open the stack itself.

5. Click OK.

Protect Stack dialog box without knowing the password, until you

remove it (as explained in “Removing a Password,” later in this
chapter). There’s no way to find ourt a password once it's been

.-'\Li-[i.‘l' \,'(HI’\-'L’ sera P;-ISS\\-’(H"&{. no one can IL'}'I;II]‘L_LL‘ [IIL‘.‘ ":L‘T.lil'lgh in [!'IL'

- S
SCT—=S80 ITI'J](!'_‘ a note of Ehl’.‘ ['H'LSS\-V{'JT(L Or use one you won t fDT‘t?;t'[.

Chapter 2; Creating and Modifying Stacks




When you're using a locked stack (that is, a stack for which the
“Can’t modity stack” option is selected in the Protect Stack dialog
box), a padlock (a) appears in the menu bar, indicating that you
can't make any changes in the stack. If you try to make changes to

a locked stack, you mig}]r see the ﬂ}Huwing di;l]ng box:

Con't modify this stock.

Figure 2-36  Trving to make changes to a protected stack

HyperCard automatically selects the “Can't modify stack” check
box when the stack is on a locked medium (a locked disk,
CD-ROM, or locked folder on a file server)—you can't deselect it.
"To make changes to such a stack, you first have to figure out why
it’s locked. If the “Can’t modify stack” check box is selected or the
Locked check box is selected in the stack’s Icon Info dialog box (in
the Finder), you have to deselect these options before you can make
changes to the stack. In many cases, copying the stack to an
unlocked disk makes the stack modifiable.

A Warning: Some stacks are designed so that, when the stack is
locked, you can type into a field or paint a picture on a card or
. background; but the changes disappear as soon as you leave the
current card. A
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Limiting the user level  You can limit the way people use and change a stack by limiting the
user level in the Protect Stack dialog box. Follow these steps:

1. Choose Protect Stack from the File menu.
The Protect Stack dialog box appears.

2. Click a user level.

Click one of these to choose a user

Protect Stock: Limit user level to: . i
O Browsi level, The user level determines the
" rowsing
(I Con't modify stack O Tuoing commands and tools people can
[dCan't delete stack () pojnting use in the current stack. When ths
Y Piiviki Nosesh (O Ruthoring user level is different from the user
@) Scripting level set in the Home stack, the I

lower of the two levels takes
| Set Passward | ' 0K ' |tunce]| l ki L &
precedence. (Browsing is the

lowest level.)

Figure 2-37  Limiting the user level

The options available at the different user levels are described in
“User Levels and Options” in Chapter 1.

Unless you set a password—as explained in the following two
steps—anyone can open the Protect Stack dialog box and

L'.|1;mgc the user level you've set.

3. To prevent others from changing the stack’s user level setting,
click Set Password. .

(This step is optional.)

The dialog box for setting a password appears.
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4. Enter a password.

("This step s opt ional.)

Type the password

Plegse enter a new possword: once here
— i
I | .and again here,
Pleasa ewter it oguin: | for verification
/
I | |_ Then click OK.
7
' 0K B ( Concel ) ‘ Clicking None or Cancel closes
== - v this dialog box without setting
\ \ a password

Figure 2-38  Setting a password

Setting a password for the stack prevents unauthorized users
from opening the Protect Stack dialog box and changing the
sertings, whether or not Private Access is selected. If you've
selected Private Access as well as setting a password, the same
password will be required to open the stack itself.

5. Click OK.

The tools and commands a user has access to while using the stack
are determined by both the user level you set in the stack’s Protect
Stack dialog box and the user level selected on the Preferences card
of the user’'s Home stack. When these two settings are different,
HyperCard uses the lower setting. (Lower means “closer to

. Browsing.”)

Atter you've set a password, no one can change the user level setting
in the Protect Stack dialog box without knowing the password,
until you remove it (as explained in the next section, “Removing a
Password”). There’s no way to find out a password once it’s been
set—so make a note of the password, or use one you won't forget.
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A Important: When the user level is set to Browsing or Typing,
(either in the Protect Stack dialog box or on the User Preferences
card in the Home stack), the Protect Stack command doesn't appear
in the File menu—which means you can't change any of the
protection settings. To get the full File menu (so that you can
choose the Protect Stack command) no matter whar the user level
is, press and hold the * key while you open the File menu.

Removing a password  Any password you set in the Protect Stack dialog box remains in
effect for the stack unil you remove it by following these steps:

1. Choose Protect Stack from the File menu.
You see a dialog box prompting you for the password. .
2. Enter the password and click OK:

This stack requires a password;

[ J

Figure 2-39  Lntering a password 1o open the Protect Stack dialog box

I'he Provecr Stack c]i;i];:; box appears,
3. Click Set Password. .

The din!og box for setting a pussword appears.
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Clicking here removes

the password

Setting user access for a
stack on a file server

4. Click None to remove the password:

Flease enter o new password:

[ |

Please enter it ogain:

L |

| e oK ’[Ennuell

Figure 2-40 Removing a password

The Set Password dialog box disappears—the password
protection is removed.

If you want to make a stack available to users on an AppleShare file
Server, you can protect it in various ways via the Protect Stack dialog
box, as described in the preceding sections. You should also be
aware of the following considerations:

= As with any file on a file server, you can make the stack available
to anyone who has access to the network, or only to people
who are registered users of the file server. For information on
setting file protection on a file server, consult your network

administrator.

= For a stack to be available to muldple users via a file server, the
stack must be either on a locked medium—a locked disk, a
CD-ROM, or a locked folder on the file server—or locked in
the Finder (that is, the Locked option is selected in its Icon Info
dialog box). When a stack is on a locked medium on a file server,
any number of network users can use the stack at the same time.
However, no one can make changes to the stack.
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Selecting the “Can't modify stack™ option in the Protect Stack
dialog box isn’t sufficient to make a stack available to more than

one user on a hle server.

m  When a stack is unlocked on a file server, only one person can
use it at a time. The user can make changes to the stack while
using it (unless changes are prohibited by the protection level set
in the Protect Stack dialog box), but other people cannort open
the stack while it’s in use.

D{'IL’[IHE_{ a4 Stack  When you delete a stack, you remove all the stack’s cards,
backerounds, and scripts. Delete a stack only when you have no
b b j _
further use for it.

To delete the current stack, choose Delete Stack from the File
menu. (The Delete Stack command is normally visible only when
one of the General tools is selected, and when your user level is
Painting, Authoring, or Scripting. When your user level is
Browsing, you can make the Delete command visible by holding
down the " key while you pull down the File menu.) Unless the
stack is protected from deletion, you see a dialog box like the

f :fi:'n,\'ing;;

Delete oll 6 cords from this stock?
HardDisk:HyperCord:Stocks:Addresses .

=)

|
Figure 2-41  Confirmation dialog box for deleting a stack
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Customizing your
Home stack

Lf the stack is protected from deletion, you see this dialog box
instead of the previous one:

Con't delete protected stack.

Figure 2-42  Trying to delete a protected stack

When you delete a stack with the Delete Stack command, it's

as though you dragged the stack to the Trash in the Finder—the
stack no longer exists on your hard disk. The stack disappears, and
HyperCard returns you to the Home stack.

You can customize your Home stack so that it’s tailored to the way
you work and the tasks you perform. With a few modifications,
your Home stack can even serve as the control center for all your
work on the Apple 11Gs—a launching pad for the applications,
utilities, documents, and stacks you use regularly.

You can organize your Home cards in any way you wish. For
example, you can put all the buttons you use on one card; or you
can put buttons that open applications on one card, and buttons
that open stacks on another. Or you can rename the cards according
to the categories you find most useful, and keep buttons on all five
cards. You can rearrange the order of the Home cards and change
the way each card looks, if you like.

This section explains all the ways you can customize the standard
Home stack that comes with HyperCard.
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Adding buttons to
your Home cards

The standard Home stack that comes with HyperCard includes five
Home cards. The first three Home cards contain buttons thar rake
you to the stacks that come with HyperCard:

» The buttons on the first Home card (called Welcome) open
stacks that introduce you to HyperCard, including the
HyperCard Help stack and the Tour stack.

s The buttons on the second Home card (Deskset) open the

HyperCard equivalent of an address book and desk calendar.

» The buttons on the third Home card (Tool Kit) open stacks that
you will find uscful as you begin to create your own stacks.

As you become more comfortable with HyperCard, you can make
these three Home cards even more useful by adding butrons that g
are linked to each of your favorite stacks, applications, and docu-
ments. ‘]':“'L] can :IISU ﬂdd bll[rﬂns o thi: OrhCI' two Home Cﬂ]—ds.

Betore you add a button to one of the Home cards, you need to
decide what you want the button to do and which Home card
you want to put it on. Buttons can take you to stacks, and they
can open other programs and documents, as described on the
following pages.

Adding a button that opens a stack

To add a button that takes you to another stack, follow

these steps:

I. Go to the Home card on which you want to place
the button.

¥

Chapter 20 Creating and Modilying Stacks




2. Click the Create QuickLink button near the upper-left corner.

A dirutml'}' Lli.tlug box appears:

Create o QuickLink vo which stack?
=2 Hordlisk:HyperCord:Stacks:
(4 Addresses
3 Artldeas
3 Birds

3 Buttonldeos
3 Calendar

3 IconEditor

3 PicturePuzzler
(3 ScriptersTools

Figure 2-43  Selecting a stack for your button to open

+ Did you get a different dialog box? 1f your user level is set to
Painting (3) or lower, you will first see dialog box asking you
to confirm that you want to create a new burron. You will
see the directory dialog box shown in Figure 2-43 after you
click OK. «

3. Using the directory dialog box, locate and double-click the

name of fl'lf.' StilC]{ you want your buttnn Lo open.

A ﬂ;whing button for the selected stack appears on the current

card.
4. Drag the flashing button to position it on the card.

When you release the mouse button, your new button Stops

Hlashing,

[f you want to test your new button, click it. It should open the
stack you specified.

» Secalio: o "Changing the Appearance of a Button™ in Chaprer 4
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Adding « button that opens an application

To add a button that opens an application (or a specific document
with an application), you must write a simple script. You can use
the technique described in this section to add such a button to any
stack, not just the Home stack. Make sure your user level is set to
Scripting (5), then follow these steps:

1. Go to the Home card on which you want to place the button.
2. Make sure you have one of the General tools selected.

The Browse tool (), the Burtton ool (<), or the Field tool ()
will work.

3. Choose New Button from the Objects menu. <

This automartically selects the Button tool, creates a button
named “New Button” in the center of the card window, and
selects the button.

* New Button !

Figure 2-44 A button created with the New Button command

4. While the button is still selected, choose Button Info from the
Objects menu.

Or double-click the button. The Button Info dialog box @

dppears.
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If this option is selected
and the button has a
name, the name will

appear on the button

5. Type a name for the button:

Button Nome: Heur Button

Type the name of the button

Card button number:1  Cord button ID: 17

Ssovione sty
Auto Hilit
s

1 Share Hilite

(Link T0..) (Font... )
(Script...] [Euluri...]

GO Goee)

(for example, the name of the
document or application you
want the button 1o open) here.

Figure 2-45

Typing the name for the button

6. Make sure the Show Name check box is selected.

This option is automatically selected when you create a new
button with the New Button command.

7. Click Script.

The button's script opens:

Script of Cord button 10 17 = "New Button"

=

<

Figure 2-46  Opening a button's script
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8. Type one of the following, substituting the name of the
dﬂcul“ent or thf_' name UF t]"le dﬂcurn(:'nt ﬂﬂd app“c:llinn }"01]
want to open:

Script of Card button 10 17 = "New Button"
on mousellp

open "opplication’ specitied application
iend mousellp

[is scripn lanehes th

This script launches the
?: ll“ " .
STt o Cord butten Rl i) specilied application and opens
| oan mouselp ) the sacifiod d o

open "document' with "application” L the specitied document
| end mousellp

Figure 2-47  Scripting a link to an application .

9. When you're finished, press Enter.
10. Choose the Browse tool.

Lf you want to test your new button, click it—it should open the
document or application you specified. If something else happens,
check the spelling of the document and application names and
check the script for errors.

When you want to return to HyperCard, quit the application. You
return to the card from which you launched the application.

You might encounter other stacks with burtrons thar launch
applications. When you launch an application by clicking one of .
these buttons on a card, HyperCard takes you back to the same

card after you quit the application.

» Seealso:  * “Changing the Appearance of a Button” in Chaprer 4
* “Linking Information” in Chapter 4
* “Opening Applications” in Chaprer |
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Renaming a Home card  The name of a Home card usually characterizes the stacks,
applications, and documents that are represented on the card. For
example, the buttons on the card named "lool Kit open stacks that

contain t()()i.'i :lﬂd parts you can usec to bllih.i new .‘1['.1[@(5.

You can rename any of the Home cards in the standard Home stack
at any time. When you rename a Home card, you automatically
change both the name that appears near the upper-left corner of the
card and the name of the button (at the bottom of each Home
card) that’s used for navigating to that card.

S 0 L R R
2 111811111

| Home Stack / Tool Kit User Neme | H}})‘&! (‘“dHUb: ;
The name of this __% / I Create QuickLink.. | :
. Home card ¢ L User Preferences |8
; Pand i

Seripter's Tools Art Ideos

=l
LS Ky
Thie bt Button Idens lcon Editor
RIS 1]

¢ 10

| Welcome || Deskset I! Rttic I Basement

this card

Figure 2-48 The name of a Home card appears near the upper-left
corner of the card
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Follow these steps to rename a Home card:
1. Make sure the Browse tool (#) is selected.

2. Click the name of the card (the name just to the right of the
words “Home Stack”).

The F(}lluwing diaﬂug box appears:

Renome this cord os:

[TooI Kit} |

q 0K ' Illuneell

Figure 2-49 Renaming a Home card
3. Type a new name for the card and click OK.

Changing the appearance  In addition to adding buttons to your Home cards, you can also
of the Home cards  change the appearance of the Home cards by adding text and
pictures to them,

When you add text or a picture to the background layer of a Home
card, it appears on all the Home cards. When you add text or a
picture to the card layer of a Home card, it appears only on that

card.

For instructions on adding text to a card or background, see
Chapter 5. For instructions on adding pictures, see Chapter 6.
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Using the Home stack
as your control center

Once you've added buttons to your Home stack for all cthe stacks,
applications, and documents you use frequently, you might want to

use your Home stack as your control center—a jumping-off point

for all your work on the Apple I1Gs.

To use the Home stack as your control center, you must tell your
computer to launch HyperCard at startup time. You can arrange
to do this only if your computer is connected to an AppleShare
network, and you normally launch HyperCard over the network.
Ask the AppleShare administrator for the network to follow
these steps:

L. Click the icon for the user (or group) who wants to use
HyperCard as the startup application.

2. Choose Startup Info from the Apple Il menu.
The Startup Info dialog box appears.

3. Click Set Startup Application.

4. Select HyperCardIIGs.

5. Click OK.

When you restart your computer, HyperCard launches
automatically and your Home stack opens.

Chapter 2: Creating and Modifying Stacks 1Y







Chapter 3

Working With Cards
and Backgrounds

: ihcn you build HyperCard stacks, you perform many tasks

that involve creating and m:mipu]diing cards and backgrounds.
For example, you might add cards to a stack, rearrange the cards

in a stack, or copy a background from one stack to another.

This chapter gives specific instructions for working with cards
and backgrounds. To do the tasks in this chapter, you must have
your user level set at least to Authoring. When a task requires the

Scripring level, the instructions say so. (For instructions on setting

vour user level, see “User Levels and Optons” in Chaprer 1).




Working with cards

Adding a new card
1o stack

A card is a rectangular area that can hold buttons, fields, and
eraphics. All cards in a stack are the same size. Each card is a
L'nmp-:milc of two I'.lyt:l‘x—;l Ilml‘tgl'uund l'.!.}-'cl'. called the card J’;'{'i'r’#l
and a background layer. You see the elements of both layers when
you look at a card, as if the card layer were a transparent layer in
front of the background. Each layer can contain its own buttons,
tields, and graphics. (“The Card Layer Versus the Background
Layer” in Chapter 2 gives more details about the differences
between the two layers.)

When you add a new card to a stack, HyperCard always puts the
new card right after the current card. The new card automarically
acquires the background of the current card. If you want to add ;1.
new card with a blank background, you add a new background.
(“Creating a New Background,” later in this c.haprcr. gives
instructions.)

Card 4

Figure 3-1  Adding a new card to a stack
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1o add a new card o the current stack, follow these steps:
1. Go to the card you want the new card to follow.

[f you want to add a new card at the end of the stack, go to the
last card in the stack by choosing Last from the Go menu (or

pressing . -4 or | —Right Arrow).
2. Choose New Card from the Edit menu, or press -N.

The new card is inserted immediately after the card you were
looking at when you chose New Card, and it has the same
background as that card (which is now the previous card).
The new card appears on your screen.

Figure 3-2  Adding a new card at the end of a stack
g A

For information about adding burttons, fields, and graphics to
your new card, see Chapters 4, 5, and 6, respectively.
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[f you want to create a new card as the first card in the stack, follow

these steps:

1. Choose First from the Go menu, or press -l.

| — 3 The first card in the stack
I 28 appears on the screen
| Ik
! i
| .

2. Choose New Card from the Edit menu, or press -N.

H]L' INUW ( .H'Ll i'w .ldtiu.{ .11-It'l l|1L'
first card and has the same

l"r;ll.]{i,_"l'tllll]ii as the first card. .

The new card appears on the

1
| "L _ screen.
LLLETeEnn G I 2 #_P

i il

3. Choose First from the Go menu, pr press -1, again.

| g ['he first card in the stack

—! —m ) ;]pi'}i_".ll'h on T.]ll.' SCreen Lll;,,['.il-]l.

O &

4. Choose Cut Card from the Edit menu.

T 3| This removes the tirst card in

| 2 '{ the stack and puts a copy of it
l | ﬁ‘ — onto the € i|iph::;1]'d. (The card
| : thar was second in the stack is

now first.)

Cliapter A Workme With Cairds e Backgrounds




[f you want to put the former first card (the card you've cut) back
into the stack, you need to do two more things:

1. Go to the card you want the cut card to follow.

J

Current card #

2. Choose Paste Card from the Edit menu, or press = -V.

Pasted card _‘.‘.8(1

¥

The pasted card is added
immediately after the card you
were looking at when you chose

Paste Card.

The pasted card appears on the

screcn.

Current card
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Copying card  You can copy a card into another stack, or to another location in the
same stack. When you copy a card, you copy everything associated
with it—its background, graphics, fields, text, buttons, and scripts.

Here's how to make a copy of a card:
1. Go to the card you want to copy.
2. Choose Copy Card from the Edit menu.
This puts a copy of the current card onto the Clipboard.
3. Go to the card you want the copied card to follow.
[t can be in the current stack or in any other stack.
4. Choose Paste Card from the Edit menu, or press "-V.

The card is pasted immediately after the card you were looking
at when you chose Paste Card. The copied card becomes the

current card.

The copied card acquires the name of the original card (if the
original card has a name). This means that, if the copy and the
original are in the same stack, you have two cards in the stack with
the same name. You might want to consider renaming one of them,
so that each card in your stack has a unique name. ("Naming a
Card,” later in this chapter, gives instructions.)

Important: When you copy a card from one place to another,

you copy the card’s script, too (if it has one), and any scripts
associated with the buttons, fields, and background that are part ®
of the card. Since scripts sometimes rely on the characteristics of a
particular stack, you might encounter problems (such as unfamiliar
messages) after you copy a card. “Copying Parts From Other

Stacks” in Chapter 2 discusses this problem.
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Moving a card

You can move a card to a different place within the same stack, or to
a different stack. When you move a card, you also move everything
associated with it—its background, graphics, fields, text, buttons,
and scripts.

"To move a card, follow these steps:

l. Go to the card you want to move.
2. Choose Cut Card from the Edit menu.

This removes the current card and puts a copy of it onto

the Clipboard.
3. Go to the card you want the cut card to follow.
It can be in the current stack or in any other stack.
4. Choose Paste Card from the Edit menu, or press -V.

The pasted card is placed immediately after the card you were
looking at when you chose Paste Card. The pasted card appears
on the screen.

[f you have pasted the card into a different stack than the stack from
which you cut it, pasting the card also adds the card’s background
to the stack (unless the stack already contains that background).

Important: When you move a card from one place to another, you
move the card’s script, too (if it has one), and any scripts associated
with the buttons, fields, and background that are part of the card.
Since scripts sometimes rely on the characteristics of a particular
stack, you might encounter problems (such as unfamiliar messages)
after you move a card. “Copying Parts From Other Stacks” in
Chapter 2 discusses this problem. 2
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Making a card the first card  Moving a card to the first position in the stack requires several steps.
in the stack  First you have to make the card the second one in the stack, and
then you have to move the first card out of the way.

To move a card so that it’s first in the stack, follow these steps:
1. Go to the card whose position you want to change.
2. Choose Cut Card from the Edit menu.

This removes the current card and puts a copy of it onto
the Clipboard.

3. Choose First from the Go menu, or press ( -1,
The first card in the stack appears.
4. Choose Paste Card from the Edit menu, or press -V. .

The pasted card appears on the screen—it's now the second card
in the stack.

5. Choose First from the Go menu again, or press ._'-1.
The first card in the stack appears again.

6. Choose Cut Card from the Edit menu.

This removes the first card from the stack and puts a copy of it
onto the Clipboard. (The card that was second in the stack is
now first.)

7. Choose Paste Card from the Edit menu, or press | -V.

The original first card is now the second card in the stack. .
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Getting information
about a card

Select this option
to protect the card
from deletion.

Select this option
to exclude the card
and background
fields on the
current card from
text searches.

Using the Card Info command, you can get information about the
current card and change some of its properties. Follow these steps to

get information about a card:

1. Make sure you have one of the General tools selected.

The Browse tool (¥5), the Button tool (<), or the Field tool (C3)

will work.

2. Choose Card Info from the Objects menu.

The following dialog box appears:

The card’s name

Z
Cord Nome: | [EFITTITNNT)

| The card's number

Card I0: 2928 Lard nusber 1'0ut of 40

The card's ID

Contains 2 cord fields.

The number of fields

Contains 3 cord buttons.
[CICon't Delete \

in the card layer
The number of buttons

[CJDon't Search

N

in the card layer

If your user
level is set to
Seripting, you can
click here to see
the card's script.

Figure 3-3

Click here to see
the card'’s color sets.

N Click OK when you're
through (or click Cancel
to close the dialog box
without saving any
changes).

Getting information about a card

3. When you’re finished, click OK.

« Another way to open the Card Info dialog box: 1f you are using the
Home stack that comes with HyperCard, the following shortcut
opens the Card Info dialog box for the current card in any stack:
While any General tool is selected, press | 1M to open the
Message box; then type ¢ and press Return. (This shortcur
is built into the standard HyperCard Home stack.) +
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.\'.llllill}.: o t;tI'L] Liu.m.'r;!.||}'. a card doesn't have a name unless you givc It one
(or someone else does). The card name is one way HyperCard
identifies a card. You can use the card name in the Message box to
briﬂg the card into view. And you can use the card name to address
the card through scripts.

'To name a card or change its name, follow these steps:
1. Make sure you have one of the General tools selected.

The Browse tool (), the Button tool (=), or the Field tool ((7)
will work.

2. Choose Card Info from the Objects menu.

3. Type or change the card’s name: ]
Cord Name: ] The card’s name

Cord 10: 2928. Card number 1 out of 40
Contains 2 cord fields.
Contains 3 cord buttons,

[ Con't Delete

[I0on't Search

(Seript.) [(Colors.) lj 0K ]

Figure 3-4 Naming a card

4. When you're finished, click OK.

Important: Don't use a number for the card name—otherwise
HyperCard might, for example, look for card number 12 when you
try to go to the card named “12.” 2
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Excluding card
vackground fields
from text searches

and

Click here to exclude the card's
fields from text searches. If you
. click again, you open the card's

fields to text searches.

The Find command (in the Go menu) allows you to search tor
specific text in the fields of a stack. (“Looking for Specific Text” in
Chapter 1 explains how to search for text.) When you're searching
for specific text in a large stack, you can speed your search by
excluding any fields that you know don't contain the text you're

looking for.

To prevent HyperCard from searching in the card and background
fields that appear on any particular card, follow these steps:

1. Go to the card whose fields you want to exclude from text
searches.

2. Make sure you have one of the General tools selected.

The Browse tool (), the Button tool (=), or the Field tool ()
will work.

3. Choose Card Info from the Objects menu.
Click the Don’t Search check box to select it:

e

TE T Tt roduction
Card 10: 2928. Cord number 1 out of 40

Contains 2 card fields
Contains 3 cord buttons,
[ICon't Delete

[]0on't Seorch

Figure 3-5 Excluding a card’s fields from text searches

5. Click OK.

When you want to allow HyperCard to search in the card’s fields
again, click Don't Search to deselect it (as shown in Figure 3-5).
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Protecting a card

Click here to protect the
card from deletion. If you
click again, yvou remove
the card's protection

»  Secalio: "I-.xa'huliny‘ Background Fields From Text Searches™ in this
chaprer
* “Excluding a Field From lext Searches”™ in Chapter 5

You can protect a card from deletion, but you can't prevent changes
to a card unless you protect the entire stack from modification (as
explained in “Protecting Your Stack” in Chapter 2).

To protect a card from deletion, follow these steps:
l. Go the card you want to protect.
2. Make sure you have one of the General tools selected.

The Browse tool (), the Button tool (=), or the Field tool (%

will work.

3. Choose Card Info from the Objects menu.
4. Click the Can’t Delete check box to select it:

LT TR Tnroduction) |
Card 10: 2928, Cord number 1 out of 40

Contains 2 card fields.
Contains 3 card buttens.

[ICan't Delete
[JDon't Search

lScfiDl...l |[:ulms..| “ 0K !ﬂ |Euncel| .

Figure 3-6  Protecting a card

5. Click OK.
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Changing a card’s color set

You can't remove the card from the stack while the Can't Delete
option is turned on. (You can, however, delete the entire stack,
taking the protected card with it.)

When you want to delete the card, you can remove its protection by
clicking Can't Delete again in the Card Info dialog box to deselect it
(as shown in Figure 3-6).

The color set for a card determines the 16 colors currently available
for use by buttons, fields, and graphics on that card. You can choose
from among at least five color sets for any given card: the standard
system color set, a gray scale color set, and three others. You can

also add a sixth color set to a card. And you can choose to have a
card make use of whatever color set is currently selected for its

background.

When you change a card’s color set, the colors of some or all the
graphics, buttons, and fields on the card may change to reflect the
new colors. See “Changing Color Sets™ in Chapter 6 for more
information about the way the color sets for cards, backgrounds,

and stacks affect the colors displayed on a card.

To change the color set for a card, follow these steps:

1. Go to the card whose color set you want to change.
2. Make sure you have one of the General tools selected.

The Browse tool (#4), the Burtton tool (<), or the Field tool (()
will work.

3. Choose Card Info from the Objects menu.
4. Click Colors.

The Colors dialog box for the card appears.
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These are the
color sets that are
available for the
current card,
Click the one you
wdnlt (o use . . .

5. Select the color set you want:

_Disploy colors for cord 10 2928
(1) TN T 1| Stondord system colors
Gray scole

Other color sets...
[ T W T

When disploying this cord:

[ Use these colors |1 { o ) (concel)

.. then press and hold the mouse button here and drag to
choose “Use these colors” (if it's not already selected) from the
pop-up menu, If you choose “Get colors from background” .
instead, the card will use the colors currently specified for the
background no matter which color set is selected for the card.

Figure 3-7 Changing a card’s color set

6. When you’re finished, click OK to confirm your selection.
You see the Card Info dialog box again.
7. In the Card Info dialog box, click OK.

If none of the five color sets for a given card includes the colors you
want, you can add a sixth color set to that card from any document

in the Apple Preferred File Format. “Importing a New Color Set Fob
a Card or Background,” in Chapter 6, describes how to do this.

You can also add a sixth color set to a card by using a desk accessory,
an XCMD, or HyperTalk to specify the colors you want. If you use
a desk accessory or an XCMD to do this, any color set you specify
while you're working in the card layer will be added automarically
to the color sets for the current card and will be selected. For
instructions on using HyperTalk to add a sixth color set to a card,
see the discussion of the colorset property in the HyperTalk
Help stack.
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Deleting a card

Working with
backgrounds

To remove the current card from the stack, choose Delete Card
from the Edit menu (or press | -Delete). The current card
disappears (unless it's protected), and you see the next card in

the stack.

Important: If you delete a card by mistake, you can bring it back
by immediately choosing Undo from the Edit menu, before you do
anything else. -

If you try to delete a protected card, you see the following
dialog box:

Con't delete protected cord.

Figure 3-8 Trying to delete a protected card

“Protecting a Card,” earlier in this chapter, describes how to set and
remove card protection.

You can't delete the only card in a stack. If there’s only one card in
the stack and you want to delete it, choose Delete Stack from the
File menu.

A background serves as a template for a stack, or for some of the
cards in a stack. Whatever’s in a background is common to all cards
associated with that background. You place buttons, fields, and
graphics in the background when you want them to appear on all
the cards that share the background.
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There’s no limit (beyond disk space) to the number of backgrounds
a stack can have. In fact, every card in a stack could have its own
background—but that would defeat the purpose of backgrounds.
Together, the elements in a background help communicate the
purpose of the stack by giving a similar appearance and function to
the cards that share the background. This makes it much easier for
other people to figure out what the stack is for and how to use it—
and much easier for you to create and modify the stack. You can
make changes to many cards at once just by changing elements in
their common background.

“The Card Layer Versus the Background Layer” in Chapter 2
ives more information about the relationship between cards
gt P

and backgrounds. £

To see the background layer of the current card, choose Background
from the Edit menu, or press (%-B. If you choose Background (or
press (I-B) repeatedly, you move back and forth between the card
layer and the background layer. When you're in the background
layer, the word Background appears in the menu bar, and a check
mark appears to the left of the Background command in the

Edit menu:

G TFile When you're in

I/ 60 Tools Objects Idm-ﬂ

Indo a2 the background

7 = layer, the word
L) a

P a Backgmzlmd

Poste Text &V} appears n the

Clewm

menu bar . . .

New Card -
Delete Cord
Cut Cord
Copy Card

.. and the Background T iiie of
command is checked. __8l___ |, pockground 48

Figure 3-9  The word Background appears in the menu bar while you're working in
a background
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While you're working in the background layer you can get back to
the card layer by choosing Background from the Edit menu again,
pressing (_{-B, or choosing the Browse tool.

You can find out how many cards share the current background by
choosing Bkgnd Info from the Objects menu (while any of the
General tools is selected):

Bkgnd N e:I- Cords) ;

ond Rome: [8E = | This number tells you
Bkgnd [D: 2760, Shared by 5 cards. how many cards in the
Contains 3 background fields. stack share the current

Cantains 7 background buttons, background.

. [ICen't Delete

[CJ0on't Search

CO)

Figure 3-10  Seeing how many cards share a background

To see how many backgrounds there are in the current stack, choose
Stack Info from the Objects menu (while any of the General tools
is selecred):

Stack Nome: | [T |

. Where: HardDisk HuperCard:
Stock contains 7 cards. This number tells
Stock contains ﬂuntsrnunds. you how many
Size of stock: HIK. backgrounds are in
Free in stock: OK. the current stack.
[ﬁnrlpt...] [En!urs_..] l 0K ]  Cancel )

Figure 3-11  Checking the number of backgrounds in a stack

Chapter 3: Working With Cards and Backgrounds 137




Creating a new background — When you want some (but not all) of the cards in a stack to have a
similar appearance or contain the same elements, you can create a
new background to be shared by just those cards.

To add a new background to a stack, choose New Background from
the Objects menu. (You must have a General tool selected to see the
Objects menu.) This adds to your stack a new, empry card with a
blank background, and puts you in the background layer of that
card. The new, empty card is added immediately after the card
you're looking at when you choose New Background.

Bution Infa.,
fieid infs... .
Cord Info...

Bkgnd Info...
Stack Info...

Bring Closer ¢
Spnd foriher O~

New Button
New Field
New Background —§— The New Background
1 command
Figure 3-12  Creating a new background .

For information about adding buttons, fields, and graphics to your
new background, see Chapters 4, 5, and 6, respectively.
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Moving between  While you're working with a stack that has more than one back-
|"LJL']~JIL’,I‘1 unds  ground, it’s useful to be able to move between the backgrounds
quickly. This can help you keep an eye on the developing stack,
and it makes stack building faster and easier.

When you're in a stack that has more than one background,
you can move between the different backgrounds by following
these steps:

1. Open the Message box.
2. Type any of the following;

T

— This takes you to the first card of
. 90 t0 next backgreund the next background in the stack.

L e e T N
Ql'.l ED m E'UI‘JUE- bﬂﬂkgl Dl.lﬂd — This takes you to the nearest card

—— e Of the previous background in
the stack

T e e e eI

" s This takes you to the first card of
HU T.U buckground EI'I!!HDHEEE .. the background named Employees

if there is such Lh.uiq.,r{_}und

Figure 3-13 Moving between backgrounds
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Copying a background

3. Press Return or Enter.

You go immediately to the first card with the specified

background, if the stack has such a background.

If there’s no such background in the current stack, you see the
following dialog box:

Mo such cord.

Figure 3-14 When HyperCard canit find a background .

For information on naming a background, see “Naming a
Background,” later in this chaprer.

You can copy a background from one stack to another, or from one
place to another in the same stack. To copy an existing background,
you copy a card thar has that background. (When you copy a card,

you copy everything associated with it, including its background.)
To copy a background, follow these steps:
1. Go to a card that has the background you want to copy.

You can see the contents of the card’s background by pressing o
“i-B to go to the background layer.

2. Choose New Card from the Edit menu, or press ' -N.
3. Choose Cut Card from the Edit menu.
4. Move to the card you want the new background to follow.

It can be in the current stack or in another stack.
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5. Choose Paste Card from the Edit menu.

The pasted card becomes the current card.

6. To make another card with this background, choose New Card
from the Edit menu.

This creates a new card with the same background as the current
card (the card you've just pasted). This new card contains only

the background elements—the background buttons, fields,
graphics, and script—of the copied card.

You can create as many cards with this background as you like
by repeating this step.

If you try to copy a background into a stack that already has that
background, HyperCard won't make the copy. However, when
you're creating a large stack with different sections, you might want
the different sections to have backgrounds with different names
(and IDs) that are identical in every other respect. This way, you
can move quickly between the sections of the stack by moving from
one background to another, as explained in “Moving Between
Backgrounds,” earlier in this chapter.

You can get two identical backgrounds into a stack (with different
names and IDs) by first making a temporary alteration to the
background you want to copy. (For example, add a button to the
background temporarily). Then follow the procedure described in
this section to copy the background. After you've copied the
background, undo the alteration you made to it.

Important: When you copy a background from one place ro
another, you copy the background’s scripr, too (if it has one), and
any scripts associated with the buctons and fields thar are in the
background. Since scripts sometimes rely on the characteristics of a
particular stack, you might encounter problems (such as unfamiliar
messages) after you copy a background. “Copying Parts From
Other Stacks” in Chapter 2 discusses this problem. _.
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Getling intormauon Using the Bkgnd [nfo command, you can get information about
about a backeround  the current background and change some of its properties.

Here's how:
1. Make sure you have one of the General tools selected.

The Browse tool (%), the Button tool (=), or the Field tool (D)
will work.

2. Choose Bkgnd Info from the Objects menu.

The following dialog box appears:

The backeround's  The background's

1D name
| ['he number of .
aek i o
cards that share
Bkgnd{Name: | [PRTXETD | - ;
this background
Select this option Bkand 10: 2760. Shared by 5'cards. B
to protect the Contains 3 backaround fields. -Ihttl _nuImh;‘r ol EII._“III._LH
T R . ) s backgrounc
hackground from Contains 7 background buttons. VLIS A
leletion. The number of butt
de ) [JCan't Delete The m\mhgz ol buttons
Select this LJ[‘I[IUJ‘I [0 Dllun't Search n this .b;ILl\‘u:Hl:ﬂu

exclude the background's -
- : : Seript...] [Colors.. ﬂ 0K D |Eunce| ]
fields from text searches. - ' =

~—_ Click OK when you'rc
through (or click
Cancel 1o close the
dialog box without
saving any changes)

If your user Click here
level is set to to see the
Scripting, youcan  background’s
click here to see the  color sets,
background's script,

Figure 3-15  Getting information about a background

3. When you're finished, click OK.
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Naming a background

Excluding background
tields from text searches

+ Another way to open the Bkgnd Info dialog box: If you are using
the Home stack that comes with HyperCard, the following
shortcut opens the Bkgnd Info dialog box for the current
background in any stack: While any General tool is selected,
press I-M to open the Message box; then type b and press
Return. (This shortcut is built into the standard HyperCard

Home stack.)

Generally, a background doesn't have a name unless you give it
one (or someone else does). A background’s name is one way
HyperCard identifies the background. You can use the background
name in the Message box to bring the first card with that
background into view. And you can use a background’s name

to address the background through scripts.

To name a background or change its name, follow these steps:
1. Make sure you have one of the General tools selected.

The Browse tool (#), the Button tool (=), or the Field tool (£3)
will work.

2. Choose Bkgnd Info from the Objects menu.
3. Type or change the background’s name.
4. Click OK.

The Find command (in the Go menu) allows you to search for
specific text in the fields of a stack. (“Looking for Specific Text” in
Chaprer 1 L’xphlins how to search for text.) When you're scarching
for specific text in a large stack, you can speed your search by
excluding any fields that you know don’t contain the text you're
looking for.

Chapter 3: Working With Cards and Backgrounds 143




To prevent HyperCard from searching in the fields that belong to
any particular background, follow these steps:

1. Go to a card with the background whose fields you want to
exclude from text searches.

2. Make sure you have one of the General tools selected.

The Browse tool (), the Button tool (=), or the Field tool (1)

will work.
3. Choose Bkgnd Info from the Objects menu.
4. Click the Don't Search check box to select it:

Bkgnd Name: | B
Bkgnd ID: 2697. Shared by 33 cords.

Cantains 3 background fields.
Contains 2 background buttons.

[ICon't Delete
t L;,C“Ek hLI,'mE'ml L{X(Ei[udl‘ the [J00n't Search
yackground’s fields from text
searches. If you click again, you (Serio...) (E"““"J [LJ
open the background's fields to
text searches.

Figure 3-16  Excluding a background's fields from text searches

5. Click OK. &

If you want to allow HyperCard to search in the background’s
fields, click Don't Search again to deselect it (as shown in

Figure 3-10).

» Seealso: * “Excluding Card and Background Fields From Text
Searches” in this chaprer
» “Excluding a Field From Text Searches” in Chapter 5
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Protecting a background  You can protect a background from deletion, but you cant prevent
changes to a background unless you protect the entire stack
from modification (as explained in “Protecting Your Stack” in
Chapter 2).

When you protect a background from deletion, you tell HyperCard
not to allow the removal of the last card that has the background.

To protect a background from deletion, follow these steps:
1. Go to a card that has the background you want to protect.
2. Make sure you have one of the General tools selected.

The Browse tool (), the Button tool (=), or the Field tool (£3)
. will work.

3. Choose Bkgnd Info from the Objects menu.
4. Click the Can’t Delete check box to select it:

Click here to protect Bkand Name: 1
the background from
deletion. If you click Bkgnd 10: 2760. Shared by 5 cards.
again, you remove Contains 3 background fields.
the background's Contains 7 background buttons,
[rotection, 8 E' Con't Delete

[J0on't Search

lScript...l |En]nrs...| ' 0K 'Il.'.ﬁm:!ll

Figure 3-17 Protecting a background

5. Click OK.

As long as the Can't Delete option is turned on, you can't
remove the last card with that background from the stack.
(You can, however, delete the stack, taking the protected
background with it.)
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To remove the background’s protection, click Can't Delete in the
Bkgnd Info dialog box to deselect it (as shown in Figure 3-17).

Changing a background’s  The color set for a background determines the 16 colors currently
color set  available for use by the cards that share the background and by the
background’s buttons, fields, and graphics. You can choose from
among at least five color sets for any given background: the
standard system color set, a gray scale color set, and three others.
You can also add a sixth color set to a background. And you can
choose to have a background make use of whatever color ser is

currently selected for the stack.

If you wish, you can select a color set for a card that is different

from the color set selected for the card’s background. If a card’s ®
color set has not been selected individually, the card makes use of
the color set currently selected for its background.

When you change a background’s color set, the colors of some or
all the graphics, buttons, and fields in the background may change
to reflect the new colors. See “Changing Color Sets” in Chapter 6
for more information about the way the color sets for cards,
backgrounds, and stacks affect the colors displayed on a card.

To change the color set for a background, follow these steps:

1. Go to any card that has the background whose color set you
want to change.

2. Make sure you have one of the General tools selected. &

The Browse tool (), the Button tool (=), or the Field ool ((J)
will work.

3. Choose Bkgnd Info from the Objects menu.
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These are the

color sets that are
available for the
current background
Click the one you
want o use . , .

4, Click Colors.

The Colors dialog box for the background appears.

5. Select the color set you want:

Disploy colors for background 1D 2697

.
Standard system colors
TSI T 1 ] Groy scole

MR T WO T WY T ] Other color sets...

L1 T T )

L [ T ST 1

When displaying this bkgnd:

| Use these colors i

. . . then press and hold the mouse button here and drag to
choose “Use these colors” (if it's not already selected) from the
pop-up menu. If you choose “Get colors from stack” instead,
your stack will use the colors currently specified for the stack
no matter which color set is selected for the background.

Figure 3-18 Changing a background's color set

6. When you’re finished, click OK to confirm your selection.
You see the Bkgnd Info dialog box again.
7. In the Bkgnd Info dialog box, click OK.

[f you're working in the card layer of a card for which a color set
is selected that’s different from the background’s color set, you
must choose (1-B to see the effect of the color set you just
selected.

[f none of the five color sets for a given background includes

the colors you want, you can add a sixth color set to that
background from any document in the Apple Preferred File
Format. “Importing a New Color Set for a Card or Background,”
in Chapter 6, describes how to do this.
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Deleting a background

You can also add a sixth color set to a background by using a desk
accessory, an XCMD, or HyperTalk to specify the colors you want.
If you use a desk accessory or an XCMD to do this, any color set
you specify while you're working in the background layer will be
added automatically to the color sets for the current background
and will be selected. For instructions on using HyperTalk to add

a sixth color set to a card, see the discussion of the colorset
property in the HyperTalk Help stack.

You can't delete a background directly. To remove a background
from a stack, you must delete every card that uses the background.
Oy, if the stack contains only one background, you can simply
delete the whole stack, as described in “Deleting a Stack” in @
Chapter 2.

Follow these steps to remove a background from a stack without
deleting the whole stack:

1. Go to a card that has the background you want to delete.
2. Choose Delete Card from the Edit menu (or press =~ -Delete).

The card disappears unless it’s protected. If the card is protected,
the following dialog box appears:

Caon't delete protected cord.

Figure 3-19 Trying 1o delete a |‘JF{JIL‘('|L‘(| card

See “Protecting a Card,” earlier in this chaprer, for instructions

on removing, card p:‘mcctiun.
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—» Important: If you delete a card by mistake, you can bring it back
by immediately choosing Undo from the Edit menu, before you do

;1[1_\-'[i1'mg_r| else.

3. Repeat steps 1 and 2 until you've removed from the stack
every card that has the background you want to delete.

When Can't Delete is selected in the Bkgnd Info dialog box for a
background, you can't delete the last card with this background.
(You can, however, delete the stack—including the protected

background.)

“Protecting a Background,” earlier in this chapter, gives information
) on setting and removing a background’s protection.
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Chapter 4

Working With Buttons

Burtons are rectangular “hot spots” you can click to make
things happen in stacks. For example, a button mighr take you to
another card, show you a picture, launch an application, or run an
animation sequence.

This chapter explains how to do the following:

s Create and modity buttons

»  Use the readymade buttons that come with HyperCard

s Use buttons to link information

To do the tasks in this chapter, you must have your user level set at
least to Authoring, For some of the tasks, your user level must be
Scripting. When a task requires the Scripting level, the instructions
say so. (The section “User Levels and Oprions” in Chaprer | tells

Vou ['I.l)\\" [0 set I\"l}lll' LIser It"‘v’t‘l.]




Adding a button to 4
card or background

Buttons allow you to link any piece of information—a card, an
idea, a picture, an address—to any other piece of informarion. You

can use buttons to link related information in any way you like.

But buttons have powers beyond linking—they can play sounds,
dial a phone, produce interesting visual effects, or even show you
a video sequence.

Behind every button is a seript that tells HyperCard what to do
when you click the button. You can create or change a script using
HyperTalk, HyperCard’s English-like programming language.
However, you don't need to learn Hyperlalk to create interesting
and powerful buttons. You can create a link without writing

the script that makes it work. You can also copy buttons (with
pre-programmed scripts) from other stacks—including the Pmttm.
|deas stack that comes with HyperCard. When you copy a button,
you also copy its script.

Whenever you add a button to a stack, you need to decide whether
you want it in the card layer or the background layer. To decide
where to put the button, consider where you want it to appear:

» If you want the button to appear on only one card, put it in the
card layer.

s If you want the button to appear on every card in the stack, put

it in the background layer.

s Ifyou wanrt the button to appear on some of the cards in the
stack (but not all of them), consider creating a difterent
background for those cards and putting the button in that
background only. (“Creating a New Background™ in Chapter 3
explains how to add a background to a stack.)

A l};:g'l(g:'mmd button appears in the same location on all the cards

that share the la;icligrmlnd.
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The tools for

To add a button to a background, you must be in the background
layer; to add a button to a card, you must be in the card layer. To
go to the background layer, press . "-B. When you're in the
background layer, the word Background appears in the menu bar.
[f you press ' -B repeatedly, you move back and forth between the
card layer and the background layer.

) See alio:  * “The Card Lal}-'cl' Versus the B;lckgnmnd 1,.;1}1,'[" in

Chaprer 2

* "Creating a Burton” in this chapter

To work with burtons, you need the Button tool, the Browse tool,

“v(:”-kinq “‘-i[h hU[[( NS and perhaps some of the Paint tools.

Use the Browse tool

to click buttons.

Use the Button
tool to create and
modify buttons.

% 4

™1 s ]
= . .
- | Use the Paint
o | tools when you
3| want to create
MO a graphic to
e display through
AlD b )
v a button
Figure 4-1  The tools for working with buttons

To make it easy to alternate between the tools, you can “tear off” the
Tools menu to create a movable Tools palette. To do this, drag
down through the menu and past the bottom or beyond either side.
(For an illustration of this, see Figure 2-12.)
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You can use the following = -key shortcuts to choose the tools you
need for working with buttons:

To choose this tool . . . Press
The Browse tool “-Tab
The Button tool -Tab-Tab

> See also: * "Uh'illg I {j,-'p:_';'[,,'.;urd':s Tools™ in (_'h.'lplicr 2

(;{)p'\,-’lng I'Cill..l}-"ﬂ 1ade HyperCard comes with a stack called Button Ideas that contains
buttons  buttons you can copy and paste into your stacks. Some of these
buttons have pre-programmed scripts that can help you develop @)
your own stacks. The Button Ideas stack includes burtons that
launch applications, play sounds, make pictures disappear and
reappear, and play animation sequences.

You don't need to know HyperTalk to make the burtons with
pre-programmed scripts work—you just need to understand what
they do, so that you can use them appropriately in your stacks.
These burtons are designed to work in virtually any stack. They
don’t depend on your stack’s structure in any way.

You can copy buttons that you like from other stacks as well as from
the Button Ideas stack. However, unlike the buttons in Button
Ideas, buttons from other stacks may not work the way you expect
in your own stack. See the section “Copying Parts From Other
Stacks” in Chapter 2 for information about the factors you need

to consider.
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Buttons lor opening stacks that

come with HyperCard:

Sty

[ et %

Addresses

A button that plays
a sound:

A button that
quickly shows you
all the cards in the

Calendar

An animated
button:

pd g

S lid
<D Q-
&0 U,

ﬂpgbﬂh

A button that lets
you search for text
in a stack:

Buttons that hide and
show the card picture

A button that opens
an application:

Applelorks

A button that takes
you to the HyperCard
Help stack:

SLAC l\

Lh

Sonne readyniede buttons

bigure 4-2

Copying buttons from the Button Ideas stack can make stack
building easier and save you a lot of time. If you see a button you
like, copy it and paste it into your stack. Note that in the Button
[deas stack, only buttons inside red borders include scripts. If you
copy a button that doesn't include a script, you must write a scripr

for it before it will do anything.

Follow these steps to copy one of the buttons in the Button Ideas

stack:

I. Open the Button Ideas stack.

i
Fil
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. Go to the card that has the button you want to copy.

3. Choose the Button tool (=) from the Tools menu (or click it
on the Tools palette).

4. Click the button you want to copy to select it.
A moving dashed line surrounds the selected button.
5. Choose Copy Button from the Edit menu, or press -C.

This puts a copy of the selected button (including its scripr,
if it has one) on the (:|ipbtmrd. (This button replaces the last
item you cut or copied; the Clipboard can only hold one item

at a time.)

6. Go to the card or background where you want to put the L
copied button.

Use the arrow L(L‘}-’.‘; or commands in the Go menu to ﬂ'.n-"ig.ltc
berween cards while the Button tool is selected.

[f you're not sure whether to put the button in the card layer
or the hﬂ-.;kgmund layer, see “P\dding a Burton to a Card or

Background” at the beginning of this chapter.

o

Choose Paste Button from the Edit menu, or press -V.

This takes a copy of the button that's on the Clipboard, puts it
on the current card or background, and selects it.

8. While the button is still selected, drag it to where you want il.
on the card.

Important: The most common mistake in copying a button is
putting it in the card layer when you want it in the background
layer. (To find out whether a button is in the background, press
-B 1o see just the background elements.) If you pur a burton in
the card layer by mistake, see “Moving a Button From the Card

to the Background,” later in chis chapter.
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Buttons for opening stacks that

come with HyperCard

Addresses

A button that plays
a sound

A button that
quickly shows you
all the cards in the
stack:

e ——. iy |
Figure 4-2

SO e

Calendar

An animated

button:
"‘ﬂh% d} ﬂp@?
<D g
A0l

ﬂngﬂm

A button that lets
you search for text
in a stack:

b

acyimade buttons

Buttons that hide and
show the card picture:

(Show Picture)

Show Picture

A button that opens
an application:

Applellorks

A button that takes
you to the HyperCard
Help stack:

Copying buttons from the Button Ideas stack can make stack

building easier and save you a lot of time. If you see a button you
like, copy it and paste it into your stack. Note thar in the Button

ldeas stack, only buttons inside red borders include scripts. If you
copy a button that doesn't include a script, you must write a script

for it before it will do ;m}-rhing.

Follow these steps to copy one of the buttons in the Button Ideas
stack:

I. Open the Button Ideas stack.
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B

Go to the card that has the button you want to copy.

Choose the Button tool (=) from the Tools menu (or click it

on the Tools palette).

. Click the button you want to copy to select it.

A moving dashed line surrounds the selected button.
Choose Copy Button from the Edit menu, or press —-C.

This puts a copy of the selected button (including its script,

if it has one) on the Clipboard. (This button replaces the last
item you cut or copied; the Clipboard can only hold one irem
at a time.)

Go to the card or background where you want to put the .
copied button.

Use the arrow keys or commands in the Go menu to navigate

between cards while the Button tool is selected.

[f you're not sure whether to put the button in the card layer
or the background layer, see “Adding a Button to a Card or
Background” at the beginning of this chaprer.

Choose Paste Button from the Edit menu, or press -V

This takes a copy of the button that's on the Clipboard, puts it
on the current card or background, and selects it.

. While the button is still selected, drag it to where you want ir..

on the card.

Important: The most common mistake in copying a button is

putting it in the card layer when you want it in the background

layer. (To find out whether a button is in the background, press

-B to see just the background elements.) If you put a button in

the card layer by mistake, see “Moving a Button From the Card

to the I’u.u'kg:'numl." later in this chaprer.
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If the button you copied includes a script, you can test it after you
copy it—just choose the Browse tool and click the button.

You can see the HyperTalk commands that make the button work
by opening the button’s scripr, as explained in “Opening a Button's
Scripe,” later in this chapter. If the button doesn't have a script, you
can learn how to write one for it by working through the exercises
in the Hyperlalk Beginner’s Guide.

> Seealo: e "(':h;lrlging the Appearance of a Burton” in this \'.'h-.Lpn:r

& Crﬁ'ﬂ[iﬂg a button  Buttons come in many different styles and sizes. A button can be
blank; it can have text, an icon, or both; or it be placed over a
graphic, so that the graphic appears to be part of the button.

You can create a hl;ll'IL'., l'réll'lfipﬂfﬂ'l'lf l}llf[’("ﬁﬂ ona Cﬂrd or l)llCl(g['(lLlI'ld

by following these steps:
I. Go to the card or background where you want the button.

It you're not sure whether to put the button in the card layer or
the background layer, see “Adding a Button to a Card or
Background” at the beginning of this chapter.

2. Choose the Button tool (=) from the Tools menu.
The pointer changes to an arrow (x).
® 3. Hold down the (! key and drag diagonally.

This creates a blank, transparent button and leaves the button
selected:

Hold down the ~ key while
youdrag fromhere ... —;ececcanvecass .

................ 10 here

Figure 4-3 Creating a blank button

Chapter 4: Working With Buttons 157




You can bring the button to life by linking it to another card or
writing a script for it (if you're familiar with HyperTalk). “Linking
Information,” later in this chapter, gives instructions for linking,

For information on scripting, see the Hyper Talk Beginner's Guide.
The sections that follow explain how to create new buttons with

text, icons, and graphics.

P Seealso: * “Changing the Appearance of a Button” in this chapter

Creating a button  Displaying text on a button is one good way to indicate what the
with text button does.

Creating a text button is also a useful way to add a short text label
to a card or background—whether or not the button does any[hh,
dynamic. Button text is easy to move around on the card, because it
moves when you move the butron.

Follow these steps to create a new button with text:
1. Go to the card or background where you want the button.

If you're not sure whether to put the button in the card layer or
the background layer, see “Adding a Button to a Card or

Background” at the beginning of this chaprer.
2. Make sure you have one of the General tools selected.

The Browse tool (¥), the Button tool (=), or the Field tool ()

will work. .
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3. Choose New Button from the Objects menu.

This automatically selects the Button tool, creates a burton
named New Button in the center of the card window, and selects
the button.

e ,— The moving dashed
* New Buttor: lineindicates that the

mmemm======-  hutton is selected,

Figure 4-4 A button created with the New Button command

% Another method: You can create a blank, transparent button
. by choosing the Button tool, then pressing and holding the
L L= L “
key while you drag diagonally (as shown in Figure 4-3). «

4. While the button is still selected, choose Button Info from the
Objects menu.
Or double-click the button. The Button Info dialog box
Elppt"dl—ﬁ.

5. Type the text you want to display on the button:

The text you type here is ~
displayed on the bution Button Nome: [ETTIITRITINE |

Cord button number: 2 Card button ID: 2

17 tem: g w deikted =] Show Name Style: __rel:tunqle
Auto Hilite
© Bamitie o

shore Hyfite

(Link T0..) (Font... )

( Seript...) [Eulurs...] ﬂ: 0K ]] (Cuncel]

Figure 4-5 Typing the text you want to display on the button
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6. Click the Show Name check box to select it, if it isn't already
selected.

7. Click OK.

The text you've typed appears on the button. (A button can
display only one line of text.) To see all the text, you might have
to enlarge the button:

aow the Topig 1, resize the button,

-------- drag from any corner.

Figure 4-6  Resizing a button

If the button is no longer selected, you can select it by choosing
the Button tool and then clicking the button.

8. While the button is selected, drag it to where you want it on
the card.

2\ Important: The most common mistake in crearing a button is
putting it in the card layer when you want it in the background
layer. (To find out whether a button is in the background, press
-B to view just the background elements.) If you put a bucton in
the card layer by mistake, see “Moving a Button From the Card to

the H:lL‘kgmuml." later in this chapter.

You can bring the button to life by linking it to another card or
writing a script for it (if you're familiar with HyperTalk). “Linking
[nformation,” later in this chapter, gives instructions for linking.
For information on scripting, see the HyperTalk Beginners Guide.,

+  Another kind of text button: Another way to make a button
with text is to create a transparent button and place it over
some Paint text. The advantages and disadvantages of this
method are described in “Creating a Button with a Graphic,”
later in this chapter. <
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P Seeabso:  »( “hanging the Appearance of a Button” in this chaprer

* “When Elements Overlap” in this ¢ haprer

Creating a button  HyperCard comes with a collection of icons you can assign to
with an icon  burtons. Displaying an icon on a button is one good way to indicate
graphically what the button does.

Creating a button with an icon is also a useful way to add a graphic
element to a card or background, whether or not the button is
d)'tmmic. Since the icon is attached to the burton, you can move

il .|“"H”i| L'Ll‘\il_‘p"— i[ NNTOVES \-\"I]L_'I'I )‘ll[l Imove ]hL' |'IL|I[(IJ'|_
Follow these steps to create a new button with an icon:
1. Go to the card or background where you want the button.

[f you're not sure whether to put the button in the card layer
or the background layer, see “Adding a Button to a Card or

Background” ar the beginning of this chaprer.
2. Make sure you have one of the General tools selected.

The Browse tool (&), the Burton tool (=), or the Field tool (£3)
will work.

3. Choose New Button from the Objects menu.

This automatically selects the Button tool, creates a button
named New Button in the center of the card window, and selects

. the button.

__________ .— The moving dashed

New Button: line indicates that the

e
1]
"""""" “  button is selected

Figure 4-7 Making a new button

*  Another method: You can create a blank, transparent button
by choosing the Button tool, then pressing and holding the
* key while you drag diagonally (as shown in Figure 4-3). #

Chapter 4: Working With Buttons 161




4. While the button is selected, choose Button Info from the
Objects menu.

Or double-click the button. The Button Info dialog box

appears:

It this option is selected

and the button has Button Nome: [(TPRIITE. |
mame:, the button name Bkgnd button number: 8 Bkand button I0: 50

will spper on the =] Show Name Style:
button along with the = i
o fluto Hilite )
icon you choose ) share Hilite Fomily:

Click here o see i

collection of icons

vou can choose from [Li“k E“"-] [ font... ] .
(Scrim...] [Eulur.,.] “ 0K i| (cancel )

Figure 4-8 The Button Info dialog box

5. Click Icon.

The Icon di:ﬂ()g box appears:

10: 0 (none)

& 0 = ol ==
i 0 o D o
q@&@&@m
d ™ & =2 @ ¢ 9

G GO D CD|| el

Scroll, if

necessary,

find the icon vou

If the icon you select isn't entirely visible, press
and hold the mouse button here to see what the
whole icon looks like.

Figure 4-9  Choosing an icon
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Click the icon you want to display on your button.
7. Click OK.

The Icon dialog box disappears and you see the Button Info
dialog box again.

8. In the Button Info dialog box, click OK.

The icon you've selected appears on the button. To see the
whole icon, you might have to enlarge the button:

----- ---!
]
{} ‘ y resize the button,

li dg from any corner.

Figure 4-10  Resizing i button

9. While it’s still selected, drag the button to where you want it
on the card.

— Important: The most common mistake in creating a button is
putting it in the card layer when you want it in the background
layer. (To find out whether a button is in the background, press

-B to view just the background elements.) If you purt a burtton in
the card layer by mistake, see “Moving a Button From the Card to
the Background,” later in this chaprer. A

If you don't want to use any of the icons shown in the Icon dialog
box, you can copy a button with an icon you like from the Button
[deas stack or create your own icon using the Icon Editor stack.

I you want to change the colors of the icon displayed on your

button, see “Changing a Button's Colors,” later in this chapter.
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You can bring the button to life by linking it to another card or

writing a script for it (if you're familiar with HyperTalk). “Linking
Information,” later in this chapter, gives instructions for linking,
For information on scripting, see the HyperTalk Beginner Guide.

P Seealso:  * “Managing Icons” in this chaprer
* “Changing the Appearance of a Button” in this chaprer
* “When Elements Overlap” in this chaprer

Combining text with an icon

You can add text to a button that already has an icon. Follow

these steps:
1. Choose the Button tool (=) from the Tools menu. .
2. Double-click the button.
The Button Info dialog box appears.
3. Type the text you want to add to the button.
4. Click the Show Name check box to select it.
5. Click OK.

The text appears along with the icon on your button. To see all
the text, you might have to enlarge the button:

- -

dome Sweet Homé

PR "._ To resize the button,
drag from any corner.

Figure 4-11  Anicon with text
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(:T'L‘;l[iﬂg 4 button  You can make a button with a gruphic hy placing a transparent
with a araphic  button over a graphic. Use this technique when you want to make
a graphic dynamic—so that something happens when you click it.
(Since a graphic can't have a script, overlaying a button is the only
way to do this.)

Important: Buttons with graphics are difficult to move and copy,
because buttons and graphics are different kinds of elements. They
have to be manipulated separately, with different tools—you use
the Paint tools to manipulate the graphic and the Button tool 1o

manipulate the button—and they're in difterent layers (as explained
in “When Elements Overlap,” later in this chaprer). It's better to

. use a button with an icon (if possible), because an icon is attached
to the button and moves easily with the button. A

Follow these steps to create a button with a graphic:
1. Go to the card or background where you want the graphic.

If you're not sure whether you want the graphic in the card layer
or the background layer, see “Adding Graphics to a Card or
Background” in Chapter 6.
2. Create the graphic.
You can create it with the Paint tools, scan it in, bring it in from
a document in the Apple Preferred File Format, or copy and
@ paste it from another stack. The graphic can include some Paint

text, or it can be entirely Paint text. Chapter 6 gives instructions
for creating graphics.

3. Choose the Button tool (=) from the Tools menu.
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While

drag from the upper-left corner

holding down the

of the graphic

Managing icons

key, —.

4. Press and hold the  key while you drag diagonally to create a

button around the graphic:

i ... to the lower-right corner

|’f;+g'.‘;1g a transpdrent button over a arapiic

Figure 4-12

You can bring the button to life by linking it to another card or

writing a script for it (if you're familiar with HyperTalk). (“Linking
Information,” later in this chapter, gives instructions for linking. For
information on writing scripts, see the Hyper Talk Beginner’s Guide.)

HyperCard comes with a collection of icons you can assign to
buttons. Assigning an icon to a button is an easy way to add a
graphic element to a card or background. You simply select the
burton and choose an icon from the Icon dialog box. (“Crearing
a Button With an Icon,” earlier in this chaprer, gives specific

instructions.)

An icon you assign to a button is associated with that button until
vou specifically change it in the lcon dialog box. When you select
the button and drag it around on a card, the icon moves with it.
But the icon is not actually stored in the button.,
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Each icon that appears in the Icon dialog box is stored in a special
part of the HyperCard program file (or a HyperCard stack) called a
resource fork. Most Apple 11Gs files—including the Home stack and
any other HyperCard stack—have a resource fork, where resources
like icons, sounds, and so on are stored. The icons that appear in
the Icon dialog box include the standard icons thar are stored in the
HyperCard I1Gs program file, any icons that are stored in your
Home stack, and any additional icons stored in the current stack.

Using HyperCard’s Icon Editor stack, you can modify an icon
that’s displayed on a button, create icons of your own, and add
icons to your stacks. The Icon Editor stack tells you how. Once you
have created or modified an icon, you need to consider where you
want to store it so that it will be available to the stacks in which

you want to use it.

For example, if you create an icon and install it in any stack other
than Home, it will appear in the Icon dialog box for buttons in that
stack, but it will not appear in the Icon dialog box for buttons in
any other stacks. If you expect to use a particular icon in several
different stacks, install it in your Home stack. That way it will
always show up in the Icon dialog box no matter which stack
you're working in.

If your Apple 1IGS is part of a network, you may want to consider

a different strategy. Each person using HyperCard over a network
uses a different Home stack. This means that any custom icons
you've installed in your own Home stack won't be available to other
people on the network. If you're creating a stack that you want
everyone on the network to be able to use, make sure that any
custom icons assigned to buttons in that stack are stored in the stack
itselt as well as in your Home stack. That way your custom icons
will be available to everyone who uses your stack, even if they don't
have them installed in their own Home stacks.

The Icon Editor stack allows you to install icons you've created
with the Icon Editor in any other stack. You can also install an
icon by copying and pasting a button, or by using the Import
button in the Icon dialog box. The sections that follow explain
these two methods.
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[nstalling an icon
by pasting a button

Click the won 1o select it

if it's not already selected)

If the Import button is
dimmed, the icon is stored
in the current stack

To copy an icon from any stack other than the Home stack into

another stack, follow these steps:

1. Go to a stack that contains a button with the icon you want to

install.

2. Choose the Button tool (=) from the Tools menu.

3. Double-click the button.

The Button Info dialog box appears.
.
4. Click Icon.

The Icon diulug box appears.

stack:

Figure 4-13  Finding out where an icon is stored

6. Click Cancel.

5. Make sure the icon you want to copy is installed in the curr-::rb

and make sune the
name shown here 15 the
name of the current stack.
[ it isnt, go 1o the stick
with the name shown and
begin again with step 1.

Scroll, if necessary, to locate
the icon you want to copy.

The Icon dialog box disappears and you see the Button Info

di;llng box again.
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7.

9.

10

11.

Click Cancel again.

"The Burton Info dialog box disappears. A moving dashed
line surrounds the button you want to copy, indicating that it
is selected. (If you deselect it by accident, just click it again to
select it.)

Choose Copy Button from the Edit menu, or press ~-C.

This makes a copy of the selected button (including its icon) and
puts it on the ( f|iplm;xrd, (This button rcphlccs the last item you

cut or copied; the Clipboard can only hold one item at a time.)
Go to the stack in which you want to install the icon.

Use the arrow keys or commands in the Go menu to navigate
between cards while the Burtton tool is selected.

If you just want to install the icon, you can go to any card or
background in your stack. If you want to use the burton (and its
script) as well as the icon, go to the card or background where
you want the button to appear. (If you're not sure whether to
put the burtton in the card layer or the background layer, see
“Adding a Button to a Card or Background” at the beginning
of this chapter.)

Choose Paste Button from the Edit menu, or press -V.

This takes a copy of the button that’s on the Clipboard, puts it
on the current card or background, and selects it. At the same
time, pasting the button installs the button’s icon in the current
stack’s resource fork.

[f you want to keep the button, drag the button to where you
want it.

[f you don't need the button, press Delete to delete it. The icon
remains in the stack and will appear in the Icon dialog box for
any button in that stack.

The icon you've installed will now appear in every copy of the stack,
even if the icon is not installed in the current Home stack.
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lllHILﬂMI]g an icon with the  'To copy an icon from your Home stack into another stack, follow
[con dialog box  these steps:

1. Go to the stack in which you want to install the icon.
2. Choose the Button tool (=) from the Tools menu.

3. Double-click the button on which you want to display
the icon.

The Burron Info dialog box appears.(You must follow this step
and the steps that follow even if the bucton already displays the

icon you want.)
4. Click Icon.
The Icon dialog box appears. ®

Install the icon as shown in this figure:

W

Click the icon to select it
(if it's not already selected)

then click here to import

the 1con o the current stack,
(If the Tmport button is
prmedd, the eon s shreacy

YO o necd to mpaor i

(hone ) (Eancel) (k)
Figure 4-14 Installing an icon with the Icon dialog box .

The icon is now installed in the current stack.
6. Click OK.

The Icon dialog box disappears and you see the Button Info
dialog box again.
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7. Click Cancel again.

%

11.

The Button Info dialog box disappears. A moving dashed
line surrounds the button you want to copy, indicating that it
is selected. (If you deselect it by accident, just click it again to
select it.)

. Choose Copy Button from the Edit menu, or press -C.

This makes a copy of the selected button (including its icon) and
puts it on the Clipboard. (This button replaces the last item you
cut or copied; the Clipbuard can only hold one item at a time.)

Go to the stack in which you want to install the icon.

Use the arrow keys or commands in the Go menu to navigate
berween cards while the Button tool is selected.

If you just want to install the icon, you can go to any card or
background in your stack. If you want to use the button (and its
script) as well as the icon, go to the card or background where
you want the button to appear. (If you're not sure whether to
put the button in the card layer or the background layer, see
“Adding a Button to a Card or Background” at the beginning
of this chapter.)

Choose Paste Button from the Edit menu, or press -V.

This takes a copy of the button that’s on the Clipboard, puts it
on the current card or background, and selects it. At the same
time, pasting the button installs the button’s icon in the current
stack’s resource fork.

If you want to keep the button, drag the button to where you

want it.

If you don’t need the button, press Delete to delete it. The icon
remains in the stack and will appear in the Icon dialog box for
any butron in that stack.

The icon you've installed will now appear in every copy of the stack,

even if the icon is not installed in the current Home stack.
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]I]hl;l”iﬂg an icon with the  To copy an icon from your Home stack into another stack, follow
[con dialog box  these steps:

1. Go to the stack in which you want to install the icon.
2. Choose the Button tool (=) from the Tools menu.

3. Double-click the button on which you want to display
the icon.

The Burton Info dialog box appears.(You must follow this step
and the steps that follow even if the button already displays the
icon you want.)

4, Click Icon.
The Icon dialog box appears. .
5. Install the icon as shown in this figure:

10: 1370 "Sunl" from "HOME"

Click the icon to select it
(if it's not already selected) . .

then click here to import

the icon mto the current stack
(1f the Import button is
dimmed. the won s alreads

VO aon b necd to omport )

View (Wone ) (Concel) L 0k}

Figure 4-14 Installing an icon with the Icon dialog box .

The icon is now installed in the current stack.
6. Click OK.

The Icon dialog box disappears and you see the Button Info
dialog box again.
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7. In the Button Info dialog box, click OK.

The icon you've installed will always appear in the Icon dialog box
for your stack, even if the icon is not installed in the current
Home stack.

L(_)L‘Ll[illg buttons Many of the buttons in stacks are easy to locate right away. Bur
some buttons are harder to find—particularly transparent ones.

You can locate the buttons on the current card and background
using any of the following methods:

a8 = While the Browse tool is selected, you can “peek” at the buttons
by pressing and holding the % and Option keys. Gray or colored

rectangles appear around the buttons:

[hin rectangles outline the
buttons in the card layer.

Eh’t_ Eu Scu_r ﬂ i
® Procice | K] MR|ES] [ chonse cotors | [“ﬂj

Thick rectangles outline the buttons in [hcl
background layer.

. Figure 4-15 Peeking at buttons
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s  When you choose the Button tool from the Tools menu,
rectangles appear around the buttons that don't already have

an outline:

When you
choose the .. rectangles appear
Button Tool . around the buttons.

T e o e Lk

3 e I
| Home Stack / Welcome User tone B perCard [1GS |
| Creote Quicklink |

I | User Preferences |

Help Fieture Puzzler

B [E B
i’ g % -
Hirds Tour §tory Board : .
§E Copuright © 1990 Apple Computer, [ne
?m[ Beskser |[ Tooikit |[ Wsic ][ Bosement |R

Figure 4-16  Locating buttons with the Button tool

= Some stacks have hidden buttons. To “peek” at all the buttons
on the current card and background—including any hidden
buttons—choose the Button tool from the Tools menu, then
press and hold the ' and Option keys. Gray rectangles appear
around all the buttons:

When vou choose the Button ool

and press "-Option, rectangles ... and the .
outline the visible buttons hidden buttons

T ————

Sroe | RIS (ouwtin] [0

T e e s e R R

Figure 4-17  Peeking at all the buttons—both visible and hidden
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Changing
the appearance
of a button

Changing the size

o of 4 button

Once you've created or copied a button, you can change its
appearance by resizing it, changing its style, adding text or an

icon to it, changing or removing its text or icon, or changing its
color. This section explains how to make a button look the way you
want it to.

% Note: You can change the appearance of both card buttons and
h'.lt.‘kgrmlnd buttons while you're working in the card layer. You
don't have to be in the background layer to modify background
burtons. <

To resize a button, follow these steps:
1. Choose the Button tool (=) from the Tools menu.
2. Click the button you want to resize to select it.

A moving dashed line surrounds the selected button.

3. Drag from any corner of the button:

.
ssssssfesmsns sassnafennnms

k_ g from any corner
o - I.
to resize the button

Figure 4-18  Changing a button's size

To resize the button in one dimension only—either horizontally
or vertically—hold down the Shift key while you drag from a

Corner.

& If you move the button instead of resizing it: Choose Undo
from the File menu to return the button to its original
position and try again. Make sure you drag from a point
close to a corner of the button. «
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Chox l.“;iﬂf.i 4 button's Hl}'lk' A button can have any onc of seven styles. Examples of the seven
button styles are shown in the following figure, along with the

names of the styles:

CLIlltFansparent —— 1 I'he background shows

....................... through trnspirent [INIGIHE

...................

g ————— v 1 | These kinds of buttons
1

shadow are all opaque
( roundrect ¥::j

...................... | The background shows through

vhd 'C)Trudio button:::: the text part of these buttons, hut

...................... not through the button part

Figure 4-19 The button styles

To set the style for a button, follow these steps:
1. Choose the Button tool (=) from the Tools menu.

2. Click the button to select it.
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3. Choose Button Info from the Objects menu.

The Button Info dialog box appcars:

Button Name: [| ]
Card button number: & Card button 10: 7

CSmhme  suyle

S bitie iy
15hare Bilite

[L:nk To. ] [ fant.. ]
[Scl'tpt...] [[:ulnrs...] f oK ) [tancel]

Figure 4-20  The Button Info dialog box

4. Press and hold the mouse button over the pop-up Style menu
and drag to choose a style:

Mikes the button an opague (whiey .. ] transparent 1 —“[?"!*L'“'-l"ﬁ |'_‘“'-"'*'-"='-"“I"='-"'~'”I
rectangle, with no visible Iu 0 Iu Card |'.'ILI1_ opaque with no visible border
Makes the button an opaque STCE rectangle , — | Makes the hlulum an opaque (white)
(white) rectangle, with a shadow shadow | rectangle with a thick black border
Hong the rght side and hortom Family: round rect | Makes an opague (white)

. Makes a small square button _ check box I rounded rectangular button

With R DpaguE inlerio radio hutt_on | Makes a small round button
with an opaque interior

[ 0K Il (Cuncal ]

Figure 4-21  Choosing a button's style
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Adding, changing,
Of removing
button text

Setting the format
for button text

For a button with an icon, don’t choose either the check box or

the radio button style—if you do, you won't see the icon.

5. Click OK.

To add, change, or remove button text, follow these steps:

1. Choose the Button tool (=) from the Tools menu.
2. Click the button you want to change to select it.
A moving dashed line surrounds the selected burron.

3. Choose Button Info from the Objects menu while the button

is selected.
The Button Info dialog box appears. ®

4. Type the text you want to display on the button; or press
Delete, if you want to delete the text.

You can also remove the text from the button by clicking the
Show Name check box to deselect ir.

5. Click OK.

[f you want to change the colors of the text displayed on your
button, see “Changing a Button’s Colors,” later in this chaprer.

To change the font, style, size, or alignment of the text that’s
displayed on a button, follow these steps: .

1. Choose the Button tool (=) from the Tools menu.
2. Click the button you want to change to select it.

A moving dashed line surrounds the selected burton.
3. Choose Text Style from the Edit menu, or press ~-T.

The Text Style dialog box appears.
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4. Choose from the options in the Text Style dialog box:

Click to select a font

Click to select the size (measured in
font you want. points)
Click to select or deselect one or “Style: —.
more text styles. (Select nothing for [] ClBold ‘ Courier :
plain text.) The sample text at the || | 1eatic U | Senevo b
hottom of the dialog box shows the i-____:il_j;',{jq;lum\ Helvetica
cffect of the selected 'il\.\'|t;.~;. ‘ [Joutline
[ Shadow & To use a font size not
Press and hold the mouse button here _hm Line Height: E Font Size: [: listed, type it here
to see i pop-up menu for choosing — N ey
the alignment o wext on the bulton ‘ The quick brown fox jumps over the lazy dog. i
- ; affect the way the text

looks on a button. (Only
one line of text can show
on 4 button. )

This shows what the text on
your button will look like

Figure 4-22  The Text Style dialog box

5. Click OK.

The burtton's text is displayed in the format you've specified.

Assigning, chz lﬂ‘}__m{t_‘ To assign a new icon to a button, assign a different icon to a button,
Or removing an icon — or remove a button’s icon, follow these steps:

1. Choose the Button tool (=) from the Tools menu.
B 2. Double-click the button you want to change.
The Button Info dialog box appears.
In the Button Info dialog box, click Icon.

The Icon dialog box appears.
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4. Select an icon for the button, or remove the icon, as shown in

the following figure:

To display an icon
it 1D: 0 (none
on the button (or (one)

S (162 G < B el S
i | HESBeD o
Q2 & GG w m

M = s 2 @ o 9

ST l|| il
necessary, 1o
find the icon vou

want rn;\'liap:;n

(Import ((Wone ) (Coneel) {0k ) o e Dustio
i1 Wi Ll
If the icon you select isnt  1Click here if you want .
cntirely visible, press and 1o remove the button’s

hold the mouse button con
here to see what the

whole icon looks like

Figure 4-23 Setting and removing an icon

5. Click OK.

The Icon dialog box disappears and you see the Button Info
dialog box again.

6. In the Button Info dialog box, click OK.
Your button displays the icon you've chosen.

[f you don't want to use any of the icons shown in the Icon dialog
box, you can either copy a button with an icon you like from the
Button Ideas stack or create your own icon using the Icon Ediror
stack.

[f you want to change the colors of the icon displayed on your
button, see the next section, “Changing a Button's Colors.”

} Seet alio: « “Managing lcons™ i this chapter
(=) o
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':.I]Zlﬂl,‘.,’.”']fc.', H| ]‘JLIHE ms  You can choose the colors for tour different parts ol a button: the
colors  icon front, icon back, burton frame, and button text. Each part is a

difterent color in the button shown here:

_ Frame

Figure 4-24  The four parts of a button

. To change a button’s colors, follow these steps:
1. Choose the Button tool (=) from the Tools menu.
2. Double-click the button you want to change.
The Button Info dialog box appears.
3. In the Button Info dialog box, click Colors.
The Colors di;ﬂug box appears.

{ St’]{.!ljt lht‘ CU[DI’S you want.

Chek the colors

you want for each lcon Front Tcon Bock

|".'.|'| O The 1c0en [T .
. I ﬁ This shows how

sample the colors you

select affect the

way the won

s
Cox )

Figure 4-25  The Colors diadog box for the hunon shown in Fiaure 4-24
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5. Click OK.

The Icon dialog box disappears and you see the Button Info
dialog box again.

6. In the Button Info dialog box, click OK.

The button disphlys the colors you have chosen.

Llﬂklng information o create a link berween relaced pieces of information, you create
| a button and link it to another card or stack. When you click a
button that'’s linked to another card, that card appears immediately.
Links are one way. To move back and forth berween two cards, j.'.

need two links—one in each direction:

e HyperCard IG5 |
Home Stack/Deskset Create Quitklink...| P

User Praferences

= ddresses

Figure 4-26 Two links that take you from one stack to another and back again
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Using the Link To method

You can close the Link Te
box without creating a link
by clicking the close box or
the Cancel button

You can link a button to a card or stack using any of the following

lllt.‘tiu:-ds:
m Use the Link To box.
s  Write a short script.

s Use the Create QuickLink button in the standard Home
stack (as described in “Customizing Your Home Stack” in
Chapter 2).

Important: If you use the Link To method to link a button
that already has a link, the new link completely replaces the
previous one. A

To use the Link To method for linking a button to any card or

stack, follow these steps:

1. Choose the Button tool (=) from the Tools menu.

o]

. Double-click the button you want to link.
The Button Info dialog box appears.

3. In the Button Info dialog box, click Link To.

The Link To box appears:

| INEARI TR LR PR T BTN FRED B AR L0 SEVRN AR ARROA S | RO PUARE L RRTI AT RELAR)

Link to:
((This Cord ) (This Stack) (_ Concel )

Figure 4-27  Using the Link To box to create a link

% Note: The Link To box works differently than a standard
Apple 11GS dialog box. You don't respond right away when
you see the Link To box. First you use HyperCard'’s
navigation methods (such as the Go menu commands)
to locate the card or stack to which you want your
button linked. «
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4. Before you click a button in the Link To box, go to the card
you want to link the button to.

The Link To box doesn’t disappear—it stays on the screen while
you move from card to card,

If the Link To box gets in your way, you can move It:

I 1L EARELAREL BTN LRI LR A RELIEL LU TR TR O

L You can move the
Link to: T !
: Link Toy hox In

(This Card ) (This Stack) (Concel ) draoging from here

Figure 4-28 Moving the Link To hox

5. When you're looking at the card or stack you want to link the
button to, click the option in the Link To box that reflects
where you want the button to take you.

Click This Card if you want to link the burton to the current

card.

Or click This Stack to link the button to the first card in the
current stack (no matter which card you're looking at).

After you click one of these options, HyperCard returns you to
the card that contains the button you've just linked. The button

is still selected.

If you want to test your new link, choose the Browse tool from tl‘u‘:.
[ools menu and click the burton. It should take you to the card or
stack you've just linked it to. If it doesn't, repeac the Link To
procedure or try the scripting procedure described in the next

section, “Scripting a Link.”

Chapter 4; Working With Buttons




Scripting a link

As an alternative to using the Link To box, you can write a script
that links a button to another card or stack. (To do this, yOUL MUSt

have your user level set to Scripting, as explained in “User Levels

and Options” in (fh;lpu:r 1).

Once you know the steps involved in scripting a link, this method

can be faster and more srmightlhn-\fard than using the Link To box

to create a link.

Follow these steps to s ript a link:

1. Ifyou're linking the button to a specific card, find out the

card’s name, number, or ID.

To find the card’s name, number, or 1D, go to the card and

choose Card Info from the Objects menu.

The Card Info dialog box appears. Make a note of the card’s

name, number, and 1D:

The card’s name

L

Card Nome: |IFTINSE ]

The card's number

Cord ID; 4670._ Cord number 3 0ut of 7

The card's 1D

Contains 0 cord fields.
Contoins 3 cord buttons
E=]Con't Delete
[10on't Search

(S(:rll:t..] [Enlurs..] Eﬂ {Euncen

Figure 4-29  Finding out a card’s name, number,
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2. Go to the card that contains the button for which you're

creating a link.

3. Press and hold the . and Option keys while you click the

bll.l'[ﬁl] once.

The button’s script opens. It should look like this:

Script of Cord button ID 1
4
s

Figure 4-30  Opening a button's script

4. If there’s any text in the script, don’t go any further.

The text indicates that the button is designed for another
purpose. Unless you're familiar with HyperTalk, it’s best to
close the script by clicking Cancel, and create or find another 3

button to link.
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5. 1f the script is empty (like the one shown in Figure 4-30), type
any of the following, substituting the card name, card number,
card 1D, or stack name for the card or stack you want to link
the button to:

deript of Card butten 101 Takes vou to the card with
on mousellp :

g0 to card "eard nams" the specified name.
end mouselp

Script of Cord button ID1

, Takes you to the card with

on mouselp !
go tocord i the specilicd number,

end mouselp

. Script of Card button ID 1

| on mouselp B
go tocard 108 the specified ID
end mousellp

Takes you to the card with

ek Ahad bl LB Takes you to the stack with
on mouselp :

80 to stack “stack nome" the specified name.
end mouselp

Seript of Cord button 10 1

Takes you to the card with
the specified card name in

on mouselp he stack with th wifiesd
g0 to card “card name” 1n stack “stack nome — (1€ SEACK With the speaihed
end mouselp stack name

Figure 4-31  Seripting a link

6. When you're finished, press Enter.

If you want to test your new link, choose the Browse tool ()
from the Tools menu (if it isn't already selected) and click the
button. It should take you to the card you've just linked it to.

[f it doesn't, check your script for typos and make sure the card
name, number, or I matches the one you've typed in the scripr.

Chapter 4: Working With Buttons 1583
| g




:\-'Ill]{illg d button  You can design a button so that it highlights momentarily when
h]‘.{_’,h]]&:h[ when You clicit' it. Su_ch a b_urmn_ is helpful when },-'nu'r%’ using a stack,
= _ : because it provides visual feedback thar you've clicked the button.
it's clicked .
Follow these steps to create a button thar highlights when you
click it:

1. Choose the Button tool (=) from the Tools menu.
2. Double-click the button.
The Button Info dialog box appears.

3. In the Button Info dialog box, click the Auto Hilite check box

to select it.
4. Click OK. @

Auto Hilite works as just described for all buttons excepr check box
and radio buttons and burttons that are part of a family. When Auto
Hilite is selected for a check box or radio burtton, clicking the
button once highlights it and leaves it highlighted. Clicking the
button again removes the highlight. When Auto Hilite is selected
for a button that is part of a family, clicking the button once
highlights it and removes the highlights, if any, from other buttons
that belong to the same family. (For more informarion about button
families, see “Making a Group of Buttons | lighlight As a Family,”

later in this chapter.)

With the Auro Hilite option turned off, you receive no visual
feedback when you click a burton. .
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I'he figure that follows shows how the different kinds of buttons
]1ighlighl when Auto Hilite is turned on.

transparent @ check box
p ! These stay highlighted
i until you click them again
opaque @) radio button
These highlight | rectungle
for only a , i
moment when

1
AL ‘li.hl!l.l.ll: m
b
m

Figure 4-32 Highlighting buttons of different styles

N’léll(lng d l)Ll[t(Jn Background buttons have an additional option available (in the

appear ]‘llghllghtt’d Button Info dialog ht‘)x] cal‘lcd Share Hilirn-:,“?(ﬂwn you click a

s background button for which both Auto Hilite and Share Hilite are

on certain cards turned on, the button becomes highlighted on every card with that

background. If the button is a radio button or check box, it stays

highlighted; if it is any other kind of button, it highlights only

. momentarily. (To make a button that is not a radio button or a
check box remain highlighted after it’s clicked, rather than high-
lighting for only a moment, you must use HyperTalk to change
the button’s hilite property. See the HyperTalk Help stack

for details.)
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However, when Auto Hilite is turned on and Share Hilite is turned
off, the highlight of the button can vary from card to card. This
allows the button to appear highlighted on some cards, and not on
others—which can be useful for signifying that something is true
for some cards but not for others. (Check boxes and radio buttons
are particularly useful for this purpose.)

To allow a background button’s highlight to vary from card to card,
follow these steps:

1. Choose the Button tool (=) from the Tools menu.

2. Click the button whose |1ighlightjng you want to vary from
card to card to select it.

3. Choose Button Info from the Objects menu. @
The Button Info dialog box appears.
4, Click the Share Hilite check box to deselect it, if it’s selected.

When a background button is first created, this option is
turned off. If it has been turned on, click it to turn it off again.

Button Name: | |
Click Auto Hilite 1o Blegnd button number: 2 Bkgnd button ID: 2
selectit, ifisnt (1 show Nome style:
aready selected G Auto Hilite
nn Fomily:
Click Share Flilite [ 5hare Hilite

o deselect o, i it's .

selected
(Link T0..) ( Font... )

[Scrm. ] Etnlnrs...] m [ Concel )

Figure 4-33  Varying a button's highlighting from card to card

5. Click the Auto Hilite check box to select it, if it isn't

already selected.
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6. Click OK.

[f you want the button to appear highlightf;d on any particular
card, you have to go to that card and click the button.

\’Iakmg d group of Normally, when you click a radio button or check box for which
hUU()I]"} hl“hlluht Auto Hilite is turned on (in the Button Info dialog box), the button
highlights; and when you click it again, the button changes back to

ds d [uln“]}’ its original appearance.

Sometimes you may want a group of buttons to work together as a
family, so that only one button in the group can highlight at one
& time. For example, you can use a group of radio buttons on one

card to choose between several different options; the radio button
that is highlighted indicates which of the options you have selected.
You could do this by means of a script that automatically turns off
the highlighting for the other radio buttons when one radio burton
is clicked. Burt there’s an easier way.

The Button Info dialog box includes a pop-up Family menu that
allows you to assign any button a family number from 0 to 9.

A family number of 0 means the button does not belong to a
family. If the family number is any number from 1 through 9, it
will highlight as part of the family composed of all other buttons
in the same layer with the same family number.

& Only one button in a button family can be highlighted at any one
time. When you click another button in the family, the button you
clicked becomes highlighted, and the button that was originally
highlighted changes back to its normal appearance:

() Level 1 O Level 1
@ Leve] 2 @ Level 2 it becomes the

When you click one only highlighted

butron in o Lunily _,Q Level 3 O Leye] 3— button in that Goily

Figure 4-34 The effect of clicking a button that is part of a family
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o assign a family number to a button, follow these steps:
1. Choose the Button tool (=) from the Tools menu.

2. Click the button to which you want to assign a family number
to select it.

3. Choose Button Info from the Objects menu.
The Button Info dialog box appears.

4. Click the Auto Hilite check box to select it, if it's not already
selected.

5. Choose the family number you want:

Button Nome: |[ITIIE |
Cord button number:3  Cord button 10: 4
&< Show Nome Style on §
B Auto Hilite _ 0 (none) Precs and hold the
Fomily: Press and nold the
] Share Hilied ? mouse button here
i :l|l1L|tL.|I".E:LI[ to L‘I]cln 5¢
the family number
(Linll To. ] (_Fi:mt... ] 5 — '»\.l'.'.l-.
['.Sr.npl...] [Eulnrs...] (: ? @
w

Figure 4-35  Assigning a family number to a button
g gnin| }

You must repeat this procedure to assign the same family number to

6. Click OK.

cach burton you want to highlight as part of the same family. All
buttons in the same family must be in the same layer.

» Seeabo:  * “The Card Layer Versus the Background Layer™ in

Chapter 2
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]\'Lll]]l[lg d h{.ll[(_}n You can give a button a name when you want to display text on i,
or if you want to be able to address the button by name through
scripts or the Message box.

Follow these steps to name a button:

1. Choose the Button tool (=) from the Tools menu.
2. Click the button you want to name to select it.

3. Choose Button Info from the Objects menu.

Or double-click the button. The Button Info dialog

l)( X illJi]L'll rs.

® 4. Type a name for the button:

TRERE, BEIS Button Nome: | STTEITRITHE |

Bkand button number:1  Bkand button ID: 1

i*.:-.||~1i‘|__13 LIe DSthme Style:

name on the e
[ JAuto Hilite

button, click sy Fomily: | 0 Cnone)

here 1o select [ ] Shore Hilite

Show Name
[Link Tﬂ...J [Funt...]
[Scrint...) [Ealurs...] [ 0K :]] [l‘.uncel]

Figure 4-36  Naming a button

l"; TS ) 1 = C o < L al C L- c
[t's best to give the button a name that communicares

Its purpose.

If you want the button’s name to appear on the button,
click the Show Name check box to select it.

6. Click OK.

o ]
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Moving a button
around on a card
or background

<+ Script writers take note: 1f you chungu the name of a burtton, be
sure to change its name everywhere you refer to it in a script,
too. For example, if you rename a button “Today™ and you use

the old name “Yesterday” in a script, the script won't work

properly—it won't be able to find the burton it needs.

You can place a button wherever you like on the card or
background. To reposition a button on the card or background,

follow these steps:
1. Choose the Button tool (=) from the Tools menu.

Click the button you want to move to select it. &

| ]

Whether the button is in the card layer or the background layer,
you can select it from the card layer.

A moving dashed line surrounds the selected button.

3. Drag from the middle of the button, or from one of its edges
(not a corner):

.......................

el Drag from the
k el middle to move
. the hutton

Figure 4-37  Repositioning 4 button on the card

To constrain the button’s movement to horizontal or vertical
directions only, hold down the Shift key while you drag from
the middle of the burtton.

You can select and move only one button ar a ume.
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When elements
overlap

Important: After you reposition a background button, it’s a good
idea to look through the cards on which the bucton appears, to sce

how the cards look. &

HyperCard puts different kinds of elements in different layers, as
shown in the ﬂ}lluwing ﬁgurc. 'lhgc[hct', all these layers make up the

card you see.

Background picture
_'.--"; H.lL'l\}l]'thI‘iLl

: : huttons and helds
: B ree® : Card picture i
i : 3 : Card buttons
1 s e : ity o
i : et and fields
1% : i What vou see

when you look
at the card

i} *taaman

is fixed in a layer by

itself—it's always ! T | . '_::
behind the background - I S <
buttons and fields and s =

all the card elements, The card picture is also é%’?} ﬂ/

fixed in a layer by
itself—it's always
behind the card huttons
and fields, and i front
of the background
buttons and fields

2=

Figure 4-38 HyperCard's layers

As shown in Figure 4-38, background buttons and fields go in a
different layer than card buttons and fields. Within each of these
layers, HyperCard places each new button or field you add
(whether you've ereated it or copied it) in front of the clement
added betore it. (/n front of means “closer to you.”)

193
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HyperCard also assigns numbers o the buttons and ficlds as you
add them. The first field you add is field number 1, the second is
field number 2, and so on. Likewise, the first button you add is
button number 1, the second is button number 2, and so on. The
numbers reflect how far away the elements are from you—the
farther away an element is, the lower its number. (These numbers
appear in the Button Info and Field Info dialog boxes.)

Although HyperCard numbers the buttons and fields separately, it
places each new element immediately in front of the previous

clement (within the same layer), whether it’s a button or a field.

This was added First.

This was added second .

This was added third

This was added tourth

}éuttnn 1 ;
. FiEM 2

This was added tilth.

This was added sixth

Figure 4-39  Backeround button and Held Livers and numbers
g =

HyperCard numbers the card buttons and fields separately from the
background buttons and fields. The card elements are always in &
front of all the background elements (as shown in Figure 4-38).

This layering of buttons and fields becomes evident when the
elements overlap. Elements that are closer to you can obscure
clements thar are farther away. If this happens, you can either
move the elements apart so they don't overlap, or you can try

either of the following:
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s Reorder the buttons and fields. (You can move any button or
field closer or farther, within its layer).

= Make some of the elements transparent, so you can see other
elements through them. (Buttons, fields, and graphics can all be

made transparent or opaque.)

I'he following sections describe these solutions.

Reordering buttons  Overlapping buttons and fields can cause visual and functional
problems in your stack. For example, a button that’s complertely
covered by a field (or another button) won't respond when you try
to click it. To solve the problem of overlapping buttons and fields,

. you can reorder them to bring the ones you need to see and use into
full view.

~\ Important: The buttons and fields in the card layer are always in
front of the background buttons and fields. Although you can
reorder the background buttons and fields relative to one another,
you can never move them closer to you than any of the card
elements. (You can, however, make card elements transparent so
you can see through them to the background elements, as explained
in the next section.)

To move a button closer or farther (relative to the other buttons and
fields in the same layer), follow these steps:

I. Choose the Button tool (=) from the Tools menu.
2. Click the button you want to move closer or farther to select it.

A moving dashed line surrounds the selected burton.
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3. Choose Bring Closer from the Objects menu to move the
button forward one position, or choose Send Farther to move
it back one position.

Ilach time you move a button back one position relative 1o
another button in the same layer, its number (in the Button Info
dialog box) decreases by 1. Each time you move a button
forward one position relative to another button in the same
layer, its number increases by 1.

Note that a button’s number may not change every time you use
the Bring Closer or Send Farther commands to change its
position. For example, if a field lies between button 3 and

button 4, you'd have to move button 4 back two positions [witb
the Send Farther command) before it would become button 3.

You can also move the selected butron all the way to the front or
all the way back using these “-key shortcuts:

To do this. .. Press
Send the button to the back -Shitt- = (minus)
Bring the button to the front -Shift-+ (p|115}

4. Repeat step 3 until the button is where you want it.
5. Choose the Browse tool () to deselect the burtton.

As you reorder buttons, the numbers of all the affected burtons
change to reflect their new positions. Each button’s number b
(shown in the Button Info dialog box) reflects its front-ro-back
position, relative to the other buttons in the same layer. (The

button that’s farthest away is button number 1. The closer a

button is to the front relative to other buttons in the same layer,

the higher its number.)

The commands Bring Closer and Send Farther work the same way
on a selected field, as described in “Reordering Fields™ in Chaprer 5.
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.'\LIJ&IH‘L’, a1 button opaque When you want to be able to see l‘salcl\'gmund or card clements
Or transparent through a burton that covers them, you can make the button
transparent. Conversely, when you want to give a button more

prominence, you can make it opaque.

F“.l“()\-\" tllt'ﬁtf S[CPS o ]Tli]_kﬂ d b]_lf['(}ﬂ {)Pﬂqll('_’ or [l—ilﬂsp'{lrt'll[:
1. Choose the Button tool (=) from the Tools menu.

2. Click the button you want to change to select it.

3. Choose Button Info from the Objects menu.

Or double-click the button. The Button Info dialog box
appears.

® 4. Choose an appropriate button style to make the button
opaque or transparent:

ButtonNome: || trensporent - Choosing this style makes
Card button number:1  Card buf o000, the button transparent

Show Nome Style:

Auto Hilite shadow Choosing one of these styles

Fomily:

1o e . rect

T ]Share Kilite round rec
check box

radio button
[Lmulu._.] [ant.. ]
I:Script...] (talors...]

makes the button opaque.

Figure 4-40 Making a button opaque or transparent

5. Click OK.
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™ - r. - - "
(-(}[)T}-‘lllg d hU[[()n You can duplicate a button on the same card, or copy a button to
another card, background, or stack. When you copy a button, you
also copy its attributes—it’s style, name, icon, script, and so on.

\ Important: To copy a button and a graphic that shows through it
you have to copy the picture and the button separately. (This is not
the case for a button with an icon.) Follow the instructions given
here to copy the button. See Chapter 6 for instructions on copying

a graphic. &

(:U[)}"[l]g 4 button  ‘lo dupliultc a button on the same card or buckgmuud, follow
on the same card  these steps:

1. Choose the Button tool (=) from the Tools menu.
2. Click the button you want to copy to select it.

You can select the button from the card layer, whether it’s a card

hLit[U” orad bil(:l(gr(.)und bl..lt[{JIL
A moving dashed line surrounds the selected button.
3. Press and hold the Option key while you drag the button.

As you drag, you create an exact duplicate of the button. If the
original is a background button, the duplicate is a background
button. If the original is a card burtton, the duplicate is a card
burtron.

To constrain the new button’s movement to horizontal or @)
vertical directions only, hold down the Shift key while you
drag from the middle of the button.

195 Chapter & Working With Buttons




Copying a button to another  To copy a button to another card or background, follow these steps:
card or background I. Choose the Button tool (=) from the Tools menu.

2. Click the button you want to copy to select it.

3. Choose Copy Button from the Edit menu, or press ~-C.

This makes a copy of the selected button (including its script)
and puts it on the Clipboard. (This button replaces the last
item you cut or L‘Opifed; the Clipboard can only hold one item
at a time.)

4. Go to the card or background where you want the button
to appear.

. Use the arrow |(r:}'5 or commands in the Go menu to navigate
between cards while the Button tool is selected.

”'_ _\'(”.11“: not sure \Vht‘[llt‘l' o pl].[ rI]f_’ hl“[ﬂl] il] [hl: L_L'ird iﬂ}’l_'r
or the background layer, see “Adding a Button to a Card or
Background” at the beginning of this chaprer.

5. Choose Paste Button from the Edit menu, or press -V,

This takes a copy of the button that’s on the Clipboard, puts it
on the current card or background, and selects it.

It you've copied a background button to the card layer of the
same card, the copy is pasted directly over the original. To see
the original, you have to drag the copy to move it.

. 6. While it’s still selected, drag the button to where you want it.

.\ Important: The most common mistake in copying a button is
putting it in the card layer when you want it in the background
layer. (To find out whether the button is in the background layer,
press - -B to see just the background elements.) If you pur a button
in the card layer by mistake, see the next section, “Moving a Button

From the Card to the Hilt_'ligl'()l_llld.“ N
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After you copy a button from another card or stack, it’s a gnml idea

to test the button to make sure it works properly. To test the button,

choose the Browse tool and click the button. If clicking the button
o ' produces an unfamiliar message (for example, a message that

begins with “Can’t Understand . . .” or “Never heard of . . .”),

see “Copying Parts From Other Stacks” in Chapter 2 for advice

on how to proceed.

.l\"I(')\-'ing a button s easy to put a button in the card layer by mistake when you
from [hL‘ L‘lﬂ‘d intend to put it in the background. If this happens, you can move
the button from the card layer to the background layer (of the same

to the background  card) by following these steps: -
I. Choose the Button tool (=) from the Tools menu.
2. Click the button you want to move to select it.
A moving dashed line surrounds the selected button.
3. Choose Cut Button from the Edit menu, or press " -X.

This removes the button from the card and puts it on
the Cli pbc—ard.

4. Go to the background layer.
Choose Background from the Edit menu, or press "-B.
5. Choose Paste Button from the Edit menu, or press -V.

This takes a copy of the button that’s on the Clipboard, puts it
in the current background, and selects it. The pasted button
appears in the same position from which it was cut.
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6. While it’s still selected, drag the button to where you want it.

Since you can't see the elements in the card layer while you're
working in the background, you might not be able to tell
whether you're putting the button in the right place. If this
happens, you can press ("-B again to go back to the card layer,
and then select and drag the button from the card layer.

MOViﬂg a button  Follow these steps to move a button from the background layer to

f]‘()m the baCkgl'OUﬂd the card layer of the same card:
s to the card - Choose the Button tool (=) from the Tools menu.

o

2. Click the button you want to move to select it.
A moving dashed line surrounds the selected button.
3. Choose Cut Button from the Edit menu, or press J-X.

This removes the button from the background and puts it on

the Clipboard.

4. If you're in the background layer, go to the card layer by
pressing (!-B.

If you're already in the card layer, skip this step.
5. Choose Paste Button from the Edit menu, or press (-V.

This takes a copy of the button that’s on the Clipboard, puts it
© on the current card, and selects it. The pasted button appears in
the same position from which it was cut.

6. While it’s still selected, drag the button to where you want it.
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MOViﬂg d hthtOI‘l You can move a button to another card in the same stack, orto a
to Hn()[hel' Cal‘d or card in another stack. When you move a button, its attributes—

it’s style, name, icon, scripts, and so on—move with it.

background

A\ Important: To move a button and a graphic that shows through it,
you have to move the picture and the button separately. (This is
not the case for a button with an icon.) Follow the instructions
given here to move the button. See Chapter 6 for instructions on
moving graphics. 2

Follow these steps to move a button to another card or background:

1. Choose the Button tool (=) from the Tools menu.

2. Click the button you want to move to select it. ®
A moving dashed line surrounds the selected burton.

3. Choose Cut Button from the Edit menu, or press -X.

This removes the selected button from the current card and puts

it on the Clipboard.

4. Go to the card or background where you want to put
the button.

Use the arrow keys or commands in the Go menu to navigate
between cards while the Burton tool is selected.

If you're not sure whether to put the button in the card layer or
the background layer, see “Adding a Button to a Card or
Background” at the beginning of this chaprer.

5. Choose Paste Button or from the Edit menu, or press —-V.

This takes a copy of the button on the Clipboard, puts it on the
current card or background, and selects it.

6. While the button is still selected, drag it to where you want it

on the card.
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2\ Important: The most common mistake in moving a butron is

Opening a
button’s script

putting it in the card layer when you want it in the background
layer. (To find out whether a button is in the background, press
—B to see just the background elements.) If you pur a burron in
the card layer by mistake, see “Moving a Button From the Card to
the Background,” earlier in this chaprer. A

Atter you move a button from another card or stack, it’s a good idea
to test the button to make sure it works properly. To test the burron,
choose the Browse tool and click the button. If clicking the burton
produces an unfamiliar message (for example, a message that begins
with “Can’t understand . . .” or “Never heard of . . .”), see “Copying
Parts From Other Stacks” in Chapter 2 for advice on how to
proceed.

Looking at the script of a button (if it has a script) is a good way to
learn about how the button works. (To look at a button’s script, you
must have your user level set to Scripting,)

Here are four ways to open a button’s script:

»  With the Browse tool or Button tool selected, press and hold the
1 key and the Option key while you click the button.

»  With the Button ool selected, press and hold the Shift |((:y while
you double-click the button.

» Choose the Button tool from the Tools menu, click the button
to select it, and hold down the Shift key while you choose
Button Info from the Objects menu.

= Choose the Button tool from the Tools menu, double-click the
button to open the Button Info dialog box, then click Seript.

To close a script without saving any changes, click Cancel.

To learn about HyperCard scripts, read the Hyperlalk Beginner's
Guide.
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Dﬁic{ing 4 button  You can remove a button from a stack by following these steps:
1. Choose the Button tool (=) from the Tools menu.
2. Click the button you want to delete to select it.

3. Choose Clear Button from the Edit menu, or press Delete.

A Warning: Once you've deleted a button with the Clear Button
command (or with the Delete key), the button’s gone for good—
you can't undo the deletion. A
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Chapter 5

Working With Text
and Fields

T:xt is an important component of HyperCard stacks. In most
stacks, text is used to communicare the function of the stack, either
alone or in combination with graphics. Text is also the primary
content of many stacks—particularly stacks designed for managing
large amounts of information.

Most of the text in stacks is contained in fields, which are
rectangular areas on a card where you can type and edit text easily.
This chapter gives instructions for working with fields. To do the
tasks in this chapter, you must have your user level set at least to
Authoring. (The section “User Levels and Options” in Chapter 1
tells you how to set your user level.)




Addlng [€Xl When you want to add a text element to a stack, you can choose
from three different kinds of text:

s lext that's stored in a field
s lext that's attached to a button
s [aint text

For most purposes, it’s best to use fields to add text to a stack. Field
text is easy to edit—you can select any part of the text in a field and
change it, move it, copy it, or delete it. You can move field.text
around on a card by selecting and dragging the field. And you can
search for specific text in fields.

The Shared Text option allows you to create a background field ths
displays the same text on every card, which means you can create
text labels made up of editable (field) text. If you are familiar with
HyperTalk, you can write a script for a field, so that clicking text

in the field can make something happen—much like clicking a
button.

Sometimes buttons can be useful for adding text labels to a card
or background. A button can't hold much text, and you can't
edit button text from the card. (To change the text on a button,
you have to rename the button.) But button text is easy to move
around on the card, because it moves when you move the button.
Chapter 4 tells you how to create a button with text.

Paint text can't be edited. Once you finish typing Paint text, it
“dries.” To change it, you have to erase it and retype it. Paint text @
is useful for adding a permanent label to a graphic. And you can
create special effects with Paint text using commands in the Paint
menu (such as Invert and Trace Edges), which appears whenever a
Paint tool is selected. Chapter 6 describes Paint text.
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Paint text in the background layer

OF THE Camuman Name
XU _ IPirsnM_— : [
Gowia b Bpecics

!Strrlsﬂlmnlulun Jl

Field text that
_ changes from
Habitat card to card

]
‘ Amazon river |

Netss
oGrovsto IS inches.  [BF

Background buttons _ [ tndex | Sort | uit | r 'I"_"""n’.i"“"
ILh:t[ d'l-‘ii‘}l;l\' text About this stack| Card 7 m . ’ fish. At

. Figure 5-1 Different kinds of text

Adding atield Tocreawea place for text, you can add a field to a card or back-
to 2 card ground. Whenever you add a field, you need to decide whether
* you want to put it in the card layer or the background layer.

Or bElegI‘()Und To decide where to put the field, consider where you want the

field to appear, and where you want its text to appear:

» If you want the field and its text to appear only on one card, put
the field in the card layer.

» Ifyou want the field to appear on every card in the stack, but
you want to be able to type different text into the field on each

. L"JTLL PU[' th‘ ﬁtld n t]‘lf_‘ bacl-;gr{)und ]ﬂ}’t‘l’.

= If you want the field to appear on every card in the stack, and
you want it to display the same text on each card, put the field in
the background layer and turn on the Shared Text option in the
Field Info dialog box.
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= Ifyou want a field to appear on some of the cards in the stack,
but not all of them, consider creating a different background
for those cards and putting the field in that background only.
(“Creating a New Background” in Chapter 3 explains how to

add a background to a stack.)

A background field appears in the same location on all the cards
that share the background.

To add a field to a background, you must be in the background

layer; to add a field to a card, you must be in the card layer. To go to
the background layer, press (/-B. When you’re in the background
layer, the word Background appears in the menu bar. If you press

'I-B repeatedly, you move back and forth between the card layer
and the background layer. »

You can enter or edit text in a field only while you’re in the card
layer. If you're in the background layer, you won't see the
I-beam pointer when you move the Browse tool over a field.

»  Seealo: *“The Card Layer Versus the Background Layer” in
Chaprer 2
* “Creating a Field” in this chaprer

The tools for ‘NOfking To work with fields and field text, you need both the Field tool and
\'Vi[h ﬁ@l(_l"‘i the Browse tool.
Use the Field tool for

creating and
manipulating fields.

Use the Browse tool for entering and
editing text (in addition to browsing).

Figure 5-2  The tools for working with fields
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Creating a field

"To make it easy to alternate between the tools, you can “tear off”
the Tools menu to create a movable Tools palette. To do this, drag
down through the menu and past the bottom or beyond either side.
(For an illustration of this, see Figure 2-12.)

You can use the following (-key shortcuts to choose the tools you

need for working with fields:

To choose this tool . . . Press
The Browse tool -Tab
The Field tool - Tab-Tab-Tab

» Seealo: * “Using HyperCard's Tools” in Chapter 2

To create a new field, follow these steps:
1. Make sure you have one of the General tools selected.

The Browse tool (%), the Button tool (=), or the Field tool (£3)
will work.

2. Go to the card or background where you want to put the field.

[f you're not sure whether to put the field in the card layer or the
background layer, see “Adding a Field to a Card or Background”
near the beginning of this chapter.

3. Choose New Field from the Objects menu.

This automatically selects the Field tool and creates a new,
transparent field. The field appears in the center of the card
window and is selected, so you can move it or resize it easily.
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Choose the Field tool,

hold down the (™ key,
and drag from here

AR EEEEEEEIEEEEENEEEEESIESEEESESFAREEEERES

B e L T T

T L T L T T T T T T P T

fEEEmms mE e mr s = s e

e -

Figure 5-3 A field created with the New Field command

% Another method: You can also create a new, transparent field by
choosing the Field tool, then pressing and holding the ™ key (@)
while you drag diagonally. +

1 L]
1] ]
[ ] 1
B - - - sEEEE . Ea L]
(] (]
Bas > & s o axapnae ¥
TS . 5 0 O 0 o 0B e 7,1 DAY

Figure 5-4 Dragging to create a new field

You can have as many fields on a card or background as will fit.
Fields can overlap to any depth.

Important: The most common mistake in creating a field is putting
it in the card layer when you want it in the background layer. (To
find out whether a field is in the background, press " -B to view just
the background elements.) If you put a field in the card layer by
mistake, see “Moving a Field From the Card to the Background,”
|ater in this chapter. &

P Seealso: *“Changing the Appearance of a Field” in this chapter
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Entering and editing

Entering and editing text in a HyperCard field is just like working

text in a ﬁeld with any other Apple I1GS text. You can click anywhere in the field

and begin typing, delete text with the Delete key, and drag to select
text for copying, cutting, or clearing. You can also copy text to and
from a field via the Clipboard. This allows you to move text
between fields and to and from other applications.

o Where’s the field? A transparent, empty field is invisible when the
Field rool isn't selected. This makes it difficult to locate the field
when you’re ready to enter text into it. One way to locate the
field is to move the Browse tool around—the pointer turns into
an I-beam when it’s over an editable field. Another way to locate
a transparent field is to press Tab repeatedly. This highlights the
editable fields (or, if a field is empty, places an insertion point at
the upper-left corner) on the current card and background, one
ata time, <

To enter and edit field text, follow these steps:
1. Choose the Browse tool () from the Tools menu.
2. Move the Browse tool over the field you want to edit.

The Browse tool pointer turns into an I-beam (I) when it’s over
an editable field. If you don't see the I-beam pointer, read the
next section, Where's the I-Beam Pointer?”

3. Click inside the field to position the insertion point where you
want to enter or edit text.

Or, if you want to replace existing text in the field, select the text

you want to I'CPI'JCC.

If you click in an empty field, the insertion point appears at the

upper-left corner of the field.
4. Start typing.
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If you type more text than will fit in a non-scrolling field, the
remaining text goes off the bottom of the field. But this text isn't
lost, it’s just hidden from view. To see the hidden text, make the

field bigger:
If you type more text | ¢ If you type more text than
thanwill fit in g rwill fitinafield you

f.i_.e.l..t!._ﬂpy.g.un.‘.!a.ﬁ.?}:: ‘can't see it untilyou
renlarge the field.

1t until unn anlavan

e Y L R 4
To see text you've ... enlarge the field by choosing the
typed beyond the Field tool from the Tools menu and
borders of a field . . then dragging from any corner. .

Figure 5-5 Revealing hidden text

Where's the  If the Browse tool doesn't turn into an I-beam (I) when you move
[-beam I)()in[el‘? it over a field, the reason could be any of the following;

s The field is locked. To unlock the field, follow the instructions
in “Locking and Unlocking a Field,” later in this chapter.

= You're working in the background layer rather than the card
layer. Press (-B to return to the card layer.

s Your user level is set to Browsing. For instructions on changing

the user level, see “User Levels and Options” in Chaprer 1. ©
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m  The text you're trying to edit is either Paint text or button
text—not field text. To see whether it’s field text, choose the
Field tool from the Tools menu and click the text. If the area
becomes selected (surrounded by a moving dashed line), it’s field
text—otherwise, it’s not. See Chapter 4 for information about
changing the text on a button, or Chapter 6 for information on
changing Paint text.

l_-.ﬁiﬂ}_', the arrow |\'L'}'H Normally, the arrow keys move you through cards. However,

(O move ElII‘(}U}_{JI text  when the Text Arrows option is selected (on the User Preferences
card in your Home stack), you can use the arrow keys to move
the insertion point through text while you’re typing in fields.

% This makes text editing easier.
Moves the insertion point
:""1"“'“5 the _ down through lines in a field,
INSErtion point or to the end of the line in the
right through text Message box

Moves the insertion ppint

up through lines in a field,
or to the beginning of the

line in the Message box

Moves the insertion
point left through text

Figure 5-6 Moving through text when Text Arrows is turned on

® When Text Arrows is turned on, you use the Option key with the
arrow keys to move through cards in a stack.

» Seealso: * “The Text Arrows Option” in Chaprer |
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Moving from one field While you're entering text into fields, you can move from one

to another editable field to the next by pressing Tab. When you press Tab,
HyperCard takes you to the field with the next higher field number.
(Field numbers are assigned to fields in the order you add them.
The first field you add is field 1, the second is field 2, and so on.)
If the insertion point is in field 3 and you press Tab, the insertion
point moves to field number 4; if there are only three fields, the
insertion point moves from field 3 to field 1:

to here . . .
Pressing Tab takes e

you from here,

to here .
e DIEI Gl N
s,
back to here. i

Figure 5-7  Tabbing order

Pressing Shift-Tab moves you backward through the fields. Locked
fields are excluded—you can't Tab to a locked field.

A Warnmg When you tab to a field that already contains text, all g
text is selected. Typing at this point will erase all the old text in the
field and replace it with what you type. To preserve the old text and
add new text to it, click in the field where you want to type. A
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A field’s number (which determines the field’s position in the
tabbing order) appears in the Field Info dialog box. Choose the
Field tool from the Tools menu and double-click the field to see

the Field Info dialog box:

GOLE T Fersonal Info |

Bkgnd field number: 8 Bkgnd field ID: 11 This number
[JLock Text Style: determines the
[ huto Tab field's position in
[ Don't Search [ Show Lines the tabbing order
] Shared Text [Iwide Morgins

Figure 5-8 Checking a field's number

If you have both card fields and background fields on the card,
pressing Tab takes you from one field to the next, according to
the following sequence:
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Figure 5-9  Tabhing through background fields and card fields

For an explanation of how fields get numbered, or if you want to
change the order in which the Tab key moves the cursor from field
to field, see “Reordering Fields,” later in this chapter.

If the Auto Tab option is selected in the Field Info dialog box, you
can press Return (instead of Tab) when the insertion pointis in the
last line of the field to go the next field.

To select the Auto Tab option for a field, follow these steps:

1. Choose the Field tool () from the Tools menu. .
2. Double-click the field.

3. Click Auto Tab to select it.

4. Click OK.

+ Note: Auto Tab doesn’t work for a scrolling field.
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Undoing your typing  To undo typing mistakes while you're editing field text, you can do
L ! ¥ o h tyP E:! o E 4

Setting the text format
for a field

any of the following;

= Erase text to the left of the insertion point, one character at a
time, by pressing Delete.

s Drag (or double-click one word) to select the incorrect text and
retype it, or press Delete to erase it.

While you're editing text in a field, choosing Undo undoes all the
changes you've made since the last time you clicked in the field to
edit. Therefore, it’s not a good idea to use Undo to fix typing
mistakes, unless you want to retype everything you've typed since
you last clicked in the field. To fix editing mistakes, it’s better to use
the Delete key or to select the incorrect text and retype or delete it.
To save the changes in a field (so that Undo can't undo them), click
anywhere outside the field.

You can set the text format—including the font, size, style,
alignment, and line spacing—for a field by following the
instructions in this section. If you want to change the color of the
text in a field, see “Changing a Field’s Colors,” later in this chaprer.

To choose the text format for a field, follow these steps:
1. Choose the Field tool (1) from the Tools menu.
2. Select the field by clicking it.
3. Choose Field Info from the Objects menu.
Or double-click the field. The Field Info dialog box appears.
4. Click Font.
The Text Style dialog box appears.

+ Another method: Alternatively, you can open the Text Style
dialog box by clicking to select the field (with either the Field
tool or the Browse tool), then choosing Text Style from the Edit
menu (or pressing ( - T). %
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5. Choose from the options in the Text Style dialog box to set the
default text format for the field:

Click to select the Click to select a font size
font you want. (measured in points).
Click to select or deselect one or e To use a font size not
more text styles. (Select nothing for I:IH:I ;' || [Tourier I listed, type it here. Then, if
plain text.) The sample text at the Ol 1tali Genevo B , * you want to adjust the line
35 ; ! . talic ; Ful
bottom of the dialog box shows I Undertine | it height to the new type size
the effect of the selected styles. [Joutline i Times | press Enter. (If vou don'
[CIshadow | | Venice 3 I press Enter, the line height
Press and hold the mouse Alignieft § Line Height: Font Size: [{—) will remain the same).
hutton here to see a pop-up e R i ————— )
menu for choosing the The quick brown fox jumps over the loz| doa. ITus shows “t!“[ yaur
alignment for text in the field. text will look like

This number determines the space .
between lines. HyperCard sets this number

automatically when you click one of the

standard font sizes, but you can change it.

Figure 5-10  Setting the text format for a field

6. When you’re finished, click OK.
The Text Style dialog box disappears and you see the Button

Info dialog box again.
7. In the Button Info dialog box, click OK.

The text in the field appears in the new format, and any new text
you type in the field acquires the same format. .
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I\’flﬂl‘(lﬂg field text “Youcan create a background field that displays the same text on
appear on every card by using the Shared Text option in the Field Info dialog
_ 1 box. (This option is available only in the Field Info dialog box for
CVCIy car d background fields.) This allows you to create an editable text label
that appears on every card in the background. Because it can be
edited so easily, a field text label is easier to manage than a Paint
text label.

To get the same field text to appear on every card, follow these steps:
I. Create a background field.
See “Creating a Field,” earlier in this chapter, for instructions.
2. Choose the Field tool (£2) from the Tools menu.
@ 3. Double-click the field.
The Field Info dialog box appears.
4. Click the Shared Text check box to select it.
5. Click OK.
6. Choose the Browse tool () from the Tools menu.

You return to the card layer (if you're not already there). The
word Background should not appear in the menu bar. If it does,
press “\-B.

7. Click in the field and type the text you want to display on
every card.

If you turn off Shared Text, the text you've entered in the
background field disappears from view.
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You can think of background fields as having (potentially) two
different layers of text, which appear and disappear as you change
the Shared Text setting:

s When you turn on Shared Text, any text you've entered in the
field while the option was turned on appears, and text you've
entered while the option was turned off disappears.

= When you turn off Shared Text, any text you've entered in the
field while the option was turned on disappears, and text you've
entered while the option was turned oft appears.

4+ Note: 1f the Shared Text option is turned on for a field, the
Don't Search option is turned on automatically. This means that
HyperCard won't search in the field when you ask it to look For.
specific text.

LOCHHHg fields Many of the fields in stacks are easy to locate right away—but some
are harder to find. You can use either of the following methods to

locate all the fields on the current card and background:

s Choose the Field tool from the Tools menu. Lines appear in all
the fields:

When you choose ... lines appear
the Field tool . . . in the fields.

E

PR et

s L e L e e e
Rl e .
i v-"

Figure 5-11  Locating fields with the Field tool
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Thin rectangles
outline the fields
in the card laver.

Changing
the appearance
of a field

s While the Browse tool is selected, you can “peek™ at both
buttons and fields by pressing and holding the *, Shift, and
Option keys. (Gray or colored rectangles appear around the
buttons and fields.) Then, while you're still holding down the

and Option keys, release the Shift key—the rectangles
around the fields disappear. Pressing and releasing the Shift key
repeatedly (while holding down the -~ and Option keys) makes
the field rectangles appear and disappear.

Thick rectangles
outline the fields
in the background
layer.

S1C
lllnrp, Guitar, Bonjo T—

Mote: Use this
harp for music
report

,|; i ::I

)

uii[mi.ﬁiﬁﬁij'

I s

e G
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Figure 5-12  Peeking at fields

Once you've created or copied a field, you can change its
appearance by resizing it, changing its style, adding margins,
displaying lines in it, or changing its colors. This section explains
how to make a field look the way you want it to.

+ Note: You can L‘lmnuu the ;1p|_1t;1r;1m;:: of both card fields and
background fields whllc you're in the card layer. You don't have
to be in the background layer to modify background fields. <

P Seealso: * “Setting the Text Formar for a Field” in this chaprer
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(,h;lﬂ};{jllg the size  You can change the size of a field whether or not it has text in ir.
of a field When you change a field’s size, any text in it wraps appropriately
to conform to the new size.

To resize a hield, follow these steps:
1. Choose the Field tool (1) from the Tools menu.
2. Click the field you want to resize to select it.

A moving dashed line surrounds the selected field.

3. Drag from any corner of the field:

et Drag from any corner
; k" region to resize the field

Figure 5-13  Changing a field's size

To resize the field in one dimension only—either horizontally or
vertically—hold down the Shift key while you drag from a
corner.

+  Ifyou move the field instead of resizing it: Choose Undo from
the File menu to return the field to its original position, ancb
try again. Make sure you drag from a point close to a corne
of the field. «

If you shrink a non-scrolling field so that there’s not enough room
for all the text, the text at the bottom of the field disappears from
view. However, the text is still there—if you enlarge the field, the
text becomes visible again.
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-\ Important: After you've resized a background field, you should
look through any cards affected by the field change to see how the
text looks. A

Choosing a field's style A field can have any one of five styles: transparent, opaque,
rectangle, shadow, or scrolling. (The style of a field has no bearing
on the style of its text.) Examples of the five field styles are shown in
the following figure, along with the names of the styles:

The background
shows through
transparent fields.

....................................................

I3 i The scroll bar
rectangle Bl scrolling —1:1__ becomes gray when
: oo ][ the text runs past the
e bottom of the field

Figure 5-14  The field styles

To set the style for a field, follow these steps:

1. Choose the Field tool (1) from the Tools menu.
@ 2. Click the field to select it.

3. Choose Field Info from the Objects menu.

Or just double-click the field. The Field Info dialog box appears.
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4. Move the pointer over the pop-up Style menu, press and hold
the mouse button, and drag to select a field style:

Makes the field transparent,
with no visible borcer

. Card Tit1d ) Maukes the tield opaque (white),
Field home: | [EipAER trnnsnuy{ without a visible border.
Bkgnd field number: 1 Blkand f opaque
[ Lock Text Style: Makes the field opaque
[JAuto Tob shodow (white), with a thin border.
; 52 sc{nlli;\ .
Eﬂ:n t::urch :;h: Morel IN Makes the field opaque
P [_IWide Horgijs {white), with a shadow along

the right side and bottom
lt 0K ] (c”““'“) .

Makes the field opaque, with a
border and a scroll bar along the
right side.

Figure 5-15 Choosing  field style

5. Click OK.

@ About scrolling: Choosing the Scrolling option adds a vertical
scroll bar to the selected field. You view text in a field with a
scroll bar the same way you view text in any scrollable
Apple 11Gs window. (For details about scrolling in windows,
see the documentation that came with your Apple [IGs.) + @

You can use this procedure to change any field’s style, even after
you've typed text into the field.
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ALIL“I‘I}}, margins  Adding margins to a field makes the text easier to read. When
you add margins to a field, you get extra space on the right and
left sides of the text in the field. (As a result, text takes up more
vertical space.)

To add margins to a field, follow these steps:
1. Choose the Field tool (£1) from the Tools menu.
2. Click the field to select it.

3. Choose Field Info from the Objects menu.

Or just double-click the field. The Field Info dialog box appears.

4. Click the Wide Margins check box to select it:

Field Name: [(TITITD |
Bkgnd field number: 2 Bkgnd field ID: 13

(] Lack Text, Style:
] Auto Tab
[JDon't Search [ Show Lines

[ Shared Text EQde Margins
Click here 1o add
margins, Click

again 1o remove

the margins.

Figure 5-16  Adding margins to a field
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5. Click OK.

Wide Margins is selected Wide Margins is not

in the Field Info dialog selected in the Field Info

box for this field. dialog box for this field.

Figure 5-17  Shadow liclds with and without margins

Displaying lines  You can display lines in a field. This is useful for making a
in 4 field  transparent field visible so you can see where to type in it.

To display lines in a field, follow these steps:
1. Choose the Field tool ((1) from the Tools menu.
2. Click the field to select it.
3. Choose Field Info from the Objects menu.
Or just double-click the field. The Field Info dialog box appears.

4. Click the Show Lines check box to select it:

Field Kome: | 3TTT | .
Bkand field number: 1 Bhkgnd field 1D: 1

Okten sute Gty || |

[ Auto Tab Click here to see

the lines in a

[CJ0on't Search 2 Show Lines field. Click again
[ Shared Text [CIWide Margins s L.'L LK il
to hide the lines

|S|:r|pt...| |I3ulori...] E 0K Bltuncell

Figure 5-18  Displaying lines in a field
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5. Click OK.

Show Lines is selected in Show Lines is not selected
the Field Info dialog box in the Field Info dialog
for this field. box for this field.

Figure 5-19  Rectangle fields with and without lines
£ + Note: You can't display lines in a scrolling field.

Changing a field's colors  You can choose the colors for two parts of a field: its frame and

Its text:

: ) E Frame
Merrily, merrily, shall I livenow, | i
Under the blossom that hangs on the bough, ——

Figure 5-20 The parts of a field that can be different colors

. 1. Choose the Field tool (1) from the Tools menu.

b

. Double-click the field you want to change.

The Field Info dialog box appears.

LS

. In the Field Info dialog box, click Colors.

The Colors dialog box appears.
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4. Choose the colors you want:

takes a running leop

This shows what the
field will look like.

Click the frame color
and text color you want.
The sample field at the
top of this dialog box

Frome

(il 4
171 A
i i

W 1 shows how the selected
N\ colors will look
Figure 5-21  The Colors dialog hox for a field .

5. Click OK.

6. In the Field Info dialog box, click OK to accept the changes
you have made to the field.

The field displays the colors you have chosen.

Nlllﬂil]g d ht’l(.i Each field can have a name associated with it. You use field names
mostly for referring to fields through scripts or the Message box.

A field name can have up to 31 characters in it, and you can use any
character in a field’s name.

Follow these steps to name a field:
1. Choose the Field tool (1) from the Tools menu.

2. Click the field you want to name to select it.
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3. Choose Field Info from the Objects menu.

Or double-click the field. The Field Info di;l]ug box appears.

4. Type a name for the field:

Field Mome: [

Bkgnd field number; 8 Bkgnd field 1D: 11

[CJLock Text Style:
I Auto Tab

[1Don't Search 1 Show Lines

[ 5hared Text [ 1Wide Margins

Figure 5-22  Naming a field

5. Click OK.

Type the field
name here

@ Script writers take note: 1f you change the name of a field, be sure

to change its name everywhere you refer to it in a script, too. For

example, if you rename a field “Wrigley” and you use the old
name “Chester” in a script, the script won't work properly

1T

won't be able to find the field it needs. «
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Moving a field
around on a card
or background

You can place a field wherever you like on the card or background.
To reposition a field on the card or background, follow these steps:

—

. Choose the Field tool () from the Tools menu.
2. Click the field you want to move to select it.

Whether the field is in the card layer or the background layer,
you can select it from the card layer.

A moving dashed line surrounds the selected field.

3. Drag from the middle of the field, or from one of its edges
(not a corner).

Drag from the
e middle region 1o
- maeve the field

Figure 5-23 Repositioning a field on the card

To constrain the field’s movement to horizontal or vertical
directions only, hold down the Shift key while you drag from
the middle of the field.

4. Click anywhere outside the field to deselect it. &

You can select and move only one field at a time.

Important: After you reposition a background field, it’s a good idea
to look through the cards on which the field appears, to see how the
cards look. 2
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When elements
overlap

HyperCard puts different kinds of elements in different layers, as
shown in the following figure. Together, all these layers make up the

card you see.

Background picture
anat’s Background
buttons and fields

Card buttons
and fields
What you see

: s when you look
'S " s \
- F 4 ; : at the card
i : : L .
The background picture : 7 gt : (/"I
is fixed in a layer by : RE ! _,.F:::'
itself—it’s always faet” % = g _:;
behind the background : R 3 -~
H v -

buttons and fields and
all the card elements.

| R

The card picture is also k’ro ==
fixed in a layer by
itself—it's always
behind the card buttons
and fields, and in front
of the background
buttons and fields

Figure 5-24 HyperCard's layers

As shown in Figure 5-24, background buttons and fields go in a
different layer from the card buttons and fields. Wichin each of
these layers, HyperCard places each new button or field you add
(whether you've created it or copied it) in front of the element
added before it. (/n front of means “closer to you.”)

231
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HyperCard also assigns numbers to the buttons and fields as you
add them. The first field you add is field number 1, the second is
field number 2, and so on. Likewise, the first button you add is
button number 1, the second is button number 2, and so on. The
numbers reflect how far away the elements are from you—the
farther away an element is, the lower its number. (These numbers
appear in the Button Info and Field Info dialog boxes.)

Although HyperCard numbers the buttons and fields separately, it
places each new element immediately in front of the previous
element (within the same layer), whether it’s a button or field.

This was added first.

This was added second. .

This was added third

L Held1'

This was added fourth.

This was added fifth.
This was added sixth.

Figure 5-25  Background button and field layers and numbers

HyperCard numbers the card buttons and fields separately from the
background buttons and fields. The card elements are always in &
front of all the background elements (as shown in Figure 5-24).
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Reordering fields

This layering of buttons and fields becomes evident when the
elements overlap. Elements that are closer to you can obscure
clements that are farther away. If this happens, you can either move
the elements apart so they don't overlap, or you can try either of the
following;

= Reorder the fields and buttons. (You can move any field or
button closer or farther, within its layer).

» Make some of the elements transparent, so you can see other
elements through them. (Buttons, fields, and graphics can all be
made transparent or opaque.)

The following sections describe these solutions.

Overlapping fields and buttons can cause visual and functional
problems in your stack. For example, you can’t edit the text in a
field that’s completely covered by a button (or another field).
To solve the problem of overlapping fields and buttons, you
can reorder them to bring the ones you need to see and use
into full view,

Important: The fields and buttons in the card layer are always in
front of the background fields and buttons. Although you can
reorder the background fields and buttons relative to one another,
you can never move them closer to you than any of the card
clements. (You can, however, make card elements transparent

so you can see through them to the background elements, as
explained in the next section.) A

To move a field closer or farther (relative to the other fields and
buttons in the same layer) follow these steps:

1. Choose the Field tool (=) from the Tools menu.
2. Click the field you want to move closer or farther to select it.

A moving dashed line surrounds the selected field.

Chapter 5: Working With Text and Fields 233




3. Choose Bring Closer from the Objects menu to move the field
forward one position, or choose Send Farther to move it back
one position.

Each time you move a field back one position relative to
another field in the same layer, its number (in the Field Info
dialog box) decreases by 1. Each time you move a field forward
one position relative to another field in the same layer, its
number increases by 1.

Note that a field’s number may not change every time you use
the Bring Closer or Send Farther commands to change its
position. For example, if a button lies between field 4 and
field 3, you'd have to move field 4 back two positions (with

the Send Farther command) before it would become field 3. .

You can also move the selected field all the way to the front or
all the way back using these " -key shortcuts:

To do this .. .. Press
Send the field to the back " -Shift- — (minus)
Bring the field to the front ~-Shift- + (plus)

4. Repeat step 3 until the field is where you want it.
5. Choose the Browse tool () to deselect the field.

As you reorder fields, the numbers of all the affected fields change
to reflect their new positions. Each field’s number (shown in the
Field Info dialog box) reflects its front-to-back position, relative to
the other fields in the same layer. (The field that's farthest away is
field number 1. The closer a field is to the front relative to the other
fields in the same layer, the higher its number.)

% Tabbing order is affected: As the fields’ numbers change, so does
the tabbing order—that is, the order in which you move
through the fields when you press Tab—because the tabbing
order depends on the field’s numbers. (See "Moving From One
Field to Another,” earlier in this chaprer, for more information
about the tabbing order.)
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The commands Bring Closer and Send Farther work the same way
on a selected burtton, as described in “Reordering Buttons” in

Chapter 4.

M:lkillg a fit?l(f opaque  When you want to be able to see background or card elements
or transparent through a field that covers them, you can make the field
transparent. Conversely, when you want to give a field more
prominence, you can make it opaque.

Follow these steps to make a field opaque or transparent:
I. Choose the Field tool () from the Tools menu.
2. Click the field you want to change to select it.
3. Choose Field Info from the Objects menu.
Or double-click the field. The Field Info dialog box appears.

4. Move the pointer over the pop-up Style menu, press and
hold the mouse button, and drag to select the opaque or
transparent style:

Field Nome: rrrre— b Choosing this style makes the
Bkond field number: 1 Bkgndf] o0 0 field transparent
(_JLock Text HTNER rectongle —| Choosing any of these stvles
[ Jfuto Tab shadon J makes the field opaque.
[CJ0an't Search E=1Sha scrolling (See Figure 5-15.)
[ Shared Text [CIWide Morgins

@

[Scrmt...] Eu!ors ] [ 0K ]] [L‘nncal]

Figure 5-26  Making u field opaque or transparent

5. Click OK.
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(( )p"}-'lﬂu d llL‘lLl You can duplicate a field on the same card, or copy it to another
card, background, or stack. When you copy a field, you also copy its
attributes—its name, style, script, text format settings, and so on.
You can copy a field either with or without its contents.

Copying a field  Follow these steps to duplicate a field without its text on the
on the same card  same card:

1. Choose the Field tool (7) from the Tools menu.
2. Click the field you want to copy to select it.

You can select the field from the card layer, whether the field is in
the card layer or the background layer.

A moving dashed line surrounds the selected field.
3. Press and hold the Option key while you drag the field.

As you drag, you create an exact duplicate of the field. If the
original is a background field, the duplicate is a background
field. If the original is a card field, the duplicate is a card field.
However, you can't duplicate the field’s text using this method.
You have to use the procedure described in the next section to
copy the text along with the field.

To constrain the new field’s movement to horizontal or vertical
directions only, hold down the Shift key while you drag from
the middle of the field.

Copying a field  To copy a field with or without its text to another card or
to another card or  background, follow these steps:

background | Ghoose the Field tool (C7) from the Tools menu.

2. Click the field you want to copy to select it.
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3. Choose Copy Field from the Edit menu, or press ~-C.

This makes a copy of the selected field (including its text) and
puts it on the Clipboard. (This field replaces the last item you
cut or copied; the Clipboard can only hold one item at a time.)

4. Go to the card or background where you want to put the field.

Use the arrow keys or commands in the Go menu to navigate
between cards while the Field tool is selected.

If you're not sure whether to put the field in the card layer or the
background layer, see “Adding a Field to a Card or Background”
near the beginning of this chaprer.

] 5. If you want to paste both the field and the text that was visible
when you copied the field, press and hold the Shift key and
choose Paste Field from the Edit menu, or press —-Shift-V.

To copy just the field without its text, choose Paste Field from
the Edit menu, or press C'-V.

This takes a copy of the field that’s on the Clipboard, puts it on
the current card or background, and selects it. If you've copied
the field and its text from the card layer to the background layer,
you won't see the text until you return to the card layer (at the
end of this procedure).

[f you've copied a background field to the card layer of the same
card, the copy is p;lstcd dirt:n.‘tly over the ()riginﬂl. To see the
© original, you have to drag the copy to move it.

6. While it’s still selected, drag the field to where you want it.

7. If you’ve copied the field and its text from the card layer to the
background layer, choose Background from the Edit menu, or
press (_-B, to return to the card layer and see the text.
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A\ Important: The most common mistake in copying a field is
putting it in the card layer when you want it in the background
layer. (To find out whether a field is in the background, press -B
to view just the background elements.) If you put a field in the card
layer by mistake, see the next section, “Moving a Field From the
Card to the Background.” A

N[()Ving d ht’ld It’s easy to put a field in the card layer by mistake when you intend
from the card o putitin the background. [f this happens, you can move the field
from the card layer to the background layer (of the same card) by

to the background  fliowing these steps: °
1. Choose the Field tool (1) from the Tools menu.
2. Click the field you want to move to select it.

A moving dashed line surrounds the selected field.

3. Choose Cut Field from the Edit menu, or press ~-X.

This removes the field from the card and puts it on
the Clipboard.

4. Go to the backgmund [aycr.

Choose Background from the Edit menu, or press ~-B.

N

If you want to move the field and its text, press and hold the
Shift Key and choose Paste Field from the Edit menu, or pre.
-Shift-V.

To move just the field without its text, choose Paste Field trom
the Edit menu, or press ©-V.

This takes a copy of the field that’s on the Clipboard, puts it in
the current background, and selects it. The pasted field appears
at the same position from which it was cut. If you've pasted the
text along with the field, you won't be able to see the texr until
you return to the card layer (at the end of this procedure).
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6. While it’s still selected, drag the field to where you want it.

Since you can't see the elements in the card layer while you're
working in the background, you might not be able to tell
whether you're purtting the field in the right place. If this
happens, you can press ("-B again to go back to the card layer,
then select and drag the field from the card layer.

7. Ifyou've pasted the text along with the field, choose
Background from the Edit menu, or press -B, to return to
the card layer and see the text.

.(J\-’iﬂg a field from  Follow these steps to move a field from the background layer to the

the hﬂ{:kql-ound card layer of the same card:
O [i;lff Clll'd . Choose the Field tool (1) from the Tools menu.

[

)

. Click the field you want to move to select it.
A moving dashed line surrounds the selected field.

3. Choose Cut Field from the Edit menu, or press ~-X.

A dialug box like this appears:

Delete this field ond all its text from all 2 ) )
cards of this background? / Click Delete to confirm that

vou want to cut the field.
. [ Delete ) l Cancel ' ’

Figure 5-27  Confirmation dialog box for cutting a background field

Click Delete in the dialog box to remove the field from the
background and put it on the Clipboard.
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4. If you're in the background layer, go to the card layer by
pressing = -B.

[f you’re already in the card layer, skip this step.

5. If you want to move the field and its text, press and hold the

Shift Key and choose Paste Field from the Edit menu, or press
~-Shift-V.

To move just the field withour its text, choose Paste Field from
the Edit menu, or press —-V.

This takes a copy of the field that’s on the Clipboard, puts it on
the current card, and selects it. The pasted field appears at the
same position from which it was cut.

6. While it’s still selected, drag the field to where you want it. ®

LMOVil-lg d held IO  You can move a field to another card in the same stack, or to a card

another card or another stack. When you move a field, its attributes—its style,

l_ k name, scripts, and so on—move with it. You can move a field either
)ac glOUﬂd with or without its text.

Follow these steps to move a field to another card or background:
1. Choose the Field tool (C1) from the Tools menu.
2. Click the field you want to move to select it.

A moving dashed line surrounds the selected field. .
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3. Choose Cut Field from the Edit menu, or press -X.

If the field is a l}:lclcgmuml field, a dialog box like this appears:

Delete this field ond oll its text from all 2
cords of this background? y Click Delete to confirm th

vou want to cut the field,
(M] ‘ Cancel ' :

Figure 5-28  Confirmation dialog box for cutting a background field

Click Delete to remove the selected field from the current card
© and put it on the Clipboard.

4. Go to the card or background where you want to put the field.

Use the arrow keys or commands in the Go menu to navigate
berween cards while the Field tool is selected.

If you're not sure whether to put the field in the card layer or the
background layer, see “Adding a Field to a Card or Background”
near the beginning of this chapter.

5. If you want to move the field and its text, press and hold the
Shift Key and choose Paste Field from the Edit menu, or press
~-Shift-V.

‘To move just the hield without its text, choose Paste Field from

. the Edit menu, or press ~-V.

This takes a copy of the field that’s on the Clipboard, puts it
i on the current card or background, and selects it. The pasted
| field appears at the same position from which it was cut. If
you've moved the field and its text from the card layer to the
background layer, you won't see the text until you return to
the card layer (at the end of this procedure).
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Locking and
unlocking a field

6. While the field is still selected, drag it to where you want it.

7. If you've moved a field and its text from the card layer to the
background layer, choose Background from the Edit menu, or

press -B, to return to the card layer and see the text.

Important: The most common mistake in copying a field is
putting it in the card layer when you want it in the background
layer. (To find out whether a field is in the background, press ~-B
to view just the background elements.) If you purt a field in the card
layer by mistake, see “Moving a Field From the Card to the
Background,” earlier in this chapter. &

You can lock a field to prevent content changes to its text. Locking
a field does not, however, prevent changes to the text format of

the field.
To lock a field, follow these steps:
1. Choose the Field tool (Z7) from the Tools menu.
2. Click the field to select it.
3. Choose Field Info from the Objects menu.
Or just double-click the field. The Field Info dialog box appears.
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3. Choose Cut Field from the Edit menu, or press = -X.

[f the field is a background field, a dialog box like this appears:

Delete this field ond all its text fromall 2 !
cords of this bockaround? Click Delete w confirm tha

rd . : EReH -
yvou want to cut the field.
| Delete | ﬂ Cancel “ E

Figure 5-28 Confirmation dialog box for cutting a background field

Click Delete to remove the selected field from the current card

. and put it on the Clipboard.
4. Go to the card or background where you want to put the field.

Use the arrow keys or commands in the Go menu to navigate
between cards while the Field tool is selected.

[f you're not sure whether to put the field in the card layer or the
background layer, see “Adding a Field to a Card or Background”
near the beginning of this chapter.

5. If you want to move the field and its text, press and hold the

Shift Key and choose Paste Field from the Edit menu, or press
~-Shift-V.

To move just the field without its text, choose Paste Field from

. the Edit menu, or press .~ -V,

This takes a copy of the field that’s on the Clipboard, puts it
on the current card or background, and selects it. The pasted
field appears at the same position from which it was cur. If
you've moved the field and its text from the card layer to the
background layer, you won't see the text until you return to
the card layer (at the end of this procedure).
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6. While the field is still selected, drag it to where you want it.

7. If you've moved a field and its text from the card layer to the
background layer, choose Background from the Edit menu, or

press -B, to return to the card layer and see the text.

2\ Important: The most common mistake in copying a field is
putting it in the card layer when you want it in the background
layer. (To find out whether a field is in the background, press ~-B
to view just the background elements.) If you put a field in the card
layer by mistake, see “Moving a Field From the Card to the
Background,” earlier in this chapter. &

LOCking and  You can lock a field to prevent content changes to its text. Locking
Ll[]lOCkil]g 1 field @ field does nox, however, prevent changes to the text format of
the field.

To lock a field, follow these steps:
1. Choose the Field tool (77) from the Tools menu.
2. Click the field to select it.
3. Choose Field Info from the Objects menu.
Or just double-click the field. The Field Info dialog box appears.
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4. Click Lock Text to select it:

Field Name: |
Bkgnd field number: 8 Bkgnd field ID: 11
Click here to prevent [ Lock Text Style:
changes to the text in [JAuto Tab
-f-l']:_‘ HL‘Jd. Click Lock [ Den't Search [ Show Lines
Text again to unlock [ Shared Text [I¥ide Harains

the field, making the
[eX1 L'L{.][:-I||'1|L'
{Eulors...l “ 0K II [ Cancel I

. Figure 5-29 Locking a field

5. Click OK.

When the Browse tool passes over a locked field, it doesn't change
to the I-beam pointer (). This lets you know that you can't edit
the field.

If you want to unlock a field to allow text changes, click Lock
Text again in the Field Info dialog box to deselect it (as shown
in Figure 5-29).
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. ) .
h.\(l“(]lﬂg d hff](,l The Find command (in the Go menu) allows you to search for
ﬁ-(-}”—] text ‘SC’II‘L‘I]C"‘} specific text in the fields of a stack. You can prevent | lyperCard
’ . i S = L - . . . -~ .
from searching in any particular field during text searches.
Follow these steps:
1. Choose the Field tool () from the Tools menu.
2. Click the field to select it.
3. Choose Field Info from the Objects menu.
4. Click the Don't Search check box to select it.
Clicking Don't Search again deselects it.

5. Click OK.

[f you want to turn off the Don't Search option to allow
HyperCard to search in the field, simply deselect the option

(as explained in step 4).

»  Secalo:  * “Excluding Card and Background Fields From Text Searches”
in Chapter 3
» “Excluding Background Fields From Text Searches™ in

Chapter 3
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l)eletlng afield Youcan delete a field whether or not it has text in it. When you
delete a field, any text contained in the field is deleted too.

Follow these steps to delete a field:

1. Choose the Field tool (1) from the Tools menu.

2. Click the field you want to delete to select it.

3. Choose Clear Field from the Edit menu, or press Delete,
[f the field is a background field, a dialog box like this appears:
Delete this field ond all its text fromall 2 ,
cords of this bockaround? P Click Delete to confirm that

. vou want to cut the field,
I Delete | ‘ Concel ' :
Figure 5-30  Confirmation dialog box for deleting o buckground field

A Warning: Once you've deleted the field with the Clear Field
command (or with the Delete key), the field and all its text
are gone for good—you can't undo the deletion. DEiE[ing a
background field also deletes all text in that field on all cards
sh.n'ing that haclcgl'm.lnd. A
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Chapter 6

Working With Graphics

Gmphic:; help communicate what a stack is for and how it
works. The graphics described in this chapter include lines, shapes,
patterns, pictures, and Paint text—any graphic element that you
create or manipulate with the Paint tools.

This chapter explains how to do the following;
» Create graphics yourself using the Paint tools.
» Copy graphics from another stack (or the same one).

= Import graphics from any document in the Apple Preferred
File Format.

To do the tasks in this chapter, you must have your user level set
at least to Painting. (The section “User Levels and Options” in

Chapter 1 explains how to set your user level.)




Add[ng gl'ﬂphl‘(}_; Each card can have its own unique graphics in the card layer in
to 2 G.'ll'd addition to the background graphics it shares with other cards.
Whenever you add a graphic element to a stack, you need to decide
Oor bﬂCkgTOUﬂd whether you want it in the card layer or the background layer.
To decide where to put the graphic, consider where you want it
to appear:

s Ifyou want the graphic to appear on every card in the stack, put
it in the background layer. A background graphic appears in the
same location on all the cards that share the background.

 Ifyou want the graphic to appear on only one card, add it to the

card layer.

= If you want the graphic to appear on some but not all of the
cards in the stack, consider creating a different background for ®
those cards and putting the graphic in that background only.
(“Creating a New Background” in Chapter 3 explains how to
add a background to a stack.)

To add a graphic to a background, you must be in the background
layer; to add a graphic to a card, you must be in the card layer.

To go to the background layer, press .~ -B. When you're in the
background layer, the word Background appears in the menu bar.
If you press ~-B repeatedly, you move back and forth between the
card layer and the background layer.

»  Seealso: *“The Card Layer Versus the Background Layer”
4 tal 4

in Chaprer 2
* “When Elements Overlap” in this chaprer .
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ThL‘ [ )(_)15 1o create and work with graphics, you use the Paint tools in the
for “’()]'king Tools menu.
with graphics

"

2 7
i =4 P
:-:-E ol — T'he Paint tools
IO |
AlD|IE

Figure 6-1 HyperCard's tools

The functions of the Paint tools are described briefly in the figure
that follows. This chapter provides detailed instructions for using
these tools.
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The Browse
ool is for
hrowsing
through stacks
and editing
rext

The Selection

P
L

LW J| is for

selecting
graphics.

j;g) The Brush
paints with

the current

l'1.'.‘.|k".'i‘_ Ul

|
RN

The Spray tool
spritzes paint
onto the
screen in the
current pattern
or color,

The Bucket fills
enclosed areas
or one-color
areas with the
current pattern
or color.

The Paint Text
tool is tor
Lyping 1ext
that's part ol

a araphic

Figure 6-2

.
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The Button toul
is for working
with huttons.

The Lasso is
for selecting
nonrectangular
graphics.

The Eraser
erases the par
of a graphic
you drag it
over

The Rectang
tool draws
rectangles and
squares

@

The Oval toal
draws ovals
and circles.

The Regular
j’U|'_'.II|.';1'1I'| tool
Creiies
polygons with
regular sides.

Whart the tools are used for

N

The Field tool
is for working
with fields

The Penci
draws thin,
free-form
lines

The Line tool

draws straight
lines .

The Rounded
Rectangle
tool draws
rectangles
with roundec

COrners

The Curve toal
draws free-form
lines and
shapes.

The Polygon
ool creates
polygons with

irregular sides




1o make it easy to alternate between the tools, you can “tear off”
the Tools menu to create a movable Tools palette. To do this, drag
down through the menu past the bottom or beyond either side.
(For an illustration of this, see Figure 2-12.) While you have the
Tools palette open, you can select a tool just by clicking it on the
palette. This makes it easy to switch back and forth berween
different Paint tools.

When you choose one of the Paint tools, three new menus appear:
Paint, Options, and Patterns. (The Objects menu disappears
temporarily while you're working with the Paint tools.)

These three menus appear when you
have one of the Paint tools 5tit.‘c[t'd.|

| |
& File Edit Go Tools| Peint Options Patterns |

This stack contains clip ort you
Ar’ |de°s con copy into your own stacks.

selected Paint ol

| "7 T TTTTE Clieko Category
@ Geoprahy D frrows
I Music B Household
&F HypertordSeuft 8 Pictures, film

| Computer Stuff | @ Bockground Art |
@ Scenery - [ rull Sereenfrt
Wi | Peonle, Animals

<k Miscel loneaus Find Stock Info  Home

Figure 6-3  Menus that accompany the Paint tools

The Paint and Options menus contain commands for crearing and
manipulating graphics. These commands are described throughout
this chaprer.
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The Patterns menu contains patterns and colors you can use to fill
shapes and draw with. For easy access to the patterns and colors,
you can tear off the Pacterns menu the same way you tear off the
Tools menu—drag down through the menu past the bottom or

beyond either side,

Options LiAT: You can close the
Putterns palette

by clicking here

To move the

e palette, drig

from here

T
0

Click any pattern

To tear off the Patterns menu,
or color to select it

drag beyond the bottom or
either side of the menu

Figure 6-4  Tearing off the Patterns menu

2 A shorteut: Whenever you have a Paint ool selected, you 5
can make the Patterns palette appear and disappear quickly

by pressing Tab or double-clicking the Bucket on the

Tools palette. «
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Selecting a graphic

The Pacterns palette works like the "Tools palette—to select a pattern
or color, just click it. “( reating Your Own Patterns,” later in this
chapter, explains how you can add your own patterns to this palette.

» Scealso: “Using HyperCard’s Tools” in Chapter 2

* “Using Power Keys™ in this chapter
“Using Modifier Keys With Paint Tools” in this chapter
“Double-Clicking Paint Tools, Patterns, and Colors” in this

chaprer

Before you can modify, move, or copy a graphic, you must first
select it. There are many different ways to select a graphic. The
method you use depends on the shape and size of the particular
graphic element(s) you want to select. The sections that follow

explain all the methods for selecting graphics.

To select a graphic, you must be working in the same layer as the
graphic. If the graphic is in the background layer, you can select

it only from the background layer. If it’s in the card layer, you

can select it only from the card layer. If you try to select a graphic
and it doesn't become selected, chances are the g graphic is in the
background layer and you're working in the card layer. (It's also
possible that the element you're trying to select is actually a button
or field. Chaprters 4 and 5 explain how ro select buttons and fields.)

% Blank space vs. white paint: A white area on a card or
background is not necessarily blank, transparent space—it can
also be white paint or an opaque area. White paint can be useful
for hiding background elements and for graphic effects such as
painting in white over a color or pattern. In most respects, white
paint is the same as any other paint: You can fill selections and
draw with it, and you can erase it. However, not all the methods
of selecting a graphic work for white paint. Each of the following
sections explains how the selection of white paint differs from

the selection of a color, +
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Once you've selected a graphic, it stays selected until you choose a
tool or click outside the selection.

& lcons are selected differently than graphics: Remember that an
icon is part of a button. To select an icon, you have to select the
button that displays it. If you’re not sure whether a particular
element is an icon or a graphic, choose the Button tool (=) from
the Tools menu, click the element, and drag it. If a moving
dashed line appears around the element and you can move it by
dragging, it’s an icon. Chapter 4 gives instructions for working
with buttons and icons. &

Hclttfiﬂg a I'Efr;flélllnglz.ll‘ area  To select a rectangular graphic element or a rectangular area ofa
picture, follow these steps:

1. Go to the card or background that contains the graphic
element or the area you want to select.

Pressing ("-B takes you to the background layer. (When you're
in the background layer, the word Background appears in the
menu bar.) If you press 3-B repeatedly, you move back and
forth between the card layer and the background layer. If you
don't see the graphic you want while you're in the background
layer, the graphic is in the card layer.

2. Choose the Selection tool (7 2) from the Tools menu.

Or click it on the Tools palette. The pointer changes to a

crosshair (+-). .
3. Move the crosshair pointer to one corner of the area you want
to select.

4. Drag diagonally to the opposite corner of the area.

A moving dashed line surrounds the selected area. If the area
includes white paint, the white paint is included in the selection,
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@ For a tighter selection: To eliminate extra blank space from
the selection, press the (" key while you drag; when you
release the mouse button, the moving dashed line snaps
in to select the smallest rectangular area surrounding the
graphic. Any white paint that lies outside the rectangular
area will also be eliminated. #

Press and hold the —, _ _ _ e
' key and drag
diagonally with

the Selection tool

[rom here

i

The moving dashed line
snaps around the graphic
to eliminate extra blank
space from the selection.

.. 1o here,

Figure 6-5 Eliminating extra blank space in a rectangular selection

[f you select too much or not enough, deselect the graphic by
clicking on the card outside the selection, then select the
graphic again.

Selecting A To select a nonrectangular graphic element or a nonrectangular area
& nonrectangular area  of a picture, follow these steps:

1. Go to the card or background that contains the graphic

element or the area you want to select.

Pressing . -B takes you to the background layer. (When you're
in the background layer, the word Background appears in the
menu bar.) If you press _-B repeatedly, you move back and
forth between the card layer and the background layer. If you
don't see the graphic you want while you’re in the background
layer, the graphic is in the card layer.

Chapter 6: Working With Graphics 255




2. Choose the Lasso (+) from the Tools menu.

Or click it on the Tools palette. The pointer turns into a lasso.

3 Dl'i]‘.g B_I'{)Llﬂd [I'lf.' gr:lphic you want to S(’.'lECE:

IfJI

ri\

I»q|

The tip of the line
trailing out of the

Liasso determines

|||I||||lm

|

|L||||||

what vou select

Figure 6-6 Selecting a nonrectangular area

You don't need to drag completely around the graphic;
HyperCard will complete the selection by drawing a straight line
between the point where you start dragging and the point where
you stop. (But if you Stop too soon, you mighr miss part of the
graphic you want to select.)

Wh(_"n yl)ll n_'il_'il.‘i(_‘ thL’ maouvse bLl[t{)n, ['hi: L"dgL‘S DF l']'lt‘ SL‘lL‘L‘t(:’d
graphic shimmer. If there was any white paint or blank space
surrounding the graphic, it’s eliminated from the selection:
selected ard hic¢
ity e 0" P

n |||U|
lﬂlﬂlfﬂ“l‘“ \Elm.u"r WI‘
shimmer.
|
b ¥y 1 L M

Figure 6-7  Only the lissoed graphic is selected

)

o) |

a

The edges of the
1{1 1“ ‘ﬂ} e edges 1
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Selecting an individual
graphic element

* If you want to include the surrounding blank space: To lasso a
graphic without eliminating any surrounding blank space or
white paint, press the Option key while you drag with the lasso.
This selects exactly the area you drag around. #

If you select too much or not enough, deselect the graphic by
clicking on the card outside the selection, then select the
graphic again.

There are several ways to select a single graphic element without
any of the blank space or white paint that surrounds it—including
the method described in the preceding section, “Selecting a
Nonrectangular Area.” This section describes two additional
methods.

Use the following technique when you want to select a specific
graphic element quickly and exclude the surrounding blank space
and white paint, or if your hand isn't steady enough to use the Lasso
with precision:

I. Go to the card or background that contains the graphic you
want to select.

Pressing ' -B rakes you to the background layer. (When you're
in the background layer, the word Background appears in the
menu bar.) If you press ~ -B repeatedly, you move back and
forth between the card layer and the background layer. If you
don't see the graphic you want while you're in the background
layer, the graphic is in the card layer.

2. Choose the Selection tool (:3) from the Tools menu.

Or click it on the Tools palette. The pointer changes to a
crosshair ().

3. Move the crosshair pointer to one corner of the graphic.
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4. Press the Option key while you drag diagonally to the opposite
corner of the graphic.

Or choose Select from the Paint menu (or press -S) after you
drag to the opposite corner. This automatically chooses the Lasso
and selects the graphic.

Press and hold (e, v cnse e neeees esen

Bt EH h

Option key and drag

diagonally with

the Selection tool
from here

L
i
b

BEAR
a8 2N

"

/
!
¢
!
* !
!
]
/
f
!

TR R TR
=

.10 here | The selected graphic .
shimmers

Figure 6-8  Selecting an individual graphic element

If you select too much or not enough, click on the card outside the
selection to deselect the graphic, then select it again.
You can use the following technique to select a one-color graphic
element that has no breaks in it—that is, one that's composed
entirely of connected dots of the same color. This technique is
useful for selecting small graphic elements of one solid color.
1. Go to the card or background that contains the graphic

element you want to select. .

2. Choose the Lasso from the Tools menu.

3. Move the Lasso’s tip into the graphic.

4 Chapter 0: Working With ( sraphics




4. Press the  key while you click the graphic.

LD

T
et |

Select a one-color L'.II’L!DI]H' The l.'L[‘EL"- of the selected
element by - -clicking it with araphic shimme

"Nananamnn N

the tip ol the Lisso

Figure 6-9 Selecting a one-color graphic elemer

Selecting the graphic  Immediately after you draw a single graphic element (and before you
you've just created  click anywhere), you can select the element you've just created by
choosing Select from the Paint menu or pressing ~-S. The Select
command selects only the graphic element (including white pain)
you've created since the last time you pressed the mouse button. (If
vou haven't just created a new graphic, the Select command selects

all the gl';lphit'n in the ]'.1}'::1' in which }‘Uu'rc \\'m'king,]

This technique is particularly useful if you've just drawn a shape
very close to or actually touching another shape, and you need to
move the new shape. You can even draw a new shape on top of an
old one, choose Select, and then drag the new shape away without

. changing the old shape.

You can also use the Select command to select an area you've
just erased. (The erased area becomes opaque after you select and
‘ move it.)

[f the Power Keys option is turned on (and the Message box is
hidden), you can press S instead of choosing Select. (“Using Power
Keys,” later in this chapter, explains the Power Keys option.)
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SEJL*L‘[iﬂg all the  When your card or background picture is made up of several
graphic elements on a card  individual graphic elements, you might want to select them all at
or b;l{:kgl'uund once to make changes to them or to copy or move them. This
section explains how to select all the graphic elements in the current
layer, excluding any blank space or white paint between them.

To select all the individual graphic elements on the card or
background, first make sure you're in the layer that contains

the graphics you want to select. Pressing ~ -B takes you to the
background layer. (When you're in the background layer, the word
Background appears in the menu bar.) If you press — -B repeatedly,
you move back and forth between the card layer and the
background layer. If you don't see the graphics you want while
you're in the background layer, they’re in the card layer. .

Select all the graphic elements in the current card layer or
background layer by using one of these methods:

» Choose Select from the Paint menu, or press  -S.

s Double-click the Lasso on the Tools palette.

» [f the Power Keys option is turned on (and the Message box
is hidden), press S. (“Using Power Keys,” later in this chapter,
explains the Power Keys option.)

Scenery 2
When voure in the Sun, Pot of Gold, Clouds, Rocks, Trees

N 2 )
card kver and vou p i%s " Altnian. S i .
[ BT iH :
Th

choose Select from
the Paint menu, all
the crd graphics
become selected
(their edges

. but the
shimmer)

background
graphics dont

Figure 6-10  Selecting all the graphic elements in the current kyer
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Selecting the  When you want to copy, delete, or change the entire card picture
entire card picture  or background picture (for example, by filling it with a pattern),
or back ground picture  you can select the whole picture at once in one rectangular selection
the size of the card. This section explains how to select the whole
picture in the current layer, including all the graphic elements and
the blank space between them.

o select an entire picture, first make sure you're in the layer that
contains the picture. Pressing B takes you to the background
layer. (When you're in the background layer, the word Background
appears in the menu bar.) If you press - -B repeatedly, you move
back and forth berween the card layer and the background layer.
If you don't see the picture you want while you're in the

. background layer, it’s in the card layer.

Select the entire picture by using one of these methods:
a  Choose Select All from the Paint menu, or press  -A.
= Double-click the Selection tool on the Tools palette.

» [f the Power Keys option is turned on (and the Message box is
hidden), press A. (“Using Power Keys,” later in this chapter,
explains the Power Keys option.)

= Choose the Selection tool (:Z) from the Tools menu and drag
diagonally from one corner of the card or background to the
opposite corner.

A moving dashed line surrounds the selected card or background
o picture. To deselect the picture, click anywhere on the card or
background, or choose a tool from the Tools menu.
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C()p}"lng gl'llpllll.'ﬁ The easiest way to get art into your stacks is to copy graphics that
[hﬂ[ come with already exist. quymg graphics can simplify the stack-building
process. HyperCard comes with a stack called Art Ideas that
H}fpel'cm'd contains all kinds of illustrations you can copy and paste into your
stacks. The first card in this stack lists categories of graphic images.
To see graphics in a particular category, click the category name.

AN

"
¥ r.
LEELELL LA

w &
3%
& ,

&g

Figure 6-11  Some graphics from the Art Ideas stack

When you see a graphic you like in Art Ideas or any other stack that
comes with HyperCard, copy it and paste it into your stack. Follow

these steps:

1. Open the Art Ideas stack (or any other stack that comes with
HyperCard).

2. Go to the card that has the graphic you want to copy. [
3. Select the graphic you want.

For instructions on selecting a graphic, see “Selecting a Graphic,”

earlier in this chaprer.
4. Choose Copy Picture from the Edit menu, or press  -C.

This puts a copy of the selected graphic on the Clipboard.
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5. Go to the card or background where you want to put the
graphic.

You can use the arrow keys or commands in the Go menu to
navigate between cards or stacks while you have the Selection

tool or Lasso selecred.

[ you're not sure whether o pur the graphic in the card layer
or the background layer, see “Adding Graphics to a Card or
Background™ at the [u'gillnil}g of this chaprer.

6. Choose Paste Picture from the Edit menu, or press -V,

This takes a copy of the graphic that’s on the Clipboard, puts it
on the current card or background, and selects it.

7. While the graphic is still selected, drag it to where you want it
on the card or background.

The graphic becomes opaque after you paste it. If you want to be
able to see through the graphic to the elements behind it, select it
and choose Transparent from the Paint menu.

» Secalo: o “Changing the Appearance of a Graphic” in this chaprer

Undoing your  1fyou make a mistake while you're working with the Paint tools
y y ks X :
lniSt'lk(fS and cmpmnnds, you can undo your last operation ¥ L:h{:ﬂ:;lﬂg
. : Undo from the Edit menu (or pressing  "-Z, Esc, or Tilde) before

you do anything else.

@ [f Undo doesn’t work: 1f Undo doesn’'t work consistently, it's a
sign that HyperCard is running low on memory. For more
information about low-memory situations, see “Working With

aint ‘Tools When Memory Is Low,” later in this chapter. ¢
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Painting with the
Brush, Spray tool,
and Bucket

Painting with the Brush

You can erase a mistake by choosing the Eraser from the Tools
menu and dragging over the graphic. You must be working in the
background layer to erase a background graphic and in the card
layer to erase a card graphic. To erase in a straight horizontal or
vertical line, press Shift while you drag the Eraser.

» Seeabo: “Reverting to the Last Version of a Graphic”™ in this chaprer
* “Saving the Graphics on a Card or Background” in
this chaprer
* “Deleting a Graphic” in this chaprer

Three of the tools in the Tools menu are analogous to everyday
o J f,
painting implements. These tools work much like the implements

they represent:

s T'he Brush (&) works like a paint brush.

» The Spray tool ( #) works like a can of spray paint.
w The Bucket (&) works like a buckert full of paint.

You can use these tools in conjunction with patterns and colors in
the Patterns menu. This section explains how.

The Brush works like a paint brush—it leaves a swath of “paint” in
its path. You can use the Brush to paint an area with a pattern or

color. (HyperCard’s default color is black.) .
Follow these steps to paint with the Brush:
1. Go to the card or background where you want the paint.

If }f()u'rc not sure whether to put the paint in the card lal_vcr
or the background layer, see “Adding Graphics to a Ca rd or
Background” art the beginning of this chaprer.
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2. Choose the Brush (#) from the Tools menu.

Or click it on the Tools palette. The pointer changes to the
current Brush shape.

3. Drag where you want to paint.

Paint (in the current pattern or color) appears where you drag.
To paintin a straight horizontal or vertical line, press and hold
the Shift key while you drag,

+ 10 erase with the Brush: You can erase any existing paint in
the patch of the Brush by pressing and holding the ™ key
while you drag. «

If you want to paint with a different pattern or color, choose the
one you want from the Patterns menu (or click it on the Patterns
palette) before you drag with the Brush,

If you want to paint (or erase) with a different brush shape, choose
Brush Shape from the Options menu or double-click the Brush on
the Tools palette. The Brush Shape dialog box appears:

Click a brush shape to
He J| = select it After vou select
e . N\ | - i hrush shape, this
dialog box disuppears.
The pointer changes

S T T to the brush shape

you select

(] . s N i =

\ box appears around the
selected brush shape

I:igurc 6-12  The different brush ~||,|!'1L'a
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The different brush shapes create different effects when you paint.
The following figure shows some examples:

Brush shape | L Elffect

Figure 6-13  The different brush shapes create different effects

Painting with  The Spray tool works like a can of spray paint—it “spritzes” paint
the Spray tool  onto the screen in the selected pattern.

Follow these steps to paint with the Spray tool:
I. Go to the card or background where you want the paint.

[f you're not sure whether to put the paint in the card layer
or the background layer, see “Adding Graphics to a Card or
Background” at the beginning of this chaprer.

2. Choose the Spray tool () from the Tools menu. .

Or dlick it on the Tools palette. The pointer changes to the
Spray tool ().
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3. Drag where you want to paint.

Spray paint, in the current pattern or color, appears where you
drag. The more you spray back and forth over the same area, the
more the pattern or color becomes apparent. (Some patterns
don't show up until you've thoroughly covered an area.)

To paint in a straight horizontal or vertical line, press and hold
the Shift key while you drag,

+ 10 erase with the Spray tool: You can erase any existing paint
in the path of the Spray tool by pressing and holding the ~

key while you drag. «

[f you want to spray with a different pattern or color, choose the
@ one you want from the Patterns menu or click it on the Patterns
palette before you drag with the Spray tool.

Filling an area with  You can fill any area on a card or background with a pattern or
a pattern or color  color by using either the Bucket (in the Tools menu) or the Fill
command (in the Paint menu). Before you fill an area, you can

choose the pattern or color you want to fill it with.

This section describes two different methods for filling an area.
The method you use depends on whether the area you want to fill
is completely enclosed.

+ Filling shapes: 1f you know before creating a shape that you
want to fill it with a pattern or color, you can fill the shape
o) automatically as you draw it. For instructions, see “Drawing a
Shape Filled With a Pattern or Color,” later in this chapter. «
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Filling an enclosed area

When you want to fill an area that's completely enclosed—that s,
completely surrounded by an outline—follow these steps:

1. Go to the card or background that contains the enclosed area
you want to fill.

If the outline enclosing the area is in the background layer, go to
the background layer. If it’s in the card layer, make sure you're in
the card layer. If the outline is composed of several different

eraphic elements, they must all be in one layer.

Pressing  -B takes you to the background layer. (When you re
in the background layer, the word Background appears in the
menu bar.) If you press ~'-B repeatedly, you move back and .
forth between the card layer and the background layer.

b

. Choose the pattern you want from the Patterns menu.
Or click it on the Patterns palette.
3. Choose the Bucket (%) from the Tools menu.

Or click it on the Tools palette. The pointer changes to the

Bucket.

4. Move the Bucket so that the tip of the stream pouring from it
is within the enclosed space you want to fill, then click:

%" This is the part of the Bucket .

that dispenses paint

PEIRT TeNt

Figure 6-14  Positioning the Bucket pointer 1o Fill an area
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[F there are any gaps in the outline that encloses the arca you want
to fll, paint will spill out and fill the surrounding area, too. If this
happens, immediately choose Undo from the Edit menu, or press

-7, Tilde, Esc, or Delete. Then check carefully for gaps in the
outline before using the Bucket again.

Friclosed are: Gap

LAl

Figure 6-15 Paint spills out of an unenclosed area

< 1o check for gaps: You can magnify the graphic to check for gaps
in its outline by using the technique described in “Magnifying a
Graphic for Editing,” later in this chapter.

Filling an unenclosed area

To fill an area that’s not completely enclosed by an outine or other
graphics, follow these steps:
1. Go to the card or background that contains the area you want

. to fill.

Pressing ('-B takes you to the background layer. (When you're
il] thC hﬂCl(grOllnL—] 13}]('.]', rh{‘ W()r(‘] l‘?j‘ffkg?'ﬂﬂ?’fdﬂppeﬂrﬁ il_l [ht‘
menu bar.) If you press ("'-B repeatedly, you move back and
forth between the card layer and the background layer.

2. Choose the pattern you want from the Patterns menu.

Or click it on the Patterns p;ﬂettc.

Chapter 0: Working With Graphics 209




3. Select the graphic element or the area you want to fill.

[f you want to fill a specific graphic element, you can select

it with either the Selection tool or the Lasso, as explained in
“Selecting an Individual Graphic Element,” earlier in this
chapter. If you want to fill a blank area, select it with the
Selection tool, as explained in “Selecting a Rc:'f.‘[;lllguhlr Area,”
earlier in this chapter.

4. Choose Fill from the Paint menu.

The selected area fills with the current pattern or color.

-:."'-"‘-'r g’
S
AL = N
=Tally
iy /
Lo k! iﬂ[
Select the graphic you wanttofill . . . ... and choose Fill

from the Paint menu.

Figure 6-16  Using the Fill command

[f the Power Keys option is turned on, you can press F instead of
choosing Fill. (“Using Power Keys,” later in this chapter, explains @)
the Power Keys option.)

Cll‘il[ll‘lé{ YOUTI'  You can change any pattern in the third or fourth column of the

OwWn pil[{(,‘l'nﬁ atterns menu or replace it with a pattern of your own'cr-::atiun. .
When you change or create a pattern, the new pattern is saved with
the stack you're working in. It appears in the Patterns menu every

time that stack is active.
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To dmngc Or create a pattern, follow these steps:

I Choose the pattern you want to change from the third or
fourth column of the Patterns menu.

Or click it on the Patterns palette. You cannot change any of the
individual colors in the first or second columns.

2. Choose Edit Pattern from the Options menu.

Or double-click the pattern you want to change on the Patterns
palette. The Edit Pattern dialog box appears.

3. Edit the pattern.

This is the editing As you edit the pattern
in the editing area to
the left, this shows
you how the pattern
will look.

area. You can click to
draw and erase the
little squares that
make up the pattern

Click here to fill the
pattern with the

selected color

Click here to mix the

the selected o 118

into the pattern

Click the color you want
to use 1o select it.

Figure 6-17  Fditing a pattern
4. Click OK to save the new pattern.

The new pattern takes the place of the one that was selected in
the Patterns menu.
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Chﬂﬂgll’lg CO‘()F SCLS The color set for a HyperCard stack determines the 16 colors
available for use by the backgrounds, cards, buttons, and fields
in the stack. You can choose from among five color sets for any
given stack: the standard system color set, a gray scale color ser,

and three others.

When you change your stack’s color set, the colors of some or all
the graphics, buttons, and fields in the stack may change to reflect
the new colors. For example, these three images all make use of the
same graphic, but different color sets:

Gray scale color set

Jl

A pastel color set

Figure 6-18  Changing color sets

b
r
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[f you wish, you can sclect color sets for the cards and backgrounds
in your stack that are different from the color set selected for the
stack as a whole. If a card’s color set has not been specified
individually, the card uses the color set currently selected for its
background. Similarly, if a background’s color set has not been
specified individually, the background uses the color set currently
selected for the stack.

For example, the cards in the Birds stack use several different color
sets so that the colors in each drawing match the bird’s true colors
more closely. By carefully selecting the color sets for cards and
backgmunds in a stack, you can control the colors in your stacks
more precisely than would be possible with just one color set.

[f none of the five color sets available for a card or background
includes the colors you want, you can add a sixth color set to a card
or background in the stack from any document in the Apple
Preferred File Format, the standard format for Apple 11Gs graphics
documents. For instructions on how to do this, see “Importing a
New Color Set for a Card or Background,” later in this chapter.

You can also add a sixth color set to a card or background by using a
desk accessory, an XCMD, or HyperTalk to specify the colors you
want. If you use a desk accessory or an XCMD to do this, the color
set you specify will be added automatically to the color sets for the
current card or background and will be selected. For instructions on
using HyperTalk to add a sixth color set to a card or background,
see the discussion of the colorset property in the HyperTalk
Help stack.

The sections that follow describe how to change the color set for a
stack, a card, and a background.
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(,h;mgmg a stack’s colorset  To change the color set for the stack you're working in, follow
these steps:

1. Make sure you have one of the General tools selected.

The Browse tool (¥), the Button tool (=), or the Field tool (3)
will work.

2. Choose Stack Info from the Objects menu.
3. Click Colors.
The Colors dialog box for the stack appears.

4. Select the color set you want:

Display colors for stack "MyStock"

Stondord system colors

i Ui broy scale
'hese are the

T 1 T T T 1

Other color sets...

color sets that are

available for the
current stack P

Click the one vou When disploying this stock:

wint to use I Use these colors 1 I“.l

then press and hold the mouse button here and drag o
choose “Use these colors™ G it's not already selected) from the
pop-up menu. If you choose “Get standard system colors”
instead, your stack will use the standard system colors no
matter which color set is selected for the stack.

Figure 6-19  Changing a stack’s color set

5. When you're finished, click OK.

The Colors di:ﬂ()g box disnppc;u‘s, and you see the Stack Info
dialog box again.
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Changing a card’s color set

hese are the
color sets that are
available for the
current card

Click the one v
. want to use

6. In the Stack Info dialog box, click OK.

The colors displayed in the stack now match the color set you
selected (unless difterent color sets have been selected for
individual cards or backgrounds).

You can easily tell which colors are in the color set for the current
card by checking the Patterns menu while you're working in the

card layer. The first and second columns in the Patterns menu show

the colors currently being used by the card.

To change the color set for a card, follow these steps:

L. Go to the card whose color set you want to change.
2. Make sure you have one of the Paint tools selected.
3. Choose “Choose ColorSet” from the Options menu.

Or double-click any color in the first or second column of the
Patterns palette. The Colors dialog box for the card appears.

4. Select the color set you want:

_Display colors for cord 10 2028
AL [t | (AP | ]| Stondard system colors
Groy scole

Other color sets...

When disploving this cord:

| Use these colors b ' 0K D (Cancel )

.. then press and hold the mouse button here and drag to
choose “Use these colors™ GF it's not already selected) from the
pop-up menu. I you choose “Get colors from background”
instead, the card will use the colors currently specified for the
background no matter which color set is selected for the card.

Figure 6-20 Changing a card's color set
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5. When you’re finished, click OK.

—I—I'I'L' L‘ﬂlﬂrﬁ di.'iplil}'(‘d on rh(_' Cﬂrd now TTIL'ITCh l'h(' COIOI' set _‘v’ﬂll
selected.

You can also change a card’s color set when you have one of the
General tools selected, as described in “Changing a Card’s Color
Set” in Chaprer 3.

If none of the five color sets for a card include the colors you want,
you can add a sixth color set to a card from any document in the
Apple Preferred File Format, the standard formar for Apple [1Gs
graphics documents. For instructions on how to do this, see
“Importing a New Color Set for a Card or Background,” later in
this chaprer.

You can also add a sixth color set to a card by using a desk accessory,
an XCMD, or HyperTalk to specify the colors you want. If you use
a desk accessory or an XCMD to do this while you're working in
the card layer, the color set you specify will be added automarically
to the color sets for the current card and will be selected. For
instructions on using HyperTalk to add a sixth color set to a card,
see the discussion of the colorset property in the HyperTalk
Help stack.

Changing a background’s  You can easily tell which colors are in the color set for the current
color set  background by checking the Patterns menu while you’re working in
the background layer. The first and second columns in the Patterns
menu display the colors currently being used by the background. .

IU (:I'l'dl'lgt‘ []IC L'(]]()i' set {'.Ul“ d bi],Cl(gl"(]LlllLi._ ﬁ)”()\’u’ II'ICSL‘_‘ Slft"p'b:

1. Go to any card that has the background whose color set you
want to change.

2. Make sure you have one of the Paint tools selected.
3. Go to the background layer.

Choose Background from the Edit menu, or press  -B.
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4. Choose “Choose ColorSet” from the Options menu.

Or double-click any color in the first or second column of the
Patterns palette. The Colors dialog box for the background
appears.

5. Select the color set you want:

_ Display colors for backaround 1D 2697

Standord system colors

Groy scale
These are the
color sets that are
available for the

. current background.

Click the one you When displaying this bkgnd:

want to use [_Use these colors ] % )

Other color sets...

.. then press and hold the mouse button here and drag to
choose “Use these colors” (if it's not already selected) from the
pop-up menu. If you choose “Get colors from stack” instead,
your stack will use the colors currently specified for the stack
no matter which color set is selected for the background.

Figure 6-21 Changing a background's color sel

6. When you're finished, click OK.

. The colors displayed in the background now match the color set
you selected (unless different color sets have been selected for
individual cards in the background).

You can also change a background’s color set when you have
one of the General tools selected, as described in “Changing a
Background’s Color Set” in Chapter 3.
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[f none of the five color sets for a background include the colors
you want, you can add a sixth color set to a background from any
document in the Apple Preferred File Format, the standard format
tor Apple 11Gs graphics documents. For instructions on how to do
this, see the next section, “Importing a New Color Set for a Card
or Background.”

You can also add a sixth color set to a background by using a desk
accessory, an XCMD, or HyperTalk to specify the colors you want.
If you use a desk accessory or an XCMD to do this while you're
working in the background layer, the color set you specify will be
added automatically to the color sets for the current background

and will be selected. For instructions on using HyperTalk to add a
sixth color set to a background, see the discussion of the co Lorsi
property in the HyperTalk Help stack.

Importing a new color set  The Colors dialog box for a card or background normally allows
for a card or background  you to choose from only five color sets. However, you can add a
sixth color set to a card or background from any document in the

Apple Preferred File Format by following these steps:

1. Go to the card or background where you want the new
color set.

\ Important: If there are any graphics on the card or background
that you want to keep, make a copy of them for temporary
safekeeping as described in “Copying a Graphic to Another Card ()
Background,” later in this chapter, before you import the new color
set. Otherwise, you will lose the graphics permanently. A

2. Make sure you have one of the Paint tools selected.
3. Choose Import Paint from the File menu.

A dil‘t:t‘mry diﬂlr}g box appears.
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4. Use the directory dialog box to locate and open the Paint file
that contains the color set you want to import.

The upper-left portion of the imported picture appears.
- G 5. Choose Keep from the Paint menu.
HyperCard adds the color set from the imported picture’s

original Paint file below the color sets in the current card or
background’s Colors diﬂlog box, and selects it.

[f you want to keep the new color set but not the imported picture,
erase the picture and replace it with your original graphics or any
other graphics you want to use. For more information about
importing graphics, see “Importing a Graphic,” later in this chapter.

Dra wing lines The Tools menuincludes tools for drawing lines and shapes—
7 o . including circles, ovals, rectangles, polyeons, and free-for
clﬂd bh,.lpeb C g circies, ovals, rectangles, polygons, and free-form
shapes. This section explains how to create lines and shapes with
these tools.

e

—
5 2
h | S i
. ":'[g I | | . IOl | These tools are
for drawing lines
{ia g g g g and shapes.
Figure 6-22  Tools for drawing lines and shapes

» Seealso: **D rawing With Patterns, Colors, and Different Line Widths”
in this chapter
* “Creating Special Graphic Effects” in this chaprer
* “Changing the Appearance of a Graphic” in this chapter
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Drawing a line
or a free-form shape

2ol

1o draw a straight line or a free-form line or shape, follow

these steps:

1. Go to the card or background where you want the line
or shape.,
If you're not sure whether to put it in the card layer or the
background layer, see “Adding Graphics to a Card or
Background™ art the beginning of this chapter.

2. If you want to draw a straight line, choose the Line tool ()

from the Tools menu.

Or, to draw a free-form line or shape, choose the Curve tool (©)
from the Tools menu. The pointer changes to a crosshair (+).

3. Drag where you want to draw the line or shape.

{
- ,_/’f

Figure 6-23  Lines and free-form shapes

[f you're using the Line tool, you can draw a straight line ata | 52
angle from horizontal, or at an angle that’s a multiple of 15° by.
pressing the Shift key while you drag. To change the angle of a
straight line while you’re drawing it, change the direction of the
mouse as you drag,
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Drawing circles, ovals,
and rectangles

When you use the Line tool, you can draw a straight line from its
center point by first turning on the Draw Centered option. To turn
on Draw Centered, choose it from the Options menu. When Draw
Centered is turned on, a check mark appears next to it in the menu.
To turn off Draw Centered, choose it again. (If the Power Keys
option is turned on and the Message box is hidden, you can also
press C to turn Draw Centered on or off. “Using Power Keys,” later
in this chapter, explains the Power Keys option.)

+ Using the Pencil: 'The Pencil allows you to draw thin lines
and free-form shapes, too. For a discussion of the special
characteristics of the Pencil, see “Drawing Wich the Pencil,” later
in this chapter. «

To draw a circle, oval, or rectangle, follow these steps:
L. Go to the card or background where you want the shape.

[f you're not sure whether to put it in the card layer or the
background layer, see “Adding Graphics to a Card or
Background” at the beginning of this chaprer.

2. If you want to draw an oval or circle, choose the Oval tool (O)

from the Tools menu.

Or, to draw a rectangle or square, choose either the Rectangle
tool () or the Rounded Rectangle tool () from the Tools
menu. (The Rounded Rectangle tool draws rectangles and
squares with rounded corners.)

The pointer -;lmngr:x to a crosshair (+).
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3. Drag diagonally 1o draw the shape.

lor deaw a cirele, oval or

rectangle, select the

appropriate tool, then

1 I. " " i T o T
drae disigonally from

One corner ; '-'__——_"j
.. to the i,___ g

apposie

COMer.

Figure 6-24  Drawing circles, ovals, and rectangles

To draw an oval or rectangle that is the same number of pixels e
wide as it is high (that is, an approximate circle or square), press
the Shift key while you drag,

To move the shape around on the card while you're drawing it,
press | before you release the mouse button. This allows you to
drag the shape anywhere on the card. You can release the ~ key
to continue creating the shape, then press the  key again to
move the shape. Once you've released the mouse button, you
have to select the shape before you can move it. (“Selecting a
Graphic,” earlier in this chapter, explains how.)

To draw a shape from the center outward, first turn on the Draw
Centered option by choosing it from the Options menu. When
Draw Centered is turned on, a check mark appears next to it in the
menu. To turn off Draw Centered, choose it again. (If the Power
Keys option is turned on and the Message box is hidden, you can
also press C to turn Draw Centered on or off. “Using Power Keys,”
later in this chapter, explains the Power Keys option.)
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To draw a shape in outline—so that only its outline appears on the
screen while you're drawing it—first turn on the Draw Outlined
option by choosing it from the Options menu. When Draw
Outlined is turned on, a check mark appears next to it in the menu.
This option allows you to draw a shape more quickly and smoothly.

"The entire shape appears after you release the mouse button.

i)a':m-'m;,; d ]'L‘}{Llldl' Bl :|}'gun To draw a regular polygon (one that is the same number of pixels
wide as it is high), follow these steps:

l. Go to the card or background where you want the polygon.

If you're not sure whether to put it in the card layer or the
) background layer, see “Adding Graphics to a Card or
Background™ at the beginning of this chapter.

2. Choose the Regular Polygon tool (©) from the Tools menu.
The pointer changes to a crosshair (+).

3. If you want to select the number of sides for your polygon,
choose Polygon Sides from the Options menu.

Or double-click the Regular Polygon tool on the Tools palette.
The Polygon Sides dialog box appears.

This step and the next step are optional. If you don't select the
number of sides before you draw the polygon, it will be either an
approximate square (the default shape) or the last shape you

. selected in the Polygon Sides dialog box.
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4. Click the shape that corresponds to the polygon you want
to draw:

Click a shape to indicate how many sides you
want the polygon to have. (The shape you
select will remain in effect until you change it
by selecting a different shape.) After you click
a shape, this dialog box disappears.

A hox appuars around

.Ci‘; I:' Q O@ O the selected \h.‘l]}r

Figure 6-25 Choosing the number of sides for a polygon

5. Drag diagonally to draw the polygon.

The polygon 1s
drawn from the

center .. outward,

Figure 6-26  Drawing a regular polygon

To move the polygon around on the card while you're drawing
it, press  before you release the mouse button. This allows you
to drag the shape anywhere on the card. You can release the
key to continue creating the polygon, then press the _ key
again to move the shape. Once you've released the mouse
button, you need to select the shape before you can move it
(“Selecting a Graphic,” earlier in this chapter, explains how.)

To rotate the polygon while you’re drawing it, drag with a
circular motion. If you press Shift while you drag with a circular
motion, the polygon rotates only in 15° increments, which
makes it easier to position at exactly the angle you want.
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To draw a shape in outline—so that only its outline appears on the
screen while you're drawing it—first turn on the Draw Outlined
option by choosing it from the Options menu. When Draw
Outlined is turned on, a check mark appears next to it in the menu.
This option allows you to draw a shape more quickly and smoothly.
The entire shape appears after you release the mouse button.

I}I';l\\'iﬂg d ]‘L‘}iLI!:il' e J|\ut N To draw a regular polygon (one that is the same number of pixels
wide as it is high), follow these steps:

l. Go to the card or background where you want the polygon.

[f you're not sure whether to put it in the card layer or the
@ background layer, see “Adding Graphics to a Card or
Background” at the beginning of this chapter.

2. Choose the Regular Polygon tool (©) from the Tools menu.
The pointer changes to a crosshair (+).

3. If you want to select the number of sides for your polygon,
choose Polygon Sides from the Options menu.

Or double-click the Regular Polygon tool on the Tools paletre.
The Polygon Sides dialog box appears.

This step and the next step are optional. If you don't select the
number of sides before you draw the polygon, it will be either an
approximate square (the default shape) or the last shape you

. selected in the Polygon Sides dialog box.

Chapter 0: Working With Graphics 283




4. Click the shape that corresponds to the polygon you want

o dl’ﬂ“-"!

Click a shape to indicate how many sides you
want the polygon to have. (The shape you
select will remain in effect until you change it
by selecting a different shape.) After you click
a shape, this dialog box disappears.

A box appears around

A OO O IQ O the selected shape

Figure 6-25 Choosing the number of sides for a polygon

5. Drag diagcn:ﬂly to draw the polygnn.

[he polygon 15
drawn from the

center outward

Figure 6-26  Drawing a regular polygon

To move the polygon around on the card while you're drawing

it, press  before you release the mouse button. This allows you

to drag the shape anywhere on the card. You can release the .
key to continue creating the polygon, then press the _ key

again to move the shape. Once you've released the mouse

button, you need to select the shape before you can move it.

(“Selecting a Graphic,” eatlier in this chapter, explains how.)

To rotate the polygon while you're drawing it, drag with a
circular motion. If you press Shift while you drag with a circular
motion, the pnl}'gun rotates nnl}.f in 15° increments, which

makes it easier to position at cx;la;ll}f the allgic you want.
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With the Regular Polygon tool, the shape is always drawn from the
center outward, whether or not Draw Centered is checked in the
Opuons menu.

Drawing an  To draw a polygon whose sides arer't necessarily the same length,
irregular polygon  follow these steps:

1. Go to the card or background where you want the polygon.

[t you're not sure whether to put it in the card layer or the
background layer, see “Adding Graphics to a Card or
Background” at the beginning of this chaprer
2. Choose the Polygon tool () from the Tools menu.
. The pointer changes to a crosshair (+).
3. Click at the point where you want to begin the first side of the
polygon.

"The Polygon tool works differently from the other tools
don’t hold down the mouse button to draw.

you

4. Without holding down the mouse button, move the crosshair
pointer to draw one side of the polygon.

You can draw the side of the polygon at a 15 angle from
horizontal, or at an angle that’s a multiple of 15°, by pressing
the Shift key while you move the mouse. To change the angle
of the side while you're drawing it, change the direction of the

. mouse as you drag,
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5. When the side of the polygon is the length you want it, click to

fix it in place.
6. Repeat steps 4 and 5 for each additional side of the polygon.
7. To finish the shape, click on the starting point.

Alternatively, you can double-click or press . -Z at any point to
stop drawing, whether or not the shape is complere. (Pressing
-Z. also deletes the line that was drawn since you last clicked.)

8. Diraw this sicde
by moving the
pointer without

0. Click here 1o holding down the 6. Draw this side by
' Click | finish the shape mouse button, 7 Click here.  moving the ;mintu!.
| I TCT ¥ .
\ without holding

10 sLart the | .
down the mouse

button.

shape.

2. Diraw this side by __ 5. Click here
moving the pointer

without holding

down the mouse
button |

j, Click here. i, Draw this side by
maoving the pointer
without holding down
the mouse button

Figure 6-27 Drawing an irregular polygon
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l rawing with the Pencil — You can use the Pencil to create free-form lines and shapes and
touch up graphics.

To draw with the Pencil, just choose it from the Tools menu and
drag where you want to draw. The Pencil draws in the color
currently selected in the Patterns palerte, unless you begin to drag
from a place that is the same color as the color you are drawing

with. In this case, the Pencil draws in white:

IFyou start dragging  If you start dragging on

o color that's the  white (or on anty color

SAMIE ds 'iu- colar other than the one YOu re
Irwing drawing with), the Pencil
the Pencil drws in the currently
ws i whil selected color

Figure 6-28 Drawing in the selected color and draw ing in white

The Pencil also draws in white if you are drawing while a pattern is
selected in the Patterns palette and you begin to drag from a place
thar is filled with any pattern.,

1o draw a straight horizontal or vertical line with the Pencil, press
the Shift key while you drng,
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Drawing with
patterns, colors, and
different line widths

Drawing a shape
filled with a pattern
or color

288

This section explains how to create lines and shapes that have
patterns and colors, and lines and shape borders in varying line
widths.

0

S _

=P 7

‘ a | (-] | - | You can use these tools (o draw
| O |0 O |02 shapes and lines with patterns,
A .;:_”) = .:::. (Z colors, and different line widths

Figure 6-29  The tools for drawing with patterns, colors, and different line widths

When you know before creating a shape that you'll want it filled
with a pattern or color, you can fill the shape automatically as you
draw it. Follow these steps:

1. Choose the pattern or color you want the shape to have from
the Patterns menu.

Or click it on the Patterns palette.
2. Choose Draw Filled from the Options menu to turn it on.

When Draw Filled is turned on, a check mark appears next to it
in the menu. (Choosing Draw Filled again turns it off.) .

%+ A shortcut: You can also turn Draw Filled on or off by
double-clicking any of the shape tools on the Tools palette
(exceprt the Regular Polygon tool).
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The Tools menu looks different when Draw Filled is turned on-

%
—
FE
L=]
o
l
|

—
= & 2
o & &P 7
"PE el T = — A pattern appears
II'\Iklr.' ’.flt' shape u IiJi‘i
=) Hl@[es] " |
2 A ||
Ihe Tools menu The Tools menu
when Draw Filled when Draw Filled
is turned oft is turned on

Figure 6-30  The Tools menu with Draw Filled turned off and turned on

3. Draw the shape.

Choose the tool for the shape you want to draw from the Tools
menu, then drag to draw the shape. (See “Drawing Lines and
Shapes,” earlier in this chapter, if you want more detailed
instructions.)

When you finish drawing the shape, it automatically fills with
the selected pattern.

* Draw Filled with the Curve tool and Polygon tool- If Draw Filled
® is turned on while you're using the Curve tool or the Polygon
tool, HyperCard draws a straigh line connecting your starting
and ending points when you finish drawing; then it fills the
shape with the selected pattern.
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— HyperCard draws

this line.
Using the Curve Using the Curve
ool with Draw tool with Draw
Filled trned off Filled wrned on

Figure 6-31  Creating a filled, curved shape

HyperCard draws

this line
[sing the Polygon  Using the Polygon
tool with Draw tool with Draw .
Filled twrned off Filled turned on

Figure 6-32  Creating an enclosed, Hilled polygon

+  Filled shapes without borders: To draw a filled, borderless shape,
turn on Draw Filled, then hold down the Option key while you

draw the shape.

Drawing with  Before you draw a line or shape, you can select the thickness of the
different line widths  line or the shape’s border (unless you're using the Pencil, which
draws in only one thickness). Follow these steps:
1. Choose Line Size from the Options menu. @

Or double-click the Line tool on the Tools palette. The Line Size

dialog box appears.
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2. To select a line thickness, click it:

width you want. After vou click a line
width, this dialog box disappears

[Jrrrnenm

A box appears around
the selected line width,

’ Click the line that represents the line

Figure 6-33  Line widths

3. Draw the line or shape.

Choose the tool for the line or shape from the Tools menu, then
] drag to draw the shape. (See “Drawing Lines and Shapes,” earlier

in this chapter, if you want more detailed instructions.)

+ A shortcut for selecting line widths: When the Power Keys o ption
is turned on (and the Message box is hidden), you can type a
number from 1 to 8 to select a line width while any Paint tool is
selected. (“Using Power Keys,” later in this chapter, explains the
Power Keys option.) 4

1 2 3 4dor56or7  B_ Powerkeys
[ I | I I I Note: These power keys don't work when

the Line Size dialog box is open

Figure 6-34 The power keys for choosing line widths
8 | ) g

Drawing borders with o draw a shape with a patterned or colored border, follow these
p P
patterns and colors ~ steps:
I. Choose the pattern or color you want from the Patterns menu.

Or click it on the Parterns palette,
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2. Choose the tool for the shape you want to draw.
Any of the shape tools will work.
3. Press and hold the Option key while you draw the shape.

See “Drawing Lines and Shapes,” earlier in this chaprer, if you
want more detailed instructions.

Figure 6-35  Shape borders with patterns and colors

& Filled shapes without borders: 1f the Draw Filled option is turned
on and you press the Option key while you draw a shape, you
create a filled, borderless shape.

Moving a gra )hi(: You can place a eraphic wherever you like on a card or background.
] grap y o
around on a card To reposition a graphic on a card or background, follow these steps:

or ])rlcl{UI*()Lln(j 1. Goto the C.al'd or background t}la‘t has the grapl’uc you want
Jc 5

[0 move. .

Pressing ' -B rakes you to the backgrmmd layer. (When you re
in the background layer, the word Background appears in the
menu bar.) If you press  -B repeatedly, you move back and
forth between the card layer and the background layer.

2. Select the graphic.
“Selecting a Graphic,” earlier in this chapter, gives instructions.

3. Position the pointer over the selected graphic so that it changes
to the arrow pointer.

Chapter 6: Working With Graphics




4. Drag the selected graphic.

Lo move the graphic straight horizontally or vertically, press and

hold Shift while you drag.

+ Cant drag the graphic? 1f you think you've selected a graphic
but you can't drag it, you might be trying to move a
background graphic from the card layer. Press ("-B and
try again. If you still can’t drag it, it’s either a button or a
field. (Chapters 4 and 5 explain how to move buttons

and fields.) «

2\ Important: After you reposition a background graphic, it’s a good
& idea to look through the cards on which the graphic appears, to see
L= L=
how the cards look. 2

Cl‘(’leting Sp(‘fdlll You can use the Paint tools in combination with one or more of
grﬂphiC eﬂ:e(:[‘; the commands in the Options menu to create a variety of special

effects. This section shows examples of the effects you can create.

|)]‘;I\‘\']'ﬂ}_{ In ]ﬂll“ip]u\ You can draw multiple lines or shapes using the Draw Multiple
option in the Options menu.

o

25 £ —

I=10=4Vd 7

] (o] [ IO | Draw Multiple
&5' O |02 (&) works with
A E-—::I E ™ these wols

Figure 6-36  The tools you can use with the Draw Multiple option
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and Draw Centered “E" (

1o draw multiple lines or shapes in a single stroke, follow
these steps:

1. Choose Draw Multiple from the Options menu to turn it on.

When Draw Multiple is turned on, a check mark appears next
to it in the Options menu. (Choosing Draw Multiple again
turns it off.)

b

Draw a line or shape.

Choose the tool for the line or shape you want from the Tools
menu, then drag to draw the shape. (See “Drawing Lines and
Shapes,” earlier in this chapter, if you want more detailed
instructions.)

Rounded Rewulur
Line tool Rectangle ool Rectanele tool — Oval toaol Polyeon 1oo]

Draw Multiple
turned off

Draw Multiple % | ”I
turned on [e—

Draw Multiple

trned on

Figure 6-37 Drawing shapes with and without Draw Multiple
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To control the spacing between the multiple images, press the
Option key in combination with a number from 1 to 9 before you

drag. The higher the number you type, the farther apart the images

will be.
Option-3 Option-5 Option-7 Option-9
=) LT =TT [

Figure 6-38  Varying the spacing between images for the Draw Multiple option

b [f the Power Keys option is turned on (and the Message box is
hidden), you can press M to turn Draw Multiple on or off. (The
Power Keys option is explained in “Using Power Keys,” later in
this chapter.)

Aligning graphics ~ You can use HyperCard’s Grid option to help you line up graphic
elements and position them more precisely. To turn on the Grid
option, choose it from the Options menu. (When Grid is turned
on, a check mark appears next to it in the menu. Choosing Grid
again turns it off.)

When Grid is turned on, the movement of the pointer is
constrained to an invisible grid whose lines are 8 pixels apart

. (just under one-quarter of an inch). As you draw graphics with the
Line tool and shape tools, or drag graphics to move them around,
they’ll be aligned to this invisible grid. The grid also constrains
the movement of the Selection tool as you select graphics and the
movement of the I-beam as you try to position the insertion point
to type Paint text.
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The Grid option is most helpful for aligning graphics that were
created with the Grid option turned on. If you create graphics with
Grid turned off and then turn Grid on, HyperCard will have a
difficult time aligning the graphics because their sizes and positions
won't conform to the grid’s intervals.

=1__ If the grid were visible,

u it would look like this.
— The graphics you

create while the Grid
- L ite

option is turned on are
——I aligned to the grid

[T 111 [ 11

Figure 6-39  Aligning graphics with the grid

E —

] o led

= P P d

H-@ Il Ol | The Grid option
works with these

5O - tools.

AlD|E AlO|E

Figure 6-40 The tools affected by the Grid option

You can use Grid in combination with other options in the Options
menu to create a variety of effects, as shown in the next section,
“Combining Options for Unique Effects.”

If the Power Keys option is turned on (and the Message box is
hidden), you can press G to turn Grid on or off. (*Using Power
Keys,” later in this chapter, explains the Power Keys opuon.)
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(ﬁ,ﬂll1|‘ri111‘ﬂg options  You can create some interesting visual images when several options
for unique effects  in the Options menu are turned on at the same time. And you can
add to the variety by holding down various modifier keys while you
draw with different options turned on. Experiment with different
combinations to see what happens.

-—'_h-\\' _-"—_H-‘-
— — .
_'_’__;-f'
Regular Polygon Oval tool, Shift key ~ Oval tool, Grid turned
. tool, Draw Filled pressed, Grid turned  on, Draw Centered
turned on, Draw on, Draw Centered  turned on, Draw
Multiple turned on - trned on, Draw Multiple turned on

Multiple turned on

Line wol, Shilt key  Rectangle tool, Grid  Line tool, Grid

pressed, Draw turned on, Draw turned on, Draw

Multiple turned on Centered turned on,  Multiple rned on
Draw Multiple

. turned on

Figure 6-41  Special effects

Chapter 6: Working With Graphics 297




Adding Paint teXt Painc text is text you create with the Paint Text tool. It looks like
the text you type in fields, but you use the Paint tools to create,
move, copy, and change Paint text, just as you would with any

other graphic.

Paint text is especially useful when you need ro include text as part
of a picture—for example, as a picture title or labels—or whenever

you want text to behave more like a picture than text. You can select
both a picture and Paint text at once with the same tool and use the
same commands on them. And you can create special effects with
Paint text by using commands in the Paint menu (for example,
Invert or Trace Edges). To add Paint text to a card or background,
follow these steps:

1. Go to the card or background where you want the Paint text..

If you're not sure whether to put it in the card layer or the
background layer, see “Adding Graphics to a Card or
Background” at the beginning of this chaprer.

2. Choose the Paint Text tool (A) from the Tools menu.
The pointer changes to an I-beam (I).

3. To select a font and style for the text, choose Text Style from
the Edit menu, or press -T.

Or double-click the Paint Text tool in the Tools palette. You see
the Text Style dialog box.

The preset format for Paint text is 8-point plain Shaston with @
line height of 9 points.
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4. Choose from the options in the Text Style dialog box:

Click o select the  Click to select 4 font size

font you want (medsured in points)
Click to select or deselect one or To use a font size not
) R T s — Style: — . . . ; .
more text styles. (Select nothing for [JBold Courier i1 B listed, type it here. Then, if
plain text.) The sample text at the | C Italic 5?'1‘“', 16 you want to adjust the
bottom of the dialog box shows Cltnduriing | ey height to the new type size,
the effect of the selected styles. [ outline Tiaes = press Enter. (If you don't
| L1 Shadow Venice 0 s press Enter, the line height
Jrac 2] 3 % ” E A . Al remiar & c =
Press and hold the mouse [Alignieft | Line Height: [T < ] Font Size: = will remain the same).
button here to see a pop-up e S .. (NN o
menu for choosing the The quick brown fox jumps over the lazy|dog. This -“h‘_"“' 5 W |1fc” vour
alignment of Paim text text will ook like

This number determines the space
. between lines. HyperCard sets this number

automatically when you click one of the

standard font sizes, but you can change it.

Figure 6-42  Selecting a font, style, and size for Paint text

The choices you make in this dialog box stay in effect for the
Paint Text tool until you change them, or until you restart
HyperCard. (The preset format is restored when you restart
HyperCard.)

N

Click where you want to position the insertion point and begin
typing.
. While you're typing, you can press Delete to delete one character

to the left of the insertion point. And you can press Return to
start a new line of text.
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As long as the insertion point is still blinking, you can change
the font, style, and size of the text you’re typing by choosing
Text Style from the Edit menu and changing the settings in the
Text Style dialog box. All the text you've typed since you last
clicked (or since you last pressed Enter) is changed to the new
font, style, and size.

Similarly, you can change the pattern or color of the text you're
typing by choosing a different one from the Patterns menu. All
the text you've typed since you last clicked or pressed Enter is
changed to the new pattern or color.

As soon as you click anywhere, choose another tool, choose Keep
from the Paint menu, switch into or out of the background, or
move to another card, the text becomes part of the picture—its
attributes become fixed. To change the text or its attributes, you
have to erase it and start again.

+  Quick text pickup tip: To select Paint text you've just finished
typing, press . -S immediately, before you click anywhere. <

\ Important: You can't use the Find command to search for Paint
text. To HyperCard, Paint text is just another graphic. If you think
that you'll want to search later for what you’re typing now, create a
field and enter the text in the field using the Browse tool. (See
Chapter 5 for instructions on entering field text.) &

FI‘LLI'[HI‘J:J field text You can turn existing field text into Paint text, if you decide thar .
into Paint text you'd like to make it part of a picture. Follow these steps:

1. Choose the Browse tool from the Tools menu.

The pointer becomes an I-beam (1) when you move it over the
field. (If you don't see the [-beam, consult “Where’s the I-beam
Pointer” in Chapter 5.)
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Drag (with the I-beam) to select the field text you want
to change.

3. Choose Copy Text from the Edit menu, or press (-C.

Or, if want to remove the text from the field, choose Cut Text
from the Edit menu, or press (-X.

4. Choose any Paint tool from the Tools menu.
5. Go to the card or background where you want the text.

If you're not sure whether to put it in the card layer or the
background layer, see “Adding Graphics to a Card or
Background™ at the beginning of this chapter.

6. Choose Paste Text from the Edit menu, or press -V.

The copied text appears in the center of the card, surrounded by
a moving dashed line:

To move the selected You can change the shape of the selection |

text, drag any part of it, by pressing the ” key and dragging from
a corner. (The text wraps at the right
horder of the selection.)

Figure 6-43 Turning field text into Paint text

While the text is still selected, you can format it by choosing Text
Style from the Edit menu (or pressing ' "-T) and changing the
sectings in the Text Style dialog box. The text becomes part of the
picture after you click outside the selected area.
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When elements
overlap

HyperCard puts different kinds of elements in different layers, as
shown in the following figure. Together, all these layers make up the

L';Il'd you scc.

Background picture
Background
huttons and fields

"
-
7]

5

- 1)

-

®

..
o
>

Card picture

P P -

Card buttons
and fields

memassrEgprRRE
—-_——

Whatt you see

L] +.r" e
' .—jl when you look
: I at the card
The background picture ;

is fixed in a layer by
itself—it's always
behind the hackground

buttons and fields and _ et I O
| The card picture is also ;ﬁ: ﬂ/

all the card elements.

smsas mEE

fixed in a layer by I: ’
itself—it's always

behind the card buttons
and fields, and in front

of the background
buttons and fields.

Figure 6-44  HyperCard's layers
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Making a graphic opaque
or ll'ilﬂ."if'}lll'L‘I]I

As shown in Figure 6-44, the graphics in the card layer (referred to
collectively as the card picture) are behind all the buttons and fields
in the card layer, but they're in front of all the elements in the
background layer. This means graphics in the card layer can obscure
the background elements, but they can be obscured by the buttons
and fields in the card layer.

Graphics can also obscure one another. Graphics in the background
layer (referred to collectively as the background picture) can get lost
behind graphics in the card layer, and a graphic that you've created
recently can cover graphics that were drawn earlier in the same layer.

When clements overlap so that some graphics obscure, or are
obscured by, other elements, you can either rearrange the elements
so they don't overlap, or you can make some of the elements
transparent so you can see other elements through them. “Moving a
Graphic Around on a Card or Background,” earlier in this chaprer,
explains how to reposition graphics on the card or background. The
next section explains how to make graphics opaque or transparent.
(Chapters 4 and 5 give instructions for rearranging buttons and
fields and making them opaque or transparent.)

When you want to be able to see elements that are obscured by a
graphic, you can make the graphic transparent. Conversely, when
you want to make a graphic more prominent, you can make it
opaque.

Follow these steps to make a graphic opaque or transparent:
I. Select the graphic.

“Selecting a Graphic,” earlier in this chapter, gives instructions.
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2. Choose Transparent from the Paint menu to make any blank
space or white paint within the graphic transparent.

Or choose Opaque from the Paint menu to make the entire
graphic opaque.

\ araphic made opague and
clement moved over a colon
Figure 6-45 Making a graphic opaque &

A graphic ... made transparent
element . . and moved over a color

Figure 6-46  Making a graphic transparent

s+ Making the entire graphic transparent: 1f you want to make the
entire graphic transparent—including blank space, white paintgy
and colors—hold down the Option key while you choose
Transparent from the Paint menu. (Note that placing a
transparent color over another color sometimes leads to
unexpected results, such as black.) +
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Changing
the appearance
of a graphic

Magnifying a graphic
for editing

When you first create or paste a graphic, it’s opaque—that is, it
covers the graphics beneath it. You can make the new graphic
transparent by choosing Transparent immediately after you create it
(before you click anywhere)—or, if you've pasted it, by choosing
Transparent while it’s still selected. Transparent will affect just the
graphic you've created since the last time you pressed the mouse
button if nothing else is selected.

If the Power Keys option is turned on, you can also press O to make
the selected graphic opaque, or T to make it transparent. (“Using
Power Keys,” later in this chapter, explains the Power Keys option.)

To identify which areas on a card or background are opaque and
which are transparent, hold down the Option key and press O. The
opaque areas will appear white and the transparent areas black until
you release the keys.

HyperCard includes many commands and options for changing the
look of an existing graphic—including commands that let you edit
a picture pixel by pixel and commands for flipping a graphic upside
down or backward. This section describes all the ways you can
modify graphics and Paint text.

» Seealso: " Using Power Keys” in this chaprer
* “Using Modifier Keys With Paint Tools” in this chapter
* “Double-Clicking Paint Tools, Patterns, and Colors” in this
chapter

You can zoom in on a section of a picture to do close-in finish
work and edit your picture one dot (two pixels) at a time. Follow

||IE.'.\'L' .\[L'[‘!NI

L. If you want to work on a particular part of the picture, select
that part of the picture.

".‘iclucling a Graphic,” earlier in this chaprer, gives instructions.
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2. Choose FatBits from the Options menu.

Or double-click the Pencil on the Tools palette. (Or press
Option-F)

Alternatively, you can zoom in on a particular part of the picture
by choosing the Pencil and pressing the ~ key while you click
on the part of the graphic you want to edit.

HyperCard zooms in on the part of the graphic you've selected
(or i-clicked with the Pencil) and magnifies it. (If nothing is

selected and you haven’t (“~clicked anything with the Pencil,
HyperCard zooms in on the graphic you were just working with,
or on the center of the card, if you weren't working on any
graphics.)

3. Edit the graphic.

You can close this window by clicking its

s . S, OU can move
close box. (This doesn't turn off FatBits.) You can m

this window by
dragging from
here.

N_ This window
displays an actual-
size version of the
graphic. As you
make changes (0
the magnified
graphic, this shows
you how the
graphic will

— actually look

When the Pencil is [ ——
selected, you can =....--=...
add or remove a
single pixel ata
tme just by
clicking

Figure 6-47  Editing a graphic with FatBits turned on

You can use any of the Paint tools to modify the graphic—they
all work at the magnified scale.
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[0 see d different
section ol the cird,
press Option while

you drag the card
with the hand
pointer.

1o see individual pixels, hold down the Caps Lock key. When
the Caps Lock key is up, you see colors more accurately; when
it’s down, you sce details more accurately and you can read Paint
text, which otherwise is not legible when FatBits is turned on.

[f you want to edit a different part of the picture, press Option
and drag the magnified graphic with the hand pointer (£7):

L As you drag the

card with the

hand pointer,

this window shows
you the actual-size
version of the part
of the card you're
lo iking at.

Figure 6-48 Moving to a different section of the magnified picture

4. When you’re finished editing the graphic, turn off FatBits by
choosing it again from the Options menu.

You can also turn off FatBits by doing any of the following;

Click in the litctle window chat shows the actual-size version
of the graphic.

Double-click the Pencil on the Tools palette.
Press Option-E
With the Pencil selected, ' -click on the magnified picture.

Choose the Browse tool (%), the Button tool (=), or the
Field tool (£7) from the Tools menu.
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(_-‘,h;l['l‘*_{i[]ft.’, the size  To resize a graphic, follow these steps:
of a graphic :

sl 1. Select the graphic.
“Selecting a Graphic,” earlier in this chapter, gives instructions.

2. Press the ' ' key while you drag from a corner or an edge of the
selected gmphic to resize it:

PR i ; i .
' / / ! /
- ' : [ : /
1 [ /
" ' / g k
' ' ! f il
W 1 ) i " /
v l ' ’ i L] /
] ] / / 1 ]
i [ / i 1 /
o : : . i ‘ ‘ - O O O O W W .
The original : : i .
i
‘LJ]".l]}J]lC oo o k. § i
) l /
! f
2 2 lommafpm o
[0 resize it
[m}]}ul'hun;l[t'h.
press ' -Shift and To make it wider, narrower, taller, or
drag from a corner shorter, press ~ and drag from an edge.

Figure 6-49 Resizing a graphic

& Can’t drag the graphic? 1f you think you've selected a graphic
but you can't drag it, you might be trying to resize a
background graphic from the card layer. Press ."-B and try
again. If you still can't drag it, it’s either a button or a field.
(Chapters 4 and 5 explain how to move buttons and fields. ©
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Changing the pattern or

color of a graphic

There are three ways to a.'h;ulgc the pattern or color of a gl';lphic:

s Use the Fill command to fill the gralphic with a different pattern
or color.

= Use the Bucket to “pour” a different pattern or color into the
graphic.

s Use the Pickup command to give the graphic the same parterns

and colors as another graphic on the card.

Using the Fill command to change a graphic’s pattern or color

Using the Fill command is the most reliable way to change the
pattern or color of an entire graphic. Follow these steps:

1. Select the graphic.
“Selecting a Graphic,” earlier in this chapter, gives instructions.
2. Choose the pattern or color you want from the Patterns menu.
Or click it on the Patterns palette.
3. Choose Fill from the Paint menu.

The selected graphic acquires the selected pattern or color.

o) W &

\ Al -

1E T —

' = =

3

=

e

! £

g | —
The original 1. Select the 2. Choose a pattern 3. Choose Fill from
graphic graphic. or color. the Paint menu.

Figure 6-50  Assigning a new pattern or color to a graphic
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[f you've just created a graphic element and you haven't clicked
anywhere, the Fill command works on the new element (that is, just
the element you've created since you last pressed the mouse button)
if you haven't selected anything else.

If the Power Keys option is turned on, you can press F instead of
choosing Fill. ("Using Power Keys,” later in this chapter, explains

the Power Keys option.)

Using the Bucket to change a graphic’s pattern or color

You can use the Bucket to change the pattern or color of a graphic.
However, this technique works best when you want to fill a solid
area of color with another color or a pattern. If you try to use this
technique rto fill a patterned area with another pattern or a color, Ll"
results will be unpredictable; the pattern might change in different
ways than you expect, or you may be able to change only a few

pixels at a time,

Important: Use the Bucket to change a graphic’s pattern or

al - » ® - 3
color only it the graphic is a solid color or completely enclosed.
Otherwise, paint might spill out and fill the surrounding area. &

To change a graphic’s pattern or color with the Bucker, follow these
steps:

1. Go to the card or background that contains the graphic. &

Pressing ( I-B takes you to the background layer. (When you're
in the background layer, the word Background appears in the
menu bar.) If you press ' “-B repeatedly, you move back and

I"t)TT}] IlCI’\'\-"{_’L‘[] rl‘IL' Ca I'(i IL]:L'L']_ .']11(! rllﬂ_" |1;1L'l{gr{}unt‘] 1'.1_\"(.1‘.
2. Choose the pattern or color you want from the Patterns menu.

Or click it on the Patterns palette.
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3. Choose the Bucket (&) from the Tools menu.

Or click it on the Tools p:ll(_'[[l'_‘. The pointer ch:mgcg to the

Bucket.

t. Move the Bucket so that the tp of the stream pouring from it
is within the graphic, then click:
H!

[T

l l lt; il
i

If paint spills out into the surrounding area, immediately choose
Undo from the Edit menu, or press C3-Z, Tilde, Esc, or Delete.

This is the part of the __2/"

Buckert that dispenses paint

Wil
1 74

Figure 6-51 Positioning the Bucket to fill a graphic

Using the Pickup command to change a graphic’s pattern or color

To give a graphic the same patterns and colors as another graphic on

the card, follow these steps:
L. Select the graphic.
“Sclecting a Graphic,” carlier in this chapter, gives instructions.

2. Drag the selected graphic to the part of the card that has the
pattern or color you want to give the graphic.

See Figure 6-52.

Chapter 6: Working With Graphics




3. While the graphic is still selected, choose Pickup from the
Paint menu.

"The selected graphic picks up the image of whatever Paint image
is behind it in the same layer, including any areas that are blank,
with no paint.

Leave the graphic selected. Don click outside the selection.

4. Drag the selected graphic away.

I Select the graphic 2. Move the selected 3. Choose Pickup 4, Drag the graphic
Gits edges will graphic over the from the Paint AWILY.
shimmer). pattern you want menu,

to give it.

r|||||||||| ||||l|

Figure 6-52  Using the Pickup command to change a graphic’s pattern

<« Ifit doesn't work: 1f you've selected a graphic in the card layer &
and it doesn't acquire the pattern that’s behind it when you
choose Pickup (or if it disappears), the pattern is probably in the
background layer. A graphic can only pick up a pattern that’s in
the same layer. If there’s no pattern behind the graphic in the
same layer, the graphic turns white,
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[f the Power Keys option is turned on, you can press I’ instead of
choosing Pickup. (“Using Power Keys,” later in this chapter,
explains the Power Keys option.)

|

[nverting a graphic  To reverse the colors of a graphic so that they become the inverse
video of the original colors—that is, so that black becomes white,
white becomes black, red becomes green, green becomes red, and
so on—follow these steps:

l. Select the graphic.

"Sclccting a Graphic,” earlier in this chapter, gives INstructions.

. 2. Choose Invert from the Paint menu.

!.'"."'.‘".'"."'."'."i.'".'".:".:".:"."C".'"."L"i:ﬂ !
i i "
o [ ol
.I l. -*
o i "
o i %I
=] I ol
Il ll II

;|II'.II'.!!'.lI'.II'-II'.II'.I!'.H'.lﬂlﬂlﬂlﬁrﬂ:l’.ll’.lllil | i

I. Select the graphic 2. Choose Invert from the Paint menu

Figure 6-53  Invering uraphic

[f you've just created a graphic element and you haven't clicked

. anywhere, the Invert command works on the new element (that is,
just the element you've created since you last pressed the mouse
button) if you haven't selected anything else.

[f the Power Keys option is turned on, you can press I instead of
choosing Invert. (“Using Power Keys,” later in this chapter explains

the Power Keys option.)
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ULll!iI]iI]g d gl‘:l!‘ll 1C 1o outline a graphic, follow these steps:
1. Select the graphic.
“Selecting a Graphic,” earlier in this chaprer, gives instructions.
2. Choose Trace Edges from the Paint menu.

An outline appears around the parts of the selected graphic that
were originally a solid color. Each time you choose Trace Edges,
another outline is added.

% Note: If the graphic is mostly a solid color, the solid areas
turn white except for their edges. Each subsequent time
you choose Trace Edges, an outline is added around each

solid edge. .
The original Trace Edges Trace Edges Trace Edges
graphic once twice three times

Figure 6-54 Repeated use of the Trace Edges command

If you've just created a graphic element and you haven't clicked
anywhere, the Trace Edges command works on the new element
(that is, just the element you've created since you last pressed the
mouse button) if you haven't selected anything else.

[f the Power Keys option is turned on, you can press E instead of
choosing Trace Edges. Pressing and holding E keeps adding
outlines. (“Using Power Keys,” later in this chapter, explains the
Power Keys option.)

314 Chapter 6: Working With Graphics




Rotating 4 gl’;ipili&;‘ 90°  To rotate a graphic 90° follow these steps:
1. Select the graphic.
“Selecting a Graphic,” earlier in this chapter, gives instructions.

2. Choose Rotate Left from the Paint menu to rotate the selected
graphic 90° to the left, or choose Rotate Right to rotate it 90°
to the righl.

i)

I Feppadtt | Iunmmnn: Zzzis = 1 B
|

i I

Figure 6-56  Rotating a graphic 1o the right 90°
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Flipping a graphic
vertically or horizontally

IFyou've just created a graphic clement and you haven't clicked
anywhere, the Rotate Left and Rotate Right commands work on the
new element (that is, just the element you've created since you last
pressed the mouse button) if you haven't selected anything else.

[f the Power Keys option is turned on, you can press [ (the left

bracket key) instead of choosing Rotate Left, or ] (the right bracket
key) instead of choosing Rotate Right. If you press and hold one of
these power keys, the graphic keeps rotating. (“Using Power Keys,”

later in this chapter, explains the Power Keys option.)

To flip a graphic vertically or horizontally, follow these steps:

1. Select the graphic. I
“Selecting a Graphic,” earlier in this chapter, gives instructions.

2. Choose Flip Vertical from the Paint menu to flip the selected
graphic vertically, or choose Flip Horizontal to flip it
horizontally.
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Figure 6-57  Flipping a graphic vertically

Figure 6-58 Flipping a graphic horizontally

[f you've just created a graphic element and you haven't clicked
anywhere, the Flip Vertical and Flip Horizontal commands work on
the new element (that is, just the element you've created since you

last pressed the mouse button) if you haven't selected anything else.

[f the Power Keys option is turned on, you can type V instead of
choosing Flip Vertical, or type H instead of choosing Flip
Horizoneal. If you press and hold one of these power keys, the
graphic keeps flipping. (“Using Power Keys,” later in this chapter,

explains the Power Keys option.)
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\Y/(’)I‘kmg with If your computer has close to the minimum amount of memory
Jqint l()()]-"‘; \\-'hL’n you need to run |‘_‘|_\.f|'r::|‘( ard, you may find that | |ypcr(._;1l'd‘lx‘ ‘
| Paint tools sometimes behave differendy than you expect. (If you're
1YY 7 \ T .. 3 2 :
MEMOIY 1S IOW 1ot sure how much memory is installed in your computer, see
“Checking Your Computer’s Memory” in Chapter 1.) This is most
likely to happen if your computer is part of an AppleShare network.
When you're using any of the Paint tools, the following symptoms
indicate that HyperCard is running out of memory:

= Fields and buttons in the card layer disappear when you're using
the Paint tools in the card layer.

» Fields and buttons in the background layer disappear when
you're using the Paint tools in the background layer.

= You can't choose Undo from the Edit menu to undo any a{:ricm,
that involve selecting a graphic first, such as filling, rotating, or
moving it. (Undo still works for other actions, such as drawing a
line or shape.)

s When you add or alter paint on a card or background and then
choose Keep from the Paint menu, switch to a different layer, go
to another card or background, or choose one of the General
tools, the changes you made disappear and the message “Failed
to save new picture” appears.

HyperCard’s use of memory depends on many factors, including

the number of desk accessories you have installed in your system,

the network software you're using, and the complexity of the card

or stack you're currently working with. The symptoms listed abovdff))
may not occur consistently, since the total amount of memory
available for HyperCard’s use can vary from moment to moment.
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Using power keys

"The best way to avoid low-memory conditions and to improve
HyperCard’s speed and general performance is to install additional
RAM in your computer. However, it may help to remove some of
the desk accessories you have installed in your system; avoid using
a RAM disk; and lower the RAM cache to 32K (or, if all else fails,
to 0K).

[f you can't obtain additional memory and you still want to use the
Paint tols, you can usually work around low-memory conditions

by following these guidelines:

s Work slowly and carefully. Remember that you can't choose
Undo to undo individual actions that first involve selecting a

graphic.

= Ifyou need to correct a mistake, use the Revert command.
Choosing Revert from the Paint menu restores the version of the
graphics you had on the current card or background before you
last saved them (by using the Keep command, leaving the card,
or switching to or from the background layer.)

P Seealso: o “HyperCard and Your Computer’s Memory” in Chapter 1
* “Reverting to the Last Version of a Graphic” in this chaprer

The Power Keys option lets you use specific keys on the keyboard to
modify the selected graphic or turn options on and off—pressing a
single key does the work of choosing a menu command.

To turn on the Power Keys option, click the Power Keys check box
on the User Preferences card in the Home stack. (The Power Keys
option is available at the Painting level and higher user levels.) You
can also turn on Power Keys by choosing it from the Options
menu, which is visible whenever a Paint tool is selected.
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When Power Keys is turned on, a check mark appears next o icin

the menu. To turn off Power Keys, choose it again. You'll find

examples of the use of the power keys in earlier sections of this
chapter. All the power keys and their effects are shown in the

following table:

Command

Power key

Menu

Black patern §
Diraw Centered (on/oth) (

Lraw Multiple (on/oft) M
Fill F
!"'l:_i*, Horizontal H
Flip Vertical v
Grridd (on/ofh) ¢
Invert |

Line Size I-
Opaque Q)
Pickup P
Revert It
Rotate Lefi |

Rotate Right |

b T |L'\.| b
Select All A
[race Edge |

[insparent T

White pattern W

Panerns
Options
Qpuons
Pain
Paint
Paint .
[ !Imi ns
%t
Options
Paint
Paint
Paint
Painl
Paint
Paint
Paint
Paint

Paint

Pallerns .

*Press these kevs to choase thinner or thicker line widths

% Note: When you're using the Paint Text too

temporarily disabled. <
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Using modifier keys

When you hold down modifier keys—Command, Shift, or

with Paint [[)Ui“- Oprion—while you drag with different Paint tools, you alter

lool

Selection

].|‘1'1'|

Line
Eraser
Pencil

ih‘a'liil]j_ﬂn‘

Lurve

Brush
RIRIHN
tounded Rectangle
Polygon

Owval

woenlin Polyveon

the eftects of some of the tools, as shown in the following table.

Maodilier key

Shift

Opuon

select tightly

Lasso ] sidjacent
lors of the same
cloar as the e

[N Y |I- n

No ellect

Draw in white
Enter/leave FatBits

Repasition

rectangle
No effect

Erase what you
pamt over

Frase wlnit you

ST OVET

|\'L"!!I psilion

rectangle
No elfect

Reposition oval

Reposition 1 ihyeon

“These elfects occus

mly when

vertically*

Mowve selection horizontally or
vertically®

Diraw at 15" angles

ically

Draw straight horizontally or vertically

Draw an approximate squdre
(equal number of pixels on each side)

No effect

Paint straight horizontally or vertically

|\ (M '.'-'r.llulll‘?.

Spry staigl

Draw an approximate rounded square

(equal number of pixels on each side)

Diraw at 15% angles

Draw an approximate circle
Cegual number of pixels
vertically and horizontally)

Rotate m 13" increments

Select like Lasso
Duplicate selection®

Duplicate selection®

No effect
No effect

No effect

Patterned borde

Patterned horder

No effect

Mo ellect

Patterned horder

Patterned border

Patterned horder

Patterned border
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Double-clicking
aint tools, patterns,
and colors

You can double-click certain Paint tools on the Tools palette (and
patterns on the Patterns palette) as a shortcut for choosing menu
commands. The following table shows the effects of double-clicking

Paint tools and the colors and patterns in the Patterns palette.

Double-click . . .
Any pattern

Any solid color

Brush
Bucker
Curve tool
Eraser

Lasso

Line rool

Owval ool

Paint Text tool

Pencil

Polygon tool

Regular Polygon tool
Rectangle tool

Rounded Rectangle tool

Selection tool
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To do this

Bring up Edit Pattern dialog box
Bring up Colors dialog box for
current card/background

Bring up Brush Shape dialog box
Hide/show Patterns menu

Turn on/oft Draw Filled option
Erase entire picture

Lasso every element on current
card/background

Bring up Line Size dialog box
Turn on/off Draw Filled option
Bring up Text Style dialog box
Turn on/off FatBits

Turn on/oft Draw Filled option
Bring up Polygon Sides dialog box
Turn on/off Draw Filled option
Turn on/oft Draw Filled option

Select entire picture




Saving the graphics
on a card
or background

Reverting to the last
version of a graphic

While you're working on the graphics on a particular card on
background, the changes you make to the graphics are stored in a
temporary location—they 're not automatically saved on your disk,
as are your other changes. (HyperCard assumes that you might
decide to throw away your graphics changes, so it doesn't save
them automatically along with everything else. This gives you the
freedom to experiment with the Paint tools and then get back your
original graphics.)

To save all the ;mphicx on the current card or background, choose

Keep from the Paint menu (or press  -K).

I.J'EL'I'L' are two l]lhk'i' \J\"ll:\"b [O save d” [I]L'_' gl}ll.‘.rl]i(ﬁ on [Il(’.‘ current L_"c“'i.J
or background:

s Switch to or from the background layer by pressing ~-B.
»  Go to another card.

When you leave the card or switch to or from the background
layer, HyperCard saves the graphics on the card or background
you're leaving,

While you're working with graphics, you can get back the last saved
version of the graphics on the current card or background by
choosing Revert from the Paint menu. Choosing Revert restores the
version of the graphics you had on the current card or background
before you last saved them (by using the Keep command, leaving
the card, or switching to or from the background layer, as explained
in the preceding section, “Saving the Graphics on a Card or
Background”).

% Revert is different from Undp: Revert undoes all the changes
you've made to the graphics on the current card or background
since they were last saved, whereas Undo undoes only the most

recent unsaved L‘h;lngu. o
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You can also restore a portion of the last saved version of the picture
on the current card or background by selecting the part you want to
restore and choosing Revert. (“Selecting a Graphic,” earlier in this
chapter, includes instructions for selecting part of a picture.)

The Revert command is most useful when you're creating graphics
in stages. Once you complete a stage and it’s just the way you want
it, you can “freeze” it with the Keep command. Then you can begin
work on the next stage, confident that your last stage 1s saved and
that you can start over from that point, if necessary.

If the Power Keys option is turned on (and the Message box is
hidden), you can press R instead of choosing Revert. (“Using Power
Keys,” earlier in this chapter, explains the Power Keys option.)

A F'. ¥ o > Al L B T s . . .
(,(_)]}}-'ll]g d @I Llphl'L I'his section explains how to duplicate a graphic on the same card
and how to copy a graphic to another card, background, or stack.

Copying a graphic  To make a copy of a graphic on the same card or background,
on the same card  follow these steps:

1. Go to the card or background that has the graphic you want
to duplicate.

Pressing ' (-B takes you to the background layer. (When you're

n th’ l‘]ilf:](gr(_:‘ulld ]H:v't'l—. []:]t' W[]rd Bﬂfl{"g']'"ﬂ”ﬁf{dppt'urs in lhl‘.’
menu bar.) If you press ("‘-B repeatedly, you move back and &
forth between the card layer and the background layer. If you
don't see the graphic you want to copy while you're in the
background layer, the graphic is in the card layer.
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2. Select the graphic.
“Selecting a Graphic,” earlier in this chaprer, gives instructions.

3. Position the pointer over the selected graphic so that it
becomes the arrow pointer.

4. Press and hold the Option key while you drag the selected
graphic.
As you drag, you create an exact duplicace of the graphic. To
move the copy straight horizontally or vertically, press and hold
Shift while you drag,

+  Can’ drag the graphic? 1f you think you've selected a graphic
& but you can't drag it, you might be trying to duplicate a
background graphic from the card layer. Press ~-B and
try again. If you still can't drag it, it’s either a button or a
tield. (Chapters 4 and 5 explain how to move buttons and
fields.) <

Copying a graphic  To copy a graphic to a different card or background, follow
£ o b [ P}r g [ [
to another card or  these steps:

background 1. Go to the card or background that has the graphic you want

o copy.

Pressing "'-B takes you to the background layer. (When you're
in the background layer, the word Background appears in the

& menu bar.) If you press ("-B repeatedly, you move back and
forth between the card layer and the background layer. If you
don't see the graphic you want while you're in the background
layer, the graphic is in the card layer.

[ ]

. Select the graphic.

“Selecting a Graphic,” earlier in this chapter, gives instructions.
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3. Choose Copy Picture from the Edit menu, or press -C.
This puts a copy of the selected graphic on the Clipboard.

4. Go to the card or background where you want to put the
graphic.

Use the arrow keys, the Go palette, or commands in the Go
menu to navigate between cards while the Selection tool or the

|asso is selected.

If you're not sure whether to put the graphic in the card layer
or the background layer, sce “Adding Graphics to a Card or

Background” at the beginning of this chapter.
5. Choose Paste Picture from the Edit menu, or press C'-V. ]

This takes a copy of the graphic that’s on the Clipboard, puts it
on the current card or background, and selects it.

The graphic is pasted in the same position it was copied from. If
there’s a button or field in the same location, the pasted graphic
will be hidden behind it (as explained in “When Elements
Overlap,” earlier in this chapter). You might have to move the
button or field to see the graphic.

6. If you want to reposition the graphic, drag it to where you
want it while it’s still selected.

The graphic becomes opaque after you paste it. If you want to be
able to see through the graphic to the elements behind it, select it &
and choose Transparent from the Paint menu.

Important: The most common mistake in copying a graphic is
putting it in the card layer when you wantitin the background
layer. (To find out whether the graphic is in the background layer,
press . -B to see just the background elements.) If you put a graphic
in the card layer by mistake, see the next section, “Moving a
Graphic from the Card to the Background.” A
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Nl()‘vring d gl‘uphi(‘ It’s easy to put a graphic in the card layer by mistake when you
fre m [h"t‘ card to intend to put it in the background. If this happens, you can move

the graphic from the card layer to the background layer (of the same

the hﬂfkgmlmd card) by following these steps:
I. Go to the card that has the graphic you want to move.

You must be in the card layer to move a card graphic. (If you see
the word Background in the menu bar, you're in the background
layer. Press ("-B to go to the card layer.)

I

. Select the graphic.
“Selecting a Graphic,” earlier in this chaprer, gives instructions.
3. Choose Cut Picture from the Edit menu, or press ~-X.

This removes the graphic from the card and puts it on the

Clipboard.
4. Go to the background layer.

Choose Background from the Edit menu, or press ~-B.
5. Choose Paste Picture from the Edit menu, or press ~-V.

This takes a copy of the graphic that’s on the Clipboard, puts it
in the current background, and selects it.

The graphic is pasted in the same position it was copied from. If
there’s a button or field in the same location on the background
layer, the pasted graphic will be hidden behind it (as explained in
“When Elements Overlap,” earlier in this chaprer). You might
have to move the button or field to see the graphic.

6. If you want to reposition the graphic, drag it to where you
want it while it’s still selected.
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M(’.)&-’ing d gl':l])hic To move a graphic to a different card or background, follow

'to another card ~ these steps:

or background -

I
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Go to the card or background that has the graphic you want
to move,

Pressing | -B takes you to the background layer. (When you're
in the background layer, the word Background appears in the
menu bar.) If you press ' “-B repeatedly, you move back and
forth between the card layer and the background layer. If you
don't see the graphic you want while you're in the background
layer, the graphic is in the card layer.

. Select the graphic,

“Selecting a Graphic,” earlier in this chapter, gives insrructinns..
Choose Cut Picture from the Edit menu, or press * -X.

This removes the graphic from the card and puts it on the

Clipboard.

. Go to the card or background where you want to put the

graphic.

Use the arrow keys, the Go palette, or commands in the Go
menu to navigate between cards while the Selection tool or the
Lasso is selected.

If you're not sure whether to put the graphic in the card layer
or the background layer, see “Adding Graphics to a Card or

Background” at the beginning of this chapter. )

. Choose Paste Picture from the Edit menu, or press ~-V.

This takes a copy of the graphic that’s on the Clipboard, puts it

on the current card or background, and selects it.




The graphic is pasted in the same position it was copied from. If
there’s a button or field in the same location, the pasted graphic
will be hidden behind it (as explained in “When Elements
Overlap,” earlier in this chapter). You might have to move the
button or field to see the graphic.

6. If you want to reposition the graphic, drag it to where you
want it while it’s still selected.

The graphic becomes opaque after you paste it. If you want to be
able to see through the graphic to the elements behind it, select it
and choose Transparent from the Paint menu.

Important: The most common mistake in moving a graphic is
putting it in the card layer when you want it in the background
layer. (To find out whether the graphic is in the background layer,

2
B

press . -B to see just the background elements.) If you pur a graphic
in the card layer by mistake, see “Moving a Graphic from the Card
to the Background,” earlier in this chapter. A

Im pOITlng d gl‘:lphlc There are many products you can use to create pictures thar are
compatible with the Apple Preferred File Format. Some products let
you create pictures in this standard Apple I1GS format from scratch;
others let you digitize images using a scanner attached directly to
your Apple 11Gs. However you create it, you can bring any picture

@ in the Apple Preferred File Format into HyperCard by following
these steps:

1. Make sure you have one of the Paint tools selected.
2. Choose Import Paint from the File menu.

A directory dialog box appears.
4 .
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Exporting a
snapshot of a card
or background

3. Use the directory dialog box to locate and open the file
containing the picture you want to import.

HyperCard pastes the imported picture onto the current card or
background, starting with the upper-left corner of the imported
picture.

% Preparing to import a picture: Before you import a picture,
Inillit' SUre lh'.' I)L”'l lll-l}]L' PiL'IlII'L' you want to PQIHI'IL' |'$ i” l!'lL'
document’s upper-left corner; or make sure the picture is small
enough to fit on a HyperCard card, including any blank space
that’s in the upper-left corner of the picture. +

Once you've imported a picture, you can work with it just as if

}mu'd created it in H}'per{:ard. .

When you import a picture into HyperCard, you also import the
color set used by the original document. The imported color set
becomes the sixth color set in the Colors dialog box for the current
card (or the current background, if you're working in the
background layer).

» Seealso: “Importing a New Color Set for a Card or Background” in
this chapter

You can take a snapshot of the current card or background and save
it as a document in the Apple Preferred File Format by using the
Export Paint command in the File menu. (This command is &
available only when a Paint tool is selected.) Follow these steps:

l. Choose Export Paint from the File menu.

A directory dialog box for saving a file appears.

)

Use the directory dialog box to specify where you want the
Apple Preferred File Format document saved and type a name
for the file.

3. Click OK.
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Creating a miniature
picture of a card

Export Paint creates a document in the Apple Preferred File Format
that contains the image of the current card and background (and all
their elements) and saves it on a disk under the name you give it.
The image of the full-sized card gets saved, even if you're using
FarBits.

It you're in the background layer, HyperCard saves only the image
of the background.

HyperCard exports only a picture of the card and background
information. The saved picture has none of the functional attribures
of the card—for example, the scripts aren't saved with the picture. If
you have a paletre, the Message box, or the FatBits window open on
the screen, their images aren’t included with the exported picture.

You can create a miniature picture of a card, like the miniatures you
see when you choose Recent from the Go menu. Follow these steps:

I. Go to the card you want a miniature picture of.
2. Choose Copy Card from the Edit menu.

3. Go to the card or background where you want to put the
miniature picture.

4. Press and hold the Shift key while you choose Paste Card from
the Edit menu.

Or press ' -Shift-V.
The miniature appears selected in the center of the card window.

Note that this is just a picture of a card—none of the normal card
attributes or scripts from the original card are pasted with the
miniature,
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DCIC[ing d gl‘zlphi(.' 'To delete a graphic, you can use any of the following techniques:

s To delete a new graphic just after you add it (before you click
anywhere else), press the Delete key or choose Clear Picture
from the Edit menu. This is not reversible; you can't bring back

a graphic that was deleted immediately after it was added.

» To delete any graphic, first select it (by using one of the
techniques described in “Selecting a Graphic,” earlier in this
chapter). Then press the Delete key or choose Clear Picture
from the Edit menu. If you delete a selected graphic by mistake,
you can bring it back by immediately choosing Undo from the
Edit menu or pressing « i-Z, Tilde, Esc, or Delete.

= To erase any graphic, choose the Eraser (<) from the Tools .
menu and drag over the graphic. (To erase a background
graphic, you must be working in the background layer. To erase
a card graphic, you have to be in the card layer.) To erase ina
straight horizontal or vertical line, press Shift while you drag. To
erase in white paint, press the . key while you drag,

% The background revealed: 1f you see a picture appearing under
the Eraser as you drag it over a card picture, you're exposing a
part of the background that was covered by an opaque card
Pi{_'tllr(_'. [F}H)Ll d(}[]‘l want [hL‘ hllCL(gr“lln(I L'IC]T]L‘” (5 1O 5}1[)W.
you can cover them by pressing the ' key as you drag with
the Eraser. (This “erases” with white paint.) Of course, you
can go to the background layer and delete the elements, but
first check to make sure they aren’t needed on the other card.
lhﬂ( SI_]:'N‘L' Th(_' I’:;lCligl‘()Lll‘ld. <>

s o erase the entire picture on the current card or background,
double-click the Eraser on the Tools palette. This wipes out
the picture on the current card or background, then selects the
tool you were using just before you double-clicked the Eraser.
This technique is useful for cleaning up your screen after you've
been experimenting with the Paint tools. (If you double-click
the Eraser by accident, choose Undo from the Edit menu
immediately, or press  -Z, Tilde, or Esc.)
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Chapter 7

Printing

his chapter explains how to print the information in a stack. You
can print a single card, a range of cards, an entire stack, or a report
that displays the contents of specific background fields. You can also
create different templates for a stack and export templates from one
stack to another,

If you're familiar with HyperTalk, you have even more printing
options—for example, you can print the contents of a specific field
ora document from another application. The | lyper Lalk Help
stack describes these options. (They aren’t covered in this chaprer.)

To do all the tasks in this chaprer, you must have your user level set
at least to Autlmring However, you can print cards, stacks, and
reports no matter what your user level is set to, as long as you don’t
need to create or change any templates. (For instructions on setring
your user level, see “User Levels and Options” in Chapter 1.)
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P['(fplll'lﬂg O [)l'll][ Betore printing with | lyperCard, you must have the appropriate
printer driver for your printer in the Drivers folder, which in turn
must be in your System folder when you start your computer. You
must also make sure your printer port and driver are correctly
configured in the Control Panel desk accessory. The documentation
that came with your computer describes how to install printer
drivers and how to use the Control Panel.

Once you have the appropriate printer driver installed and the

printer selected, you can give HyperCard information about your

paper and printing preferences before you print by using the Page

Setup command.

» Note: You don't need to use the Page Setup command each
time you print. If the settings in the Page Setup dialog box e
reflect your paper size and printing preferences, you don't need
to use the Page Setup command until you want to change
the settings.

To change the settings in the Page Setup dialog box, follow these

N'rL"PS‘.

1. Make sure you have one of the General tools selected.

The Browse tool (), the Button tool (=), or the Field tool (53)

will work.
2. Choose Page Setup from the File menu.

The Page Setup dialog box appears. The options in this dialog
box vary, depending on the kind of printer and the version of

system software you have.
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Print horizontally

3. Select the options you want in the Page Setup diaﬂog box:

Laserbriter vil

Paper: @ US Letter (O RY Letter |

(O USLegal (OB Letter |

Print vertically

This is 4 line-tuning option that can
make some text and bit-mapped

graphics look et

Orientotion: Vertical Sizing:
7 = ® Hormal —l
% % O Intermediate
O Condensed
Printer Effects Beduos or
: ]
=] Smoothing? Enlarge; ‘

Select this option to substitute Times 117

for New York, Helvenca for Geneva,
Louner for Monaco, and a special

torm of Helvetica for Shaston

Select this option to make the
top margin of your printout as

=] Font Substitution?

Imagelriter/Printer vy.0

Poper Tupe: [ USLetter. B.5"xI1" §

Reduction: | Full Size

small as possible.

Click the option that describes
the size of your paper.

These options have no effect
on the way HyperCard prints,

Type a percentage here o
reduce or enlarge the entire
image on each page.,

Press and hold the mouse
button here to see the
Paper Type pop-up menu,
Drag to choose the option
that describes the size of

I Mo Vertical Gaps
[ Vertical Condense

Height: 2
your paper

This option has no effect on
the way HyperCard prints )
Orientation Print horizontally

wj[E

Cancel

o)

Figure 7-1  Selecting options in the Page Setup dialog box

4. Click OK.

The options you select in the Page Setup dialog box are saved
with the current stack (unless the stack is locked). They're in
effect when you print the stack (or any part of it) using the
Print command.
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e If the stack is locked: Changes you make in the Page Setup
dialog box for a locked stack will not be saved after you leave
the stack, and may not remain in effect for the entire nme
you're working in the stack.

You can change the Page Setup settings at any time by repeating this
procedure.

I)I‘inting d Siﬂglﬁ' card To print a single card in a stack, follow these steps:
I. Go to the card you want to print.
2. Make sure you have one of the General tools selected.

The Browse tool (&), the Button tool (=), or the Field tool (£1)
will work.

3. Choose Print Card from the File menu, or press -P

HyperCard prints the current card.

Pl‘iﬂtiﬂg the cards HyperCard allows you to prepare card templates that allow you to
in a stack print um-all the cards or a range of cards in the current stacli in a

variety of ways. You can create and save up to 32 templates for a
stack (including both card templates and report templates). For
example, you could create one card template that prints out the
cards ar full size, just the way they appear on the screen, and anoth
that prints cight reduced card images on a page—both for the same
stack. You can also export card templates from one stack to another.
For more information about templates, see “Creating Templates,”
later in this chapter.
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To print all the cards or a range of cards in the current stack, follow
these steps:

1. Make sure you have one of the General tools selected.

The Browse tool (¥4), the Button tool (<), or the Field rool (1)
will work.

2. Choose Print from the File menu.
The Prine Stack dialog box appears.

3. Ifa card template is not already selected, select one in the Print
dialog box:

Print, ; A
L (Options... ) (_Concel ) (( Print )] B i G
[ Templates I print the cards in
: the current stack,
‘ | Select o template: O Ject :
= Lobels by 7 e you muslt Se LLL..J
| 22 Report s template with this
L =P Untitled icon. To select a
T L - template, click it.
O

Figure 7-2  Selecting a card template

[f you want to create your own card template now, click Cancel
and go to the section “Creating a Card Template,” later in this
chapter. If you want to print a report that displays the contents
of specific background fields, click Cancel and go to the next
section, “Printing a Report.”
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To print all the
cards in the stack,
click here

To print a range
of cards, click here
and type in the

card numbers for the

ringe of cards you
want [ prot,

4. Press and hold the mouse button over the pop-up Templates
menu and choose Edit Template.

You can also double-click the name of the template or press
Enter to edit it. The Template dialog box appears.

o Ifyou can’t see the pop-up Templates menu: The pop-up
Templates menu appears only if your user level is set to
Authoring (4) or higher. [f you can't see it, you must either
click Cancel and change your user level, or skip to step 7.
(For instructions on setting your user level, see “User Levels

.

and ()prinn&;" in Chapfcr 1.)
5. To print all the cards in the stack, click AlL

Or, to print only a specific range of cards, click From and [}'pe.
the range of cards you want to print.

& Template "Untitled" i
N 4

e e (" 1]

|" -] /(:)Frum: D To: :I

| Loyout: | Spread out .

! . <) Cord Nomes
........................ =1 Scaling: [ Full sizecards |

Order: | Left toright

-------- — Groy scole; —————
(Tender.) (Tonter.) |Brields  BJbictures |

Figure 7-3  Indicating which cards you want to print .

6. Click OK, or press Return or Enter.

The Template dialog box disappears, and you see the Print
dialog box again.
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7. If you want to adjust any of the standard print options, click
Options.

The standard Options dialog box for your printer appears. The
options in this dialog box vary, depending on what kind of
printer and which version of system software you have. These
options are described in the documentation that came with
your computer.

Loserbiriter va.l
Poges ® Al

Dh'um:D Ta: El
Capies;

Paper Source:

@ Paper Tray
O Monual Feed

ImogeWriter/RppleTalk viLp

Copies: E'

Pages: @Al O Range
From
To

Quality:

Chroma: Block/White

Sheet Feed: |Hutnnutici
ll 0K D

Figure 7-4  Examples of the Options dialog box for different printers

8. Select the options you want in the Options dialog box and
click OK.
The Options dialog box disappears, and you see the Print dialog
box again.

=
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Printing a report

9. Click Print.

HyperCard prints the cards in the current stack according to the
settings in the Page Setup dialog box, the Template dialog box
for the template selected in the Print dialog box, and the
Options dialog box for your printer.

HyperCard allows you to prepare custom report templates that
display a background’s field text and card pictures in any way you
like. You can create and save up to 32 templates for a stack
(including both card templates and report templates). For example,
you can create a table-style report template, a template for printin
the results of calculations, and a template for printing labels—all t
the same stack. You can also export report templates from one stack

to another.

You can control the appearance and placement of each elementina
report template—including the font, size, and style of the text. You
can also insert pictures into a report. For more information about
templates, see “Creating Templates,” later in this chapter.

To print a report from the current stack, follow these steps:
1. Make sure you have one of the General tools selected.

The Browse tool (#), the Button tool (=), or the Field tool (CJ)
will work.

2. Choose Print from the File menu. .

The Print dialog box appears.
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3. If you've created a report template you want to use, select it in

the Print dialog box:

Print... (Ostions... ) (Cancel ) {_Print )

N '| | Select o template:
e — 7 Labels 3by 7

== Report

¥ Untitled

Before you can print 4
report, you must select a

. template with this icon, To

select a template, click it.

Figure 7-5  Selecting a report template

[f you want to create your own report template now, click
Cancel and go to the section “Creating a Report Template,” later
in this chapter.

4. Press and hold the mouse button over the pop-up Templates
menu and choose Edit Template.

You can also double-click the name of the template or press
Enter to edic it. The Template dialog box appears.

& < Ifyou can't see the pop-up Templates menu: The pop-up
Templates menu appears only if your user level is set to
Authoring (4) or higher. If you can't see it, you must either
click Cancel and change your user level, or skip to step 7.
(For instructions on setting your user level, see “User Levels
and Options” in Chaprer 1.)
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Only cards with the
selected background will
be included in the report

I background has no

name, its 1D number

appears in this list instead

5. To print a report based on all the cards in the stack with the
selected background, click All.

Or, to printonly a range of cards with the selected background,
click From and type in the range of cards you want.

To print a report based on all the cards with the

selected |‘r.l|.‘|-i‘£,=l'c wnd, click |‘|L'I'L’.

== Template "Report”

L e e Cords: @ A1l

| Select o background:

Qtrm o[ ]

Introduction
Bk #3690
Bk #5602

Figure 7-6  Indicating which cards you want to print

6. Click OK.

[0 print a report
based on a range
of cards with the

selected background,

click here and tvpe i
the card numbers fo
the range of cards
YOu want o print

The Template dialog box disappears, and you see the Print

dialog box again.

7. If you want to adjust any of the standard print options, click

Options.

The standard Options dialog box for your printer appears (as
shown in Figure 7-4). The options in this dialog box vary,
depending on what kind of printer and which version of system

software you have. These options are described in the
documentartion that came with your computer.

Chapter 7: Printing

N




®caiing templates

8. Select the options you want in the Options dialog box and

click OK.

The Options dialog box disappears, and you see the Print dialog
box again.

9. Click Print.

HyperCard prints information from cards in the current stack
according to the settings in the Page Setup dialog box, the Template
dialog box for the template selected in the Print dialog box, and the
Options dialog box for your printer.

You can create two types of templates for printing the information
in a stack: card templates, which print some or all of the cards in a
stack as they appear on the screen; and report templates, which print
reports that display a background’s field text and card pictures. If
you want to create a template for printing the cards in a stack,
follow the instructions in the next section, “Creating a Card
Template.” If you want to create a template for printing a report,
follow the instructions in the section “Creating a Report Template,”
later in this chapter.

You can create and save up to 32 templates (including both card
templates and report templates) for a stack.

@:cating a card template 1. Make sure you have one of the General tools selected.

The Browse tool (%), the Button tool (=), or the Field tool (=)
will work.

2. Choose Print from the File menu.

The Print di.th)g box appears.
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3. Choose New Template from the pop-up Templates menu:

Print... (options... ) (Cancel ) { Print )

T —— Temglates = Press and hold the
S Edit Template... mouse button here . ..

Hew Template.., .and drag down to
Duplicate ' choose New ']L'|11|J|.L[L'.
Export...
Renome...
Delete... |

=

Z|

Figure 7-7 Creating a new card template

A dialog box for naming the template appears. .

4. Type a name for the new card template:

Hew template...
Current nome:  Untitled Type a name for your new
New nome; [[ICITR) : card template here.
_T;r;n_lutestsle_@ 5 Cords - The default setting for the
(O = Report template's style is Cards

Figure 7-8  Naming a new card template

5. Click OK. &

You see the Print dialog box again. The name of your new
template appears in the list of templates and is selected.

6. Press and hold the mouse button over the Templates pop-up
menu and choose Edit Template.

You can also double-click the name of the new template or press

Enter to edit it. The Template dialog box appears.

3 Chapter 7: Printing




7. Select the options you want in the Template dialog box:

This shows you the layout of the printed page

It you don't want your template Press and hold the
to print all [|:1t' cards in the stack, =7 Templote|"My Cord Templote" (et ) ( ® ) mouse hutton here 1o
click this button and enter a see a pop-up menu tha
range of cards. Cords: @ Al lets you adjust the space
O from: D T[] between the cards on
Press and hold the mouse ‘ Layout: page. “Spread out”
button here to see a pop-up (53 Card Names leaves space between
menu for choosing the size of IR—— Scaling: | Tull size cards  § each card. “Adjacent”
the printed cards butts each card up

Grdur; | ZeTb oy against the next. “One

Press and hold the mouse /
| here s | ------------- broy scale: — card per page” prints
utlon here 1o see a pop-up (Header... ) ( Footer... ) EFields EPmures ‘ one catd s tiee: 10

menu for choosing the order in e - SATG pei pags, o

matter what size vou've

which successive cards will sl G il
. appear on the page.  When you're printing in black and white with ¢t| HsEIO e e
LaserWriter or ImageWriter, these options allow you to
print field text or pictures using a gray scale. If you are
using an ImageWriter fnrnhnh Chroma is set to Color in
the Options dialog box (see Figure 7-4), these options
allow you to print field text or pictures in color.

Figure 7-9  The Template dialog box for a card template

8. To adjust the header for your card template, click Header in
the Template dialog box.

The Header dialog box appears. Even if you don't plan to use a
header, you may want to use this dialog box to eliminate the
space the header would normally occupy, so that printing can
o start as high as possible on each page. (If you don’t want to
adjust the header, go to step 11.)
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9. Specify the header you want:

To prevent the header from occupying any space
at the top of each page, click here to deselect the
Show Header option,
Press and hold the mouse
button here to see a pop-up

. = Header of template “{ly Card Templote"
menu for mserting the date, =g 52 Show Head (_Concel ) {0k )
time, page number, or stack s suctbdbcnid \
) [ 1 To add
manwe into the hesides ! i
: _ text to the
automatically, Poste Picture

header
L Wi lVpe here
It the header contains a =
graphic, it appears here and
prints out just below the
header's text. =

To paste a graphic into the Drag from this corner to .
header, click this button. (The adjust the height of the
button is active only when the portion of the header that
Cliphoard contains a graphic.) contains o graphic

Figure 7-10  The Header dialog box

To reposition a graphic after you've pasted it into the header,
dr:ig with the crosshair pointer to select the graphic, then drag
with the arrow pointer to move it. (Hold down the Shift key
while you drag to move the graphic one pixel at a time.) To
duplicate the currently selected graphic, hold down the Option
key while you drag the graphic.

10. Click OK. .

The Header dialog box disappears, and you see the Templarte

dialog box again. (To return immediately to the Print dialog box
without seeing the Template dialog box, hold down the Oprion
key while you click OK or Cancel.)
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I1. If you want to add a footer to your card template, click Footer
in the Template dialog box.

The dialog box for the footer appears. (If you don’t want to add
a footer, go to step 14.)

12. Specify the footer you want:

To make the footer show up in the printout,

click here to select the Show Footer oplion
[0 paste a graphic into the

footer, click this button. (The

£ = Footer of template "M Card Template"
button is active only when the , Concel (o ]
Clipboard contains 4 erachic ) Paste Picture [ Shaw Footer
Clipboard contains g eraphic

. It the footer contains d ',_1_!',|§'.\|':.__ fﬁ

it appears here and prints out

just above the footer's text

Text Insert

'T'

[oadd text oty
footer, type here

Press and hold the mouse button here  Drag from this corner

to see a pop-up menu for inserting to adjust the height of the
the date, time, page number, orstack  portion of the footer that
name into the footer automatically. contains 4 graphic

Figure 7-11  The Footer dialog box

To reposition a graphic after you've pasted it into the footer, drag
with the crosshair pointer to select the graphic, then drag with

@& the arrow pointer to move it. (Hold down the Shift key while
you drag to move the graphic one pixel at a time.) To duplicate
the currently selected graphic, hold down the Option key while
you drag the graphic.

13. Click OK.

The dialog box for the footer disappears, and you see the
Template dialog box again. (To return immediately to the Print
dialog box without seeing the Template dialog box, hold down
the Oprtion key while you click OK or Cancel.)
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14. In the Template dialog box, click OK.

The Template dialog box disappears, and you see the Print
dialog box again. Your new template is now saved with the stack.

15. If you want to print the stack now (using the current
template), click Print in the Print dialog box.

Ortherwise, click Cancel in the Print dialog box.

HyperCard prints the cards in the current stack (either all the
cards or just the range of cards specified in the Template dialog
box) according to the settings in the Page Setup dialog box, the
Options dialog box for your printer, and the Template, Header,

and Footer dialog boxes for your new card template.

—_—

Creating a report template Make sure you have one of the General tools selected.

The Browse tool (%), the Butron tool (=), or the Field twool (53)
will work.

2. Choose Print from the File menu.
The Print dialog box appears.

3. Choose New Template from the pop-up Templates menu:

Print... (Ootions... ) ( Concel ) [ Print )
[ ———p— Templates = Press and hold the
R —— Edit Templote... mouse button here . . . .
‘ ennlte __ i and drag down to

Duplicate choose New Template
Export..
Renome...

Delete..

Figure 7-12  Creating 4 new report template

A dialog box for naming the template appears.
et 5 I |
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4. 'Type a name for the new report template and select the

Report style:
N
ev templote... (taneel ) j
Current nome:  Untitled Type a name for your new
New name: [[EITANY) ! report template here .
m[};ﬁm style: @ Cords ... then click here to select
Oz Report the Report template style.

Figure 7-13  Naming a new report template

® 5. Click OK.

You see the Print dialog box again. Your new template appears in
the list of templates and is selected.

6. Press and hold the mouse button over the Templates pop-up
menu and choose Edit Template.

You can also double-click the name of the new template or press
Enter to edit it. The Template dialog box appears.

7. In the Template dialog box, select the background on which

you want to base your report.

== Templote "My Report Templote” If the background on
. _y = — (Coneer ) (_ox ) which you want 1o
This shows you the Liyour ——I|  Cards: @ A1l buse your report is not

of the printed page

I Ofrom: [ J10:[ ] already selected, click
l its name or 1D in this

Select a background: " .
| Header... RLtoh _ list to selectit. (If a
'-"'—"7 (Content... ) ETIETIENTD background has no

Bk #3690 name, its [ number
Bk #3602

footer...

appears here instead.)

Figure 7-14  The Template dialog box for a report template

Only information from cards with the selected background wall

print.
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8. Click Content, or press Enter.
The Content dialog box for the report template appears:
I'he spaces o the left of and above the cell indicate the lelt

and top margins lor the body of your report, The top margin
is measured from the bottom ol the header

This represents the area -T'_Ecnr. " "
: dres e ent of templote "My Report Templote
reserved for a cell (the | A (Concel J_0k_J
informaton from one card), i 1 ] Preview... ]( R just ]
The spaces to the right of and 3 s Picture & Bkand fields:
|11'|1.-\\'I|1t'u'|| H]ill{.llL'llIl' i
amount ol space between cells i
T Morgin;— ——Size;—~ - Spocing:— .
[hese measurements reflect the ?_f 0.95 433 1y i? 0.25 J
size and positioning of the cell S 08 | |5 10 | |° 08
frrange: | Left toright § Dimensions:

This area lists the picture insert and background
fields that are available for the background selected
in the Template dialog box. The picture insert

consists of the card picture

Figure 7-15  The Content dialog box

This dialog box allows you to specify what text you want in your
report by adding report items to a report cell. You can also add a
report item called a picture insert that consists of the card picture.
The report items you specify will print for each card.
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9. Set up the layout for the cells in your report:

When you move the pointer over === Content of template "My Report Template"
the cell's lower-right corner or its
bottom or right edge, it becomes a
double-headed arrow. To adjust the
size of the cell in any direction, drag
from the corner with this arrow

((Preview... || ﬁiﬁ,l\.i:i ]

Picture & Bkand fields:

[0 addjust the size of the cell anly Bl . ::::s
verticlly or horizontally, de
from its hottom or right edge — Margin; —— Size: - Spacing:—  —Fisld chorocteristios -
Any changes you make to the m‘f 0.9 il_} .24 | 1[: 0.23 ‘ femt. ‘
marging, size, and .-ilnl;n ing of the cell (& 038 | (T 1B | |& 028
are reflected here. You can also click Arrange: [_Left toright | Dimensions: [_inches I “Erih_'”h‘m' ‘
the arrows to make fine adjustments.
Press and hold the mouse Press and hold the mouse
. button here to see a menu for button here to see a4 menu
choosing the order in which the for choosing the units of
report will print successive cards. measurement for the
You can also choose Full Width to dimensions given above.

extend the cell across the entire page.

== Content of l.mpl:lte "Myl When you move the pointer over this

line, i >-headed
._ arrow. Drag with this arrow to adjust
B ; — | the vertical space between each cell
|1 T

When you move the pointer over this
line, it becomes a double-headed arrow,
Drag with this arrow to adjust the
horizontal space between each cell.

== Content of template "My | When you move the pointer over the

E_L'.,._._llljlttiL‘_L-I[||LlL1] it hecomes i fous
i headed arrow. Drag with this arrow to
i, adjustthe left and top margins of the

hody of your report

Figure 7-16  Adjusting the size, spacing, and margins for the cells in @ report
8 4 | 8 b
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[f the lower-right corner of the cell coincides with the
intersection of the two lines that control the spacing between
cells, you can adjust one of those lines rather than the cell itself
by holding down the ¢ ' key while you drag from the corner.

10. Drag the picture insert or background field you want to
display in your report into position:

Press and hold the mouse button over the
picture insert or background field in this list
that you want 1o add to your report

== Content of templote "My Report Templote" m m
cand drag it into position ( ' ' B ”{p,-wm”_ W Rejuse.. )

Picture & Blegnd fields: .

1 Picture Insert

inside the cell, To move the item

around after you've released the

MOLSE |‘.lLII[I HiN -‘||',l:_ It from s

; Hia i I el E=3 Nome
center. Hold down the Shift key = Notes
while vou t|i'.|:_; o ahen the - EpRnaanoonoaroDnonnoDn “4 e Lk
item to an invisible grid — Margin: — Size:— — Spocing:— —Field sharocteristics o
4 0.63 } F 7.30 } 4 035 ’ I v
& 080 $ 3Mu ¢ 03

Arrange: [ Left toright § Dimensions: [inches | L s el Bame

Figure 7-17  Dragging a picture or background field into position

A small rectangle appears in the place where you release the
mouse button. This rectangle represents one item in your

report. A rectangle filled with a diagonal pattern represents a
picture insert, which consists of the portion of the card picmre.
(starting at the upper-right corner of the card) that will fit in the
rectangle. A rectangle filled with a crosshatch pattern represents

d [‘_lﬂC]{gr()Llnd ﬁﬁ']d
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To resize an item within a
cell, drag the item from its
lower-right corner

or double-click the item

o see o window like flis
You can then drag the lower-
right corner of the window

1o resize the item

I'1. Adjust the size of the item as necessary:

To close the Adjust window,
click here or click anywhere
outside the window,

To move the Adjust
window, drag it from here.

Content of templateN!My Report Template”
i et SEigSauEEnas S My

::[ Concel [

(Preview . ) ( Adjust.. 3

Picture & Bkand fields:
B Picture Insert

N

E= Nome
E=S Notes

* [risiei: IR RRRARRRRRRRRE ¥
— Margin;—— —— Size: =1 Spacing: — — Fiedd chorocteristies -
4 065 a4 130 ‘ a 0.35 T Tont..
¢ 080 ¢ MW || & 03 T

[ 16how Field Rome

Bimensions: | inches j

Figure 7-18

Adjusting the size of a report item

You can
also open
the Adjust
window hy
clicking the
Adljust
button or
pressing
Enter while
the item is
selected

If the lower-right corner of an item coincides with the lower-

right corner of the cell, you can adjust the item racher than the

cell by holding down the

key while you drag from the corner.

If the item is a picture insert, the pointer turns into a hand when
it’s over the Adjust window. To bring the desired portion of the

card picture into view, drag with the hand.

To make the size box in the lower-right corner of the Adjust

window disappear temporarily (so you can see whatever it’s
covering), press and hold the mouse button. This works for both

picture inserts and text items.

To save your changes and return immediately to the Print dialog
box, hold down the Option key and press Return. This works

whether or not the Adjust window is open.
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12. If the item represents a background field and you want your
report to display its text in a format that’s different from
the text format used in the stack itself, choose Other from the
pop-up Font menu:

If the item whose text format you want to change is
not selected, click it to select it

== Content of template "My Repor| Templote"

L Cancel )0k )
(Preview... ) ((Adjust.. )

Picture & Bkgnd fields:
B Picture Insert

¥ trenint I RRARRY iER iF
— Wargin: — I Size: — - Spocing:—  — Field characteristies: - .
Then press and hold the 4 065 £ 130 ! ¢ 035 |
mouse button here |V w0 | |s 3| I_ﬂ33_| | +Field Font
-

Arrange: | Left toright Ilimensinns.'

Other.. . .

. and drag to choose Other from the pop-up menu
(If you choose Field Font, the item will appear in your
report in the same text format selected for the field in
the stack itsell.)

Figure 7-19  Changing the text format for i report item

The Text Style dialog box appears. (If the Font menu is dimmed,
click the item to select it. The Font menu is active only when an
item representing a background field is selected.) .

354 Chapter 7: Printing




13. Specify a text format for the item:

Click to select a

Click the font font size
you want to (measured in
" select it nomils)
Click to select or deseled! one :
or more text styles. (Selear = To use a font size not
nothing for pliin wext.) The Style: — | [Courier listed, type it here. (1 you
sample text at the hottom o Dfnw. Geneva use a size that's different
the dialog box shows the I;!zﬁ:lhln.l?;s Helvetica from the sizes listed above
ellect of the selected styles, ] 0utline = for the lont, the text nay
[CIshadow | | Venice Font Size: [B look rough or jagged.)
Press and hold the mouse MR TRN 1171017 LD AR A C“L'k the color you
button here 1o see a pop-up want to use for text in

menu for choosing the The quick brown fox jumps over the lazy deg. the report item

alignment for text in the
. report iten.

This shows what the text will look like

Figure 7-20  Specifying the text format for a report item

14. Click OK.
You return to the Content dialog box.

I5. Repeat steps 10 through 14 if you want to add more items to
your report.
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16. Click Preview.

The Preview dialog box appears:
2 PP

Click these buttons o preview the report eell
for the previous or next card in the report

.

; .'-J--.n-f-“_)f ( — Y C_ tone _}_ L Click Done
T M e when vou'n

finished

John Chapman

Born in 1774, died in 1845, Plonted o lot
of opple trees

Figure 7-21  The Preview dialog box

17. When you're finished looking at the preview, click Done to
return to the Content dialog box.

If you're not satisfied with the layourt of the report cell, adjust the
report items as necessary in the Content dialog box. (To save
your changes and return immediately to the Print dialog box
from the Preview dialog box, hold down the Option key and
press Return or Enter.)

18. When you're satisfied with the layout of your report items in.
the Content dialog box, click OK.
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19. To adjust the header for your report template, click Header in
the Template dialog box.

The Header dialog box appears. Even if you don't plan to use a
header, you may want to use this dialog box to eliminate the
space the header would normally occupy, so that printing can
start as high as possible on each page. (If you don’t want to
adjust the header, go to step 22.)

20. Specify the header you want:
o prevent the header from o LY I iy spxLee

at the top of each page, click here to deselect the
Show Header option.

. Press and hold the mouse
I e 2 gy v "
button here to see 4 pop-up = Header of template "y Report Template"
menu for inserting the date, e (53 Show Head (Concel ) (__0k_J
time, page number, or stack ! okhiseobdetzskl
; Ry [ 1 To add
name into the heacler ] .
g d R ; text to the
automatically. ((Poste Picture ) header
" tvpe here
If the header contains a |
graphuc. itappears here and
prints out just betow the =]
header's text =
To paste a graphic into the Drag from this corner to
header, click this button. (The adjust the height of the
button is active only when the portion of the header that
Clipboard contains a graphic.) contains a graphic,

Figure 7-22  The Header dialog box

1o reposition a graphic after you've pasted it into the header,
drag with the crosshair pointer to select the graphic, then drag
with the arrow pointer to move it. (Hold down the Shift key
while you drag to move the graphic one pixel at a time.) To
duplicate the currently selected graphic, hold down the Option
key while you drag the graphic.
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21. Click OK.

The Header dialog box disappears, and you see the Template
dialog box again. (To return immediately to the Print dialog box
without seeing the Template dialog box, hold down the Oprion
key while you click OK or Cancel.)

22. If you want to add a footer to your report template, click
F['JL‘I[L’I'.
The Footer dialog box appears. (If you don't want to add a

footer, go to step 25.)
23. Specify the footer you want:
To make the footer show up in the printout.

click here to select the Show Footer option

[0 paste a graphic into the

footer, click this button. (The —

! == Footer of templote "Mjj Report Templote"
button 1s actuve only when the Paste Plt T Show F
Clipboard contains a graphic.) AL bl

If the footer contains a graphic, =]

it appears here and prints oul 7

just above the footer's text
Text Insert
Tor add text 1o the ]
dd text to the g ]
e

footer, type here

Press and hold the mouse button here  Drag from this corner

to see i pop-up menu for insening to adjust the height of the
the dine, time, g number, or stack partion of the foorer thar
meme into the looter automatically contains g graphic

Fignrt' 7-23  The Fox ter dialog hox

To reposition a graphic after you've pasted it into the footer, drag
with the crosshair pointer to select the graphic, then drag with
the arrow pointer to move it. (Hold down the Shift key while
you drag to move the graphic one pixel at a time.) To duplicate
the currently selected graphic, hold down the Option key while

you drag the graphic.
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24. Click OK.

The Footer dialog box disappears, and you see the Template
dialog box again. (To return immediately to the Print dialog box
without seeing the Template dialog box, hold down the Oprion
key while you click OK or Cancel.)

25. In the Template dialog box, click OK.

The Template dialog box disappears, and you see the Print
dialog box again. Your new template is now saved with the stack.

26. 1fyou want to print a report now (using the current template),
select the standard print options you want (as described earlier
in the section “Printing a Report”) and click Print in the Print

. dialog box.
Otherwise, click Cancel in the Print dialog box.

HyperCard prints information from the cards in the current
stack (either all the cards or just the range of cards specified in
the Template dialog box) according to the settings in the Page
Setup dialog box, the Options dialog box for your printer, and
the Template, Content, and Header and Footer dialog boxes for
your new report template.

-
o

1o print mailing labels: 1f you want to print mailing labels, you
can use the Labels 3 by 7 template in the Addresses stack (which
comes with HyperCard). If you want to print mailing labels
from a stack other than the Addresses stack, copy the Labels 3 by
. 7 template using the procedure described in the next section,
“Exporting a Template to Another Stack.” If you like, you can
customize this template by selecting it in the Print dialog box
and following steps 6 through 25 in this section. If you're
printing on a LaserWriter, be sure to use only labels made

especially for LaserWriters or photocopiers. #
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E,\I]"J("Jl“[iﬂg d l'L‘I]]plthL‘ If you have a template for one stack that you think would work well
tO AN« Jth(fi' “;I'lf;]ﬂ in another stack, you can export it to another stack by following

these steps:
I. Go to the stack that has the template you want to copy.
2. Make sure you have one of the General tools selected.

The Browse tool (%), the Button tool (=), or the Field tool (1)

will work.
3. Choose Print from the File menu.
The Print dialog box appears (see Figure 7-2).
4. Click the template you want to export to select it.

5. Press and hold the mouse button over the pop-up Témp]ares.
menu and drag to choose Export.
The directory dialog box for exporting a template appears.

6. In the directory dialog box, find and select the stack to which
you want to export the current template.

7. Click Open.
Or double-click the name of the stack. You see the Print dialog
box again. The template is now saved in the stack you selected
in step 6 as well as the current stack.

8. Click Cancel to close the Print dia](}g box.

[f you want to print from the stack to which you exported the .
template, go to that stack and follow the instructions in the section
“Printing the Cards in a Stack” or “Printing a Report,” earlier in

this chapter.
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C( )p}-’mg d [L‘[n])hllc You may sometimes find it useful to make a copy of a template
'\"\-"i[hin [htf same H{llfl{ within the same stack as the original
use the template as the basis of a new template without changing

the original.

for example, so that you can

To make a copy of a template within the same stack as the original
template, follow these steps:

l. Go to the stack that has the template you want to copy.
2. Make sure you have one of the General tools selected.

The Browse tool (#), the Button tool (), or the Field tool (=)
will work.

& 3. Choose Print from the File menu.
The Princ dialog box appears (see Figure 7-2).
4. Click the template you want to copy to select it.

5. Press and hold the mouse button over the pop-up Templates
menu and drag to choose Duplicate.

A copy of the template appears in the list of templates. You can
make any changes you want to the copy withour changing the
original.

R@I]Ellning d tﬁ‘lﬂpllltt’ 1o rename a card or report template, follow these steps:

1. Go to the stack that has the template you want to rename.

2. Make sure you have one of the General tools selected.

The Browse tool (%), the Button tool (<), or the Field tool (5)

will worls,
3. Choose Print from the File menu.

"The Print dialog box appears (see Figure 7-2).
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4. Click the template you want to rename to select it.

5. Press and hold the mouse button over the pop-up Templates
menu and drag to choose Rename.

A tii.lill!_r‘ box like the |:n|ln\-'u'i|!g appears:

Rename templote... (" Cancel ]II_— 0K ]]

Current name:  Untitled

New name: [TRIIDONY ——— ] Type the new name for

your template here.

Figure 7-24  Renaming a template

6. After y{)u‘vc Lypcd a new name for the remplutc, click OK.

I)Clk’liﬂg d [{,‘H]]}{Lil() 1o delete a template from a stack, follow these steps:
1. Go to the stack that has the template you want to delete.
2. Make sure you have one of the General tools selected.

The Browse tool (), the Button wool (=), or the Field tool ()

will work.
3. Choose Print from the File menu.

The Print dialog box appears (see Figure 7-2). .
4. Click the template you want to delete to select it.

5. Press and hold the mouse button over the pop-up Templates
menu and drag to choose Delete.

A confirmation dialog box appears for deleting the report
templare.

6. Click Yes to delete the template.
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Glossary

@
A

application program - A program that helps you
perform a specific task, such as word processing,
database management, or cre: iting graphics.

authori INg  Creating or modifying buttons, links,
Iu_]nlk cards, bx iL]\ymnnd\ and stacks using the
Button tool, the Field tool, and commands in

the Objects menu. Also refers to the user level

that allows you to use the Button ‘lool, the Field

tool, and the Objects menu.

‘o
background
template shared by a number of cards. Fach

A type of HyperCard object; a

card with the same background has the same
background picture, background fields,
background buttons, and 1 rackground script
in its background layer.

kground button A butron that is common to
al

card button.

cards .ﬁh;lring a

background field A field that is common to all cards
sharing a background; its size, position, and text
format remain constant on all cards associated
with that background, but its text can change
from card to card. Compare with card field.

background layer The layer behind the card layer,
containing all the elements of the background.
You sce the elements of both layers when you
look at a card, as if the card layer were a
transparent layer in front of the background
layer. The background button or background
field created most recently is the topmost object
in the background layer (that is, closest within
the background layer to the front of the screen).
The background picture is behind (farther from
the front of the screen) the objects in the
background layer.

background picture  The graphics in the
background layer; the entire picture that is
common to &IJ] Ci”'d.'\ .‘-'Il-';ll'j”g d i)ﬂfkgl'(]“”d.
You can sce and edit the background picture
by choosing Background from the Edit menu.

Compare with card picture.




browse  To explore HyperCard stacks by clicking
buttons and using the Go menu.

Browse tool (£9) The ool you use o click burtons
and ro position the insertion point in fields.

button A type of HyperCard object; a “hot spot” on
a card or background that responds when you
click it according to the instructions in its script.
For example, clicking a right arrow button with
the Browse tool takes you to the next card.

Button tool (=) The ool you use (o create, L‘ll;mgc.
and select buttons.

C,D,E

card A type of HyperCard object; a rectangular area
that can hold buttons, fields, and graphics. All
cards in a stack are the same size. Each card is a
composite of two layers—a foreground layer,
called the card layer, and a background layer.
You see the elements of both layers when you
look at a card, as if the card layer were a
transparent layer in front of the background
layer. Each layer can contain its own buttons,
fields, and graphics.

card button A button in the card layer of a specific
L‘ﬂ.['d. ( :(TT]]"';{]'C \*'\f'i[l'i 11:lc'i<grnl.|l‘ld l‘ll[tﬂ“.

card field A field in the card layer of a speciﬁc card;
its size, position, text attributes, and contents are
limited to the card on which the field is created.
Compare with background field.

404

card layer The layer in front of the background

layer. You see the elements of both layers when
you look at a card, as il the card Layer were a
transparent layer in front of the background
layer. The card button or card field created
most recently is the topmost object in the card
layer (that is, closest within the card layer to the
front of the screen). The card picture is behind
(farther from the front of the screen) the objects
in the card layer and in front of all the elements
in the background layer.

card []iL‘lLlI'L‘ The graphics in the card layer of a

specific card. Compare with background
picture.

card template A template for printing the cards in a

stack (or a range of cards) as they appear on the
screen. You can create your own card templares
or use ones that already exist in a stack.
Compare with report template.

sel A set of 16 colors that appears in the
Colors dialog box for a stack, a background, ora
card. Color sets are used to specify the colors
available to buttons, fields, and graphicsin a
stack. You can choose from ar least five color sets
for any stack, background, or card: the standard
system color set, a gray color set, and three
others. You can also add a sixth color set to the
Colors dialog boxes for cards and backgrounds.
When you select a different color set, the .
buttons, fields, and graphics that are affected by
it reflect the new colors.

current (adj.) The card, background, or stack

you're looking at now. For example, the current
card is the one you see on your screen.
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field A type of HyperCard object; a container in
which you type field text. | lyperCard has two
kinds of fields—card fields and background
fields.

field text  Texe that appears in a field. Field text can
be edited and searched, while Paint text cannot.

Field tool (E21)  The tool you use to create, change,
and select fields.

—
-

'nfrl:ﬂ. tools The tools that appear in the top row
of the Tools menu: the Browse tool (), the

Burtton tool (=), and the Field wol ().

GO palette  The palette that you can “tear off” the
alternate Go menu. To see the alternate Go
menu, hold down the ' key while you pull
down the Go menu.

1,1,], K

fome cards The first five cards in the standard
Home stack, designed to hold buttons thar rake
you to stacks, applications, and documents.

| |f.'pq';{”\' HyperCard’s built-in script language for
yperCard users.

8

Ink A short script, usually in a button but
potentially in any HyperCard object, thar allows
you to move immediately to a specific card in a
stack, to an application, or to a document. For
example, clicking a button thar contains a link
to your Addresses stack rakes you immediately
to the first card of that stack.

locked stack A stack for which “Can’t modify stack”
is selected in the Protect Stack dialog box; a
stack for which Tocked is selected in the stack’s
lcon Info box in the Finder; or a stack on a
locked medium—a locked disk, a CD-ROM,
or a locked folder on a file server. A padlock
appears after the last menu title in the menu bar
of a locked stack.

M,N

message A string of characters sent to an object
from a script or the Message box, or that
HyperCard sends in response to an event.
Messages that come from the system—from
events such as mouse clicks, keyboard actions, or
menu commands—are called system messages.
Examples of messages are help and

mouseUp.

Message box A special window that you use to send
messages to HyperCard.

O

ohject  An element of the HyperCard environment
that can have a script associated with it and that
can send and receive messages. There are five

kinds of HyperCard objects: buttons, fields,

cards, backgrounds, and stacks.

PO

Paint text Text you type using the Paint Text tool.
Paint text can appear anywhere, while field text
must appear in a field created with the Field
tool. When you finalize Paint text by clicking, it
becomes part of a card or background picture
and cannot be edited except by erasing it and
starting, over. Unlike field text, Paint text can't
be searched.
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Paint tools  Any of the HyperCard tools you use to
create graphics. The Paint tools are all the tools
below the top row in the Tools menu.

palette A small window thar displays icons or
patterns you can select by clicking, You can
open three of HyperCard’s palettes—the Go
palette, the Tools palette, and the Patterns
palette—Dby “tearing off” their respective menus.
See also Go palette and tear-off menu.

Patterns ]);i|t'EIL* The palette that you can “tear off”
the Patterns menu.

picture Any graphic or part of a graphic, created
with a Paint tool or imported from an external
file, that is part of a card or background.

picture insert  An item in the Content dialog box for
a report template that consists of the card
picture.

pixel  Short for “picture element”; a single dot on the
screen.

point The unit of measurement of the height of a
text character; one point is approximately equal
to one pixel. When you select a font, you can
also select a point size, such as 10-point,
12-point, and so on. (Note that a point on
the Apple TIGs is larger than the point used
in typography.)

power ]\t'\ One of a number of keys on the Apple
[IGs I\t'\ 'board that you can press to invoke a
menu command when a Paint tool is active and
the Message box is closed. To turn on the power
keys, choose Power Keys from the Options
menu or select the Power Keys option on the
User Preferences card in the Home stack.

66

program A set of coded instructions describing
actions for a computer to perform. This general
term includes programs such as HyperCard and
system software files as well as application

PﬂlgT:!Il’lS.

R

Recent A special dialog box that holds miniature
representations of up to the last 18 unique cards
viewed. Choose Recent from the Go menu to
get the dialog box.

report template A template for printing the
contents of specific background felds in a stack.
You can create your own report templates o
ones that already exist in a stack. Compare with
card template.

resource fork The part of a file that contains
resources such as icons and sounds.

A collection of instructions written in
HyperTalk and associated with a particular
object. You use the script editor to add to and
revise an object’s script. Every object has a scripr,
even though some scripts are empty (that is, they
contain nothing).

script

script editor A special dialog box in which you can
type and edit a script. The title at the top of the
script editor describes the object to which the
script belongs. You can use keyboard commands
to edit text in the script editor. See also object.

scripting  The act of writing scripts; writing
programs in HyperTalk. Also refers to the user
level that allows you to look at and change
objects’ scripts.
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search p;ilh When you open a file from within
HyperCard, HyperCard attempts to locate the
stack, document, or application you want by
searching the folders listed in the appropriate
field on the Search Paths card in the Home

stack. Each line in a Search Paths field indicates
the location of a folder, including the disk name

(and folder and subfolder names, if any). This
information is called a search path. Items in a
search path are separated by colons, like this:
:MyDisk:HyperCard:MyStacks:

eirch Paths card - A card in the Home stack used
to store information abour the location of
stacks, documents, and applications that you
,vn while Hypercard is running. See also
carch path.

hared text  Field text that appears on every card
with the same background. Shared text can be
edited only from the card layer. Text in shared
text fields can't be searched.

lack A type of HyperCard object that consists of
one or more cards; a HyperCard document,

YSIEM MEssage A message sent by HyperCard to
an object in response to an event such as a
mouse click, keyboard action, or menu
command. Examples of HyperCard system
messages are mouseUp and doMenu.

T

tear-off menu - A menu that you can remove from
the menu bar by dragging the pointer beyond
the side or bottom edge of the menu.
HyperCard has three menus that can be torn
off: the alternate Go menu, the Tools menu, and
the Patterns menu. When torn off, these menus
are called palettes.

Tools palette  The palette that you can “tear off” the
Tools menu.

UVWXY,Z

user level A HyperCard setting, ranging from
1 to 5, that determines which of HyperCard’s
capabilities are available. You can select the user
level on the User Preferences card in the Home
stack. Each user level makes all the options from
the lower levels available, and also gives you
additional capabilities. The five user levels are
Browsing, Typing, Painting, Authoring, and
Scripting,

User Preferences card The last card in the Home
stack, where you can set your user level and
select or deselect the Blind Typing, Power Keys,
and Text Arrows options.
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A

access. See protecting a stack
adding buttons 157-166
to a card or background 152-153
to Home cards 112-116
adding button text 176
adding cards to stacks 122-125
adding fields 207-210
adding graphics 248-292
adding margins ro fields 263-264
adding Paint text 298-301
adding search paths 26
adding text 206-207
to button 176
i@:ld 50-52
with Paint Text tool 298-301
aligning graphics 295-296
alignment in fields, setting 217-218

Apple Preferred File Formar, documents in

.1ddi:1g color sets from 273

importing color sets from 278-279

importing graphics from 329-330
AppleShare network

custom icons and 167

launching HyperCard over 119

using stacks on 55
setting user access for 109-110

applications
adding buttons that open 154-157
adding Home card buttons for 114-116
importing graphics from 329-330
opening from HyperCard 52-53
quitting 53
Search Paths card for 24-26

Arrow Keys in Text option. See Text Arrows option

Art Ideas stack 262-263

Authoring level, defined 19

Auto Hilite option 186187

Auto Tab option 216

B

Back command (Go menu)
Prev command vs. 35-36
for reviewing cards 48
background(s) 135-1306. See also background
buttons; background fields; background layer
adding buttons to 152-153
adding fields ro 207-208
adding graphics to 248-292
adding Paint text to 298-300




background(s) (continued)

changing color set for 146-148
checking number of 137
color sets for 96

adding 97-98, 273

changing 146-148, 273, 276-278
copying 140-141

when making new stack 88-90
copying buttons on the same 198
copying buttons to  199-200
copying ficlds on the same 236
copying fields to 236-238
copying graphics on the same 324-325
copying graphics to 325-326
creating new 138
exporting a snapshot of 330-331
getting information about 85, 142-143
locating fields on 220-221
moving between 139-140
moving buttons between 202-203
moving buttons from card to 200-201
moving fields between 240-242
moving fields from card to 238-239
moving graphics berween 328-329
moving graphics from card to 327
naming or renaming 143
number of cards in 137
protecting 145-146
for report, selecting 349, 350
repositioning buttons on 192-193
repositioning fields on 230
repositioning graphics on 327, 329
saving graphics on 323
selecting all graphics on 260
white area on, blank space vs. white paint 253
working with 136-149

background buttons. See also buttons

numbering of 194
and overlapping elements 193-197
reordering 195-196
Share Hilite option 187-189

370

Background command (Edit menu) 136
background fields. See also fields
changing appearance of 221-228
numbering of 232
and overlapping elements 231-235
placing in report template 352-355
reordering 233-235
Shared Text option for 219-220
tabbing through 215-216
background layer. See also background(s)
card layer vs. 63-65, 122, 193
when adding buttons 152-153
when adding fields 207-208, 209, 210
when adding graphics 248
when entering or editing text 219
when selecting graphics 253, 260 .
moving between card layer and 136-137
overlapping buttons in 195-197
overlapping fields in 231-235
overlapping graphics in 302-305
viewing 136
background picture 302-303
selecting 261
background script, viewing 85
backing up
importance of 10
when modifying stacks 79
Bkgnd Info command. See Bkgnd Info dialog box
Bkgnd Info dialog box 85, 142
Can't Delete option 145-146
changing color set with 146-147
checking number of backgrounds with 137 .
Don't Search option 144
excluding backgrounds from searches with 144
naming or renaming a background with 143
protecting a background with 145-146
shortcut for choosing 143
blank space
selecting graphic without 255, 257-259, 260
white paint vs. 253
Blind Typing option 24

Index
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A
access. See protecting a stack
adding buttons 157-166

to a card or background 152-153

to Home cards 112-116
adding button text 176
adding cards to stacks 122-125
adding fields 207-210
adding graphics 248-292
adding margins to fields 263-264
adding Paint text 298-301
adding search paths 26
.1dding text 206-207

to button 176

i@ld 50-52

with Paint Text tool 298-301
aligning graphics 295-296
alignment in fields, setting 217-218

Apple Preferred File Format, documents in

;ldding color sets from 273

menrring color sets from 278-279

importing graphics from 329-330
AppleShare network

custom icons and 167

launching HyperCard over 119

using stacks on 55
setting user access for 109-110
applications
adding buttons that open 154-157
adding Home card buttons for 114-116
importing graphics from 329-330
opening from HyperCard 52-53
quitting 53
Search Paths card for 24-26
Arrow Keys in Text option. See Text Arrows option
Art Ideas stack 262-263
Authoring level, defined 19
Auto Hilite option 186-187
Auto Tab option 216

B

Back command (Go menu)
Prev command vs. 35-36
for reviewing cards 48
background(s) 135-136. See also background
burtons; background fields; background layer
adding buttons to 152-153
adding fields ro 207-208
adding graphics to 248-292
adding Paint text to 298-300




background(s) (continued)

changing color set for 146-148
checking number of 137
color sets for 96

addirig 97-98, 273

changing 146-148, 273, 276-278
copying 140-141

when making new stack 88-90
copying buttons on the same 198
copying buttons to  199-200
copying helds on the same 236
copying, fields to 236-238
copying graphics on the same 324-325
copying graphics to 325-326
creating new 138
exporting a snapshot of 330-331
getting information abour 85, 142-143
locating fields on 220-221
moving between 139-140
moving buttons between 202-203
moving buttons from card to 200-201
moving fields between 240-242
moving fields from card to 238-239
moving graphics between 328-329
moving graphics from card to 327
naming or renaming 143
number of cards in 137
protecting 145-146
for report, selecting 349, 350
repositioning buttons on 192-193
repositioning fields on 230
repositioning graphics on 327, 329
saving graphics on 323
selecting all graphics on 260

white area on, blank space vs. white paint 253

working with 136-149

background buttons. See also buttons

numbering of 194

and overlapping elements 193-197
reordering 195-196

Share Hilite option 187-189

370

Background command (Edit menu) 136
background fields. See also fields
changing appearance of 221-228
numbering of 232
and overlapping elements 231-235
placing in report template 352-355
reordering 233-235
Shared Text option for 219-220
tabbing through 215-216
background layer. See also background(s)
card l;l_\_-'l.'l' vs. 03-05,122,193
when adding buttons 152-153
when adding fields 207-208, 209, 210
when adding graphics 248
when entering or editing text 219
when selecting graphics 253, 260 .
moving between card layer and 136-137
overlapping buttons in 195-197
overlapping fields in 231-235
overlapping graphics in 302-305
viewing 136
background picture 302-303
selecting 261
background scrip, viewing 85
backing up
importance of 10
when modifying stacks 79
Bkgnd Info command. See Bkgnd Info dialog box
Bkgnd Info dialog box 85, 142
Can't Delete option 145-146
changing color set with 146147
checking number of backgrounds with 137 .
Don't Search option 144
excluding backgrounds from searches with 144
naming or renaming a background with 143
protecting a background with 145-146
shortcut for choosing 143
blank space
selecting graphic without 255, 257-259, 260
white paint vs. 253
Blind Typing option 24

Index




sorders, drawing with patterns 291-292
Bring Closer command (Objects menu)
reordering a button with 195
reordering a field with 234
Browse tool
choosing 33
shortcut for 154
editing shared text with 219
editing text with 51, 211-213
locating buttons with 171
locating fields with 211, 221
locked field and 243
drowsing level, defined 19
rowsing methods 32-50
brus 4-266
srush'"hape dialog box 265
bucket 264
changing a graphic’s pattern or color with
310-311
positioning 268-269, 311
jutton Ideas stack 154-155
utton Info command. See Button Info dialog box
utton Info dialog box 81
adding text and icon with 164
assigning icon to button with 162
Auto Hilite option 186187
button numbers in 194
changing button color with 179-180
changing button style with 175
changing button text with 176
c ing or removing an icon with 177-178
choosing button style with 175
copying an icon with 168-169, 170-171
creating link with 181
creating text button with 159
Family menu, highlighting buttons with 189-190
highlighting button with 186-190
installing an icon with 168-171
making button opaque or transparent with 197
naming button with 191
opening a script with 203

Share Hilite option 187-189

Show Name option 191
varying highlighting among cards with 187-190

button names, Finder stack names vs. 27—-28
button numbers 194
burton(s) 66, 151, 152. See also background buttons;

card buttons

adding to card vs. background 152-153
adding to Home cards 112-116
assigning an icon to 177-178
changing colors for 179-180
changing an icon for 177-178

copying 198-200

from Button Ideas stack 154-157
creating 157-166

blank and transparent 157-158

with a graphic 165-166

with an icon 161-164

with icon and text 164

opaque or transparent 197

with text 158-161
deleting 204
disappearing 9
getting information about 80-81
highlighting 186-190
on Home cards 15-16, 112-116
linking to cards or stacks 112-116, 180-185
locating 171-172
making transparent or opaque 197
managing icons of 166-171
modifying 173-180

by adding, changing, or removing text 176

by choosing style 174-176

by resizing 160
moving to another card or background 202-203
moving from background to card 201
moving from card to background 200-201
moving through stacks with 38
naming or renaming 191-192
for opening applications 114116




button(s) (continued)
for opening cards or stacks 180-185
from Home cards 112-113
for opening documents 114-116
opening scripts of 203
overlapping, solutions to 195-197
readymade 67, 154-155
copying 154157
removing an icon from 177-178
|'L'm'u.lcring| 195196
reposttioning, 192-193
resizing 173
selecting 72
styles for 174176
text on. See button text
tools for working with 153-154
viewing 171-172
button text 206
'.ldding. ch:mging, or removing 176
combining with button icon 164
creating 158-161
setting or changing style of 176-177
Button ool 153
locating buttons with 80, 171-172
opening a script with 203
repositioning a button with 192-193
resizing a button with 173
shortcut for choosing 154, 209

C
card(s) 4. See also card fields; card layer
adding buttons to 152-153
adding fields to 207-208
adding graphics to 248-292
adding Paint text to 298-300
adding to stacks 122-125
color sets for 96
u.‘ldinb 98, 273
Lhangmg 133-134, 273, 275-276
copying 126
C(Jp},’ing l)llt[l]ﬂﬁ on Ijll’ s4Ine It)hl

copying buttons to 199-200
L“E"YI‘“I-, ficlds on the same 236
1.J.:pymi_r fields to 236-238
u:—pwng) graphics on the same 324-325
copying graphics to 325-326
deleting 135
exporting a snapshot of 330-331
flipping through 4243
;,L[[mg information about 84, 129
going back o 48-49
going (o .apt'n_'iﬁc 4143
Home 15-16. See alse Home cards
linking buttons to 180-185
locaring fields on 220-221
moving. See cards, repositioning
moving buttons to background from 200-201 .
moving buttons from background to 201
moving buttons between 202-203
moving buttons on 192-193
moving field to background from 238-239
moving field from background to 239-240
moving fields between 240-242
moving fields on 230
moving graphics to background from 327
moving graphics between 328-329
moving graphics on 292-293
naming 130
printing 336-340

creating template for 343-348

from current card template 348
protecting from deletion 132-133 .
rt:pnsi[inning 127-128
repositioning graphics on 329
a.lwnE graphics on 323
viewing quickly 42-43
white area on, blank space vs. white paint 253

working with 122-135

card buttons. See also buttons

numbering of 194
and overlapping elements 193-197
recordering 195-196

Index




card fields

changing appearance of 221-228
numbering of 232
and overlapping elements 231-235
reordering 233-235
tabbing through 215-216
Card Info command. See Card Info dialog box
Card Info dialog box 84, 129
Can't Delete option 132-133
changing color set with 133—134
Don't Search option 131
excluding fields from searches with 131
naming or renaming a card with 130
protecting a card with 132-133
scripting a link with 183
’ortcm for choosing 129
card layer. See also card fields; card(s)
background layer vs. 63-65, 122, 193
when adding buttons 152-153
when adding fields 207-208, 209, 210
when adding graphics 248
when entering or editing text 219
when selecting graphics 253, 260
moving between background layer and 136-137
overlapping buttons in 194-197
overlapping fields in 231-235

overlapping graphics in 302-305

card picture 302-303

adding to report template 350, 352-355
printing in report 340-343
selecting 261

ciggscript, viewing 84
card templare(s) 336

copying within the same stack 361
creating 343-348

deleting 362

editing 338

exporting to another stack 360
footer for 347

header for 345-346

naming 344

renaming 361-362

selecting 337-338

L‘il;m;:;:.'s. protecting a stack from 103-105
changing a burton’s icon 177-178
chunging button text 176
changing colors

for a button 179-180

for a field 227-228
changing color sets 272-279

for a background 146148, 276-278

foracard 133-134, 275-276

for a stack 95-98, 274-275
changing a field’s appearance 221-228
changing a graphic’s appearance 305-317
changing a Home card’s appearance 118
check box button

Auto Hilite and 186

Share Hilite and 187
Choose ColorSet (Options menu) 275, 277
circles, drawing 281-283
Clear Button command (Edit menu) 204
Clear Field command (Edit menu) 245
Clear Picture command (Edit menu) 332
clicking buttons to move around 38
clicking text 39
Clipboard operations

copying a button 169, 199

copying a card 126

copying a field 237

copying a graphic 326

moving a button 200-202

moving a card 127, 128

moving a field 238-241

moving a graphic 327, 328
closing a stack 31
color (Patterns palette)

changing 309-313

double-clicking, effects of 322
Colors dialog box

changing button colors with 179-180

changing background colors with 146148,

276-278
changing card colors with 133—134, 275, 277
changing field colors with 227-228

changing stack colors with 96-97, 147-148, 274




color set 95, 272
adding 273
changing 272-279
for a background 146-148, 273
for a card 133-134, 273, 275-276, 276-278
for a stack 95-98, 274-275
for imported graphics 330
importing from a document 278-279
Command key, using with Paint tools 321
Compact Stack command (File menu) 31, 100
Content dialog box, for report template 350-356
Copy Button command (Edit menu) 169, 199
Copy Card command (Edit menu) 126
for creating miniature card 331
Copy Field command (Edit menu) 237
copying a background 88-90, 140-141
copying a button 198-200
from Button Ideas stack 154-157
copying a card 126
copying a field 236-238
copying a graphic 324-326
that comes with HyperCard 262-263
copying an icon 167, 168-171
copying a stack 98-99
copying a template
to another stack 360
within the same stack 361
Copy Picture command (Edit menu) 262, 326
Copy Text command (Edit menu) 301
correcting mistakes 87
with Brush 265
with Bucker 269
with Eraser 264, 332
in graphics operations 263-264, 332
in inw—lm-m-::ry conditions 319
with Spray tool 267
in text entry 52, 217
undeleting a card 135
Create QuickLink button 113
creating a background 138

creating a button. See buttons, creating

creating a card template 343-348
creating a field 209-210
creating a graphic 248-292
opaque or transparent 303-305
creating an icon 167
creating links 180-185
with Link To method 181-182
by scripting 183-185
creating a miniature picture of a card 331
creating Paint text 298-300
creating stacks. See stacks, creating
crosshair pointer
drawing circles, ovals, or rectangles with 281-282
drawing an irregular polygon with 285-286
drawing lines or free-form shapes with 280
drawing polygons with 283-285 .
selecting a graphic with 254-255, 257-258
Curve tool
Draw Filled option with 289-290
drawing with 280
customizing the Home stack 111-119
Cut Button command (Edit menu) 200, 201, 202
Curt Card command (Edit menu)
adding new first card with 124-125
copying a background with 140
moving a card with 127, 128
Cut Field command (Edit menu) 238, 239, 241
Cut Picture command (Edit menu) 327, 328

D
Delete Card command (Edit menu) 135 .
deleting a background with 148-149
Delete command (Templates menu) 362
Delete key, correcting mistakes wich 87
Delete Stack command (File menu) 110-111
du|uling. See also correcting, mistalkes; removing
a background 148-149
a button 204
button text 176
acard 135

a card template 362




deleting (continued)
d ﬁcld 245
a graphic 332
with Brush 265
with Eraser 264, 332
with Spray tool 267
a report template 362
scripts 91
search paths 26
astack 110-111
text 217
deletion
protecting a background from 145-146
protecting a card from 132-133
protecting a stack from 104-105
desk @i¥essory, adding a color set with 273
to a background 148
to a card 134, 276, 278
to a stack 98
directory, Home cards as 15
directory dialog box 11, 25
Don't Search option 46
{ouble-clicking, as error 38
louble-clicking Paint tools, patterns, or colors 322
Draw Centered option (Options menu)
circles, ovals, or rectangles with 282
lines or free-form shapes with 281
Draw Filled option (Options menu) 288-290
for filled shapes without borders 292
drawing, using pencil for 287
drawing lines and shapes 279-292
c‘s, ovals, and rectangles 281-283
with different line widths 290-291
filled with patterns 288-290
line or free-form shape 280-281
in multiples 293-295
polygons 283-286
Draw Multiple option (Options menu) 293-294
Draw Outlined option (Options menu) 283
luplicating. See copying

editing a graphic 305-317
editing an icon 167
editing text 52, 211-218

correcting mistakes 87

Edit menu commands

Background 64-65, 136

Clear Button 204

Clear Field 245

Clear Picture 332

Copy Button 169, 199

Copy Card 126
for miniature picture of card 331

Copy Field 237

Copy Picture 262, 326

Copy Text 301

Cut Button 200, 201, 202

Cut Card
adding new first card with 124-125
copying a background with 140
moving a card with 127, 128

Cur Field 238, 239, 241

Cur Picture 327, 328

Delete Card 135
for deleting a background 148-149

New Card
adding card with 123, 124
copying a background with 140, 141

Paste Button 169, 199-202

Paste Card
adding new first card with 125
copying a background with 141
copying a card with 126
creating miniature card with 331
making card first in stack with 128
moving a card with 127, 128

Paste Field 237, 240, 241

Paste Picture 263, 326, 327, 328-329

Paste Text 301




Edit menu commands (continued)
Text Style
choosing button text formar with 176177
choosing field text format with 217-218
with Paint text 298-299
Undo 87
low memory and 318
Revert command vs. 323
undeleting a card with 135
undeleting field text with 217
undeleting a graphic with 263, 332
user level and 20
Edit Partern dialog box 271
Edit Template command (Templates menu)
modifying a card template with 344-348
modifying a report template with 349, 357-359
selecting cards for printing 338
selecting cards for report 341-342
clements, overlapping
buttons 194-197
fields 231-235
graphics 302-305
entering and editing text in fields 50-52,211-218
and Text Arrows option 213
Eraser, deleting a graphic with 264, 332

error correction; erasing, See correcting mistakes;

deleting
error messages 78—79
Esc key
going to last card seen with 48
for Undo command, with Paint tools 87, 263, 332

evaluating stacks 76-77
Export command (Templates menu) 360
Export Paint command (File menu) 330-331

F
Family menu, highlighting buttons with 189-190
FatBits option (Optinm menu) 306307
hield(s) 66, 205, 206
adding to card or background 207-210
adding margins to 263-264

changing appearance of 221-228
changing colors for 227-228
;.n|!'-_,’int_r_ 2306238
creating 209-210
deleting 245
disappearing 9
displaying lines in 226-227
entering and editing text in 50-52, 211-218
getting information about 83
locating 220-221
|Uclcing and unIuL‘king 242-243
making opaque or transparent 235
moving to another card or background 240-242
moving from background to card 239-240
moving between 214-216
moving from card to background 238-239 .
naming 228-229
numbering of. See field numbers
overlapping of, solutions to 233-235
peeking at 221
preventing word wrap in 212
printing text in 340-343
protecting 242-244
reordering 233-235
repositioning 230
resizing 222-223
for viewing hidden text 212
searching for text in 45-46, 47
exclusions when 46, 131-132, 244
selecting 73
h[)'lt}. fht' 223—224
tabbing through 214-216 .
tools for working with 208-209

Field Info command. See Field Info dialog box
Field Info dialog box 83

adding margins with 225-226
Auto Tab option 216
changing field colors with 227-228

checking field number with 215
choosing text format with 217

displaying lines in field with 226-227

Index




Field Info dialog box (continued)
Don't Search option 244
Shared Text option and 220
Lock Text option 242-243
making a field opaque or transparent with 235
naming a field 229
protecting field from search with 244
Shared Text option 219-220
Show Lines option 226-227
Wide Margins option 225-226
field names, choosing 228-229
field numbers 194
reordering fields and 234
tabbing order and 215
field size, changing 222-223
ficld@yle, changing 223-224
field text 206
adding to cards 50-52
changing to Paint text 300-301
choosing look of 217-218
clicking 39
copying a field with 236-238
copying a field without 236
correcting mistakes in 87, 217
creating fields for 209-210
entering and editing 50-52, 222-218
and Text Arrows option 213
on every card 219-220
hidden, viewing 212
moving through 21-22
plgcing in report template 354-355
p‘ing reports using 340-343
Shared Text option, for background fields
219-220
Field tool 208-209
locaring fields with 82, 220
repositioning a field with 230, 233
resizing a field with 222
File menu commands
Compact Stack 31, 100
Delete Stack 110-111
Export Paint 330-331

Import Painc 278-279, 329
New Stack 89
Open Stack
closing a stack with 31
gerring to Home stack with 26
moving to another stack with 48
opening a stack with 27, 28-29
Print
copying a template with 361
creating a card template with 343
creating a report template with 348
deleting a template with 362
exporting a template with 360
renaming a template with 361-362
report from current stack 340
Print Card 336
Protect Stack. See Protect Stack dialog box
Quit HyperCard 31, 57
Save A Copy 98-99
user level and 20
files, finding 10-11, 24-26
file server
setting user access for stacks on 109-110
using stacks on 55
Fill command (Paint menu)
changing a graphic’s pattern or color 309-310
filling arca with pattern or color 269-270
filled shapes, drawing 288-290
without borders 292
Find command (Go menu)
finding text with 43-46
searching a specific field with 45-46
Finder
changing stack name in 94
copying a stack in 99
HyperCard icons and 13-14
finding buttons 171-172
finding a file
directory dialog box for 11, 25
Search Paths cards for 24-26
finding text. See searching for text
finding a transparent field 211

Index
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Find Whole command 4647
First command (Go menu) 35

making card first in stack with 124, 128
Flip Horizontal command (Paint menu) 316-317
flipping a graphic 316-317
Hipping through cards 4243
Flip Vertical command (Paint menu) 316-317
font, setting 217-218
Font menu, for report template 354-355
font size, choosing 217-218
Footer dialog box

for card template 347

for report template 358-359
FI'YPE.HyperCard 13

G
General tools 68, 69
Go menu commands 34-36
Back
Prev vs. 35-36
reviewing cards with 48
Find 4346
searching a specific background field with
45-46
searching for a whole word or phrase with
4647
First 35
making card first in stack with 124, 128
Help 53
Home 26, 50
icons for 36-37

Last 35

Message. See Message box
Next 35

Prev, Back vs. 35-36
Recent 49

Show All Cards 42
Go palette, moving through stacks with 36-37
graphic(s) 66

adding to card or background 248-292

adding to card template header or footer 346, 347

378

adding to Home cards 118
adding to report template 350, 352-355
in header or footer 357, 358
aligning 295-296
changing appearance of 305-317
by changing pattern or color 309-313
by flipping vertically or horizontally 316-317
by inverting 313
by outlining 314
by rotating 90° 315-316
changing color of 309-313
changing pattern of 309-313
changing size of 308
color sets and 95, 272
changing 272-279
with imported picture 330 .
combining options for 297
copying 324-326
to another card or background 325-326
readymade graphics 262-263
on same card 324-325
creating 248-292
opaque or transparent 303-305
creating buttons with 165-166
creating your own patterns for 270-271
deleting 332
drawing lines and shapes 279-292
circles, ovals, and rectangles 281-283
with different line widths 290-291
filled with patterns or colors 288-290
line or free-form shape 280-281
in multiples 293-295 .
polygons 283-286
drawing patterned or colored borders 291-292
editing 305-317
filling with patterns or colors 267-270, 288-290
flipping 316-317
importing 329-330
magnifying for editing 305-307
making opaque or transparent 303-305
miniature pictures of cards 331
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graphic(s) (continued)
moving 292-293
to another card or background 328-329

on specific cards 187-189
Home cards 15-16
adding buttons to 112-116

from card to background 327
outlining 314
overlapping, solutions to 303-305
painting with Brush 264-266
painting with Bucket 267-269, 310-311
painting with Spray tool 266-267
with Paint text. See Paint text
readymade 67, 262-263
repositioning 263, 292-293, 303, 326
reverting to last version of 323-324
rotating 315-316
sggng on card or background 323
.siting 74, 253-261
all in current layer 260
after creation 259
entire card or background picture 261
nonrectangular area 255-257
rectangular area 254-255
without white space 255, 257-259, 260
special effects with 293-297
text with. See Paint text
tools for working with 249-253
using modifier keys for 321
using power keys for 319-320
white paint for 253
working with 247-332
Grid option (Options menu) 295-296

]I.

hardware requirements 6-7
Header dialog box
for card template 345-346
for report template 357-358
help, getting 53-54
Help command (Go menu) 53
hidden buttons, locating 172
hidden field text, viewing 212
hidden menu bar, viewing 32

highlighting, adding to buttons 186-190

buttons on 15-16, 112-116
changing appearance of 118
renaming 117-118
returning to 50

Home command (Go menu) 26, 50
Home stack 14-26

as Apple IIGS control center 119
copying a button from 170-171
customizing 111-119

deletion warning 15

going to (Home command) 26, 50
installing an icon in 167, 168-169
locating 11

Search Paths card 24-26

startup and 10-11, 119

User Preferences card 17-24

house icon, getting to Home stack with 26, 50

HyperCard

with CD-ROM 56
getting help in 53-54
hardware requirements for 6-7
help sources. See HyperCard Help stack
Home stack required for 1415
installing 9-10
Finder and 13-14
introduction to 1-6
layers of elements in 193—-194
in network environment 55
opening applications from 52-53
quitting 57
readymade elements in 67. See also specific elements
running from locked disk 56
software requirements for 7
starting 10-13
starting Apple IIGS with 119
uses for 2-3

HyperCard Help stack 53-54

f f y,‘wr( -.‘.f.*;"rf f ff " Jrffl’ﬁ‘r."m'r’ VA, EJfI
readymade button for 155
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HyperCard.Icons file 13
HyperTalk 2, 63
adding a color set with 273
by, %9 backergund 148
to acard 134, 276, 278
to a stack 98
help sources 5354
printing options with 333

[, ]
icon(s)
assigning to buttons 161164, 177-178
copying 167, 168-171
creating 167
creating buttons with 161-164
Finder and 13-14
installing
by copying and pasting a button 168-170
managing 166-171
removing from buttons 177-178
5c|c£[ing, sclcuing gr;lphic vs., 254
lcon dialog box 162-163
changing or removing an icon with 177-178
copying a button with 168, 170
lcon Editor stack, role of 167
[mageWriter, Print dialog box for 339
importing a graphic 329-330
Import Paint command (File menu) 278-279, 329
installing HyperCard 9-10
Finder and 13-14
installing an icon
by copying and pasting a button 168-170
with [con dialog box 170-171
Invert command (Paint menu) 313

K

Keep command (Paint menu), 323
low memory and 318

keyboard shortcuts. See also specific tasks
for choosing wols 209

o

480

for Go menu 36-37
Power Keys option 319-320
for J'L't_nl'dt:ring hields 234

L
labels, printing 359
LaserWriter
Print dialog box for 339
printing labels on 359
Lasso, selecting graphics with 74, 256-260
all in current layer 260
entire card or background picture 261
Last command (Go menu) 35
layers. See background layer; card layer
layout for report 351-352 .
previewing 356
lines
displaying in a field 226-227
drawing 280-281
patterned, drawing 291-292
varying width of 290-291
Line Size dialog box (Options menu) 290-291
line spacing, setting 217-218
Line tool
choosing 280
drawing with 280-281
line width, selecting 290-291
linking information 6
creating buttons for 180-185
by Link To method 181-182
by scripting 183-185 .
using Create QuickLink button for 113
stack renaming and 94
Link To box 181-182
locating buttons 171-172
locating fields 220-221
locked disk, running HyperCard from 56
locked stacks 13
making changes to 105
using on file server 55, 109-110
) I

locking and unlocking fields 242-243
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Juu!-&mg back rhruu;h cards seen ILLenrfy 48-49
|uuL|m_: at scripts 203
looking through stacks. See moving through stacks

M
magnifying a graphic for editing 305-307
mailing labels, printing 359
managing icons 166—171
margins
adding to fields 263-264
adjusting for report 351
memory
checking 7-8
low
aint tools and 318-319
symptoms of 8-9, 318
working with 9, 319
requirements 6, 7
menu bar
in background layer 136
viewing hidden 32
menus. See also specific menus
hidden 32
with Paint tools 251-253
stack 32
Message box
and Find command 43-44, 45-46
and Find Whole command 47
getting help with 53
getting to Home stack with 26
g to card with 41-43
moving to another stack with 48
moving between backgrounds with 139-140
moving through stacks with 42-43
opening an ;1pp|ic;uiun from 52-53
opening a stack from 27, 28
returning to Home stack with 50
miniature picture of card, creating 331
mistakes. See correcting mistakes
modifier keys, using with Paint tools 321

modifying a button’s appearance 173-180
modifying an icon 167
modifying stacks 78-87
promcriun from 103-10
Imwmg:, back through urds seen recently 48-49
m«:w;ng1 between b.i{.k%munds 139- 140
moving a button 200-203
to another card or background 202-203
from |:-.1L|-;g;ruund to card 201
from card to background 200-201
moving a card 127-128
moving a field 230
to another card or background 240-24
from background to card 239-240
from card ro background 238-239
moving a graphic 292-293
to another card or background 328-329
from card to background 327
moving a template 360
moving through fields 214-216
moving through stacks 21-23, 32-50
with arrow keys 39-40
by clicking buttons 38
by clicking text 39
by flipping through cards 42-43
with Go menu 34-36
with Go palette 36-37
with Message box 4243
reviewing cards viewed 48-49
by searching for text 43-47
moving through text 21-22
from one field to another 214-216
Text Arrows option for 213
multiple lines or shapes, dmwing 293-295

N

naming a button 191-192

naming a card 130

naming a field 228-229

naming or renaming a background 143

Index



naming a stack 93-94
network
custom icons and 167
launching HyperCard over 119
low-memory symptoms with 8-9, 318
using stacks on 55
New Background command (Objects menu) 138
New Button command (Objects menu)
creating a button with an icon 161
creating a button with text 159
New Button (Objects menu) 114-116
New Card command (Edit menu) 123, 124
copying a background with 140, 141
New Field command (Objects menu) 209-210
New Stack command (File menu) 89
New Srack dialog box 89-90
New Template command (Templates menu) 344,
348-349
Next command (Go menu) 35
nonrectangular graphic, selecting 255-257

O
Objects menu commands
Bkgnd Info dialog box 85, 142
changing color set with 146-147
checking number of cards that share
background 137
naming or renaming a background with 143
protecting a background with 145
search exclusions with 144
Bring Closer command
reordering a button with 195
reordering a field with 234
Button Info dialog box 81
changing button style with 175
changing button text with 176
creating a text button with 159
installing an icon with 168-171
making button opaque or transparent with 197
naming a button with 191
opening a script with 203

382

Card Info dialog box 84, 129
changing color set with 133—134
naming or renaming a card with 130
protecting a card with 132-133
scripting a link with 183
search exclusions with 131
examining stacks with 80
Field Info dialog box 83
adding margins with 225-226
changing field style with 223-224
L‘htmsing text format with 217
displaying lines in field with 226-227
locking a field with 242-243
making a field opaque or transparent with 235
naming a field with 229
protecting field from search with 244 .
New Background command 138
New Button command 114-116
creating a button with an icon 161
creating a button with text 159
New Field command, for creating a field 209-210
Send Farther command
reordering buttons with 195
reordering fields with 234
Stack Info dialog box 86, 92
changing color set with 96-97, 274-275
checking free space with 100
checking number of backgrounds with 137
opaque burtons, changing to transparent 197
opaque fields, creating 235
opaque graphics, creating 303-305
opening an application program 52-53 .
adding a button to Home card for 114-116
opening a button’s script 203
opening a document 52-53
adding a button to Home card for 114-116
opening HyperCard 10-13
at startup 119
opening a stack 27-30
adding button to Home card for 112-113
closing old stack and 31
locked 30
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opening a stack (continued) Painting level, defined 19
pening &

with a password 29 and Power Keys option 24
readymade buttons for 155 Paint menu commands
Open Stack command (File menu) 27, 28-29 Fill 269-270
closing a stack with 31 changing a pattern with 309-310
getting to Home stack with 26 Flip Horizontal 316-317
moving to another stack with 48 Flip Vertical 316-317
Option key Invert 313
copying a button with 198 Keep 323
copying a field with 236 low memory and 318
using with Paint tools 321 Opaque 304
Options dialog box, adjusting printing options in Pickup 311-313
339, 342-343 Revert 319, 323-324
Options menu Rotate Left 315-316
Brush Shape command 265 Rotate Right 315-316
(gmose ColorSet 275, 277 Select 258, 259, 260
cOmbining options in 297 Select All 261
Draw Centered option 281, 282 Trace Edges 314
Draw Filled option 288-290 Transparent 304
Draw Multple option 293-294 Paint text 206, 298
Draw Outlined option 283 adding 298-301
Edit Pattern command 271 changing field text to 300-301
FatBits option 306-307 choosing a format for 298-299
Grid option 295-296 preset format for 298
Line Size command 290-291 Paint Text tool
Polygon Sides command 283-284 choosing 298
Power Keys option 319-320 power keys disabled with 320
outlining a graphic 314 Paint tools 68, 69, 249-251. See also specific tools
ovals, drawing 281-283 choosing 71
Oval tool 281 double-clicking, effects of 322
overlapping elements, solutions to Grid option and 296
t*ns 195-197 low-memory conditions and 9, 318
fields 233-235 menus with 71, 251-253
graphics 303-305 for special effects 293-297

Tilde (-) key with, 263, 332
using modifier keys with 321

])

rassword
padlock in menu bar, for locked stacks 30, 79, 105 F opening a stack with 29
Page Setup dialog box, selecting printing options in removing 108—109

334-336

g . : _ setting 101-102
Paint file, importing a color set from 278-279 =

user level };L’tring, and 106, 107
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Paste Button command (Edit menu) 169, 199-202
Paste Card command (Edit menu)
adding new first card with 125
copying a background with 141
copying card with 126
creating miniature card with 331
making card first in stack with 128
moving a card with 127, 128
Paste Field command (Edit menu) 237, 240, 241
Paste Picture command (Edit menu) 263, 326-329
Paste Text command (Edit menu) 301
patterns, changing 309-313
Patterns menu
changing or creating a pattern on 270-271
L'ht)(]h’illg a pattern from 268, 269, 288, 291
editing a pattern on 270-271
tearing off 252
Patterns palette 252-253
L_'h-:msing a pattern from 288, 291
shortcur for showing or hiding 252
peeking
at buttons 171-172
at fields 221
Pencil
drawing with 281, 287
editing a graphic with 307
phrase, searching for 4647
Pickup command (Paint menu) 311-313
picture insert, adding to report template 350,
352-355
pictures. See background picture; card piciure;
graphics
planning a stack 75
Plll.l'lfl._'l'f'i
arrow
with Button tool 157
copying a graphic with 325
moving a graphic with 292-293
Brush shape 265
Bucket
L'h'.mg'lng, a I_{I';l]_1|]ii:‘$ pattern or color with
310-311

positioning 268-269, 311

crosshair
drawing circles, ovals, or rec tangles with
281-282

drawing an irregular polygon with 285-2806
drawing lines or free-form shapes with 280
drawing polygons with 283
selecting a graphic with 254-255
I-beam 51
adding Paint text with 298
editable field shown by 211, 212
for editing text 51, 52
failure to appear 212-213
locked field and 243
Spray tool 266
Tools palette and 70 .
polygons, dr'.lwing 283-286
Polygon Sides dialog box 283-284
choosing shape in 283-284
Polygon ool
choosing 285
Draw Filled option with 289-290
drawing with 285-286
Power Keys option 23, 319-320
power lit_'}’!i listed 320
Prev command (Go menu), Back command vs.
35-36
Preview dialog box, checking report layout with 356
Print Card command (File menu) 336
Print dialog box
choosing a card template with 337
choosing a report template with 341 .
copying a template with 361
creating a card template with 343-348
creating a report template with 348-359
deleting a template with 362
exporting a template with 360
printing all or range of cards with 337-340
printing cards in stack with 337-340
printing a report with 340-343
renaming a template with 361-362
printer driver required 7
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printing 333-359
card pictures 340-343
cards 336-340
creating template for 343-348
entire stack 336-340
single 336
specific 3306, 338
field text 340-343
mailing labels 359
Page Setup options for 334-336
preparing for 334-336
reports 340-343. See also report templare(s)
Private Access check box 101
protected cards, deleting 135
protected stacks

t"ning 30
trying to delete 111

types of 101
protecting a background from deletion 145-146
protecting a card from deletion 132-133
protecting a stack 101-110

from changes or deletion 103-105

on a file server 109-110

by limiting user level 106108

with a password 101-102
Prorect Stack dialog box

limiting user level with 106-108

preventing changes or deletion with 103-105

removing a password with 108

restricting access with 101-102

setting file server access with 109, 110

..ng password with 101-102

Q
Quit HyperCard command (File menu) 57
for closing stack 31

R

radio button
Auto Hilite and 186
Share Hilite and 187

RAM icon, checking memory with 7-8

readymade buttons 67, 154-155
copying 154-157

readymade graphics, copying 262-263

Recent command (Go menu) 49

rectangles, drawing 281-283

Rectangle tool 281

rectangular area of graphic, selecting 265-255

Regular polygon wol 283-285

removing button text 176

removing an icon 177-178

removing a password 108-109

removing search paths 26

renaming a background 143

renaming a button 191-192

renaming a card 130

renaming a field 228-229

renaming a Home card 117-118

renaming a stack 93-94

renaming a template 361-362

reordering buttons 195-196

reordering cards. See repositioning cards

reordering fields 233-235

reordering graphics. See repositioning graphics

reports, printing 340-343, See alsoreport templare(s)

report template(s) 336, 340, 343
copying within the same stack 361
creating 348-359
deleting 362
editing 341-342
exporting to another stack 360
for mailing labels 359
naming 349
previewing cell layout for 356
renaming 361-362
saving 359
selecting 341
specifying content for 350, 352-356
specifying footer for 358-359
specifying header for 357-358
specifying layout for 351-352

repositioning buttons 192-193

Index




repositioning cards 127-128
repositioning fields 230

rcpnxhiuniilg gr'uph]u& 263, 292-293, 303, 326

after copying 326
after moving 327, 329
resizing a button 173
to show text 160
resizing a field 222-223
for viewing hidden text 212
ru.ai;-‘.lntt; a gruplﬂu 308
resource fork, icons stored in 167
restoring a graphic 323-324
restricting access. See protecting a stack
Revert command (Paint menu) 319, 323-324
Rotate Left command (Paint menu) 315-316
Rotate Rjghr command (Paint menu) 315-316
rotating a graphic 315-316
Rounded Rectangle ol 281

\
Save A Copy command (File menu) 98
Save A Copy dialog box 98-99
saving graphics 323
saving a report template 359
saving a stack copy 98-99
scanned graphics, as card element 66
scanner, importing gr;lpllics via 329-330
Scripting level, defined 19
Blind Typing option 24
scripts 63
background, viewing 85
button, viewing 81, 203
button name changes and 192
card, viewing 84
copying, error messages and 91
creating links with 183-185
deleting 91
field, viewing 83
field name changes and 229
for linking 183—185
pre-programmed 154

380

stack, viewing 86
stack modification warning 78-79
viewing 80-86, 203
Scrolling field style, in Field Info dialog box 224
searching for text 43-47
exclusions when 46, 131, 143—144, 244
nint text excluded from 300
Shared "Text option and 220
in a specific field 4546, 47
speeding up 45
stopping 44
for whole word or phrase 4647
search p;nhs 25
Search Paths cards 24-26
Select All command (Paint menu) 261
Select command (Paint menu) 258, 259, 260
sclecting a button 72 .
selecting a field 73
selecting a graphic 74, 253-201
all in current layer 260
after creation 259
entire card or background picture 261
nonrectangular area 255-257
rectangular area 254-255
selecting an icon vs. 254
without blank space 255, 257-259, 260
selecting an icon, selecting a graphic vs. 254
selecting a pattern 253
selecting printing options 334-336, 339
selecting text format 217-218
Selection tool 74, 254, 257, 261
Send Farther command (Objects menu) .
reordering buttons with 195
reordering fields with 234
Set Password burton (Protect Stack dialog box) 101
shapes
drawing
circles, ovals, and rectangles 281-283
free-form 280-281
polygons 283-286
drawing patterned borders for 291-292
filled, drawing without borders 292

Index




Shared Text option, making text appear on every card

with 219-220
Share Hilite option 187189
Shift key, using with Paint tools 321
Show All Cards command (Go menu) 42
size of button, changing 173
size of field, changing 222-223
size of graphic, changing 308
software requirements 7
special graphic effects 293-297
Spray tool 264
painting with 266-267
Spray tool pointer 266
stack(s) 5-6
adding cards to 122-125
h‘up, importance of 10
cM®remplates for, saving 348
on CD-ROM 56
changing name of 93-94
closing 31
color ser for, changing 95-98, 274-275
compacting before closing 31
copying buttons between 167, 168-171
copying a template within 362
creating 59-78
card layer vs. background layer 63-65
by copying from other stacks 88-91, 90-91
evaluation while 76-77
by modifying existing stacks 78-87
planning 75
scripts for 63
pps in 88-91
ools for 68-71
creating new backgrounds for 138
dt‘]ﬂing 110-111
examining parts of 80-86
exporting a template to 360
on file server 55
getting information about 86, 92
icons for 5

links between 6
L'ruutjng 180185

locating buttons in 171-172
locked 13
making a card first in 128
modifying 78-87
moving between 48
moving a card in 127-128
moving a template between 360
moving through 21-23, 32-50
with arrow keys 39-40
with buttons 38
by clicking text 39
by flipping through cards 4243
with Go menu 34-36
with Go palette 36-37
with Message box 42-43
reviewing cards viewed 48—49
by searching for text 43-47
naming or renaming 93-94
opening 27-30
adding a burton to Home card for 112-113
readymade buttons for 155
planning 75
printing all cards in 336-340
printing options saved with 335
protecting 101-110
from changes or deletion 103-105
on a file server 109-110
by limiting user level 106-108
from unauthorized access 101-102
readymade elements in 67
readymade graphics from, copying 262-263
reclaiming free space in 99-100
renaming 93-94
report templates for 340
creating 348-359
saving 359
selecting 340-342
repositioning cards in 127128
sample 60-63
saving a copy of 98-99
scripts and 63




stack icons 5
startup from 12
Stack Info command. See Stack Info dialog box
Stack Info dialng box 86,92
changing color set with 96-97
for a stack 274-275
checking free space with 100
x_'iu:c]{ing number of l)LtLIiEI__[I'LILi]ILi.‘: with 137
shortcut for -_Jmming‘ 92
stack menus 32
stack names, in Finder vs. on button 27-28
stack script, viewing 86
starting HyperCard 10-13
at Apple 11Gs startup 119
Startup [nfo Llinlmg box (.'\p])IL'Sl‘ull'c network) 119
style of button, choosing 174-176
style of button text, setting 176-177
style of field, changing 223-224
style of field text. See text format
Style menu
choosing button style with 175-176
choosing field text format with 218
choosing field style with 224
setting button text with 176
system software requirements 7

[ab key, moving through helds with 214-216
reordering fields and 234
tcmpidtc(s). See card template(s); report template(s)
Template dialog box
choosing cards to print with 338
creating a card template with 344-348
Templates menu commands
Delete 362
Edit Template 338, 341-342
creating a card template with 344-348
creating a report template with 349, 357-359
Export 360
New Template 344, 348-349
testing a button 157

after copying 200
after moving 203
testing a link 182, 185
text. See also button text; field text; Paint text
Arrow Keys in Text option 21-23, 3940, 213
combining with an icon 164
creating a button with 158-161
formatting. See text format
role of 205
searching for 4347
exclusions when 46, 131, 143-144, 244
Paint text excluded from 300
Shared Text option and 220
types of 206
determining 212
Text Arrows option 21-23, 39-40
moving through text with 213 .
text fields. See field(s)
text format
choosing 217-218
for Paint text 298-299
specifying in report template 354-355
Text Style dialog box
for button text style 176177
for chmmng field text formar 217-218
3

for Paint text 298-299
shortcut for opening 217
text style. See text format
Tilde (-) key
for looking [hmugj] cards viewed 48

for undeleting a graphic 263, 332 .

Tools menu G8-71. See also a}}f’c‘{:ﬁc' tools

choosing a border tool from 292

Draw Filled option and 289

shortcuts
for choosing General tools 154, 209
for painting commands 320

tearing off 70

for working with buttons 72, 1531 54

for working with fields 73, 208-209

74, 249-253

for working with ::;J'.'lphit_'s




Shared Text option, making text appear on every card locating buttons in 171-172

with 219-220 locked 13
Share Hilite option 187-189 making a card first in 128
Shift key, using with Paint tools 321 modifying 78-87
Show All Cards command (Go menu) 42 moving between 48
size of button, changing 173 moving a card in 127-128
size of field, changing 222-223 moving a template between 360
size of graphic, changing 308 moving through 21-23, 32-50
software requirements 7 with arrow keys 39-40
special graphic effects 293-297 with buttons 38
Spray tool 264 by clicking text 39
painting with 266-267 by flipping through cards 42-43
Spray tool pointer 266 with Go menu 34-36
stack(s) 5-6 with Go palette 36-37
adding cards to 122-125 with Message box 42-43
bﬁup, importance of 10 reviewing cards viewed 48-49
co® templates for, saving 348 by searching for text 4347
on CD-ROM 56 naming or renaming 93-94
changing name of 93-94 opening 27-30
closing 31 adding a button to Home card for 112-113
color set for, changing 95-98, 274-275 readymade buttons for 155
compacting before closing 31 planning 75
copying buttons between 167, 168-171 printing all cards in 336-340
copying a template within 362 printing options saved with 335
creating 59-78 protecting 101-110
card layer vs. background layer 63-65 from changes or deletion 103-105
by copying from other stacks 88-91, 9091 on a file server 109-110
evaluation while 76-77 by limiting user level 106-108
by modifying existing stacks 7887 from unauthorized access 101-102
planning 75 readymade elements in 67
scripts for 63 readymade graphics from, copying 262-263
psin 88-91 reclaiming free space in 99-100
ools for 68-71 renaming 93-94
creating new backgrounds for 138 report templates for 340
deleting 110-111 creating 348-359
examining parts of 80-86 saving 359
exporting a template to 360 selecting 340-342
on file server 55 repositioning cards in 127-128
getting information abour 86, 92 sample 60-63
icons for 5 saving a copy of 98-99
links berween 6 scripts and 63

LL‘L‘;iljllg 180-185
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[ools palette Blind "lyping option and 24

choosing a tool from 70-71 Compact Stack command and 31
creating 70 File and Edit menus with 20
Trace Edges command (Paint menu) 314 limiting 106-108
transparent buttons listed 19
changing opaque buttons to 197 Power keys option and 23
creating 157-158 setting or changing 17-18
transparent fields User Preferences card vs. stack 21
changing opaque fields to 235 User Preferences card 17-24
creating 210 Arrow Keys in Text option 21-23, 39
finding 211 Blind Typing option 24
transparent graphics, creating 303-305 Power Keys option 23, 319-320
[yping level, defined 19 stack user level vs. 21
ryping mistakes, correcting 87. See also correcting
mistakes

v
_ viewing cards quickly 4243

[ viewing cards seen recendy 48-49

undeleting a card 135 viewing scripts 80-86, 203

undeleting field text 217

undeleting graphics 263-264, 332

Undo command (Edit menu) 87
low memory and 318

white paint, blank space vs. 253

Revert comimiand ve. 373 Wide Margins, for fields 225-226
L= E £ TR 1y - g e

undeleting a card with 135 word, searching for 46-47 o

undeleting field text with 217 write-protected stack, opening 50
undeleting a graphic with 263, 332

unlocking a field 243 X N

updating Search Paths card 25-26

i : e XCMD, adding a color set with 273
user levels 17-21. See also specific levels

to background 148, 278
A e » I a3 e 1 p b ‘ —
Arrow Keys in Text option and 21 toacard 134, 276
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